[TUTO] Rooter le Xperia M2 en 4.4 - {BL verrouillé compatible}

  • Auteur de la discussion maxouffr
  • Date de début
Statut
N'est pas ouverte pour d'autres réponses.
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #101
J'ai voulu faire Power + volume haut lors de l'étape avec flashtool
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #102
Il n'y a qu'une manipulation : téléphone éteint, tu le branche en appuyant sur volume bas.
Le led verte s'allume et flashtool le flash.
Tu dois brancher le téléphone seulement quand flashtool te le demande !
 
P

PaYYa

Membre
Inscrit
24 Juillet 2013
Messages
6
Points
1
  • #103
yo man disons que je ne suis pas un novice et la ta manipe ne marche pas a savoir tout va bien jusqu'a rootkit sauf que la ben aucune reaction de la commande voir capture hihi :) reste figé comme sa aarrff ...


S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


quand je verifie avec flashtool je vois que c'est ecrit que le telephone n'est pas en mon debugging alors que bien sur je l'active ainsi que source inconnu avec de faire la manipe du kernel un fois que le tele redemar en mode bootloop ben il n'est plus en mode debugging
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #104
bonjour maxouffr
la je vais retenter la manip et avant j'aimerai te poser quelques questions pour que je sois sûr de la faire bien comme il faut,
aujourd'hui j'ai télécharger le firmware de KK 4.4.4 sur le net et je l'ai remis avec flashtool sur mon téléphone.

1-[Flasher le fichier "D2303_18.0.C.1.13_Global Generic_Only kernel.ftf" avec Flashtool]. dans cette étape le téléphone démarre normalement et pas en boucle.
2-[Rooter le téléphone avec RootKitXperia. (ou autre méthode compatible)]. pas de problème dans cette étape nickel.
3-[Lorsque le programme restera bloqué sur "phone reboots", faire Ctrl+C]. la aussi pas de problème ainsi que lorsqu'on tape la commande pour vérifier le root jusque la tout marche bien.
4-[Éteindre le téléphone] avec le débogage usb et source inconnu coché.
5-[Flasher le Kernel de FTF du firmware présent sur votre téléphone (pour cela, décochez tout les options de wipes et chez toutes les options d'exclude SAUF Kernel)]. pour ce dernier point [tu dis décochez tout les options de wipes et.......] alors que sur la photo ils sont cochés dans la partie exclude sauf kernel qui est décoché.
alors au tout début et avant de faire les manips que tu as cité dans le tuto est ce qu'il faut faire quelques choses genre sauvegarde de firmware ou avoir une ou des appllis qu'il faut avoir dans le téléphone ? si oui qu'est qu'il faut faire et comment le faire ?
pour la cinquième étape du tuto et dans la photo que tu as posté la partie content il y'a kernel.sin, rpm.sin et loader.sin. pour moi j'ai que kernel.sin et loader.sin est ce que c'est normal ? et concernant cette cinquième etape le flash du firmware 4.4.4 ne dure pas longtemps comme pour la première fois avec le firmware du 4.3 donc quand flashtool me demande de débrancher l'usb et de rallumer le téléphone c'est la qu'il commence à redémarrer en boucle et les manips avec rootkit xperia ne passe pas.
voila ça c'est mon cas a moi, alors s'il ya quelque chose a faire que j'ai négligé n’hésite pas a me faire la remarque et merci encore maxouffr.
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #105
maxouffr a dit:
Il n'y a qu'une manipulation : téléphone éteint, tu le branche en appuyant sur volume bas.
Le led verte s'allume et flashtool le flash.
Tu dois brancher le téléphone seulement quand flashtool te le demande !
Non,quand je branche sur USB tant en faisant volume bas,rien ne passe,j'ai appuyé sur tout les bouton de mon téléphone,rien...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #106
Salut à tous,

Patrick34150 a dit:
Non,quand je branche sur USB tant en faisant volume bas,rien ne passe,j'ai appuyé sur tout les bouton de mon téléphone,rien...

Je n'avais pas vu ça :

Patrick34150 a dit:
J'ai voulu faire Power + volume haut lors de l'étape avec flashtool

Tu as éteints ton téléphone lors du flash ?!?!?! :O :O :O

------------------------------------------------------------------------------------------------

PaYYa a dit:
yo man disons que je ne suis pas un novice et la ta manipe ne marche pas a savoir tout va bien jusqu'a rootkit sauf que la ben aucune reaction de la commande voir capture hihi :) reste figé comme sa aarrff ...


S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


quand je verifie avec flashtool je vois que c'est ecrit que le telephone n'est pas en mon debugging alors que bien sur je l'active ainsi que source inconnu avec de faire la manipe du kernel un fois que le tele redemar en mode bootloop ben il n'est plus en mode debugging

Bonjour peut-être ?

Le problème vient de ton PC. tu devrais avoir au moins "waiting for devices".

--------------------------------------------------------------------------------------------

usmba2010 a dit:
aujourd'hui j'ai télécharger le firmware de KK 4.4.4 sur le net et je l'ai remis avec flashtool sur mon téléphone.
Le FTF, tu le garde super précieusement ! c'est à chaque fois lors du flash du kernel du FTF que tu bloquais !

usmba2010 a dit:
1-[Flasher le fichier "D2303_18.0.C.1.13_Global Generic_Only kernel.ftf" avec Flashtool]. dans cette étape le téléphone démarre normalement et pas en boucle.
Justement, il doit redémarrer en boucle.

usmba2010 a dit:
2-[Rooter le téléphone avec RootKitXperia. (ou autre méthode compatible)]. pas de problème dans cette étape nickel.
3-[Lorsque le programme restera bloqué sur "phone reboots", faire Ctrl+C]. la aussi pas de problème ainsi que lorsqu'on tape la commande pour vérifier le root jusque la tout marche bien.
4-[Éteindre le téléphone] avec le débogage usb et source inconnu coché.

Merci d'avoir confirmer le bon fonctionnement de ces étapes lors de tes précédentes manipulations :)

usmba2010 a dit:
5-[Flasher le Kernel de FTF du firmware présent sur votre téléphone (pour cela, décochez tout les options de wipes et chez toutes les options d'exclude SAUF Kernel)]. pour ce dernier point [tu dis décochez tout les options de wipes et.......] alors que sur la photo ils sont cochés dans la partie exclude sauf kernel qui est décoché.
alors au tout début et avant de faire les manips que tu as cité dans le tuto est ce qu'il faut faire quelques choses genre sauvegarde de firmware ou avoir une ou des appllis qu'il faut avoir dans le téléphone ? si oui qu'est qu'il faut faire et comment le faire ?
pour la cinquième étape du tuto et dans la photo que tu as posté la partie content il y'a kernel.sin, rpm.sin et loader.sin. pour moi j'ai que kernel.sin et loader.sin est ce que c'est normal ? et concernant cette cinquième etape le flash du firmware 4.4.4 ne dure pas longtemps comme pour la première fois avec le firmware du 4.3 donc quand flashtool me demande de débrancher l'usb et de rallumer le téléphone c'est la qu'il commence à redémarrer en boucle et les manips avec rootkit xperia ne passe pas.

C'est en effet à cette étape que tu rate la manipulation. Pour cette étape, tu ressort le FTF en 4.4.4 qui tu as mis au tout début de ton message.
Tu n'a rien à sauvegarder (sauf avant de commencer le tutoriel par précaution). C'est la dernière étape "stressante" du tutoriel.

L'image d'exemple vient d'un firmware pour Z1 et on a ce fichier mais si flashtool ne le met pas dans la partie kernel, c'est normal !
Et oui, le flash est très rapide, comme pour le flash du kernel en 4.3 à la 1er étape ?

Par contre c'est ta dernière phrase qui n'est pas normal... Ton téléphone devrait repartir.
Si en prenant exactement le firmware FTF en 4.4.4 que tu as téléchargé, ça ne change rien, poste ici le log (texte) du logiciel flashtool dans son INTEGRALITE.

---------------------------------

Tenez-nous au courant !
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #107
salut,

[ le flash est très rapide, comme pour le flash du kernel en 4.3 à la 1er étape ?] non le flash du kernel 4.3 est plus long que le flash du 4.4.4. est ce qu'on coche ou en décoche des cases avant le flash du kernel 4.3 comme on le fait avant le flash du kernel 4.4.4 ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #108
Le flash en 4.3 est prêt à l'emploi.
Tu n'as rien à faire !
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #109
re-salut

enfin je suis en KK 4.4.4 full root merci beaucoup maxouffr pour ton aide précieuse et ta patience.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #110
Super :)
Enfin une bonne nouvelle :lol:

La dernière commande à la fin également ?
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #111
oui je l'ai fait la dernière commande. merci encore ;)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #112
avec plaisir :)
 
P

PaYYa

Membre
Inscrit
24 Juillet 2013
Messages
6
Points
1
  • #113
maxouffr (mon yo man => voulait dire bonjour ) :)

et tu me dis que le probleme viens de mon pc car je devrais avoir " wait for device"

ben figure toi que j'ai deja effectué la manip sur 2 pc different et quand etais affiché juste " wait for device " pareil aucune reaction ...
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #114
Salut paYYa

[avant il faut tout fermer sur ton ordi] quand tu veux lancer le flash ya une fenêtre qui s'affiche sur ton mobile pour l'autorisation de l'ordi, là tu fait OK mais ne coche pas la case, ensuite normalement le flash du kernel 4.3 ne dure pas longtemp, tu débranche ton mobile de l'ordi et tu ferme flashtool et ensuite allume le il va démarrer en boucle la tu fait le root mais tu pourras pas rentré la première commande pour vérifier le root et la tu fait le flash du KK 4.4.4 en respectant les cases à coché comme sur le tuto et normalement ça devrait marcher. ;)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #115
ok Désolé ^^

Un problème de pilotes ? Tu as installé les pilotes adb ?
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #116
maxouffr a dit:
Salut à tous,

Patrick34150 a dit:
Non,quand je branche sur USB tant en faisant volume bas,rien ne passe,j'ai appuyé sur tout les bouton de mon téléphone,rien...

Je n'avais pas vu ça :

Patrick34150 a dit:
J'ai voulu faire Power + volume haut lors de l'étape avec flashtool

Tu as éteints ton téléphone lors du flash ?!?!?! :O :O :O
Non,j'ai éteins mon téléphone lorsqu'ils ont dit de débrancher le téléphone (unplug) de le mettre en flashmode et de le rebrancher
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #117
Ouf ^^ si tu avais fait ça... tu aurais cramer ton téléphone...

Bah normalement, en le branche avec volume bas, il devrait lancer le flash.
Il vibre quand tu fais power+volume haut ?
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #118
maxouffr a dit:
Ouf ^^ si tu avais fait ça... tu aurais cramer ton téléphone...

Bah normalement, en le branche avec volume bas, il devrait lancer le flash.
Il vibre quand tu fais power+volume haut ?
Oui mais ça c'était avant,là il fait plus rien,je pense que jlai cramé mais jsais pas pourquoi car lors du seul flash que j'ai fait (pour flasher ton kernel) tout s'est bien passé et après jpouvais pas le flash car root access denied donc je trouve sa un peu bizarre mais je pense qu'il n'y a pas d'autre choix que de l'envoyer au SAV
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #119
ok ... :/

C'est pas une panne de batterie ?
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #120
maxouffr a dit:
ok ... :/

C'est pas une panne de batterie ?
Jlai rechargé toute la nuit et il y a une LED rouge et un écran noir s'allume
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #121
Salut,

Le Root acces denied provient parce que tu cherches à brancher ton mobile en fastboot (volume haut) avec un bootloader verrouillé alors qu'il faut le brancher en flashmode (volume bas).

Au pire essaye de reprendre ton mobile avec PC Compagnon.
 
P

PaYYa

Membre
Inscrit
24 Juillet 2013
Messages
6
Points
1
  • #122
usmba2010 salut man

alors t'inquiete je ne suis pas un novice en la matière le probleme est que tout est fait dans l ordre ya juste que quand je lance le fichier bat il ouvre l invite de commande et reste figé sur wait for device et je peux rester la a contempler l'écran mais rien hihi :)

donc quand le tel est rester en mode bootloop je me suis dit que je recommencerai tout
j'ai donc appuyé sur le petit bouton reset pres de la sim puis volume bas pour flashtool j'ai reformater a neuf en 4.4.4

puis active le mode debugging ainsi que source inconnu et recommencé le tuto au complet ( meme celui de xda) mais rien toujours pas de reaction au moment de root quand le tel en est bootloop avec le kernel 4.3 ...

voila :) tester sous windows 10 / windows 8.1 et / windows 8 tous pilotes installés telephone reconnu sous tout les modes

EDIT :

Patrick34150 salut mec fait la manipe que j ai expliqué plus haut a savoir

prendre une petite epingle pour presser le petit bouton en bas a gauche de la carte sim
une fois le telephone eteint lance flashtool choisi ton FTF en 4.4.4 puis lance le flash au moment ou il te demande branche en effectuant la manip classic pour flashtool qui est volume bas et tu branche au pc ( tu aura led rouge puis verte ) et la le flash se lance apres tu pourra tout reprendre a zéro

EDIT 2 :

root ok pour moi :)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #123
@PaYYa : Super :)

Du coup, c'était quoi le problème ?

Je fusionne tes messages, les multi-postes sont interdit ! Merci d'utiliser la fonction EDITER.
 
P

PaYYa

Membre
Inscrit
24 Juillet 2013
Messages
6
Points
1
  • #124
maxouffr a dit:
@PaYYa : Super :)

Du coup, c'était quoi le problème ?

Je fusionne tes messages, les multi-postes sont interdit ! Merci d'utiliser la fonction EDITER.



a vrai dire c'est le téléphone qui n'etais pas tres presser donc a la detection il fallais vraiment atteeeeeeennnnnnndre :vieux-smiley: lol pourtant bonne config pc usb 3 / 8g de ram / 3ghz 4core ( windows 10 ) mais un sony m2 au bout mdrrr qui est celui de ma femme d'ailleur perso je prefaire mon note 3 coool

tester sur ma tablet windows 8.1 et sa marche aussi avec un delai d'attente long :) au moin au bout ya le resultat :frime1:
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #125
super alors :)
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #126
PaYYa a dit:
EDIT :

Patrick34150 salut mec fait la manipe que j ai expliqué plus haut a savoir

prendre une petite epingle pour presser le petit bouton en bas a gauche de la carte sim
une fois le telephone eteint lance flashtool choisi ton FTF en 4.4.4 puis lance le flash au moment ou il te demande branche en effectuant la manip classic pour flashtool qui est volume bas et tu branche au pc ( tu aura led rouge puis verte ) et la le flash se lance apres tu pourra tout reprendre a zéro
Bonsoir,j'ai essayé d'appuyer dessus et toujours rien ne passe,mais Flashtool le detecte,j'arrive pas à éteindre mon téléphone,l'écran est allumé et est noir,la LED est rouge et c'est tout ce que je peux vous dire...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #127
Bonsoir,

Tu n'arrives toujours pas à l'éteindre ?
Normalement, volume haut et power devrait fonctionner.
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #128
Bonjour maxouffr

Je ne sais pas si je suis dans le bon endroit, mais j'ai une question à posé.
Quelles applications sont indispensables pour un smartphone rooter ? Merci pour les réponses.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #129
Salut,

Pour moi, c'est titanium, adaway, es explorateur file et éventuellement Xposed.
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #130
Merci pour la réponse :wink: les trois premiers je les ai mais pour xplode tu peux m'expliquer STP ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #131
C'est un système qui te permet d'avoir des modules pour personnaliser ton téléphone au niveau de l'interface principalement.
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #132
Et l'installation de xposed et de ses modules est simple pour un novice comme moi ou il faut que je cherche un tutoriel concernant cette appli pour être un peu près sur de ne pas faire n'importe quoi sur mon Xperia ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #133
C'est simple ;)
Tu as un guide quelques pars sur le forum.
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #134
Merci
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #135
Salut maxouffr

Tu peux me dire quel module xposed permet le redémarrage du téléphone Xperia m2 STP
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #136
Salut,

Il doit y en avoir un qui se nomme advanced power menu je crois !
 
U

usmba2010

Membre
Inscrit
31 Janvier 2015
Messages
37
Points
0
  • #137
C'est bon j'ai trouvé merci :wink:
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #138
maxouffr a dit:
Bonsoir,

Tu n'arrives toujours pas à l'éteindre ?
Normalement, volume haut et power devrait fonctionner.
Salut,
non je n'arrive pas à l'éteindre en faisant haut et power
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #139
Ça devrait pourtant... Il ne vibre pas ?
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #140
Ok tout d'un coup il recommence à redemarré en boucle quand j'ai voulu le rallumer,mais là jsuis un peu perdu,là je dois lancer flashtool et le brancher en flash mode? Car le problème c'est que Power + volume haut sa s'éteins,Power + volume bas rien ne se passe...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #141
Tu avais un autre marque avec un mode download avant (comme Samsung) ?

Tu ouvre flasher, tu sélectionne le FTF et tu coche les options comme indiqué sur le tutoriel et tu valide. A ce moment la, tu attends (TRES important).
Quand tu vas avoir une fenêtre te demandant de connecter ton téléphone (et pas avant), tu le connecte de la manière suivante :
- Lorsqu'il est éteint (donc pas de logo, d'écran demi éclairé ou autre)
- Tu appuie sur la touche VOLUME BAS (et uniquement celle la)
- Tu connecte (toujours en maintenant la touche) ton câble USB (avec l'autre coté déjà dans ton PC) et seulement à ce moment la, tu lâche le bouton volume.
- Le flash devrait se lancer !
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #142
maxouffr a dit:
Tu avais un autre marque avec un mode download avant (comme Samsung) ?

Tu ouvre flasher, tu sélectionne le FTF et tu coche les options comme indiqué sur le tutoriel et tu valide. A ce moment la, tu attends (TRES important).
Quand tu vas avoir une fenêtre te demandant de connecter ton téléphone (et pas avant), tu le connecte de la manière suivante :
- Lorsqu'il est éteint (donc pas de logo, d'écran demi éclairé ou autre)
- Tu appuie sur la touche VOLUME BAS (et uniquement celle la)
- Tu connecte (toujours en maintenant la touche) ton câble USB (avec l'autre coté déjà dans ton PC) et seulement à ce moment la, tu lâche le bouton volume.
- Le flash devrait se lancer !
Enfin sa marche !
Le truc que j'arrivais pas à faire en faite,c'est que je faisais Power + volume bas quand je le connectais,et je relachais le bouton volume bas quand je le connectais...
Donc en faite,le problème ne venais pas du téléphone mais du manipulateur :lol:
J'ai fais adb shell "su -c /data/local/tmp/install_tool.sh" dans la commande,le téléphone a vibré et je l'ai redémarré,et puis j'ai voulu mettre les binaires à jour mais ça n'a pas marché,ça m'a dit "L'installation a échoué!" mais on y est presque..
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #143
Bonne nouvelle :)

La commande doit se faire téléphone allumé ;)
Essaye aussi de la faire plusieurs fois !
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #144
maxouffr a dit:
Bonne nouvelle :)

La commande doit se faire téléphone allumé ;)
Essaye aussi de la faire plusieurs fois !
Oui :)
J'ai fait la commande ce matin et sa faisait *daemon started successfully*
maintenant,toujours téléphone allumé,sa me fait error:device not found
Donc je dois le redémarré en un mode spécial ou pas?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #145
Non, le téléphone dois être allumé et fonctionnel.
Par contre, tu as bien le mode débloguage USB.
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #146
Salut, je voudrais savoir ou trouver le FTF qui est utilisé dans le tuto ?
De plus, y à t-il besoin que j'ai le FTF de mon tel ou non ? C'est le d2303_1281-1578_18.3.1.c.0.21.
Merci de votre aide :)
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #147
Salut,

Avec Flashtool :)
Tu fais "Device/upgrade" puis tu te laisses guider pour la suite.
 
P

Patrick34150

Membre
Inscrit
24 Novembre 2013
Messages
22
Points
0
  • #148
C'est bon !!!
Je suis enfin full root
Je tiens à vous remercier énormément,pour votre patience et vous étiez toujours là et toujours capable à me répondre.
Je vous doit un grand respect,je sais même pas comment je peux vous remercier...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #149
Super :)
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #150
Re: Re : [TUTO] Rooter le Xperia M2 en 4.4 - {BL verrouillé compatible}

Patrick34150 a dit:
C'est bon !!!
Je suis enfin full root
Je tiens à vous remercier énormément,pour votre patience et vous étiez toujours là et toujours capable à me répondre.
Je vous doit un grand respect,je sais même pas comment je peux vous remercier...

Tu viens de le faire ;) merci à toi :)
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #151
Me voici maintenant dans ce TUTO maxxou :)
J'ai un problème :
Quand mon téléphone redémarre en boucle, rootkitxperia ne fait aucune action ... Il est écrit : waiting for device.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #152
Tu as fais l'essai avec rootkitXperia lorsque le téléphone fonctionnais ?

Réfléche le kernel de KITKAT pour relancer le téléphone.
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #153
J'ai reflasher c'est bon
Voici ce qu'il me dit quand je le branche en étant allumer sous KItKat
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #154
Ok^^

Bah la il détecte le téléphone...

Du coup, réessaye manipulation car ça devrait marcher !
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #155
On est d'accord pour le rooter, il suffit de lancer le cmd ?
EDIT : toujours pareil ... waiting for devices
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #156
Arf...

Tu as essayé un autre port USB ?
Un autre PC aussi ?
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #157
Oui j'ai essayé, toujours pareil...
Waiting for device
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #158
Arf... Je sais pas du tout quoi te dire :/

Tu as essayé depuis un autre PC aussi ?
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #159
As-tu coché le débogage USB eet les source inconnues?
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #160
Oui j'ai bien activer ces deux paramètres.
A la fin du flash, flashtool me dit ça :
09/022/2015 17:22:31 - INFO - Device connected with USB debugging off
09/022/2015 17:22:31 - INFO - For 2011 devices line, be sure you are not in MTP mode
Est-ce normal ?
En fin c'est affiché quand je le rallume et qu'il démarre en boucle.
De plus, dans l'invité de commande, je ne peut pas écrire ... Est-ce normal ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #161
Le logiciel flashtool n'est pas l'invité de commande.
Tu dois prendre celui de Windows !

Tu branche quand ton téléphone lorsqu'il redémarre en boucle, avant le démarrage ou pendant ?
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #162
Oui je sait bien pour l'invité de commande, c'était juste à titre indicatif. Par contre je lance celui qui se trouve dans rootkitxperia.
Et j'ai essayé toutes les possibilités ...
Démarrage du téléphone, branchement.
Branchement, démarrage du téléphone.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #163
Et ton ordinateur symbolise une connexion détectée (bip sonore) ?
Tu as quelque chose qui apparaît dans le gestionnaire de périphérique ?
 
L

loicgeii

Membre
Inscrit
7 Février 2015
Messages
13
Points
0
  • #164
Oui il est détecté, il y a bien le bip sonore.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #165
Ok^^

Donc tu as toujours un problème de pilotes...

Tu as PC Companion sur ton PC ?
 
chov kipeu

chov kipeu

Membre
Inscrit
17 Décembre 2014
Messages
56
Points
6
  • #166
Bonjour a tous, j'ai réussi a rooter avec le dernier kit kat stock téléchargé sur xpérifirm (18.1.3.C.1.13) par contre impossible de mettre les binaires su a jour malgré le full root. si quelqu'un a une idée......

Et pour ceux qui ont des problèmes de connections du téléphone avec l'invite de commande Rootkit, ce que j'ai également eu, il faut simplement laisser ouvert pc compagnon a coté (juste l’accueil sans aucune opération) sinon les drivers ne sont pas détectés.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #167
Merci pour le retour :)
 
chov kipeu

chov kipeu

Membre
Inscrit
17 Décembre 2014
Messages
56
Points
6
  • #168
Petite précision pour ceux qui veulent installer CWMR 6.0.4.6. après le root en bl verrouillé sans avoir de problème de mises a jour binaire SU:
1) Télécharger SuperSU v 2.46 (lien :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
)
2) Renommer le fichier téléchargé en Superuser.apk
3) Ouvrir le dossier rootkitXperia_20140719
3) Aller dans files et remplacer l'ancien Superuser par le nouveau téléchargé
4) Rooter normalement avec le tuto
5) Et pour ceux qui veulent installer CWMR 6..0.4.6 en bl verrouiller, femer la fenêtre de commande, ne pas éteindre le téléphone et se référer au tuto correspondant à l’installation du CWRM 6.0.4.6 en bl verrouillé

!!!! IL FAUT FLASHER LE KERNEL DE VOTRE FIRMWARE A LA FIN DES 2 OPERATIONS ET NON PAS ENTRE LES 2!!!!

6)R edémarrer le téléphone en débogage usb et ouvrir une fenêtre de commande dans le dossier rootkit pour le root avec bl verrouillé
7) Mettre à jour les binaires et redémarrer le téléphone

Point particulier une led bleu ciel s'allume entre l'affichage du logo Sony et l'entée en recovery.
Root et installation CWRM 6.0.4.6 effectue sur le dernier firmware kitkat 18.3.1.C.1.13
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #169
Merci pour le retour :)

PS : Je pense que tu as eu un problème avec la dernière étape !
 
chov kipeu

chov kipeu

Membre
Inscrit
17 Décembre 2014
Messages
56
Points
6
  • #170
Le driver pour le debogage usb n'était pas bien installé tout simplement, il se connecte et se reconnecte sans arrêt.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #171
Arf dans ce cas tu n'as pas pu faire la dernière étape et du coup tu n'étais pas en full root !
Tu as réussi a régler le problème ?
 
R

robinson91

Membre
Inscrit
29 Octobre 2014
Messages
74
Points
6
  • #172
J'ai bien suivi le tuto mais je crois que je ne suis pas en full root: installation du framework Xposed impossible (erreur de droits en écriture dans des dossiers système je crois). Comment savoir clairement si on est en full root ou pas?

Root Check me donne ça comme info:

Rooted
Permissions: rwxr-xr-x (755)
ADB root: disabled
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #173
arf oui c'est possible en effet^^

Essaye de refaire la dernière étape.
 
R

robinson91

Membre
Inscrit
29 Octobre 2014
Messages
74
Points
6
  • #174
J'ai beau réessayer toujours le même problème.
Et la denière étape ne me retourne rien, mais quand je le fais après avoir réinstaller le firmware et démarré le téléphone elle me retourne bien "uid=0(root) gid=0(root) context=u:r:init_shell:s0".
Je ne sais pas d'où vient le problème
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #175
Si tu as réinstaller le firmware, tu dois tout recommencer.
 
R

robinson91

Membre
Inscrit
29 Octobre 2014
Messages
74
Points
6
  • #176
J'ai dû recommencer plus de 5 fois déja, toujours le même problème... la dernière commande pour vérifier le root semble avoir du mal à trouver le téléphone (au moment où l'écran clignote en noir)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #177
Arf... je vois pas trop :/
Il me semble que quelqu'un avais eu le même problème... Essaye de remonter le sujet.
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #178
Salut, j'essaye cette méthode de root pour un peu repartir de zéro et faire ta deuxième étape pour l'écriture sur le systeme, mais rootkitxperia ne fonctionne pas sur le kitkat? Si? Car sur le tuto du rootkitxperia la version 18.3.1.c.0.21 n'est pas reprise comme étant compatible??

Quand tu dis qu'après le flash de D2303_18.0.C.1.13_Global Generic_Only kernel.ftf le phone va redémarrer en boucle, qu'entends-tu par là? Est-ce que le logo sony s'affiche? Car perso, j'ai un écran noir dont l'intensité change comme si il voulait démarrer mais n'y arrive pas. Là je reflashe la version 18.3.1.c.0.21, et je recommence ton tuto (j'ai installé les drivers entre temps, bien que je pense que je les avaient déjà)...

On verra, sinon je root comme avant et je suis uniquement la deuxième partie de ce tuto.

Et une dernière question: la version D2303_18.0.C.1.13_Global Generic_Only kernel.ftf correspond à jelly bean, alors comment être rooté en 4.4.4 comme le titre du sujet?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #179
Le but de la manipulation est de flasher un ancien kernel qui est rootable par rootkitXperia.
A la fin, tu reviens bien à ta configuration d'origine, le root en plus.

Pour l'état du téléphone avec le kernel en 4.3, j'ai peut-être mal interprèté le tutoriel de xda.
Peu importe comment il est, il faut juste que rootkitXperia le détecte.
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #180
J'ai réessayé encore une fois, mais après le flash du D2303_18.0.C.1.13_Global Generic_Only kernel.ftf le téléphone ne démarre pas en boucle, il démarre pas du tout, comme je disais dans le message d'hier, je vois à l'écran une variation de l'éclairage de l'écran, avez-vous déjà eu ça?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #181
Est-ce qu'il est détecté par RootKitXperia ?
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #182
Non. Il reste sur waiting device, mais bon le phone ne démarre pas comme il devrait, le démarrage en boucle, c'est quoi, il doit arriver jusqu'à l'affichage de la page d'accueil et redémarrer ou avant ça?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #183
En général c'est sony puis vagues puis re sony et vagues et ainsi de suite.

Tu as bien le D2303 ?
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #184
Oui c'est ca, le D2303
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #185
Donc ça devrait marcher !

Est-ce que ton PC détecte ton téléphone ?
Il y a un bip ? Les pilotes sont Ok ?
 
S

Salmoneus

Membre
Inscrit
8 Mars 2015
Messages
14
Points
0
  • #186
RootkitXperia block a "Daemon Successfully Started".

J'ai installé tout les drivers possible est imaginable (le téléphone est bien detecté par le pc quand il dans la boucle) et j'ai fermé Flashtool et enlever manuellement tout adb.exe qui bloquerait Rootkit.

Toujours rien

PS: Ma boucle personnellement est le logo Sony puis l'écran qui reste noir mais qui s'éteint et s'allume
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #187
Le problème viens de adb.
Essaye de redémarrer ton PC, vérifie sur PCC est bien fermé, ect...
 
S

Salmoneus

Membre
Inscrit
8 Mars 2015
Messages
14
Points
0
  • #188
Apres avoir fermé adb.exe alors que Rootkit fonctionne, maintenant j'ai "device unauthorized. Please check the confirmation dialog on your device.".
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #189
Tu as fais l'essai avec rootkitXperia avant de commencer le tutoriel comme conseillé ?
 
S

Salmoneus

Membre
Inscrit
8 Mars 2015
Messages
14
Points
0
  • #190
Oui. rootkitXperia exclame "error: device not found" plusieurs fois. Du coup j'ai essayé de brancher mon appareil pour tester.

Quel est la réponse normal que rootkitXperia est sensé donner quand il fonctionne sans un portable connecté?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #191
Il fallait lancer rootkitXperia avec le téléphone pour autoriser la connexion.

Ensuite tu flash le kernel et tu continues !

Tu en es où la ?
S'il ne s'allume pas, reflash le kernel d'origine pour le relancer.
 
S

Salmoneus

Membre
Inscrit
8 Mars 2015
Messages
14
Points
0
  • #192
Alors, ça a finalement marché pour des raison que j'ignore. J'ai redemarré mon pc pour le énieme fois et ca a d'un coup fonctionné. Je n'ai pas pu verfié qu'il était rooté comme dis dans le tutoriel a cause de mon windows XP qui marche mal.

J'ai reflashé mon FTF de base et le téléphonne s'allume normalement.

Je comprend mal par contre: il faut inviter les commandes dans le smartphone ou sur le pc?

Edit: J'ai du mal ces derniers jours... Je viens de remarquer que ce Tuto a pour source un post de XDA et il y a une explication plus detaillé la bas. Ca a répondu a ma question.

Ca m'a l'air bon! Merci beaucoup maxouff
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #193
Super :)
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #194
Perso, ça ne fonctionne toujours pas, après le flash du D2303_18.0.C.1.13_Global Generic_Only kernel.ftf je redémarre le phone et j'ai toujours ce fameux rétroéclairage qui s'allume et s'éteind et rien avec rootkitxperia...
Petite question, le dossier rootkitxperia doit être à la racine C: ?

Lorsque je lance adb shell en commande dos dans le répertoire rookitxperia (comme indiqué sur xda) j'ai ceci : shell@D2303:/ $, je suppose donc qu'il reconnait mon phone
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #195
Oui il le reconnaît donc tu peux suivre le tutoriel.
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #196
Je vais réessayer car quand j'ai ce fameux écran qui semble vouloir s'allumer, je ne sais plus rien faire, je suis obligé de repasser par flashtool et de flasher la version 18.0.C.1.13 et ensuite reflasher en 18.3.1.C.0.21 avant de réessayer ce tuto. Donc là, je suis en 4.4.4 non rooté, et j'ai placé le dossier rootkitxperia à la racine du C.

Alors il y a du mieux, rootkitxperia lance le hack, j'ai cet écran
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Mais il reste sur waiting device....????
 
S

Salmoneus

Membre
Inscrit
8 Mars 2015
Messages
14
Points
0
  • #197
C'est normal que l'ecran clignote comme ça. C'est le but pour pouvoir passer le root a travers rootkitxperia qui utilise ce bug a son avantage.

Il faut que tu le connecte sur ton PC alors qu'il clignote comme ça, puis lancer rootkitxperia. Si ca ne fonctionne pas, redemarre ton pc ou ton téléphone ou les deux et réesseye.

De plus:
* Assure toi que tu as tout les drivers installés et qu'on ton téléphone est reconnu même quand it clignote.
* Lance rootxperia en tant qu'administrateur si jamais tu as l'option.
* Dis nous ce que te dis rootkitxperia quand tu le lance pour que l'on puisse t'aider

EDIT: Réesseye et branche ton téléphone assez rapidement apres que le logo Sony apparait
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #198
Salut,

De plus lisez bien les tutos, c'est écrit en rouge que le mobile sera en bootloop.
 
R

Ramea

Membre
Inscrit
3 Juin 2014
Messages
49
Points
6
  • #199
Oui j'ai bien lu mais le bootloop, comme je l'ai demandé avant, pour moi devait arriver jusqu'au logo sony....


"Si ca ne fonctionne pas, redemarre ton pc ou ton téléphone ou les deux et réesseye." Ok pour le pc parce que le phone à ce moment là, je ne sais plus l'allumer.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #200
Si tu n'arrive pas à l'éteindre, tu fais Volume haut + power, sinon, tu devrais avoir un bouton d'extinction d'urgence sur le téléphone.
 
Statut
N'est pas ouverte pour d'autres réponses.
Haut Bas