[Tuto] Rooter Iconia Tab A210

  • Auteur de la discussion HuKoPer
  • Date de début
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #1
Le tuto du Noob :

Voila étant donné la longueur du post "Root Iconia A210" j'ai décidé de faire un tuto ou je reprenais toutes les infos en une fois, donc le tuto n'est pas vraiment (du tout même) de moi. Remerciez donc pour avoir fait la traduction du tuto disponible sur xda
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
pour ceux-qui font pas confiance ;)

Averissement :
Avant toute manipulation, sachez que suivre ce tuto peut comporter des risques, ni moi, ni Phonandroid ne peuvent être responsables des éventuelles conséquences (bugs, laggs, reboots...) suite à une mauvaise manipulation (ou pas... :D ).
Sachez aussi que la dernière version d'android compatible avec l'A210 est disponible sur le site de Acer au cas où...

Pré-Requis :
-Avoir installé les pilotes de la tablette
-Télécharger ce
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
(remerciez Largo pour le partage) ou celui ci
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
mais il est apparemment buggé...
-Activer le mode débogage USB sur la A210 en version 4.1 (Options pour les développeurs -> mettre "oui" en haut à gauche -> cocher "débogage USB")

Manipulations :
Si vous êtes prêts, alors allons-y ;)

-Dé-zippez le... "zip" :roll:
-Branchez la tablette à votre PC.
-Lancez "shell.bat"
-Sur la fenêtre de commande qui va s'ouvrir, vous allez rentrer à chaque étape les codes uns à uns (Tapez le code -ou copiez/collez le- et appuyez sur "Entrée" entre chaque code pour valider, un code par ligne):

1) Pour Allumer la tablette en mode "Bootloader" :
- adb reboot bootloader ou si ça ne marche pas adb reboot-bootloader
- fastboot oem unlock
- Faites "volume -" sur la tablette pour que le cadenas clignote, puis "volume +"

2) Flasher le Kernel :
- fastboot flash boot insecured_kernel.img

3) Flasher le Recovery :
- fastboot flash recovery cwm_recovery.img
- fastboot reboot (la tablette va redémarrer, attendez qu'elle soit sur l’écran de déverrouillage pour la suite)

Voila, ceci (vous avez installer plein de petits trucks sur la tablette sans le savoir :ugeek: ) fait, passons au *Rootage* :
4) Root de la Tablette
Tapez encore et toujours sur "shell.bat", cette suite de codes (pour ceux-ci, je vous conseille de les
copier/coller ;) ):
- adb remount
- adb shell mount -o rw,remount /system
- adb push su /system/bin/su
- adb shell chmod 06755 /system/bin/su

Voila c'est fini, vous avez réussi hmm, vous pouvez télécharger "SuperUser" ou "SuperUtilisateur" (c'est la même chose Anglais/Français) sur le Play-Store pour pouvoir accéder aux apps qui nécessitent le Root.
Je pense avoir tout dit, je pense aussi avoir du mal à répondre aux questions car j'y comprends pas vraiment grand-chose :lol:
Posez les tout de même dans l'espoir (très faible haha) où je connaisse la réponse ou que quelqu'un de bien gentil vienne vous éclaircir
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #2
Bonjour,

Je repose la question déjà posé sur le post d'origine : l'étape d'installation des drivers est-elle nécessaire sous Windows 7 et 8 ? Pour ma part, sous Windows 7, la tablette a été reconnue immédiatement par le système, sans ajout de drivers.

Mais peut-être que ceux-ci sont différents et nécessaires pour rooter ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #3
J'en sais rien, essaies et regarde si ça marche tant mieux, sinon il ne se passera rien car les actions ne s'effectueront pas donc aucun risque normalement...
J'essaie si tu veux
->Ça marche pas, pour la deuxième commande ça met < waiting for device >
 
scad

scad

Membre
Inscrit
18 Septembre 2012
Messages
98
Points
6
  • #4
les driver sont nécessaire je ne serai dire pourquoi mais c'est comme sa sur tout les android que j'ai rooté il a toujours fallu les driver.
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #5
HuKoPer a dit:
->Ça marche pas, pour la deuxième commande ça met < waiting for device >

Sous Windows 7 ? Et avec les drivers sus-cités, ca marche ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #6
Largo38 a dit:
Sous Windows 7 ? Et avec les drivers sus-cités, ca marche ?
Ca marche pas sans les drivers et sous windows 7, j'essaie avec et je vous tiens au jus :D
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #7
Et ta tablette est reconnu et "montée" sous ton windows 7 comme appareil mobile ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #8
La tablette est bien détectée mais le root ne marche pas sous Windows 7, car on ne peut pas installer les drivers...
Le tuto est donc que pour Xp dsl...
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #9
Je n'ai pas ma tablette en ce moment (sav), mais l'install des drivers semble s'être bien passée chez moi (pas de msg d'erreur).
Le problème apparait quand chez toi ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #10
Non pour moi le problème apparaît quand je rentre les codes
 
V

vincentdu76

Membre
Inscrit
20 Janvier 2013
Messages
1
Points
0
  • #11
Ton lien de téléchargement n'est plus dispo...

-c'est bon il marche, le site devait être temporairement indispo...
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #12
HuKoPer a dit:
Non pour moi le problème apparaît quand je rentre les codes
As-tu essayé de lancer le script shell.bat en mode administrateur (clic droit sur le shell.bat, "Executer en tant qu'administrateur") ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #13
Le problème ne vient pas au lancement du shell.bat mais lorque on rentre le premier code (sous win7), il ne trouve pas la tablette
< Waiting for devices >
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #14
Le problème vient peut-être du fait que le script n'a pas les droits nécessaires pour trouver le "device". Il se lancerai alors correctement mais échouerai pour connecter la tablette. Ca ne coûte rien d'essayer...

A priori, il faut que la tablette soit allumée avant de la connecter et lancer la 1ere commande. Est-ce le cas ?
As-tu essayé de débrancher/rebrancher la tablette quand le "waiting device" s'affiche ?
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #15
Je veux bien ré-essayer mais elle est déjà rootée, je sais pas trop ce que ca va donner... La tablette est bien allumée tkt ^^
Et j'ai essayer de débrancher/rebrancher aussi; sans succès...
Edit :
Avec shell lancé en tant qu'administrateur ça donne -> device not found
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #16
Comme tu veux. Sinon, je verrai bien dès que j'aurai à nouveau ma tablette (dans la semaine, j'espère...).

edit : j'avais pas vu ton edit... Bon, heureusement que j'ai encore un pc sous XP au taf, ca m'aurait saoulé de devoir reinstaller un xp rien que pour rooter ma tablette :/
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #17
Ouais moi aussi j'ai du rebrancher un vieil ordi qui ne servait plus dans ma maison ><
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #18
Il suffit de télécharger les drivers usb sur le site de Acer :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Moi aussi ça me mettait un message d'erreur disant qu'il ne trouvait pas la tablette.

Vous sélectionner A210 mais attention prenez version ICS 4.0 et non JB 4.1.1 car pas de pilotes sinon. Après intall des drivers ça fonctionne impec !
 
D

dandou

Membre
Inscrit
29 Décembre 2012
Messages
34
Points
6
  • #19
Sinon, sous Win7, monter une machine virtuelle avec Virtualbox et installer WinXp dans la machine virtuelle.
C'est ce que j'ai fait pour continuer à utiliser mon vieux scanner.
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #20
Oui enfin c'est un peu plus compliqué que de juste installer 40 mo de drivers.
 
R

roms0406

Membre
Inscrit
23 Janvier 2013
Messages
1
Points
0
  • #21
Bonjour,

Juste pour info, root réussi sans aucun souci avec les drivers Acer et sous Windows 7 Pro x64

J'ai juste suivi la méthode ligne par ligne et ça m'a pris moins de 2mn ^^

Merci pour le tuto
 
HuKoPer

HuKoPer

Membre
Inscrit
13 Janvier 2013
Messages
20
Points
0
  • #22
De rien =) bizarre que t'ai réussi sous win 7 pour les drivers mais bon :D
Je peux plus activer la rotation automatique ce qui est pas très génant en sois mais parfois les pages internet sont mieux affichées en vertical, ça vous le fait aussi ?
 
B

batdav08

Membre
Inscrit
27 Janvier 2013
Messages
2
Points
0
  • #23
Bonjour, je n'arrive pas a obtenir le fichier shell.bat
Le fichier ZIP ne comporte pas ce script, et jai du bien du mal a le de zipper (uniquement avec 7zip) malgrés plusieurs téléchargement...
Peut-être aurais-je louper quelque chose ??
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #24
Un antivirus un peu trop zélé qui le vire du zip dès son téléchargement ?

Edit : Sinon, tu peux le créer à la main, il ne contient que :
Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #25
HuKoPer a dit:
De rien =) bizarre que t'ai réussi sous win 7 pour les drivers mais bon :D
Je peux plus activer la rotation automatique ce qui est pas très génant en sois mais parfois les pages internet sont mieux affichées en vertical, ça vous le fait aussi ?

Tu n'aurais pas basculé l'interrupteur sur la tranche par erreur ?
 
B

batdav08

Membre
Inscrit
27 Janvier 2013
Messages
2
Points
0
  • #26
Merci de ta réponse largo38, mais rien n'y fait, impossible d'extraire l'archive avec la tablette. Le fichier serait corrompu, quelqu'un aurait une copie du ZIP ?
 
F

FLORENT4420

Membre
Inscrit
25 Janvier 2013
Messages
2
Points
0
  • #27
batdav08 a dit:
Bonjour, je n'arrive pas a obtenir le fichier shell.bat
Le fichier ZIP ne comporte pas ce script, et jai du bien du mal a le de zipper (uniquement avec 7zip) malgrés plusieurs téléchargement...
Peut-être aurais-je louper quelque chose ??
bonjour
j ai le meme probleme j ai essaye sur plusieurs pc seven et xp rien, pas de fichier shell.bat
il y a t il un autre fichier zip?
merci d avance
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #28
Voilà mon zip a moi que j'ai. Je ne l'ai pas installé (vu que ma tablette est toujours chez le SAV Acer... Comment ça je rabache tongue ), mais décompressé sans soucis.
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


C'est chez Free, donc il ne restera pas vitam eternam, si quelqu'un peut reuploader chez un hébergeur plus pérenne...
 
F

FLORENT4420

Membre
Inscrit
25 Janvier 2013
Messages
2
Points
0
  • #29
Largo38 a dit:
Voilà mon zip a moi que j'ai. Je ne l'ai pas installé (vu que ma tablette est toujours chez le SAV Acer... Comment ça je rabache tongue ), mais décompressé sans soucis.
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


C'est chez Free, donc il ne restera pas vitam eternam, si quelqu'un peut reuploader chez un hébergeur plus pérenne...
MERCI :geek:
c est la bonne archive elle fait20.mo alors que l autre fait 11.5mo et il ya bien le fichier shel dat :geek: :geek: :geek: :geek:
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #30
Et en téléchargeant directement sur le site d'XDA ?
 
P

pepyxx

Membre
Inscrit
2 Février 2013
Messages
4
Points
0
  • #31
Bonjour à tous,

Je viens d'acheter un acer210 et je me decide de le rooter ( bien que je sois novice dans ce domaine )

J'ai pu recuperé le zip sur le lien de Largo38 ( merci largo ), et je me lance dans l'aventure grace au tuto simplifié de Hukoper ( merci egalement)...au moment de la 4éme phase lors du copier coller de : adb push su /system/bin/su.....la tablette se met en veille ( est ce normal ) ????? et quand je colle la 4eme ligne " adb shell chmod 06755 /system/bin/su"
il y a aucun message..............avez vous eu le meme symptome ???? cependant au demarrage de la tablette il y a une petite ligne marquant unlock mode ( est ce suffisant )???

En attente de vos réponses :)
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #32
bonsoir,
je me suis lancé dans le root de ma tablette.
mais j'ai un petit problème
l’or de la 1er phase.(bootloader)
tablette allumé je fais power moins le cadenas ne clignote pas?
comme je ne connais pas grand chose en informatique.
pourriez-vous me venir en aide.
merci
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #33
Power moins ? Je lis :
Faites "volume -" sur la tablette pour que le cadenas clignote, puis "volume +"
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #34
bonjour,
désole je me suis mal exprimé"
je voulais dire.
tablette allumé et faire
power et volume moins puis power et volume plus
ou uniquement volume moins et volume plus ( sans power)
encore désole
merci
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #35
Désolé, je ne sais pas répondre. J'attends d'avoir un écran correct avant de rooter ma tablette. Et comme elle repart demain au sav...
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #36
bonjour,

je vous remercie pour votre réponse.
dans l'attente d'une réponse qui pourra peut-être m’éclairer.
je passionterais .
encore merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #37
miolui40 a dit:
bonjour,
désole je me suis mal exprimé"
je voulais dire.
tablette allumé et faire
power et volume moins puis power et volume plus
ou uniquement volume moins et volume plus ( sans power)
encore désole
merci
C'est écrit en toutes lettres, il n'y a qu'à suivre bêtement :

" Sur la fenêtre de commande qui va s'ouvrir, vous allez rentrer à chaque étape les codes un à un (Tapez le code -ou copiez/collez le- et appuyez sur "Entrée" entre chaque code pour valider, un code par ligne) :

1) Pour Allumer la tablette en mode "Bootloader" :
- adb reboot-bootloader
- fastboot oem unlock
- Faites "volume -" sur la tablette pour que le cadenas clignote, puis "volume +"
2) Flasher le Kernel :
- fastboot flash boot insecured_kernel.img
3) Flasher le Recovery :
- fastboot flash recovery cwm_recovery.img
- fastboot reboot (la tablette va redémarrer, attendez qu'elle soit sur l’écran de déverrouillage pour la suite) "
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #38
bonjour,
pour Allumer la tablette en mode "Bootloader"
j' allume tablette écran d’accueil on il y'a le verrou.
j'ai fait power + "volume -" sur la tablette pour que le cadenas clignote. le cadenas ne clignote pas.
et une autre manif. toujours tablette allumé mais uniquement "volume -" toujours la même chose le le cadenas ne clignote pas.
donc dans les deux cas je n'ai pas pu faire "volume +"
comme je n'y connais pas grand chose en informatique.
dans l'attente .
je vous remercie de votre compréhension.
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #39
Et tu fais bien ça tablette connectée au PC, en mode fastboot ?
Tu as lancé shell ?
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #40
mich41 a dit:
Et tu fais bien ça tablette connectée au PC, en mode fastboot ?
A la lecture du tuto, je comprends que ce sont les 2 premières commandes suivies du volume - / volume + qui redémarrent la tablette en mode fastboot, ce qui ne fonctionne apparement pas chez miolui40. Tu veux dire qu'il y aurait une autre manip a faire avant (par exemple, sur mon xperia, il faut effectivement éteindre le tel, appuyer sur volume - en branchant l'usb) ?
mich41 a dit:
Tu as lancé shell ?
miolui40 nous répète qu'il n'y connait pas grand-chose et au vu des "raccourcis" que prennent certains utilisateurs (dont je fais parfois partie), je demanderai plutôt :
as-tu bien
- décompréssé l'ensemble du zip dans un dossier
- double-cliqué sur le fichier shell.bat (ou shell si -ô hérésie- les extensions connues sont masquées). Le démarrer en mode administrateur ne peut pas faire de mal (clic-droit, executer en tant qu'administrateur)
- tapé ou copié collé les commandes (une ligne à la fois, en validant à chacune d'elle, sans le - du début de chaque ligne) ?

tongue
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #41
Ouais, et je me demande même s'il ne vaudrait pas mieux le lancer en mode DOS, après avoir lancé la commande CMD...
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #42
Bonjour,
Mode fastboot.
J'ai essayé tablette eteinte
1. Power et volume + et volume - en temps rien ne passe
2. Power et volume + toujours rien
3. Power et volume - toujours rien
La seule chose qui ce passe avec la cas 2 et 3 la tablette redemarre
Merci
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #43
miolui40 a dit:
Bonjour,
Mode fastboot.
J'ai essayé tablette eteinte
1. Power et volume + et volume - en temps rien ne passe
2. Power et volume + toujours rien
3. Power et volume - toujours rien
La seule chose qui ce passe avec la cas 2 et 3 la tablette redemarre
Merci
Pourquoi toujours avec Power ? Ce n'est pas demandé sur le tuto.
Tu as bien activé "le mode débogage USB sur la A210 en version 4.1 (Options pour les développeurs -> mettre "oui" en haut à gauche -> cocher "débogage USB")" ?
Il est vrai que le tuto ne précise pas si la tablette doit être éteinte ou allumée au début de la procédure. A tester dans les 2 états.

mich41 a dit:
Ouais, et je me demande même s'il ne vaudrait pas mieux le lancer en mode DOS, après avoir lancé la commande CMD...
C'est ce que fait le shell, qui ne fait qu'un "start" ;)
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #44
Je viens de télécharger le zip A210-root.
Il est bizarre, une fois décompressé, j'ai un seul fichier sans extension ?
Il n'y a rien à ouvrir.......
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #45
Il fait 22Mo. Essaie sur le lien que je donne plus haut.
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #46
Oui, là c'est mieux ;)

Bon, si c'est une question de pilotes, et ça semble être le problème, la première question est : qu'y a-t-il dans le gestionnaire de périphériques du PC quand la tablette est connectée et qu'y a-t-il dans l'explorateur Windows ?
 
P

pepyxx

Membre
Inscrit
2 Février 2013
Messages
4
Points
0
  • #47
Bjr,

Pour ma part la manipulation volume + et - se fait apres avoir copié les 2 premieres lignes de commandes ( la tablette se met en mode dos si je puis dire et en tout petit il est indiqué la manipulation du volume pour choisir et valider une fonction)........
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #48
bonsoir
tablette allumé est connecté au par usb.( tablette bien reconnue par le pc)
je fais volume - le cadenas ne clignote pas!(comme indiqué dans le tuto)
ce faite je ne peux pas continué la procédure.
pourrirez-vous m'aidé?
merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #49
Bonjour
J'ai posé une question ci-dessus...
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #50
bonjour,
toujours réussi a root ma tablette
j'ai réinstalle le driver aucun problème bien reconnu
la tablette est aussi reconnue par le pc par usb branché.
tablette allumé pour voir le cadenas clignoté lorsque je fait "volume -"
rein ne ce passe le cadenas ne clignote pas!
merci a tous pour votre aide
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #51
Comment veux-tu qu'on t'aide, tu ne réponds pas aux questions qu'on te pose.
 
P

pepyxx

Membre
Inscrit
2 Février 2013
Messages
4
Points
0
  • #52
Bjr,

J'ai suivi au pied de la lettre la procedure : ce n'est pas le cadenas de la tablette mais le cadenas de l'ecran dos qu'il faut deverouiller avec une pression sur la touche volume.

(tablette branché en usb + dezip du programme + lancement du shell.bat + insertion des 2 premieres lignes de commandes = la apparait une porte et un cadenas sur l'ecran dos de la tablette)
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #53
Puis sans vouloir être méchant, quand on n'est pas très doué en informatique (monde android) ou débutant, on ne tente pas des choses comme cela.

IL FAUT INSTALLER LES DRIVERS MEME SI L'ON EST SOUS W7. cf tuto installer les drivers j'ai tout expliqué.

Moi les lignes de commandes ne faisaient rien tant que je n'avais pas installé les drivers (pourtant tablette bien reconnue).
 
W4Rr1oR

W4Rr1oR

Membre
Inscrit
5 Février 2013
Messages
14
Points
0
  • #54
Merci beaucoup ! Fait sous Windows 8 et ça marche impec'
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #55
bonjour à tous,
j'ai suivi le petit tuto de pepyxx dans je le remercie.
mais rein ni fait .
deinstalle le driver sur le pc puis réinstalle avec le driver (usb_acer1.0_A4OI_A) reconnu par le pc

puis suivi le tuto
je l'ai fait tablette allume puis éteinte dans les 2 cas toujours rein

(tablette branché en usb + dezip du programme + lancement du shell.bat + insertion des 2 premières lignes de commandes = la apparaît une porte et un cadenas sur l’écran dos de la tablette)

quand je clique sur shell.bat un fenêtre noire s'ouvre
copie la première ligne puis entré
réponse
'adb' n'est pas reconnue en tant que commande interne ou externe,un programme exécutable ou un ficher de commande.
dans l'attente
merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #56
C'est marrant ça, du baratin, que du baratin.
Ca ne sert à rien le baratin...

Ce qu'il faut savoir en premier lieu, c'est si les drivers sont bien installés. Tant qu'on ne sait pas ça, on patine dans la choucroute.
Et, pour ça, il faut savoir EXACTEMENT, ce qu'il y a dans le gestionnaire de périphériques quand la tablette est connectée.
Mais notre ami ne voit pas clair ou ne sait pas lire ou fait la sourde oreille. Tant pis pour lui.
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #57
Pis c'est pas comme si c'était écrit en rouge plus haut ! :lol:
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #58
A sa décharge, il semble avoir fait l'install des drivers sus-cités...

Le message donné semble indiquer que le shell ne s'ouvre pas sur le bon répertoire.
Avant de lancer les commandes données, quand la feneètre du shell s'ouvre, que donne la commande "dir" ? Vois-tu le fichier adb.exe ?
Si tu le vois, que donne la commande adb seule dans cette fenêtre ? Chez moi, ça crache le help de la commande, preuve qu'elle est bien trouvée.
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #59
BNen oui, hein, autant piseer dans un violon ! :D :D :lol:
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #60
bonsoir à tous
pour repondre a mich41
un dossier; adb interface
sous dossier: acer composite adb interface
un dossier: appareils mobiles
sous dossier :acer iconia a 210
voila ce qui se trouve dans le gestionnaire de périphérique
merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #61
Et dans l'explorateur windows ?
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #62
et dans la fenêtre shell ;) .
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #63
Bon, histoire de savoir de quoi je causais, j'ai voulu rooter ma tablette.
Drivers installés (win 7 32), tablette allumée, connectée en USB.
La 1ere commande me rend un vilain "device not found" et un "adb devices" ne sort rien alors que mon Xperia apparaît s'il est branché.
J'ai essayé de désinstaller le pilote, le réinstaller, nada undecided . Pas cool. Je verrai après un reboot du pc, plus tard.
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #64
bonsoir,
j'ai suivi le tuto du Noob tout ce passe comme prévu jusqu’à la 4eme étape 'root de tablette'

des que je tape la 1 er ligne 'adb remout' est que je fait enter

le shell me dit ' remout failed:eek:peration not permitted'

merci
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #65
Alors voila le parfait exemple de ce qu'il ne faut pas faire : lire le tuto une fois et oublier l'essentiel : le mode debogage usb. En le suivant, ca va nettement mieux, la tablette est listée par adb. Il est tard, je verrais le root demain.
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #66
Si vous ne lisez pas les tutos aussi... Ya des gens qui se sont fait chier à les faire pour rendre service à d'autres utilisateurs. Pour rooter la tablette même un môme de 10 ans pourrait le faire : juste besoin d'un cerveau de deux mains et de savoir lire c'est tout ! :cool:

Je ne dis pas ça pour toi Largo38. Mais c'est vrai que c'est énervant les posts de gens qui ont briqué leur tablette ou qui ont des pb de root ou autre sans avoir tout simplement bien lu ce qui était écrit. Mais c'est pareil pour tout. Sur le forum du galaxy s2 c'est la même. ;)
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #67
Bonjour,
Pour répondre aux deux compère ci dessus .
Tout d'abord le mode débogage ubs est activé.
En suite soyer un peu humble on est sur un forum entraide par définition il y a des personnes férues en informatique comme vous
Et il y a des néophytes qui ne demande cas apprendre.
Merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #68
Et bien justement : apprendre commence par la lecture des posts existants, des tutos et des prérequis sur ce forum et sur d'autres, sans oublier les recommandations des développeurs, en anglais d'accord, mais il y a Google traduc qui se défend très bien.
Or, on peut constater beaucoup de brickages proviennent de la précipitation à vouloir rooter, déverrouiller ou encore flasher, sans s'occuper des prérequis des tutos.
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #69
Bonjour,
ceci étant dit.
venant au faite.
pourquoi malgré le mode debogage usb activé.( comme le préconise largo38)
je n'ai pas la permission?
a partir du paragraphe 4 'root la tablette'
puisque avant aucun problème sur les paragraphes 1,2,3
pc: windows 7 ultimate 64bit
merci
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #70
Si tu as bien le débogage usb d'activé et que tu as bien réussi les étapes 1,2 et 3 il n'y a pas de raison que tu aies un pb avec la dernière étape. As-tu lancé le shell.bat en mode administrateur ? Je suppose que tu as bien installé les pilotes usb vu que tu arrives les étapes 1,2 et 3. Vu le message d'erreur que tu as, c'est un problème de droit.

Recommence toutes les étapes depuis le début, il n'y a pas de raison. Quelle OS as-tu ? Fais-tu la manip tablette allumée ou éteinte ? Tu as bien 10 fichiers présents dans ton répertoire ?

Tu sais si ça a fonctionné pour moi et d'autres c'est qu'il y a un truc que tu n'as pas fait ou mal fait. Comme je te le disais il n'y a pas de raison que ça ne fonctionne pas. Ta tablette elle reste bien tout le temps branchée en usb pendant l'opération ?
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #71
bonjour,
os : windows 7 ultimate 64 bit
la tablette allumé.

merci
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #72
Répond à toutes mes questions stp. Mode admin ou pas de lancé ?
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #73
bonjour
oui en mode admim.
je viens de faire un autre essai en mode admim.
toujours la même chose les 3 premières étapes aucun problème.
et a la 4. étape pas de permission .
la tablette est allumé.
merci
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #74
Alors là... :? Si tu as un autre PC (de préférence en windows XP) tente. Tu as bien 10 fichiers dans ton répertoire de root ?
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #75
Tu es bien en JB 4.1 ou + ?
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #76
bonjour,
ma tablette est bien 4.1 jb
d'autre par je n'ai que 9 fichiers non 10.
sur le tuto noob
il y a que 9 fichiers le que manque?
MERCI
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #77
bonjour,
il y a un probléme .je n'a que 9 fichiers sur le tuto noob pas 10
voici les fichers du tuto. le quel manque?
1
- adb reboot-bootloader
- fastboot oem unlock
2
fastboot flash boot insecured_kernel.img
3
fastboot flash recovery cwm_recovery.img
fastboot reboot
4.
adb remount
- adb shell mount -o rw,remount /system
- adb push su /system/bin/su
- adb shell chmod 06755 /system/bin/su
merci
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #78
Tu te lances dans des bidouillages et tu ne sais même pas faire la différence entre une ligne de commande et un fichier...
C'est à tes risques et périls, cette histoire.
Il y a bien 10 fichiers dans le zip, mais sont-ils bien dans ton dossier ?
Pour ton info, ces fichiers se terminent par une extension .xxx
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #79
Oula bon ... je passe la main à mich41 là je fatigue. :lol:

As-tu essayé sur un autre PC ? Comme le dit mich41, as-tu bien 10 fichiers dans ton répertoire que tu as téléchargé pour rooter la tablette ?
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #80
bonjour,
merci pour la pression.
oui j'ai bien les 10 fichiers les voici
adb.exe,
adbwinapi.dll
adbwinusbapi.dll
cwm_recovery
fastboot.ex,
insecured_kerne
l,shell.bat,
stock_kernel.img
stock_recovery.img
su
merci
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #81
3ème édition : As tu essayé sur un autre PC ?
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #82
bonjour,
je n'ai pas d'autre pc.
je peux essai avec windows xp mode.
quands pensez-vous?
est-ce possible?
MERCI
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #83
Je ne peux malheureusement pas dire grand-chose de plus, je n'ai qu'une A500...
Mais, sans vouloir te mettre la pression comme tu dis...peux-tu nous décrire ce que tu fais comme manip.
Tu réécris tout précisément.
Parce que je suis persuadé que tu commets une faute de syntaxe ou qqchose comme ça quelque part
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #84
bon bah là je sèche. Mouai... mode XP j'y crois pas trop... si tu as bien installé les drivers usb en les téléchargeant sur le site de acer et que les étapes 1,2 et 3 fonctionnent, ya pas de raison... ça ne peut être qu'une erreur humaine. Pour nous ça a fonctionné et j'ai aussi windows 7 64 bit.

As-tu accès au mode "Recovery" ? Si non c'est que tes étapes 1 2 et 3 n'ont pas été faites correctement.
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #85
bonjour,
je vous remercie de votre patience.
j'abandonne.
merci
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #86
roll
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #87
bon jour,
me revoilà.
j'ai réussi ,
j'ai été sur le site xda suivi leur tuto sauf que qu’a la 4 eme étape .je n'ai pas mi la ligne de commande
'adb shell mount -o rw,remount/sytem'
puis j'ai pu installé super user pro ,titanium backup pro , rom manger pro. les 3 programme fonctionne.
merci.
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #88
Bonjour
C'était donc bien une question de saisie...
Cool pour toi ;)
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #89
Bonjour,
Oui .
merci tout de même pour votre patience.
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #90
Comme je le disais : ya pas de raison que ça fonctionne pas ! :cool:

Tant mieux pour toi alors. Amuses-toi bien avec ton joujou ! Maintenant tu peux même installer une Rom custom.
 
miolui40

miolui40

Membre
Inscrit
22 Octobre 2012
Messages
92
Points
0
  • #91
Bonjour,
Je vous remercie de votre patience.
Et conseil.
Merci
 
N

Neeruson

Membre
Inscrit
24 Septembre 2012
Messages
6
Points
0
  • #92
Bonjour,

quand je tape "adb reboot-bootloader" au lieu de reboot la tablette les commandes possibles avec adb sont affichés sur la console. Cela est il nomarl ?

Quand je branche ma tablette elle est pourtant bien détecte.

Merci
 
L

Largo38

Membre
Inscrit
22 Février 2012
Messages
553
Points
16
  • #93
Mode déboggage USB activé ?
Pour être sur que ta tablette est bien détectée par adb (et non pas par windows seulement):
Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!
qui permet d'avoir la liste des devices connectés.

A priori oui, sans quoi tu aurais un "error: device not found"
On dirait qu'adb ne reconnait pas le paramètre qui semble pourtant correct. Et en le tapant (plutot qu'un copier-coller qui peut rammener des caractères parasites) ?
 
N

Neeruson

Membre
Inscrit
24 Septembre 2012
Messages
6
Points
0
  • #94
J'ai réussi finalement en la démarrant moi même en fastboot en ayant au préalable bloqué la rotation de l’écran à l'aide du bouton situé à côté de celui du son. Assez étrange ^^
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #95
Oui effectivement. Merci pour ton astuce qui pourra certainement servir à d'autres. ;)
 
K

kitano77

Membre
Inscrit
18 Février 2013
Messages
2
Points
1
  • #96
bonjour,

je suis vraiment un newbee,
et je vais essayer de rooter la tab

j ai installer les drivers , c est ok
j ai lancer le shell.bat , une fenetre dos s ouvre , j ai la main, mais je mets quoi comme code ?
je les trouve ou ?

et quand vous parler de mode recovery avec volume - ,
il faut que la tab soit eteinte et on reste appuyer sur volume moins au demarage ?

et c est quoi le cadena ?

merci d avance, je suis vraiment perdu
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #97
Te lances pas la dedans si tu es newbee. TU veux rooter mais pour quoi faire exactement ? Ce n'est pas une manip anodine et tu risques de bricker ta tablette.
 
K

kitano77

Membre
Inscrit
18 Février 2013
Messages
2
Points
1
  • #98
je voudrais juste enlever tout les prog qui sont fixer sur la tab
 
mich41

mich41

Membre
Inscrit
1 Novembre 2011
Messages
483
Points
0
  • #99
C'est une erreur, surtout pour un newbie, comme tu dis.
Moi qui n'en suis pas un, je ne le fais pas.
 
toutoune28

toutoune28

Membre
Inscrit
7 Décembre 2011
Messages
217
Points
18
  • #100
Tu peux le faire avec certaines applis, je crois qu'il en existe où on ne doit pas être nécessairement root pour s'en servir. Google est ton ami.
 

Sujets en relation

Haut Bas