[TuTo]-Root-Xperia S-ICS[CH/FR](bootloader verrouillé)

  • Auteur de la discussion MutantX
  • Date de début
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #301
J'ai telechargé les drivers, selectionné manuellement le pilote SEMC Flash Device Version: 3.0.0.0 [25/11/2011],redemarage du PC, et toujours le meme probleme. La je telecharge tous les logiciel sur le PC que j'ai emprunté. C'est un netbook mais bon j'vais tenté qui sait.
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #302
Bon j'ai recommencé la procédure depuis le début avec le netbook. Apparemment aucun problème de driver. Je flash sur la 0.75 et je te retiens au jus.

EDIT: je suis passé à la 0.75, step1 s'est déroulé correctement mais Flashtool s'est arrêter, "ERROR: Flash aborted". Le téléphone s'est rallumé avec une icone représentant un panneau attention et un tél. Là, restauration vers ICS via update service et je recommence.
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #303
bon nouveau problème mais plus chiant celui ci, des que je redémarre mon XS il faut que je réinstalle le backup fait avec titanium sinon toute les applis et paramètres virent comme ci elles étaient stocké dans le cash, comment faire pour que toute les modif après le flashage soit permanente sans devoir la refaire a chaque fois?

merki ^^
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #304
Bon, décidément j'ai la poisse. Passage à la 0,75 réussi mais je bloque toujours après step1, et j'ai ce log:

06/046/2012 02:46:12 - INFO - <- This level is successfully initialized
06/046/2012 02:46:12 - INFO - Flashtool Version 0.8.0.0 built on 2012-05-27 21:57:12
06/046/2012 02:46:12 - INFO - You can drag and drop ftf files here to start flashing them
06/046/2012 02:46:20 - INFO - Device disconnected
06/046/2012 02:46:32 - INFO - Selected Xperia S_MaJ_ICS_6.1.A.0.452_FR.ftf
06/046/2012 02:46:32 - INFO - Preparing files for flashing
06/048/2012 02:48:07 - INFO - Please connect your device into flashmode.
06/048/2012 02:48:17 - INFO - Device connected in flash mode
06/048/2012 02:48:17 - INFO - Opening device for R/W
06/048/2012 02:48:18 - INFO - Reading device information
06/048/2012 02:48:18 - INFO - Phone ready for flashmode operations.
06/048/2012 02:48:18 - INFO - Start Flashing
06/048/2012 02:48:18 - INFO - Flashing loader
06/048/2012 02:48:20 - INFO - Loader : S1_Root_de72 - Version : R5C004 / Bootloader status : ROOTABLE
06/048/2012 02:48:20 - INFO - Disabling final data verification check
06/048/2012 02:48:20 - INFO - Flashing partition-image.sin
06/048/2012 02:48:22 - INFO - Ending flash session
06/048/2012 02:48:23 - ERROR -
06/048/2012 02:48:23 - ERROR - Error flashing. Aborted
06/048/2012 02:48:23 - INFO - Device connected in flash mode

Par contre, quand il se rallume avec le panneau de signalisation, je peux flasher la 0,75 sans passer par ICS via update service.
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #305
j'ai eu le mm problème que toi, et en faite j'ai apres chaque step<1et2> débranché mon XS, préparer flashtool avec les para puis lancé l'appli, des qu'il me demande de connect l'usb, je branche selon la technique du flashmode et voila. smile

par contre met la maj 0.8.6 de flashtool que tu trouvera sur gogol, je croit que sa m'a aidé, et j'espere que sa t'aidera aussi
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #306
Oui oui c'est ce que je fait. D'ailleurs c'est ce qui est indiqué sur le tuto. Après je ne sais pas d'où peut bien venir le problème. Je reste sur GB en attendant.

J'ai aussi utilisé la version CH qui ne fonctionne pas, re-télécharger le ROOT TOOLKIT 1.0.2, mais toujours le même problème:


06/012/2012 10:12:36 - INFO - <- This level is successfully initialized
06/012/2012 10:12:36 - INFO - Flashtool Version 0.8.0.0 built on 2012-05-27 21:57:12
06/012/2012 10:12:36 - INFO - You can drag and drop ftf files here to start flashing them
06/012/2012 10:12:38 - INFO - Device disconnected
06/012/2012 10:12:56 - INFO - Selected LT26_6.1.A.0.452_Generic_CH_1257-3740_.ftf
06/012/2012 10:12:56 - INFO - Preparing files for flashing
06/013/2012 10:13:13 - INFO - Please connect your device into flashmode.
06/013/2012 10:13:19 - INFO - Device connected in flash mode
06/013/2012 10:13:19 - INFO - Opening device for R/W
06/013/2012 10:13:19 - INFO - Reading device information
06/013/2012 10:13:20 - INFO - Phone ready for flashmode operations.
06/013/2012 10:13:20 - INFO - Start Flashing
06/013/2012 10:13:20 - INFO - Flashing loader
06/013/2012 10:13:23 - INFO - Loader : S1_Root_de72 - Version : R5C004 / Bootloader status : ROOTABLE
06/013/2012 10:13:23 - INFO - Disabling final data verification check
06/013/2012 10:13:23 - INFO - Flashing partition-image.sin
06/013/2012 10:13:24 - INFO - Ending flash session
06/013/2012 10:13:25 - ERROR -
06/013/2012 10:13:25 - ERROR - Error flashing. Aborted
06/013/2012 10:13:26 - INFO - Device connected in flash mode
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #307
tient télécharge la maj de flashtool
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #308
Voila!!!! Enfin!!! Merci Kgprod pour ton aide, c'est bien la MAJ de Flashtool qui manquait.

Par contre, ce que je voudrais savoir, c'est la différence que je vais avoir en ayant mis la CH plutôt que la FR??

Merci aussi à Sebastien sans qui ce root aurait été impossible.

Bon bah j'attendrais le déverouillage du bootloader quand ma garantie sautera ou quand une custom rom de prestige sera proposé (par doomlord si possible!!lol).
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #309
Bravo,
La différence, c'est les applications pré-installés.
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #310
super content pour toi smallybaby ^^

@sebastien tu a vu mon poste sur le fait que le backup ne tient pas? car c'est galère tu peux m'aider la dessus svp
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #311
Ouais, j'vois pas d'applications différentes entre la FR et la CH. Mais quel bonheur de pouvoir utiliser RomToolBox, Titanium ou encore No-frills CPU. Par contre la restauration des données s'est déroulée correctement pour moi.

Et....BRAVO pour ton appli "Illummination Bar Notification" sebastien, c'est une appli incontournable apparemment sur XDA.....et maintenant sur mon XS. ;)
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #312
t'as bien de la chance :( moi des que je redemarre hop plus rien a part ce que PCC a bien voulu me remettre.

et merci pour romtoolbox je vais pouvoir essayé un nouveau truc ^^
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #313
As tu essayé de refaire la restauration, avec PCC ?
 
Z

Zaer

Membre
Inscrit
28 Juillet 2012
Messages
22
Points
0
  • #314
Ca y est, grâce à la MaJ de Flashtool, ça fonctionne...

Je voulais savoir, combien de temps devons attendre à l'étape F ?!

Merci pour l'aidez que vous m'apportez/m'avez apporté !
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #315
Moi je lui laisse 2mn, avant de continuer

Bon, vu que vous avez eu besoin de la mise à jour de Flashtool, je vais rajouter le lien.
 
Z

Zaer

Membre
Inscrit
28 Juillet 2012
Messages
22
Points
0
  • #316
D'accord, car là, ça fait bien 20 minutes que j'attends, et toujours pas de truc qui plante :/
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #317
Tu peux continuer, si tu n'as rencontrer aucun message d'erreur ce n'est pas grave, je l'avais rencontré car j'avais, je pense un, fond d'écran animé
 
Z

Zaer

Membre
Inscrit
28 Juillet 2012
Messages
22
Points
0
  • #318
Bon bah je crois que ça y est !

Comment on le sait quand le téléphone est rooté ?
J'ai installé superuser, ça suffit ?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #319
Installe Titanium backup sur le play store, et vois si il te demande les permissions super utilisateur
 
Z

Zaer

Membre
Inscrit
28 Juillet 2012
Messages
22
Points
0
  • #320
Alors ça y est, j'ai bien les droits supers utilisateurs.

Encore merci à vous 2 !
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #321
De rien ;)
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #322
Je pense que tu devrais rajouter sur le tuto la MAJ de Flashtool à appliquer apres l'instal de Flashtool 8.0, le fond d'ecran animé par defaut à changer avant le flash vers ICS, ainsi que le TOOL ROOTKIT, car sur le lien XDA sur ton tuto, c'est une version 2.0 qu'il y a, et il n'y a pas d'etape 3, 4 et 5. On constate une facilité améliorée.

Pourquoi à chaque redemarage j'ai la selection de la langue, comme si c'etait la premiere fois que je l'allumais? D'ailleurs j'ai plus le verouillage par reconnaissance faciale, il a disparu? Une explication?)
EDIT: problème réglé, il suffit de redemarrer le téléphone avec une puce, et le paramètrage se fait automatiquement, et face unlock apparait par la même occasion.
 
waree

waree

Membre
Inscrit
12 Décembre 2011
Messages
81
Points
6
  • #323
kgprod a dit:
merci pour romtoolbox je vais pouvoir essayé un nouveau truc ^^

Profitez en l'appli est en promo sur le market à moins de 3 euros ! Je l'ai achetée plei tarif quelques jours avant cette promo, les nerfs !

Désolé pour le HS...
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #324
@Smallybaby: Que veux tu dire par un redémarrage avec une puce?
 
waree

waree

Membre
Inscrit
12 Décembre 2011
Messages
81
Points
6
  • #325
Avec une sim dedans ! Je fais mon mêle tout désolé.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #326
Merci,
Pff, oui c'est logique. Des fois le cerveau percute plus :lol:
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #327
Lol raaa ca sent la fin de soirée ca!
Nan je m'explique: n'ayant pas encore mis ma micro sim vu que je l'avais commandé, et apres avoir fait le flash avec la version suisse, chaque fois que je redemarais le phone, j'avais le droit à la selection de la langue comme pour la premiere mise en route d'android.
En gros je l'eteins en francais et il redemarre en anglais. Et face unlock n'etait pas present encore. Puis des que je suis rentré chez moi et que j'ai mis la puce, le redemarage s'est deroulé correctement, et avec l'apparition de face unlock dans les reglages. L'ecran de choix des langues est apparu avec la langue francaise directement selectionné. Et le probleme a disparu depuis.
Bizarre... Ca me rappele les iphones que tu branche sur itunes mais avec la puce de l'operateur concerné.
Mais bidon le probleme en fait...
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #328
bon bin j'ai rien glandé de particulier et du coup ca marche normalement roll
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #329
Bizarre ton histoire, donc la tu n'as plus le problème avec les applications?
 
K

kgprod

Membre
Inscrit
31 Juillet 2012
Messages
59
Points
0
  • #330
non ça marche impeccable, je ne sais pas ce qui empêchait le fixe du backup mais ça a disparue, par contre j'ai l’impression que ma batterie tient moins la charge, avec un ptit overclockage et surtout du undervolting je pense trouvé un équilibre :lol:

d'ailleurs j'ai vu ton poste doomkernel, tu parle d'ajout de gouverneur, sont ils intégré ou il faut les up pour les installé?.................. d'accord j'ai compris je vais posté direct dessus wink

encore merci pour ton soutiens sur ce poste, on ne se répète jamais assez ^^
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #331
Et oui mauvais endroit pour parler du Doomkernel ;)
 
M

malet974

Membre
Inscrit
6 Août 2012
Messages
42
Points
6
  • #332
J'ai installer superuser et titanium, sa me dis que le mobile pas rooter.

Quand je fais les step1,2,3,4,5 il doit y avoir un message de fin?
Car pour le 1,2,3 j'ai succefully mes pour 4,5 je click sur une touche et sa mes ADB et un petit point qui clignote et sa reste comme sa...

J'ai suivi tous qu'il faut faire il y a que pour step 4 et 5 que sa fonctionne pas pareil!

Merci pour votre aide!
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #333
Es tu repassé sous un firmware Gingerbread avant de commencer le Root?
 
M

malet974

Membre
Inscrit
6 Août 2012
Messages
42
Points
6
  • #334
oui comme dans le tuto sous 2.3.7

Edit:

malet974 a dit:
oui comme dans le tuto sous 2.3.7

Il faut bien mettre la 2.3.7 faire le step1 et ensuite revenir sous 4.0.4 c'est bien ça?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #335
Oui, tu flash d'abord la 0.75, ensuite tu commence par le step1 etc.....

Edit:

Le step1-2-4-5 te demande d'appuyer sur une touche lorsque c'est fini, le step3 se ferme tout seul
 
M

malet974

Membre
Inscrit
6 Août 2012
Messages
42
Points
6
  • #336
Par contre des qu'ont fais la mise à jours le root part, y a t'il un moyen de faire en sorte qu'il reste?

Merci!
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 400
Points
38
  • #337
malet974 a dit:
Par contre des qu'ont fais la mise à jours le root part, y a t'il un moyen de faire en sorte qu'il reste?

Merci!
La manipe expliquée dans le tuto est justement là pour que le root soit conservé après la mise à jour, mais ce n'est pas sûr qu'elle fonctionne aussi avec les prochaines mises à jour qui arriveront.
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #338
Bonjour,
Bien que mon S soit au SAV pour un problème d'écran qui vire au jaune, je commence à parcourir les tutos et notamment celui-ci très bien détaillé par sebastien. J'ai quand même une question. Lorsque j'ai téléchargé et installé flashtool, je dois donc installer les drivers. Problème, je ne sais pas quelles cases cocher en dehors de ceux du Xperia S. Dois-je cocher en plus fastboot drivers et/ou flasmode drivers ?
j'ai déjà Companion d'installé sur mon PC, cela veut-il dire que j'ai déjà les drivers et que je n'ai pas besoin de les mettre avec Flashtool ? A noter que j'ai flashé sous ICS avec Companion et que tout a bien fonctionné. Merci pour votre aide.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #339
Bonjour,
Pour les drivers de flashtool, coche flashmod, si ton BL est de verrouillé tu peux cocher aussi fastboot pour installer les kernels en mode fastboot avec flashtool
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #340
Merci Sébastien, mon Bootloader est verrouillé mais il est déverrouillable, j'avais regardé ça en faisant je sais plus quel code avant de le retourner au SAV.
j'ajoute donc uniquement flashmode. Je suppose que je devrai ajouter fastboot si je déverouille mon bootloader plus tard.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #341
De rien, pour les drivers fastboot aucune obligation sauf si tu utilise flashtool en mode fastboot. Aussi non il y a la méthode avec la ligne de commande habituel ;-)
 
J

Jhun

Membre
Inscrit
13 Août 2012
Messages
6
Points
1
  • #342
Salut tout le monde,

Avant tout, merci Sebastien pour la qualité du travail que tu fournis! On sent que tu est passionné et cela profite a toute la communauté :)

Pour revenir a ce tuto, j'ai vraiment du mal bien qu'il soit bien expliqué et assez simple a réaliser: après plusieurs essais je n'arrive toujours pas à le rooter. Pour info, mon tel est simlocké donc je n'ai pas encore mis de puce dedans, peut-être est-ce lié?

Tout se passe bien et sans message d'erreur et je crois que c'est ça le problème... D’après le tuto, à la partie F je devrais avoir un message après avoir redémarrer mon tel

Redémarrez Votre Mobile et faite une pose le temps qu'il se stabilise. Vous verrez «processus ... fermée ( cessé de travailler) de façon inattendue », il suffit de fermer la boîte de dialogue et d'attendre que le téléphone se règle.

Sauf que là, j'ai rien du tout...le tel s'allume normalement et je continue de finir le tuto. Tant mieux, pas tant mieux?

Une fois le tuto fini, les 2 applications Titanium backup et Root checker me confirment que mon tel n'est pas rooté. :/

Vous avez une idée ou le mieux c'est d'attendre que je puisse insérer une puce dans mon tel ?

Tout au debut, quand on remet la rom en 2.3.7, quelle sont les cases a cocher dans flashtool? C'est pas indiqué dans le tuto, peut-être que mon problème viens de là?


Merci :)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #343
Bonjour, une fois que tu as fini toutes les manipulations, installes tu "Super User" (super utilisateur)?
 
J

Jhun

Membre
Inscrit
13 Août 2012
Messages
6
Points
1
  • #344
Oups :oops:

Je l'avais bien installé la premiere fois mais ça n'avais pas reussis. A force de recommencer j'ai du me laisser distraire et oublier la derniere etape la plus importante du tuto :lol:

Merci beaucoup ça fonctionne bien :)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #345
De rien ;)
 
B

boss79170

Membre
Inscrit
19 Août 2012
Messages
11
Points
1
  • #346
Merci pour se tuto de qualité! j'ai galéré la première fois car je lançais rooltik alors que flashtool était ouvert, j'ai vu ensuite que flashtool devait être fermé lors des commandes .bat
XPERIA S ROOTE! :D
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #347
De rien :grin:
 
J

Joe Bill

Membre
Inscrit
16 Décembre 2011
Messages
59
Points
6
  • #348
Hello everybody !

Merci Merci Merci !!! Super travail à vous, j'ai un peu ( beaucoup ) galéré mais ça la fait !!! ;)
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #349
Bonjour à tous,
Dis-moi sébastien, est-ce que le root fonctionne avec la nouvelle version ICS que tu as mis en partage hier ? Merci pour l'info et pour ce tuto tres détaillé.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #350
Bonjour,
Oui, en suivant la procédure j'ai Roote mon mobile avec le firmware 45
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #351
Ok, super. Je crois que je vais me lancer dans le root cette fois. Je repasserai ici après. Bonne journée.
 
M

melissawindig

Membre
Inscrit
29 Août 2012
Messages
2
Points
0
  • #352
Bonjour,

Tout d'abord merci Sébastien pour ton tuto. Voilà je viens d'acheter mon Xperia s et hier soir, j'ai passé 6h à essayer de le rooter sans succès. Je ne sais pas ce que je fais faux. J'aurais besoin d'aide s'il te plait.

Je suis revenu sous Gingerbread comme demandé puis j'ai suivi tout les step mais sans succès. Je vais paraître bête de demander mais quand tu active le step 2,3,4 et 5 , ton téléphone doit être allumé ou pas ?? De plus il y a un moment où tu dis que le téléphone se règle et qu'il y marqué quelque chose avec le verrouillage mais chez moi à ce moment il se passe rien.

J'espère avoir été claire. Merci d'avance
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #353
Bonjour,
Ok Taram.

Mélissa,
Pour éviter le message d'erreur après le step3, il faut mettre un fond d'écran normale et non animé. Oui pour effectuer les step1,2,3,4,5 le mobile doit être allumé. Petite précision lorsque tu arrives au step4 et 5. Il faut d'abord faire le 4 une fois que tu vois appuyer sur une touche, tu le fais la fenêtre se fermera et ensuite tu lance le step5.
La fenêtre du step3 se ferme toute seule
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #354
Bonjour,
pour te répondre et bien que je n'ai pas encore rooté mon Xperia, je dirais oui il doit être allumé puisque si tu lis la suite, tu dois éteindre ton téléphone pour le flash. CQFD
oUPS TROP TARD...
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #355
Je suis content de voir que l'entraide pour les sections des modèles de 2012 arrive.

@Taram: Si tu t'investi dans l'entraide, et que tu effectue de jolie Tuto bien rédigé (Mr le rédacteur :grin:) ), tu as une grande chance de passer VIP dans environ 180 messages.

Ps: Cela est valable pour toute personne qui s'investit sur le Forum ;-)

Édit: Pour le Root, pensait à bien fermer Flashtool avant d'effectuer les step
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #356
Pour rédiger, c'est ok, mais pour faire un joli tuto, il faut déjà que je maitrise un peu mieux mon S. Enfin, je te remercie pour cette proposition. Je vais garder ça dans un coin de ma tête et si je m'en sens capable et que je dispose d'un peu de temps libre, je partagerai avec plaisir mes acquis ;)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #357
Ce que j'ai écrit n'ai aucunement une obligation, j'ai moi même mis du temps à comprendre et à maîtriser tous ces outils lorsque j'ai débuté avec mon Xperia Arc.
Bien sur il faut avoir du temps, le goûts de la bidouille, pour chercher aider et partager ce que l'on a pu trouver.

J'ai juste profiter de lancer un appel, je commence à me sentir seul pour l'entraide de ces mobiles :lol:
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #358
Je l'avais compris comme ça ;)
 
M

melissawindig

Membre
Inscrit
29 Août 2012
Messages
2
Points
0
  • #359
MERCI !!!!!!!!! Merci beaucoup Sébastien. je suis une super user maintenant.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #360
De rien ;-)
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #361
<hs> Sympa ton nouvel avatar Sebastien</hs>
bon, je pense avoir bien tout noté, je vais tenter ma chance aujourd'hui. Une demande toutefois : n'existe-t-il pas une méthode qui puisse être effectuée d'une main car les manips "brancher le cable USB du téléphone et appuyer sur volume bas en même temps", ça je peux pas le faire seul... sad
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #362
Bonjour,
Merci pour l'avatar. Non pas de façon en un clic. Regarde il y a une methode 2, moins de manip a faire avec avec le bouton bas + le cable USB
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #363
Ok, merci. Par contre, le rootkit, on peut utiliser la dernière version 1.0.2 pour les deux méthodes j'imagine, parce que dans la 1ere méthode, c'est la 1.0.1 qui est indiquée et la 1.0.2 pour la méthode 2.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #364
Non le Rootoolkit 1 pour uniquement la méthode 1 et le Rootoolkit 2 pour uniquement la méthode 2
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #365
Ok, c'est noté :cool:
Edit : salut,
j'ai essayé hier de rooter hier soir, mais quand j'ai vu la fenêtre avec les lignes de code, je n'ai pas compris de quoi il s'agissait undecided . du coup, j'ai cru avoir fait une boulette et j'ai pas pu flasher car mon S restait en écran noir mais allumé si j'en crois les sons de branchement et débranchement de l'USB.
Pour une bonne compréhension du tuto, il faudrait qu'une image écran des lignes de commandes apparaisse, car en voyant cette fenêtre, on peut penser qu'il s'agit d'une erreur. j'ai pas vu qu'il fallait appuyer sur une touche pour continuer.
Après, j'ai dû faire un hard reset pour le remettre en marche. La trouille de la semaine. c'est en parcourant les post que j'ai vu que c'était normal de voir cette fenêtre dos s'ouvrir.
Autre point, on ne sais pas quand brancher, débrancher le téléphone entre les différentes étapes.
Ex : Connecter le Xperia S à votre PC via le câble USB et exécuter step1.bat (se trouvant dans ROOT TOOLKIT 1.0.1)
Image
Éteignez votre mobile et passer le en Mode Flash. (Appuyer sur le bouton Volume Bas et branchez le câble USB, une Led Verte doit s'allumer)
il faut le débrancher et le rebrancher lorsqu'on est entre les deux phases ? car là, ce n'est pas précisé. Bon, je suis chiant mais je suis sûr que certains ont dû avoir les mêmes interrogations avant d'arriver à rooter leur S. Au fait, on fait comment pour avoir une copie écran et la mettre dans un post, stp ?
Voilà, je vais recommencer.
bon impossible de rooter... quand je branche mon téléphone allumé et que je fais le step 1, il ouvre une fenêtre dos, affiche des lignes jusqu'à la ligne appuyez pour continuer et puis il m'affiche deux autre ligne et rien,le tiret passe à la ligne suivante et clignote, rien de plus. La fenêtre reste ouverte. Est-ce normal ?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #366
taram7703 a dit:
Ok, c'est noté :cool:
Edit : salut,
j'ai essayé hier de rooter hier soir, mais quand j'ai vu la fenêtre avec les lignes de code, je n'ai pas compris de quoi il s'agissait undecided . du coup, j'ai cru avoir fait une boulette et j'ai pas pu flasher car mon S restait en écran noir mais allumé si j'en crois les sons de branchement et débranchement de l'USB.
Pour une bonne compréhension du tuto, il faudrait qu'une image écran des lignes de commandes apparaisse, car en voyant cette fenêtre, on peut penser qu'il s'agit d'une erreur. j'ai pas vu qu'il fallait appuyer sur une touche pour continuer.
Après, j'ai dû faire un hard reset pour le remettre en marche. La trouille de la semaine. c'est en parcourant les post que j'ai vu que c'était normal de voir cette fenêtre dos s'ouvrir.
Autre point, on ne sais pas quand brancher, débrancher le téléphone entre les différentes étapes.
Ex : Connecter le Xperia S à votre PC via le câble USB et exécuter step1.bat (se trouvant dans ROOT TOOLKIT 1.0.1)
Image
Éteignez votre mobile et passer le en Mode Flash. (Appuyer sur le bouton Volume Bas et branchez le câble USB, une Led Verte doit s'allumer)
il faut le débrancher et le rebrancher lorsqu'on est entre les deux phases ? car là, ce n'est pas précisé. Bon, je suis chiant mais je suis sûr que certains ont dû avoir les mêmes interrogations avant d'arriver à rooter leur S. Au fait, on fait comment pour avoir une copie écran et la mettre dans un post, stp ?
Voilà, je vais recommencer.
bon impossible de rooter... quand je branche mon téléphone allumé et que je fais le step 1, il ouvre une fenêtre dos, affiche des lignes jusqu'à la ligne appuyez pour continuer et puis il m'affiche deux autre ligne et rien,le tiret passe à la ligne suivante et clignote, rien de plus. La fenêtre reste ouverte. Est-ce normal ?

Bonjour,
Tu aurais du utiliser la méthode 2 :lol:

Pour effectuer les step ton mobile doit être allumé.
Il faut aussi que flashtool soit bien fermé, avant de lancer les step.
pour le flash du firmware tu n'as pas le choix de l'éteindre. :D
Pour mettre une image sur le forum, il faut que tu passe par un hébergeur d'image.

Edit: une petite explication pour poster une image
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #367
ben mon tel est branché allumé, flashtool fermé, je lance step 1 et résultat : la fenêtre dos qui s'ouvre, les lignes de codes et elle reste ouverte apres que j'ai appuyé sur une touche. C'est normal ou elle doit se fermer cette bon sang de fenêtre !!! Pff, un vrai boulet le Taram... T'as raison, je devrais essayer la 2, ça y ressemble plus mon truc.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #368
C'est long à ce lancer mais une fois que tu as d'affiché "appuyé sur une touche", si tu appuies sur une touche elle doit se fermer.
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #369
ok, bon de toute façon je suis seul et je peux plus faire les manip, alors bonne soirée à toi et à demain. :)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #370
Bonne soirée à toi aussi et à demain ;)
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #371
salut, bon j'ai essayé mais je ne suis pas root. est-ce normal que je doive appuyer 2 fois sur "appuyer pour continuer" avant que la fenêtre DOS se ferme ? je crois que je vais avoir du mal avec les manips. je vais recommencer. ce qui me rassure, c'est que j'arrive à flasher. en allant vite entre le moment ou on branche et celui ou l'on appuie sur back, ça passe.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #372
Bonjour Taram,
Essais avec cette méthode
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
, il y a moins de manipulation de flash de firmware à effectuer. 1 flash pour passer en 2.3.7 pour pouvoir lancer le step1 et ensuite le flash en 4.0.4 pour lancer le step2. Une fois ceci fait il faut juste débrancher et rebrancer le mobile au PC.
 
taram7703

taram7703

Membre
Inscrit
14 Mai 2012
Messages
286
Points
18
  • #373
Merci Sebastien, je viens de repasser en gingerbread. juste une question sur la méthode présente avant de tester l’autre. faut-il a chaque redémarrage faire le code pin car je le fais et peut-être qu'il ne faut pas. Bon, je vais tester l'autre méthode de suite :)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #374
Oui il faut que tu rallume normalement le mobile en mettant le code Pin
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #375
Bonsoir!

Je reviens sur le post car ce matin j'ai eu une notification de mise à jour (6.1.A.2.45), mise à jour que j'ai d'ailleurs effectuée. Je sais pas si je suis le seul dans ce cas mais en procédant à celle-ci j'ai perdu le root.

Comment récupérer le root tout en effectuant cette mise à jour?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #376
Bonjour,

Tu aurais pu regarder ceci:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


le firmware .45 tu peux le récupérer là:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Et il y à aussi une nouvelle méthode de Root.
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #377
Oui je n'ai pas été attentif, je viens tout juste de le voir.

Je n'ai qu'à regretter en silence lol. Quelle est cette nouvelle méthode de root?? Est-elle plus rapide que celle présentée sur ce post? Et surtout,surtout, est-il obligatoire de repasser sur GB???

Merci Sébastien pour ta disponibilité

[EDIT] j'avais déjà le firmware .45 mais c'était 6.1.A.0.45
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #378
Oui la nouvelle méthode et un peu plus rapide, beaucoup moins de flash, mais on est obligé de repasser sous GB.
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Smallybaby

Smallybaby

Membre
Inscrit
5 Juin 2012
Messages
42
Points
0
  • #379
Re!

Tuto clair comme d'hab. J'ai réussi à le mettre à jour et à le rooter. J'avoue c'est beaucoup plus rapide. Je savais pas sur quel post répondre par contre.

Maintenant reste à attendre les rom customs pour déverrouiller le BL et avoir de meilleurs performances, surtout niveau batterie....... :roll:

En tout cas merci pour tout! :D

Bonne nuit.
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #380
Bonjour,

Excusez moi je débarque tout juste dans le monde de l'android :oops:
Je viens de m'inscrire sur phonandroid et je voudrais rooter mon téléphone, c'est un portable
nu, mise à jour 6.1.A.2.45. Donc quelle procédure dois-je suivre s'il vous plait?

Merci d'avance :D ,

PS: J'espère m'être adressé dans la bonne section.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #381
Bonjour,
Pour Rooter ton mobile tu es au bon endroit ou regarde un peu au dessus il y a un lien pour la méthode 2. Tout en sachant que ce sont des méthodes pour Bootloader Verrouillé.
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #382
Bonjour,

Merci pour l'info sébastien207. Je pensais utiliser la méthode avec Bootloader Verrouillé pour ne pas perdre ma garantie, et ne pas perdre certains droits.
Si j'ai bien compri mon Bootloader est déverouillable mais reste verrouillé pour le moment. Donc je pourrais utiliser la méthode pour BL verrouillé. J'espère ne pas me tromper en disant ça!
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #383
Oui c'est ça. Donc bonne Root :lol:
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #384
Merci lol :D
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #385
Bonjour,

Je me suis raté je pense, j'ai un point d'exclamation jaune à l'écran :(
Ca craint. J'ai utilisé la méthode 2, j'ai du me planter après le step1.bat, l'étape flashtool.
Comment puis-je me sortir d'affaire SVP?

Edit:
J'ai réussi à passer en Gingerbread, mais après l'étape step1.bat, donc avec flashtool, je suis rester bloqué sur " reading device information" plus de 30min. Et là j'ai eu la bonne idée de fermer flashtool :?
Quand j'ai rallumé mon téléphone j'ai eu à l'écran un point dexclamation jaune dans un paneau triangle et à coté un portable. Help me please...
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #386
Bonjour,
Fait une réparation avec
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #387
Merci, il a redémarré! J'avais réinstallé le firmware que j'avais créé avec flashtool. J'ai du mal créé mon fichier *.ftf peut-être.
Je ne sais pas ce qui s'est passé vraiment. Pas sûr de retenter l'aventure, dommage.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #388
De rien
Pourquoi n'essais tu pas avec un autre firmware?
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #389
Je ne trouve pas de firmware 6.1.A.2.45 nu. De plus dans la méthode 2 pour rooter tout allait bien jusqu'à l'étape step1.bat, j'ai pas bien compri la procédure. Je débranche, je lance step1.bat, je branche ca démarre, je ferme l'écran après, et ensuite j'ai rien compri, j'en ai déduit que je devait lancer flashtool et charger un firmware.
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #390
Celui la ne te plait pas:

il faut que tu fasse les step avec le mobile branché et allumé.
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #391
Merci, je ne savais pas où chercher :? Sinon pour la procédure step1 c'est ok mais c'est juste après que je bloquais. Donc je retente avec le firmware que tu m'a proposé!!!
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #392
Ok, n’hésite pas si tu as un soucis
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #393
C'est sympa de ta part!!! Bon je suis limité en téléchargement sur ton lien, je retente demain. Si j'arrive à décrypter leur texte à retaper, c'est abusé ce truc :D
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #394
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #395
C'est parti! Mais avec mon ADSL de guadeloupe j'en ai pour 39min!!! Je te tiens au courant de l'évolution des choses!
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #396
D'accord ;)
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #397
Pareil, à l'étape ou je dois charger le firmware ca plante, même avec celui que tu m'as conseillé, j'ai encore le point d'exclamation jaune. Je répare et je laisse tomber.
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #398
J'ai eu ca

07/033/2012 19:33:35 - INFO - <- This level is successfully initialized
07/033/2012 19:33:35 - INFO - Flashtool Version 0.8.2.0 built on 2012-05-31 19:51:15
07/033/2012 19:33:35 - INFO - You can drag and drop ftf files here to start flashing them
07/033/2012 19:33:35 - INFO - Device disconnected
07/034/2012 19:34:04 - INFO - Device connected in flash mode
07/034/2012 19:34:11 - INFO - Selected Xperia S_6.1.A.2.45_Nu - FR.ftf
07/034/2012 19:34:11 - INFO - Preparing files for flashing
07/034/2012 19:34:35 - INFO - Please connect your device into flashmode.
07/034/2012 19:34:36 - INFO - Opening device for R/W
07/034/2012 19:34:37 - INFO - Reading device information
07/034/2012 19:34:53 - INFO - Start Flashing
07/034/2012 19:34:53 - INFO - Flashing loader
07/034/2012 19:34:53 - INFO - Ending flash session
07/034/2012 19:34:53 - ERROR -
07/034/2012 19:34:53 - ERROR - Error flashing. Aborted
07/034/2012 19:34:53 - INFO - Device disconnected
07/034/2012 19:34:57 - INFO - Device connected with USB debugging off
07/034/2012 19:34:57 - INFO - For 2011 devices line, be sure you are not in MTP mode
07/035/2012 19:35:14 - INFO - Device disconnected
07/035/2012 19:35:17 - INFO - Device connected with USB debugging off
07/035/2012 19:35:17 - INFO - For 2011 devices line, be sure you are not in MTP mode
07/035/2012 19:35:37 - INFO - Device connected with USB debugging on
07/035/2012 19:35:38 - INFO - Connected device : LT26
07/035/2012 19:35:38 - INFO - Installed version of busybox : N/A
07/035/2012 19:35:38 - INFO - Android version : 2.3.7 / kernel version :
07/037/2012 19:37:19 - INFO - Device disconnected
07/037/2012 19:37:46 - INFO - Device connected in flash mode
07/038/2012 19:38:11 - INFO - Selected Xperia S_6.1.A.2.45_Nu - FR.ftf
07/038/2012 19:38:11 - INFO - Preparing files for flashing
07/038/2012 19:38:25 - INFO - Please connect your device into flashmode.
07/038/2012 19:38:27 - INFO - Opening device for R/W
07/038/2012 19:38:27 - INFO - Reading device information
07/038/2012 19:38:32 - INFO - Start Flashing
07/038/2012 19:38:32 - INFO - Flashing loader
07/038/2012 19:38:32 - INFO - Ending flash session
07/038/2012 19:38:32 - ERROR -
07/038/2012 19:38:32 - ERROR - Error flashing. Aborted
07/038/2012 19:38:33 - INFO - Device disconnected
07/038/2012 19:38:33 - INFO - Device connected with USB debugging off
07/038/2012 19:38:33 - INFO - For 2011 devices line, be sure you are not in MTP mode
07/038/2012 19:38:52 - INFO - Device disconnected
07/039/2012 19:39:38 - INFO - Device disconnected
07/039/2012 19:39:46 - INFO - Device connected with USB debugging off
07/039/2012 19:39:46 - INFO - For 2011 devices line, be sure you are not in MTP mode
07/040/2012 19:40:05 - INFO - Device disconnected
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 733
Points
0
  • #399
Bizarre, essais en installant la dernière version de flashtool.
 
LERICAR

LERICAR

Membre
Inscrit
30 Août 2012
Messages
33
Points
0
  • #400
Bonjour,

Désolé pour le délai de réponse, décalage horaire oblige!
Donc avec la version 0.9.3.0 de flashtool c'est ok, sauf lors du step2.bat.
Quand j'arrive à la step3 il me marque /system/bin/sh: not found Finished!
Rien a voir avec ta copie d'écran. Je pense que ça a échoué.
 
Haut Bas