[TUTO][OREO] Root du Xperia XZ + Installation du TWRP

  • Auteur de la discussion Skelett
  • Date de début
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #1


Un grand merci à
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
!


Source :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


=====================================================================================================================================

Avertissement : Comme précisé dans le titre, ce tuto est UNIQUEMENT pour Oréo. Ne tentez pas de le suivre si vous êtes encore sous Marshmallow ou Nougat. De ce fait, cette opération comporte des risques. Phonandroid et moi-même ne pouvons être tenus pour responsables des éventuels problèmes rencontrés.

=====================================================================================================================================


  • Avoir déverrouillé votre bootloader -->>
    S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
    (Avoir "Bootloader Unlock Allowed : Yes" ne signifie pas que votre appareil à le bootloader déverrouillé, mais simplement qu'il y est éligible ! Vous devez faire les manipulations nécessaires avant de poursuivre ce tuto !)
  • Avoir les drivers ADB installés -->>
    S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
  • Avoir téléchargé les fichiers suivants :

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


- Veuillez choisir le dossier concernant à votre firmware / numéro de build ;
- Dans chaque dossier ce trouve le fichier flashable de Magisk (qui servira au root), le twrp, ainsi que les kernel. Vous aurez besoin des 3 ;
- Concernant les kernel, faites très attention au numéro de modèle ! Si vous avez un F8331, prenez le kernel pour le F8331 et pas un autre ! Si vous vous retrouvez avec un problème quelconque suite à ces manipulations, ce sera la première chose à vérifier !


Du coup, cela ce passe en 2 étapes :

I- Flasher le fichier kernel et le TWRP :

1. Activer le Déboguage USB et autoriser votre PC
2. Extrayez le fichier boot.img du kernel précédemment téléchargé, et l'extraire dans votre dossier adb ou platform-tools (seulement si vous avez installé le SDK Android).
3. Copier ou déplacer aussi le fichier .img du TWRP dans le même dossier cité ci-dessus.
4. Sur ce dossier, appuyez sur Shift + Clique droit de votre de votre souris, et sélectionnez Ouvrir une fenêtre de commandes ici
5. Branchez votre appareil au PC et dans l'invite de commande qui s'est ouverte, rentré cette ligne de commande afin de démarrer votre appareil en fastboot :

Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!

6.Une fois fait, votre LED est maintenant de couleur bleue, ce qui veut dire que tout est bon. Ensuite, flashez le fichier boot.img en entrant cette commande (n'hésitez pas à renommer le fichier afin de l'adapter à la commande) :

Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!

7. Le kernel est donc flashé, on passe ensuite au TWRP :

Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!

8. Redémarrez votre appareil avec cette commande :

Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!

9. Lors du redémarrage de votre appareil, attendez que la LED s'allume jaune (la couleur peut varier selon le bon vouloir des devs des kernels et de Sony eux-même). Dès que c'est le cas, appuyez plusieurs fois sur le bouton volume haut. Là, elle vire au ambre.
Votre appareil démarre alors sur le TWRP

II- Rooter votre XZ sous Oreo / Mettre à jour Magisk :

1. Placez le fichier Magisk-v16.0.zip à la racine de votre appareil ou à la racine de votre carte SD.
2. Démarrez votre appareil en recovery
3. Appuyez sur Installer puis sur Sélectionner emplacement, pour enfin choisir Mémoire interne ou Mémoire Externe
4. Sélectionnez Magisk-v16.3.zip et slidez pour accepter et lancer le flash.
5. Après le flash, le TWRP vous demande si vous voulez effectuez un wipe cache. Vous pouvez ne pas le faire si vous le souhaitez, cependant je vous conseille tout de même de le faire.
6. Redémarrez votre appareil et vérifiez si l'application Magisk Manager est bien présente. Si c'est le cas, c'est fini !

Et voilà ! Votre téléphone est maintenant rooté avec le TWRP v3.2.1-0 d'installé !


N'hésitez pas si vous avez des questions / précisions / corrections.
 
Dernière édition:
Dernière édition:
lohanbarth

lohanbarth

Moderateur Global
Inscrit
8 Novembre 2011
Messages
16 765
Points
63
  • #2
Hello et merci pour le partage :super:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #3
Salut :hello:

Avec plaisir :wink:
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
  • #4
Hello j'ai testé , mais je bootloop a l'ecran Sony

En resumé j'ai flashé une rom Customized AU SW ID/Version: 1302-9157 / 41.3.A.2.107

j'ai flashé le kernel F8331_41.3.A.2.107_CLEAN.img

j'ai flashé le TWRP

Et je suis bloqué , je ne peux accéder au twrp et je bootloop gentiment...
Donc j'ai reflasher ma rom Customized AU en attendant...mon BL est Unlock
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #5
Salut,

Je n'ai pas vraiment de ce qu'il se passe sur ton appareil.

Pour commencer, flash uniquement le kernel et redémarre ton appareil. Est-il bien installé ?
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
  • #6
Voici mon Log :

27/012/2018 13:12:44 - INFO - Device connected in fastboot mode
27/012/2018 13:12:57 - INFO - Selected kernel (boot.img or kernel.sin): C:\Users\user\Desktop\F8331_F8332_41.3.A.2.107_8.0.0_05April2018\KERNEL_F8331_41.3.A.2.107_CLEAN.img
27/012/2018 13:12:57 - INFO - Flashing selected kernel
27/012/2018 13:12:59 - INFO - target reported max download size of 268435456 bytes
27/012/2018 13:12:59 - INFO - sending 'boot' (18100 KB)...
27/012/2018 13:12:59 - INFO - OKAY [ 0.808s]
27/012/2018 13:12:59 - INFO - writing 'boot'...
27/012/2018 13:12:59 - INFO - OKAY [ 0.256s]
27/012/2018 13:12:59 - INFO - finished. total time: 1.064s
27/012/2018 13:12:59 - INFO - FASTBOOT Output:
target reported max download size of 268435456 bytes
sending 'boot' (18100 KB)...
OKAY [ 0.808s]
writing 'boot'...
OKAY [ 0.256s]
finished. total time: 1.064s

Le démarrage m'affiche maintenant le logo Sony noir sur blanc mais cela ne vas pas plus loin .
PS en passant par cmd j'ai le même résultat... Pas de solution
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
  • #7
Je vais attendre des MaJ car je n'y arrive pas bizarrement , pour tout ceux qui n'arrive pas a passer par CMD et doivent le faire par PowerShell , la commande reste la même avec .\
.\adb reboot bootloader

.\fastboot flash boot *nom_du_fichier_kernel*.img

.\fastboot flash recovery *nom_du_fichier_twrp*.img

.\fastboot reboot

( toujours gardé sa TA de coté :frime1: )
 
P

pike31

Membre
Inscrit
14 Décembre 2012
Messages
12
Points
1
  • #8
Bonjour,

Ca marche aussi sur XZ2 compact modele H8324 ? (sous Oreo)

merci
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #9
Salut,

D'après toi ? Est-ce que tu as vu, dans le tuto, ton numéro de modèle ?
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #10
Salut à tous et bravo pour ce tuto!
De mon côté, je suis bloqué à l'étape 6.
En effet, lorsque je rentre la commande pour flasher le kernel, j'ai un message "waiting for devices" qui s'affiche.
Quelqu'un sait il comment résoudre ce problème ?
Précision, dans le gestionnaire de périphériques, j'ai un point d'exclamation jaune à côté du périphérique S01 fastboot.

Merci pour votre aide et bravo à ce forum très instructif !!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #11
Salut,

Il doit manquer les drivers de ton appareil. Tu peux les télécharger sur le site développeur de Sony.
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #12
Merci, mais j'ai déjà installé les pilotes du site Sony Developper
Mon XPeria est bien reconnu lorsque je le connecte en USB, mais en mode Fastboot,, ça ne fonctionne pas correctement

Le gestionnaire de périphériques indique S1Boot Fastboot avec un point d'exclamation.

Les détails de l'état du périphérique sont:

Les pilotes de ce périphérique ne sont pas installés. (Code 28)

Il n’y a pas de pilotes compatibles pour ce périphérique.


Pour trouver un pilote pour ce périphérique, cliquez sur Mettre à jour le pilote.


Je suis têtu, j'aimerais bien résoudre ce problème, avec votre aide!!

Merci
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #13
Ben tu as un problème de drivers, très clairement...

Tu as aussi installé les drivers adb comme précisé dans le tuto ? Si oui, fais la réinstallation des 2 drivers
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #14
Ca avance!
J'ai réusssi à flasher le kernel et à installer twrp
En revanche, twrp me demande un mot de passe au démarrage...

Que faire?

Edit : Me voila bloqué sur le logo sony au démarrage et puis, rien d'autre...

Edit 2 : Ouf, j'ai reflashé le kernel et j'ai pu redémarrer mon téléphone!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #15
Salut,

Merci d'éviter de poster plusieurs messages d'affilés, le bouton "éditer" n'est pas là juste pour faire jolie.

Et content que tu ai réussi.
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #16
Salut, et désolé pour ces messages à répétitions!
A l’avenir, j'éditerai mes posts!

J'ai néanmoins un soucis avec le Twrp, qui me demande un mot de passe...

Des idées sur comment résoudre ça?

Merci beaucoup
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #17
En général, le mot de passe du TWRP est exactement le même mot de passe que tu as mis pour ton écran de verrouillage.

Si ça ne marche pas, c'est un problème de "décryption" du au TWRP et pour le résoudre, il te faudra faire un Factory Reset dans les Wipes du recovery. Mais attention, cela efface littéralement toutes les donnes (images, musiques, etc.) présentes sur ton appareil.
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #18
Je n'ai pas de mot de passe de verrouillage et j'ai déjà fait un "Format Data", sans résultat...
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #19
Comment as-tu effectué le Format Data ?
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #20
Avec l'option Format Data dans le Wipe
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #21
Donc redémarre sur le recovery, vas dans Wipes -> Advanced Wipes -> Coche cache, Dalvik et Data. Redémarre encore sur le recovery, refais un Format Data -> Yes dans les wipes, redémarre encore sur le TWRP.

Qu'est-ce que ça donne ?
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #22
En faisant ça, twrp ne me demande plus de mot de passe, c'est parfait!
En revanche, je ne trouve pas le zip de Magisk, puisqu'il a dû être supprimé par le Format Data!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #23
Effectivement, il a été supprimé.
Le TWRP faisant aussi MTP, branche ton appareil sous TWRP sur ton PC, et transfert le zip de Magisk sur ton appareil.
 
  • Like
Les réactions: wiikita
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #24
On avance! Merci beaucoup pour tes compétences et ta patience!
J'ai réussi à transférer le zip de Magisk et à débuter le flashage.

Mais encore un petit soucis, j'ai un message d'erreur qui me dit:

"Sony ELF64 format detected
Stock Kernel cannot be patched, please use a custom Kernel"
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #25
Quelle version de Magisk as-tu flashé ?

Ca peut être 2 solutions : Soit c'est le kernel qui met le dawa, soit c'est tout simplement Magisk qui n'est pas compatible avec ton appareil (ce qui me semblerait bizarre, mais possible).

Re-télécharge le kernel, et met le fichier sur la mémoire de ton téléphone. Sur le TWRP, vas dans Install -> Install Image -> Selectionne le fichier du kernel puis choisi "Boot".
Une fois flasher, ré-essaye avec Magisk, et vois si ça fait la même chose ou pas.
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #26
Super, ça a fonctionné!
Maintenant, impossible d'aller plus loin que le logo Sony au redémarrage!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #27
C'est à dire ? Logo Sony, puis redémarrage, puis logo Sony, puis redémarrage, etc... c'est ça ?
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #28
Oui, c'est ça!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #29
Chiottes...

Tu ne t'es pas planté de kernel ? Tu as bien prit celui compatible avec ton numéro de build ?
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #30
J'ai installé KERNEL_F8331_41.3.A.2.107_CLEAN.img et mon build d'origine est 41.3.A.2.149.
C'est compatible ?

J'ai re-flashé un .img et du coup le téléphone redémarre, et la bonne nouvelle c'est que je n'ai plus de mot de passe pour le Twrp!!
En revanche, il n'est toujours pas rooté!

je suis maintenant en 41.3.A.2.99
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #31
On y est presque!
J'arrive maintenant à flasher un .zip de Magisk, et le processus va jusqu'au bout!
En revanche, lors du redémarrage, pas de trace de root!
Si je vais sur l'appli Magisk Manager, j'ai un message qui me dit "Voulez-vous installer Magisk-v16.0(1600).zip maintenant?"
Pourtant, je viens de flasher cette version...

Comment résoudre ce soucis?

Merci par avance de votre aide!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #32
Salut,

Ok donc tu avais flashé le mauvais kernel, d'où le bootloop.

Sur la page d'accueil de Magisk, sur la ligne "version installée" tu as bien 16.0 ?

Si oui, passe sur la 16.4
 
L

Larry Jr

Membre
Inscrit
26 Juin 2018
Messages
13
Points
1
  • #33
Salut et merci encore!

Oui, sur la première ligne est inscrit "Dernière version: v16.0"
Et sur la deuxième ligne "Magisk n'est pas installé"

J'ai flashé la v 16.4, mais j'ai toujours le même message

MAJ: J'ai flashé la v16.4 en modifiant les paramètres de Magisk (mise à jour du canal en Béta)
Dans Magisk Manager, ça me dit: "Dernière version v16.4
Magisk n'est pas installé"

Et ça me propose d'installer magisk-v16.4(1642).zip

Problème, je n'arrive pas à mettre la main sur le fichier lorsque je boot sur Twrp...

MAJ2: J'ai flashé la v16.4(1642), mais toujours pas de root en vue...
Magisk Manager me propose encore de télécharger et d'installer la v16.4(1642)...

MAJ3: POur ceux qui, comme moi, bloquent, j'ai réussi à rooter mon xz2 grâce à un tuto en anglais.
Je ne sais pas si je peux mettre le lien du forum qui le propose...
 
D

darkshirata

Membre
Inscrit
11 Décembre 2014
Messages
7
Points
1
  • #34
bonjour,

j'ai dévérouiller mon bootloader,
j'ai flasher avec flashtool la F8331_41.3.A.2.149_1304-9023_R1E.ftf
j'ai mis usb debug on dans les options de devellopeur
j'e met le boot.img de la 149 prix sur xda
je me le recovery
tout ça par adb en fastboot
et a chaque fois je peux aller sur le recovery qui me demande un password
et des que je reboot le tel reste bloquer sur le logo xperia

j'ai aussi essayer avec les ftf F8331_41.3.A.2.75_1305-9091_R4E.ftf et celui de la .157 GL
j'ai toujours le même resulta

les seul warning que j'ai c'est quand je flash le ftf
WARN - No loader found or set manually. Skipping loader
WARN - Unit 2212 not found in bundle
WARN - Unit 2550 not found in bundle
INFO - Closing TA partition
INFO - Opening TA partition 2
WARN - Unit 2553 not found in bundle

j'ai bien mis les driver et j'utilise la derniere version de flashtool
j'ai pris les ftf avec xperia frimware

est-que quelqu'un aurai une solution ?
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
  • #35
J'ai finalement réussi a Rooté le XZ sous Oreo kernel 41.3.A.2.171 avec Magisk 17.1 tout roule mais 'ai pas mal galéré .

Merci
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #36
Skelett a dit:
Ok donc tu avais flashé le mauvais kernel, d'où le bootloop.

Bonjour à tous,

Je me bagarre depuis hier soir avec le tuto je deviens fou je ne sais plus quoi faire.

J'ai donc déverrouillé le bootloader sans soucis puis j'ai changé le kernel pour mettre le F8331 - 41.3.A.2.75_8.0.0.0 car c'est le numéro de build que le Xperia XZ avait avant que je commence le tuto).

Ensuite j'ai réussi à démarrer sur TWRP pour importer Magisk là aussi pas de soucis, mais maintenant d'après TWRP je n'ai plus de système d'exploitation d'installé et le smartphone ne dépasse plus le logo sony, ou dans le meilleur des cas ça boot en boucle. Je précise que j'ai reflasher un coup le boot.img évoqué dans le tuto mais rien n'y fait.

Je ne sais plus quoi faire, j'ai essayé de reflasher la rom avec flashtool pour faire un rollback (retour en arrière) mais le smartphone ne semble pas démarrer en flashmode car flashtool ne réagit pas, la popup avec les instructions de connexion reste ouverte et rien ne se passe (pendant plusieurs minutes) même en gardant le dogit sur le bouton de volume indiqué par flashtool.

Le fastboot fonctionne sans soucis mais en gros j'ai l'impression d'avoir un téléphone vide sans android dedans et je suis perdu je ne sais plus quoi faire pour ne serait ce que juste retrouver le téléphone dans son état initial avec ou sans root... :confused:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #37
Salut,

Tu as dû faire des Wipes, pour qu'il t'affiche que ton appareil n'a plus d'OS. Tu es bon pour une réinstallation complète de l'OS, soit avec Xperia Companion, soit avec Flashtool.
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #38
Skelett a dit:
Salut,

Tu as dû faire des Wipes, pour qu'il t'affiche que ton appareil n'a plus d'OS. Tu es bon pour une réinstallation complète de l'OS, soit avec Xperia Companion, soit avec Flashtool.

Hello merci pour la réponse.

J'ai essayé avec flashtool mais quand je reste appuyé sur le volume - (moins) pour que le logiciel le détecte et l'installe, il 'e se passe rien.

J'ai peut être mal fait quelque chose ?
Y'a t'il une procédure pour refaire ce type de manipulation, maintenant que le problème semble être identifié ?

Édit : Xperia Companion ne détecte pas le smartphone quand je souhaite faire une réparation , j'avais oublié de le préciser .
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #39
Salut,

Tu trompes de touche... Ce n'est pas volume bas, mais volume haut. C'est donc normal qu'il ne le détecte pas.

D'ailleurs, ce sera exactement pareil avec Xperia Companion.
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #40
Skelett a dit:
Salut,

Tu trompes de touche... Ce n'est pas volume bas, mais volume haut. C'est donc normal qu'il ne le détecte pas.

D'ailleurs, ce sera exactement pareil avec Xperia Companion.

Je viens d'essayer plusieurs fois avec Flashtool, il charge la ROM je connecte le XZ mais il ne lance pas le flash, il ne se passe rien après l'étape "Opening Device R/W" .
Xperia Companion ne veut pas faire la réinstalllation à cause du bootloader déverrouillé. :confused:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #41
Pour Xperia Companion, c'est normal, du coup.

Pour FlashTool, mets-moi tout ce qu'il a d'écrit sur le logiciel.
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #42
08/046/2018 09:46:56 - INFO - Selected Bundle for Sony Xperia XZ(F8331). FW release : 41.3.A.2.184. Customization : Orange MCV FR/ES/PL/SK/RO
08/046/2018 09:46:56 - INFO - Preparing files for flashing
08/047/2018 09:47:13 - INFO - Device connected in flash mode
08/047/2018 09:47:36 - INFO - Please connect your device into flashmode.
08/047/2018 09:47:42 - INFO - Using Gordon gate drivers version 3.2.0.0
08/047/2018 09:47:47 - INFO - Opening device for R/W
08/047/2018 09:47:53 - INFO - Device ready for R/W.
08/047/2018 09:47:53 - INFO - Reading device information

Une autre tentative :
08/006/2018 10:06:34 - INFO - Selected Bundle for Sony Xperia XZ(F8331). FW release : 41.3.A.2.184. Customization : Orange MCV FR/ES/PL/SK/RO
08/006/2018 10:06:34 - INFO - Preparing files for flashing
08/007/2018 10:07:17 - INFO - Please connect your device into flashmode.
08/007/2018 10:07:21 - INFO - Device connected in flash mode
08/007/2018 10:07:27 - INFO - Using Gordon gate drivers version 3.2.0.0
08/007/2018 10:07:32 - INFO - Opening device for R/W
08/007/2018 10:07:44 - INFO - Device connected in flash mode

Et après plus rien .

EDIT2 : Et si je revérouille le bootloader, est-ce que ça passerait avec Xperia Companion?
 
Dernière édition par un modérateur:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #43
C'est juste les drivers qui ne sont pas assez récent.

Installe ceux-ci :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Et ceux-là :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Puis réessaye.
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #44
Skelett a dit:
C'est juste les drivers qui ne sont pas assez récent.

Installe ceux-ci :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Et ceux-là :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Puis réessaye.

Je viens de le faire, mais ceux sont les drivers identiques que j'ai installé pour le tuto, dans le gestionnaire de périphérique j'ai quand même voulu updater mais Windows me dit que c'est déjà à jour ("SOMC FLash Device").

:(
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #45
Alors regarde dans ton C:\Flashtool\Drivers et lance l'exe.
Dans la liste qui va s'afficher, sélectionne ton appareil.
 
R

Rootix

Membre
Inscrit
5 Octobre 2018
Messages
9
Points
3
  • #46
Skelett a dit:
Alors regarde dans ton C:\Flashtool\Drivers et lance l'exe.
Dans la liste qui va s'afficher, sélectionne ton appareil.

Le Xperia XZ n'est pas dans la liste, cela s'arrête au Z5 Premium.

EDIT : J'ai fait un restart du PC et maintenant j'ai Sony ADB Driver interface qui s'est installé. Le pc me demande un nouveau restart. Je vais retenter avec FlashTool et vous tient informé.

EDIT2 : Flashtool semble imager, je patiente mais ça sent bon. SI le téléphone conserve le bootloader dévérouillé, je vais retenter le tuto de 0.

EDIT 3 : ROM installé le téléphone est de nouveau normal avec le bootloader dévérouillé. Juste une question, avec Flashtool on est d'accord que l'on peut flasher le KERNEL et le Recovery n'est ce pas ?
Je suis paumé du coup avec tout ce que j'ai cherché pour me dépatouiller depuis jeudi :LOL:.

EDIT 4 : bootloop car du coup je n'avais plus le bon Kernel, j'ai donc prit le bon Kernel et j'ai refait la procédure mais de nouveau bootloop. J'ai reflashé normalement avec la ROM une nouvelle fois. Je remetterai le nez dans le tuto plus tard :rolleyes:. Un grand merci pour l'assistance et les conseils en tout cas (y)
 
Dernière édition:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #47
Bon et bien c'est cool ! Content que tu t'en sois finalement sorti ;)

Pour le kernel et le recovery, pas du tout. Lis le tuto en page 1.
 
B

Bouniii

Membre
Inscrit
1 Octobre 2014
Messages
1
Points
1
  • #48
Bonjour,
Cela fait maintenant plusieurs heures que j'essaye de root mon F8331 sans succès.
J'ai suivi le guide, mais comme un idiot je n'avais pas noté sous quel kernel j'étais, j'ai donc tenté de flash le boot avec la version qui me semblait la plus logique, mais cela m'a causé un bootloop sur le logo Sony.

J'ai donc reflashé mon téléphone avec un .ftf français générique (version 41.3.A.2.192), puis retenté le tutoriel, toujours sans succès (et cette fois avec le clean boot.img qui correspond à ma version).
J'ai ensuite essayé avec toutes les versions disponibles et aucunes n'ont fonctionnées, toujours coincé en bootloop.

J'ai après extrait mon boot.img du firmware .ftf qui fonctionnait, avec espoir de pouvoir le patch au moyen de Magisk Manager, mais encore une fois cela ne fonctionne pas (magisk_log: boot_patch.sh[73]: can't create /proc/self/fd/: Is a directory).

Est-ce que quelqu'un a une idée pour pouvoir root mon téléphone ?
Merci beaucoup d'avoir lu, et encore plus de m'aider,
Bouniii.
 
J

joel SAULE

Membre
Inscrit
13 Mai 2019
Messages
4
Points
1
  • #49
Bonjour j ai un experia xz Android 8 que je voudrais ramène en Android 6 ou 7 Quand tu dis Flasher le fichier kernel c est bien déverrouiller son bootloader ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #50
Salut,

Non, ce sont 2 choses bien différentes (pourtant, en lisant bien le tuto, tu auras compris).

Avant de tenter quelconque manipulation, surtout que tu n'as pas l'air de t'y connaitre vraiment, je te conseille de faire un tour ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
B

bsk1

Membre
Inscrit
18 Décembre 2019
Messages
1
Points
1
  • #51
Bonjour à tous,
Hier je me suis lancé dans l'aventure en suivant ce tuto à la lettre et j'ai bien choisis le bon kernel.
Tout s'est bien passé jusqu’à la fin du flash TWRP.
Et au moment du Reboot, même problème que Dorynous, à savoir logo Sony noir sur fond blanc et Bootloop en permanence.
J'ai essayer de refaire le tuto et j'ai encore exactement le même soucis.
Du-coup est-ce que quelqu'un a la solution à ce problème? :D
( Sony XZ : F8331 : 41.3.A.2.192)

Merci d'avance ;)
 
Dernière édition:
J

julien04131802

Membre
Inscrit
29 Août 2014
Messages
3
Points
1
  • #52
Bonjours a tous , J'ai une petite question si débile soit-elle ....

Pourquoi nous faire télécharger et flasher un kernel ? Ayant flasher une rom juste avant, le Kernel de la rom en question ne suffit-il pas ?
De même que le Kernel de la rom d'origine pour ceux qui ont encore leur stock rom ...

Merci d'avance pour ce petit éclaircissement. :)
 
Dernière édition:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #53
Salut,

Ce n'est pas une question débile, mais légitime. Beaucoup suivent nos tutos à la lettre sans se poser trop de question. Ce qui compte pour eux, c'est le résultat. C'est cool de voir des gens s'intéresser au pourquoi du comment ;)

Sinon, pour te répondre, tout simplement parce que ce sont des kernels patchés et pré-rootés, qui facilitent l'installation du TWRP, rendant accessible la partition recovery, qui ne l'est pas d'origine sur les Sony (essaye de démarrer en recovery sur un Xperia full stock, tu n'y arrivera jamais), et de Magisk.

Non, les kernels de ROM Custom ne suffisent pas. Essaye de flasher un kernel AOSP sur ton Sony, et tu softbrick ton appareil. Aussi, le kernel d'origine des ROM Stock ayant l'accès au recovery fermé, ils ne suffisent pas non plus.
 
Dernière édition:
J

julien04131802

Membre
Inscrit
29 Août 2014
Messages
3
Points
1
  • #54
Skelett a dit:
Salut,

Ce n'est pas une question débile, mais légitime. Beaucoup suivent nos tutos à la lettre sans se poser trop de question. Ce qui compte pour eux, c'est le résultat. C'est cool de voir des gens s'intéresser au pourquoi du comment ;)

Sinon, pour te répondre, tout simplement parce que ce sont des kernels patchés et pré-rootés, qui facilitent l'installation du TWRP, rendant accessible la partition recovery, qui ne l'est pas d'origine sur les Sony (essaye de démarrer en recovery sur un Xperia full stock, tu n'y arrivera jamais), et de Magisk.

Non, les kernels de ROM Custom ne suffisent pas. Essaye de flasher un kernel AOSP sur ton Sony, et tu softbrick ton appareil. Aussi, le kernel d'origine des ROM Stock ayant l'accès au recovery fermé, ils ne suffisent pas non plus.

D'abord merci pour ta reponse , Grace a toi j'y vois déjà un peu plus claire .

Cependant étant en train d'essayer depuis maintenant deux jour complet de rooter ce fichu Xperia xz, f8331 41.3.A.2.192(R9E, c'est la rom stock de orange sur xpfirm) Je me permet de te demander si ton tuto est toujours d'actualité .

Je m'explique , malgrés mes nombreuses tentatives , j'arrive tj a un bootloop aprés le flash du kernel fournis dans ce tuto , c'est d'ailleurs le cas pour tous les autre kernel que j'ai trouver chez mon vieux copain google ...Parmis tous ce que j'ai essayer , le tiens me permet de flasher proprement magisk mais m’empêche d"allumer mon telephone en me laissant dans un bootloop ou au mieux bloquer sur le logo sony. et certain autre me disent systematiquement que mon boot img format n'est pas compatible au moment de flasher magisk ... c'est un veritable casse tête, je pense pourtant avoir bien compris les fondamentaux et executer la procedure correctement. Donc pour ma part jje pense que le soucis vient du kernel ... j'ai fait tous les wipe et je suis certain d'avoir choisit les bon fichier par rapport a ma version. Auriez-vous une idée ? ou mieux un kernel qui me permet a la fois d'installer magisk et de demarrer mon telephone ... et pas l'un ou l'autre xD

Encore une fois merci d'avance de prendre du temp pour m'aider. Vous etes reellement mon dernier recours ... j'ai passer plus de 30 h sur le probleme, essayer de nombreuse rom differente et j'arrive tj au meme resultat. Merci d'avance!
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 978
Points
113
  • #55
Mon tuto est d'actualité, pour la build indiquée.
N'ayant plus de Xperia, je ne suis pas vraiment les mises à jour, quand il y en a.

Aussi, a chaque build son propre kernel patché (si les devs indépendants ont travaillé dessus).
Enfin, les Xperia font parti des téléphones où on ne peut pas utiliser le kernel de build précédentes sous peine de sérieux bugs.

Pour finir, le kernel patché est présent dans le lien Mega du tuto, vers la fin de la liste.
 
Dernière édition:
J

julien04131802

Membre
Inscrit
29 Août 2014
Messages
3
Points
1
  • #56
Skelett a dit:
Mon tuto est d'actualité, pour la build indiquée.
N'ayant plus de Xperia, je ne suis pas vraiment les mises à jour, quand il y en a.

Aussi, a chaque build son propre kernel patché (si les devs indépendants ont travaillé dessus).
Enfin, les Xperia font parti des téléphones où on ne peut pas utiliser le kernel de build précédentes sous peine de sérieux bugs.

Pour finir, le kernel patché est présent dans le lien Mega du tuto, vers la fin de la liste.

Comme je te l'ai expliquer , j'ai pris tous les fichier correspondant , j'ai la version f8331 41.3.A.2.192, et j'ai bien pris le kernel F8331 41.3.A.2.192 CLEAN ... qui se trouve effectivement en bas de la liste que tu nous a fourni sur mega . Mais Bootloop a TOUS les coups...
 
K

KinfOgTheMeat

Membre
Inscrit
17 Juillet 2020
Messages
1
Points
1
  • #57
Bonjour,

j'ai suivie le tuto mais je bloque sur un truc stupide. Lorsque je met le fichier .zip dans mon téléphone, je ne peux que le mettre dans la mémoire interne partagée, ce qui n'est pas bien grave mais lorsque je vais sur le recovery TWRP, il m'est impossible d'accéder à cette partie de la mémoire. J'ai réussi tant bien que mal à enlever le mot de passe qu'il demande au démarche de TWRP pour bloquer sur ça :cautious:

En espérant avoir une réponse (ça fait 16h que j'essaye de root mon xperia :cry:)

PS : Je n'ai pas de microSd, elles sont toutes HS

Edit: J'ai réussi à trouver une carte SD dans un carton ^^

EDIT2: Tout marche parfaitement, merci pour ce tutoriel (même si j'ai pioché dans 3 tuto au total ^^)
 
Dernière édition:
Haut Bas