[TUTO]Créer un boot animation custom

  • Auteur de la discussion brybe
  • Date de début
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Bonjour à tous bon voilà suite à une requête je vous fais ici un tuto pour créer vous même vos boot animations et en faire des zip flashables en recovery (facile d'installation) wink
Alors je vous dis tout de suite c'est la première fois que je fais un tuto alors soyez cool

Alors ce qu'il vous faut:

- des images , des animations , et en réalité.... des animations décomposées en images....

pour celà internet ^^ et oui vous allez probablement comme moi passer plus de temps à en chercher qu'a travailler dessus.
pour décomposer les gif animés j'utilise bloggif
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


- un logiciel pour travailler vos images décomposées, j'utilise photoshop...( je vous préviens celà va vous prendre du temps)
je ne ferais pas de tuto photoshop c'est à vous de vous expérimenter .

- "Boot animation factory" logiciel sur XDA
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

pour créer un boot animation

- "Android ultimate toolbox pro" logiciel sur XDA
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

pour créer un zip flashable en recovery

- 7zip si vous ne l'avez déjà pas
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

pour pouvoir mettre votre signature ...vous savez? le truc qui défile en recovery quand vous flashez ben vous pourrez y mettre votre nom/marque de fabrique... tongue


Allez on zy go:

- les images , animations et etc...sa je vous laisse faire il faudra juste ne pas oublier de les redimensionner pour votre mobile là ... ça dépend de vous.

alors...une fois vos images prêtes à emploi donc , petite astuce ; renommez vos images décomposées d'animation par ordre avec un numéro ( attention !! 0 , 01 , 02, 03 etc...n'oubliez pas le zéro avant le 1 , 2 , 3 etc... jusqu'a 09)

créer un dossier sur votre bureau exemple " boot animation machin truc" ; dans mon image il s'appelle "test"

à l'intérieur de ce dossier créer d'autres dossier appelés " part" exemple ici avec "part0" "part1" "part2"



Pas de Panique!!! je vous explique ...

"part0" contient la première animation donc ; toutes les images (numérotés par ordre wink ) de votre première animation ; alors pour exemple moi la première partie c'est un logo pas forcément une animation donc une seule image pour ma part

"part1" contient la deuxième animation donc; toutes les images de la deuxième animation ( un chien qui crotte ou ce que vous voulez ça.... ça ne me regarde pas)

et ainsi de suite si vous avez plusieurs animations on peut allez jusqu'a "part9" si j'ai bien compris....

donc vous voilà avec un dossier "machin truc" sur votre bureau contenant "part0" "part1" "part2" etc...


Vous êtes maintenant prêts pour attaquer Boot animation Factory:



alors vous faites "create new boot animation"



vous choisissez " folder"

vous sélectionnez votre dossier sur le bureau

et là vous allez avoir :


on explique : "480, 800" celà correspond au format de l'image celà dépend de votre mobile .
"30" correspond au nombre d'image par seconde
vous pouvez changer les valeurs en cliquant sur la ligne et puis sur "edit" en bas

bref... faites "add a loop"



vous choisissez quel " part" ,combien de loop et le delai à la fin du loop

je m'explique;
-bon "part" c'est quelle animation vous voulez
-le nombre de loop : ici j'ai mis "60 " à savoir qu'il fait 30 images par seconde ( si vous n'avez pas changé la première ligne) pour une seule image dans un dossier "60" correspond à 2 secondes et etc...pour une animation toute faite "1" jouera l'ensemble des images une fois et etc
- le délai ben c'est en millisecondes à la fin d'un loop

si vous voulez une boucle infinie mettez tout à "0" mais je vous préviens faites le sur la dernière animation car autrement ben...oui....la boucle est infinie donc les suivantes ne passeront jamais ....

Je ne sais pas si c'est assez clair en tout les cas essayez ...
ne vous inqiétez pas une fois que vous avez entré toutes vos données vous avez la possibilité de prévisualiser
donc... essayez et prévisualisez jusqu'au résultat désiré ^^



une fois le résultat satisafaisant, faites "save boot animation"

sauvez le sur le bureau et nommer le "bootanimation"



Vous avez donc maintenant un zip "bootanimation" sur votre bureau vous pouvez le revisualiser avec Boot animation factory
et vous venez de créer votre premier boot animation... c'est chouette non? non? ^^ mais c'est pas encore fini...

Maintenant on va en faire un zip flashable en recovery

on ouvre Android toolbox pro :



alors je sais pas pour vous mais moi quand je l'ouvre à chaque fois il me demande un update alors qu'il est à jour bref...faites le une fois , deux si vous voulez , mais ensuite faites juste annuler....

faites "create update zip"




puis faites "add file"



choisissez votre "bootanimation" zip que vous venez de créer sur le bureau

choisissez "system/media"



cliquez sur le fichier et faites "set permission"



choisissez un des trois codes moi j'ai essayé les trois et sa marche



maintenant faites "save" et nommer votre zip flashable

vous allez maintenant remarquer qu'il y a " _signed" à la fin du nom de votre zip...renommez le au besoin

Félicitations!!! vous avez un boot animation flashable en recovery....fini? eh ben non.....mais on voit le bout...on voit le bout bigsmile

Maintenant dernière partie mouth. mettre votre propre signature dans le recovery....

j'explique; le fait d'avoir créer un zip flashable en recovery par " Android tool box pro" fait aussi que lorsque l'on regarde le texte défiler dans le recovery on s'aperçoit qu'il porte la signature du logiciel et de son créateur....pas grave que j'entends-je?
oui mais nous sommes des perfectionnistes n'est-ce pas?....et c'est agréable d'avoir son nom de boot animation et sa signature ...ah quand même c'est vous qui l'avez créé ce boot animation...que diable!!

alors voilà déjà il faut avoir 7zip ;
faites un click droit sur votre zip flashable et ouvrez avec 7 zip



ouvrez "META-INF" puis "com" puis "google" puis "android" et vous arrivez là




ouvrez "updater-script" avec bloc- notes




alors on a ces deux champs à changer je les ai surlignés en bleu




celui de gauche c'est pour le titre du boot animation et celui de droite pour votre nom.
Ne changez rien d'autre à moins de vous y connaître

Faites "enregistrer sous" sur votre bureau et nommer le "updater-script"



OK maintenant revenez dans la fenêtre de 7zip et supprimer "updater-script"

faites un glisser coller avec votre nouveau " updater-script" de vote bureau , une fenêtre de confirmation apparaît faites ok
et vous avez "updater-script.txt"



renommer le juste "updater-script" et il remplace l'ancien ^^

Et voilà vous avez un boot animation que vous avez fait vous-même ,flashable en recovery et portant votre signature

wouuuu finito !!! j'espère que celà vous sera utile personellement j'ai beaucoup aimé en faire ^^
à vous de jouer et bon boot animation à tous

sans oublier...vive Phonandroid!! wink
 
mahoni

mahoni

Membre
Inscrit
26 Septembre 2012
Messages
5 487
Points
0
Bonjour
Merci pour le partage wink
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Avec joie ^^
 
The x Prodige

The x Prodige

Membres VIP
Inscrit
8 Septembre 2012
Messages
1 102
Points
36
Pas moi , j'ai découvert un nouveau logicel grace à toi , et si tu veux je ferais un tuto pour les anim ( Cinema 4D)
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
ce serai vraiment chouette ^^
 
The x Prodige

The x Prodige

Membres VIP
Inscrit
8 Septembre 2012
Messages
1 102
Points
36
Un truc basique aussi ^^
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
réservé ^^ ça m'interesse !! tiens moi au courant
 
The x Prodige

The x Prodige

Membres VIP
Inscrit
8 Septembre 2012
Messages
1 102
Points
36
Donne moi la résolution de ton écran stp
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
mon écran 480x800 galaxy s2 i9100
 
The x Prodige

The x Prodige

Membres VIP
Inscrit
8 Septembre 2012
Messages
1 102
Points
36
Laisse moi le temps d'acheter un micro et la je pourrais faire le tuto ( Youtube )
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
ya pas de soucis rien ne presse wink je rajouterai un lien dans mon tuto .
 
Kal-el59

Kal-el59

Membre
Inscrit
30 Mars 2012
Messages
133
Points
0
Super Tuto Brybe ! ;)

+1 concernant le futur tuto de Maxcraft02 !!!! :cool:
 
skorpion

skorpion

Membre
Inscrit
4 Juin 2012
Messages
627
Points
16
Merci pour cet excellent tuto, jamais vu mieux et aussi pertinent, fonctionne du 1er coup, l'option preview notamment :)
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Merci les amis wink vraiment je compte pas vraiment faire carrière dans la création de boot animation alors pour ceux qui souhaitent en faire j'espère que ce sera un bon coup de pouce...aussi , partager vos créations ; j'ai pas vu beaucoup de boot animation customs sur phonandroid...je suis certain qu'avec le tuto de maxcraft02 en plus sa va déchirer!! smiley
 
X

XxbrandoXx

Membres VIP
Inscrit
19 Février 2013
Messages
1 670
Points
0
Merci pour ce Tuto ( qui est très bien pour pas dire excellent :lol: :lol: et qui à du te prendre du temps :mrgreen: )
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Merci beaucoup bigsmile
 
B

Bdmiam2

Membre
Inscrit
1 Janvier 2013
Messages
23
Points
0
Chez moi, il ne s'enregistre pas sur le Bureau quand je clique sur Save as Update.zip ? Comment faire ?
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Bdmiam2 a dit:
Chez moi, il ne s'enregistre pas sur le Bureau quand je clique sur Save as Update.zip ? Comment faire ?
il faut que tu définisses l'endroit (donc le bureau à gauche de l'écran) avant de valider...après avoir tapé le nom du zip tu cliques sur le bureau à gauche de la fenêtre pour définir que c'est là que tu veux sauvegarder...je sais pas si j'ai été clair...j'espère que tu réussiras
 
B

Bdmiam2

Membre
Inscrit
1 Janvier 2013
Messages
23
Points
0
Oui, ça je le sais mais quand je clique sur Enregistrer, il me dit successfully saved et puis il n'apparait pas sur le bureau !
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
C'est bizarre... hmm tu as essayé de faire une recherche dans le menu démarrer pour savoir où il l'a sauvegardé?
Je n'ai pas ce soucis personellement
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
mmmm...je viens de réessayer une dizaine de fois et je n'ai pas de problèmes..... hmm
ceci n'est pas une offense, j'essaye de comprendre et t'aider...as tu suivi toutes les étapes correctement?
 
B

Bdmiam2

Membre
Inscrit
1 Janvier 2013
Messages
23
Points
0
Oui, je le fais sur un autre ordi et ça marche mais sur le mien il ne veut pas... Je ne comprends pas du tout là ???
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Mince.... sad alors là je sais pas....
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Bdmiam2 a dit:
Oui, je le fais sur un autre ordi et ça marche mais sur le mien il ne veut pas... Je ne comprends pas du tout là ???
peut être tenter une désinstallation du programme puis reinstallation....ou aussi voir les droits administrateur...enfin je sais pas ... c'est quand même bizarre undecided
 
G

gicman

Membre
Inscrit
27 Février 2013
Messages
62
Points
6
salut a tous donc voila j' ai un soucie avec android ultimate toolbox , quand je sauvegarde leboot logo que j ai fait il se met sur le ureau deux seconde et disparait voir se met pas du tout des fois , comment puis je faire ? help me
 
G

gicman

Membre
Inscrit
27 Février 2013
Messages
62
Points
6
je suis sous windows 8 et sa ne marche pas sur windows7 j'arrivemais aprerje n'arrive pas a metre le boot logo sur letelephone
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
gicman a dit:
je suis sous windows 8 et sa ne marche pas sur windows7 j'arrivemais aprerje n'arrive pas a metre le boot logo sur letelephone
Bonjour , je connais pas windows 8 malheureusement. Sur seven comment procèdes tu pour le transfert ? j'utilise air droid personellement mais je pense qu'avec un cable usb celà est faisable de même...as tu vérifié l'emplacement de ton transfert?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 750
Points
0
Salut,
J'ai suivi toute la procédure, mais lors du flash j'ai un "status 4"
Une idée d'où le problème peu venir ?
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
sebastien207 a dit:
Salut,
J'ai suivi toute la procédure, mais lors du flash j'ai un "status 4"
Une idée d'où le problème peu venir ?
Pardon pour le retard je ne me connectais plus récemment. Non aucune idée... :?: désolé peut-être réessayer en suivant bien les étapes ( je sais que tu as du essayer plusieurs fois déjà...ne sachant que dire d'autre malheureusement je suis obligé de le faire)
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 750
Points
0
En fait j'obtient cette erreur lorsque je modifie la signature. Donc je ne la modifie pas et ça passe
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
sebastien207 a dit:
En fait j'obtient cette erreur lorsque je modifie la signature. Donc je ne la modifie pas et ça passe
D'accord ^^ c'est quand même bizarre chez moi ça marche. Bon l'essentiel c'est que ton boot anim fonctionne ^^
 
Al06

Al06

Membre
Inscrit
5 Juillet 2013
Messages
51
Points
0
brybe a dit:
C'est bizarre... hmm tu as essayé de faire une recherche dans le menu démarrer pour savoir où il l'a sauvegardé?
Je n'ai pas ce soucis personellement

J'ai le même problème d'enregistrement que Bdmiam2 ! Je fais enregistrer sur le bureau (j'ai essayé aussi dans mes documents) : rien...
j'ai utilisé la fonction rechercher, ça me propose les fichiers (j'ai essayé plusieurs fois) comme si ils existaient, mais ils sont introuvables...
Dans Android tool box ils aparaissent dans la liste des fichiers enregistrés, avec la bonne adresse...
Ils restent invisibles (j'ai même fait afficher les fichiers cachés)...
J'ai bien regardé au moment de l'enregistrement, le fichier apparait sur le bureau et disparait aussitôt...
Ghost buster à l'aide ! ! !

Là je m'arrache les cheveux (déjà que j'en ai plus beaucoup ! ! ! :D )

______________________

J'ai réinstallé le programme....
Je viens de scanner tous mes disques durs et la corbeille : les fichiers apparaissent dans la recherche, mais ne sont que virtuels car ils restent introuvables !
Depuis le temps que j'utilise un ordinateur je n'avais pas encore rencontré ce cas de figure ! ! !
Non mais c'est diiinngggue ! tongue mad1

_______________________

Suite et fin... sans plus d'explications !
J'ai refais la même chose sur mon PC portable et là tout c'est déroulé sans problème ? ? ?
Si quelqu'un a ne serait-ce qu'un début d'explication je suis très intéressé wink smiley

Et surtout MERCI pour ton tuto super bien fait :D
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Salut Je suis désolé de ne pas avoir répondu plus tôt Je ne suis plus souvent sur le forum car manque de temps.
Je ne saurais expliquer le soucis que vous avez rencontré car je ne suis pas un as de l'informatique. Chez moi ça marche , après ben c'est peut-être le gars qui mal programmé mais je ne jugerai car je ne saurais faire ce qu'il a fait lol. Content de voir que ça fini par fonctionner.
 
F

Fares7680

Membre
Inscrit
2 Septembre 2013
Messages
1
Points
0
Bonsoir à tous. J'en ai marre de ça! Je viens d'exploser mon ordinateur portable car le fichier qui devait sortir sur le bureau n'apparaît pas. Je ne comprends plus rien à cela. J'ai répété cette même opération une dizaine de fois mais sans succès. Le logiciel affiche pourtant un message de succès mais rien y faire. Il me reste plus que mon pc fixe maintenant. Il faut que j'arrive à me contrôler. Toute aide sera la bienvenue. Merci, bon dimanche.
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Fares7680 a dit:
Bonsoir à tous. J'en ai marre de ça! Je viens d'exploser mon ordinateur portable car le fichier qui devait sortir sur le bureau n'apparaît pas. Je ne comprends plus rien à cela. J'ai répété cette même opération une dizaine de fois mais sans succès. Le logiciel affiche pourtant un message de succès mais rien y faire. Il me reste plus que mon pc fixe maintenant. Il faut que j'arrive à me contrôler. Toute aide sera la bienvenue. Merci, bon dimanche.
Mince j'espère que ton portable s'en tirera. Je n'ai pas de soucis concernant l'enregistrement sur le bureau. essaye de remonter le post je crois que "Bdiam" a eu le même soucis. Je ne sais pas si il a réussi depuis , peut-être lui envoyer un mp? J'espère que tu trouveras une solution
 
Morgane3D

Morgane3D

Membre
Inscrit
13 Juin 2012
Messages
183
Points
0
Merci pour le tutoriel. ça ne marche pas sur Xperia P. J'ai tout fais, et tout suivis à la léttre. Je flash, mais mon android démarre avec le boot d'origine. Je crois que sur Sony, c'est pas Média, ou les permissions doivent changer. une solution ??
 
B

brybe

Membre
Inscrit
9 Mars 2013
Messages
71
Points
6
Morgane3D a dit:
Merci pour le tutoriel. ça ne marche pas sur Xperia P. J'ai tout fais, et tout suivis à la léttre. Je flash, mais mon android démarre avec le boot d'origine. Je crois que sur Sony, c'est pas Média, ou les permissions doivent changer. une solution ??
Aucune idée malheureusement je suis sur S2, tu as essayé d'autres codes de permissions proposés?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 750
Points
0
Morgane3D a dit:
Merci pour le tutoriel. ça ne marche pas sur Xperia P. J'ai tout fais, et tout suivis à la léttre. Je flash, mais mon android démarre avec le boot d'origine. Je crois que sur Sony, c'est pas Média, ou les permissions doivent changer. une solution ??
C'est que tu t'y prend mal, car c'est bien dans "media" que se trouve les bootanimations.
Je réalise les boot et ils passent très bien sur mon Xperia S.

Vérifie que tu le nomme correctement, tu dois avoir un fichier nommé "bootanimation_signed.zip" que tu flash depuis le recovery.
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Bonjour,​
Magnifique tuto tout d'abord, mais j'ai un petit problème avec BootAnimationFactory, quand je sélectionne mon dossier, il me met "X" à la place de "V" en haut à gauche, pourquoi ? Et j'ai essayer avec le dossier, le bureau, les sous dossier et pulsieur dossier que j'avais, mais toujours cette croix ! :'( Et y a t'il un format spécifique pour les images ? (les miennes sont au format png, dois-je les convertir ? )
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Bonjour,​
Magnifique tuto tout d'abord, mais j'ai un petit problème avec BootAnimationFactory, quand je sélectionne mon dossier, il me met "X" à la place de "V" en haut à gauche, pourquoi ? Et j'ai essayer avec le dossier, le bureau, les sous dossier et pulsieur dossier que j'avais, mais toujours cette croix ! :'( Et y a t'il un format spécifique pour les images ? (les miennes sont au format png, dois-je les convertir ? )


(Désolé pour le doublon, le premier n'apparaissait pas)
 
X

x59xnatcf

Membre
Inscrit
24 Décembre 2013
Messages
14
Points
0
Bonjour,

Je suis arrivé a la premiere etape du tuto que jai deja un probleme...
En effet, lors de l'ouverture de mon fichier avec ton logiciel sa me met que limage ne rentre pas dans le tableau.. et sa refuse.. jai essayer de modifier la taille ou le FPS mais sa ne fait rien..
Il y a une solution...?

Merci,
Cordialement,
Nathan.
 
T

Thomasv24

Membre
Inscrit
16 Novembre 2013
Messages
7
Points
1
Bonjour, j'ai un problème tout se passe bien mais quand je redémarre, cela me met juste le mot android comme boot animation donc voila :-(
 
R

replay21

Membre
Inscrit
11 Mai 2013
Messages
22
Points
1
bonjour a tous , se tuto est super merci bien , mais petit problème , mon animation est méga lente .... :pleur4:
un idée ?
merci
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Bonjour, si ton animation est lente tu n'a qu'a augmenter la vitesse des fps dans la première ligne après les dimensions de l'écran (par exemple : met 30 ou 40).
 
ludo1981

ludo1981

Membre
Inscrit
21 Octobre 2013
Messages
599
Points
18
Bonjour,

j'ai fais toutes les démarches, flasher en recovery mais rien ne ce passe. je fais flasher à partir de ma carte sd ext et j'ai toujours mon bootanimation d'origine...
Que dois je faire ou n'ai pas fait?
Je me retrouve avec 2 dossiers meta inf et sysytem. Dans system y a un dossier zip contenant un dossier part avec toutes les animations. Dans le premier dossier j'ai 3 dossiers.
Lequel zip je dois mettre et flashé, celui qui contient tous les dossiers ou le zip avec part?
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Le .zip avec part ( qui contiennent tes images ).
 
ludo1981

ludo1981

Membre
Inscrit
21 Octobre 2013
Messages
599
Points
18
Opération aborded
Avec triangle rouge
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Autre solution :

Rend toi dans system / média avec un explorateur de fichiers. Supprime ou Renomme le bootanimation.zip puis colle l'archive bootanimation.zip que tu a créé.
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
Bonjour !
J'ai tout bien suivi (j'ai pris pas mal de temps), mais mon animation reste figée au premier dossier part...

Sur la prévisualisation tout fonctionne bien, j'ai mis un son de 5/6 s en .mp3 ça peut bloquer ?

Merci d'avance :)

@ The X Prodige:

Je fais aussi de l'animation 3D sur Cinema4D, j'essayerai plus tard de m'en faire une !
J'ai pas trouvé le lien pour le tuto :3


@ x59xnatcf:

Même problème. Tu dois mettre toutes tes images en .JPG, pas en .gif !
Utilises ça:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Tu peux renommer pleins de fichiers en même temps (en gardant l'ordre) et changer l'extension de toutes les images du dossier :)

@chef chauffard:

Pour ton problème, c'est le fichier que tu as crée avec Android Toolbox Pro, celui qui termine par _signed que tu dois flasher.

Cordialement.
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Slt,

Moi une fois ma bootanimation était trop "lourde" pour mon tél et elle se ne lançais pas.
Peut tu montrer tes parts ?
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
Bonjour :)
Autre problème (oui osef de mon 1er :D), j'ai fais un gif propre sur Easy Gif Animator, le problème c'est que l'animation est trop rapide...
Le logiciel Boot Animation Factory découpe bien toutes les frames (j'importe directement le .gif), mais ne maintient plus les images..
Par exemple, j'ai un texte qui clignote, il va pas faire de poses, il va passer d'une image à l'autre instantanément.

Lien de mon bootanim:

Une idée ?

Merci d'avance :)
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Sinon après avoir découpé ton gif en plusieurs frames, tu créé différents dossiers ( part0, part1, part2... ) et avec le logiciel Boot Animation Factory tu met un nombre de loop différents des autres.
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
D'accord donc j'ai mon .zip:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Mon .zip flashable:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


J'installe le .zip flashable grâce a clockworldmod (sans aucun wipe)...

J'obtient ceci:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Un piti carré blanc !

Oui la résolution est pas la bonne (je la change), mais même, il devrait y avoir un truc :)

EDIT: Avec la bonne résolution (720*1280), écran blanc. :l
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
essaye avec celle-ci >>
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
Certaines frames ne sont pas du tout dans l'ordre, mais on s'en approche !
La résolution aussi est pas la bonne ;)

Je ré-edit la mienne et je vais essayer de ne pas la mettre flashable, juste en C/C :)
Je te tiens au courant !
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
MAJ:

Donc !
J'ai refais un bootanimation.zip avec 3 part, mais mon samsung reste bloqué sur le part0 ...

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Une fois bloqué il reste sur un écran noir ...

Une idée ?

[EDIT] C'est pas un écran noir, il reste bloqué sur la première frame du part1 !
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
LDami a dit:
Certaines frames ne sont pas du tout dans l'ordre, mais on s'en approche !
La résolution aussi est pas la bonne
Pour la résolution j'ai mis 720x1280. Ces ont les même dimensions que la tienne.

Sinon pour l'ordre essaye de renommer les frames >> 99 = 099
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
Oui j'ai tout refais lis mon double post :)
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
L'animation est trop rapide !
Tu n'as pas un moyen de la ralentir un petit peu ? :)

Merci d'avance !
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
A part la vitesse, l'animation répond t-elle à ta demande ?

Pour la vitesse tu peut le faire toi même :

>> ouvre l'archive .zip
>> ouvre le fichier desc.txt
>> à la 1ère ligne il y a 720 1280 30, ici le trente correspond à la vitesse
>> modifie le 30 ( tu peut le remplacer par 20 ( un exemple ) )
>> enregistre le fichier
 
L

LDami

Membre
Inscrit
16 Mai 2013
Messages
17
Points
1
C'est parfait !!
Merci ! C'est vrai que j'avais oublié le nombre de frames par secondes :p

Je vous partage le bootanim dès que j'ai fini mes petits ajustements :)

Merci pour tout :)
 
A

al-sony

Membre
Inscrit
9 Septembre 2011
Messages
141
Points
0
Salut,

Merci pour le tuto.
Pour ma part je crée le zip etc tout se passe bien, je la flash etc mais j'ai toujours le logo samsung :/

J'ai même essayé avec bootanimations et rien n'y fait :/
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Slt,

Vérifie dans system/media quel bootanimation tu a.
 
A

al-sony

Membre
Inscrit
9 Septembre 2011
Messages
141
Points
0
Salut,

J'ai finalement réussi à le flasher, et l’animation est bien la, seulement, elle ne finit jamais et reste au premier plan.
Je m'explique :

La tablette démarre, le logo personnalisé s'affiche mais ne disparait jamais, par contre si je tourne la tablette à la verticale, j'arrive à voir le pad numerique sur la moitié de l'ecran, l'autre moitié le logo est toujours la, je rentre le code pin et je vois encore que la moitié de l'écran.

Une solution ? Merci
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
A mon avis c'est surement un bug car si ça aurait été un problème de bootloop tu ne devrais pas voir le pad numérique ( de ne rien faire ).
Essaye d'enlever ta bootanimation pour voir si le problème viens de la.
 
D

dakdakou

Membre
Inscrit
17 Mai 2014
Messages
1
Points
0
Hey,

Pour ceux qui n'arrivent pas à créer le zip, ou bien qu'il s'auto-supprime, il faut installer Java ou bien le mettre à jour.
Cela à réglé mon problème.
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
Salut à tous,

Tout d'abord super tuto merci !!!
En revanche j'ai tout de même un souci. L'animation s'arrête dans mon 1er part , aux environ de la 100-130 frames.
L'écran reste noir et lorsque le système est chargé, j'arrive normalement sur l'écran du code PIN.
Mais du coup j'ai que 3-4 sec d'animation puis 5-6 sec de noir....

une idée ? Je peux vous fournir plus de détails si besoin.
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Montre nous le fichier de ta bootanimation stp.
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
Yop,
Ok, mais je suis parti en vacances pour la semaine. Je vous donne ça ce week-end en rentrant.
Merci
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
brybe a dit:
maintenant faites "save" et nommer votre zip flashable

vous allez maintenant remarquer qu'il y a " _signed" à la fin du nom de votre zip...renommez le au besoin
:hello:

Après le clic sur "SAVE" mon zip est exactement le même qu'avant, aucun dossier "META-INF" ou autre dedans que part0 ...

Une idée ??
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
iMiTcH a dit:
brybe a dit:
maintenant faites "save" et nommer votre zip flashable

vous allez maintenant remarquer qu'il y a " _signed" à la fin du nom de votre zip...renommez le au besoin
:hello:

Après le clic sur "SAVE" mon zip est exactement le même qu'avant, aucun dossier "META-INF" ou autre dedans que part0 ...

Une idée ??
Salut, as-tu bien le framework.net v4 et le sdk d'android installés ?
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
maxime3447 a dit:
Salut, as-tu bien le framework.net v4 et le sdk d'android installés ?
Le framework oui c'est sur, en revanche sdk il me semble pas. Celui ci >
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
?
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
Ok merci beaucoup je compile ce soir et je vous dit ;)

:super:
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Avec plaisir, j'espère que ça fonctionneras ;)
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
Re,

bon j'ai un peu zappé à mon retour de vacances dsl...
la voici
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
@Tickle Slt, possible d'avoir un screen ?
:hello:
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
@Tickle
Essaye cette modif et dis moi >>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
maxime3447 a dit:
iMiTcH a dit:
maxime3447 a dit:
Salut, as-tu bien le framework.net v4 et le sdk d'android installés ?
Le framework oui c'est sur, en revanche sdk il me semble pas. Celui ci >
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
?
Pour être sur, je te conseil de télécharger
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
Non même soucis avec Toolbox pro, il me dit "succes" alors que je n'ai pas le nouveau zip de créer. :/
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Re: Re : [TUTO]Créer un boot animation custom

iMiTcH a dit:
maxime3447 a dit:
iMiTcH a dit:
maxime3447 a dit:
Salut, as-tu bien le framework.net v4 et le sdk d'android installés ?
Le framework oui c'est sur, en revanche sdk il me semble pas. Celui ci >
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
?
Pour être sur, je te conseil de télécharger
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
Non même soucis avec Toolbox pro, il me dit "succes" alors que je n'ai pas le nouveau zip de créer. :/
J'avais le même problème, et c'est parti en réinstallent le framework.net 4 (pas 4.5), java (jdk + jre si ma mémoire est bonne) et le sdk.
Bon courage ;)
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
Ok, bon je vais clean ce soir et je verrais si ça change quelque chose.
Je vais test de compiler sur mon mac, on verra bien.

Si je trouve, je partage ;)
:hello:
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Re: Re : [TUTO]Créer un boot animation custom

iMiTcH a dit:
Ok, bon je vais clean ce soir et je verrais si ça change quelque chose.
Je vais test de compiler sur mon mac, on verra bien.

Si je trouve, je partage ;)
:hello:
pas du tout une bonne idée, désolé : les fichiers ".DS_store" foutu dans tout les dossiers ne sont pas hyper bien accepter par android (j'ai un mac aussi ;) ), et la méthode de compression de l'utilitaire d'archive est loin d'être correcte, j'avais trouvé un site où il donnait la solution pour le faire sous mac sans problème, simplement (juste avec le terminal ! ) je renvoie le lien dès que je le retrouve ! ;)
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
Ne t’en fait pas, j'ai une virtual box et au pire une deuxième partition avec Win 7 dessus.
 
M

maxime3447

Membre
Inscrit
23 Avril 2013
Messages
46
Points
6
Alors le zip ne sera pas flashable, il faudra le copié dans /system/media, mais ça fonctionnera :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
quelle réactivité ! merci je teste...
voilà l'anim

dites moi d'ailleurs si les vidéos chargent chez vous.... moi ça tourne en vain... peut-être ma connexion

Tu as juste changé le fps en fait ?
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Oui les fps et j'ai essayé d’alléger le fichier mais en sortie il est plus gros que le tien. Bizarre.
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
euh.... je sais pas s'il a bien pris la tienne, j'ai bien renommé pourtant. Disons que ça ne défilait pas plus vite qu'avant alors.
sérieusement ça me fait un peu ****** tout ces bugs....
je commence à en avoir raz la casquette...
bugs inexpliqué qui se résolve de manières tout aussi inexpliquée...
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Tu a toujours que le part0 qui se lance ?
SI c'est le cas fait qu'un seul part.
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
non pas du tout, le part 0 se finit après sony, xperia, honami.
Le part 1 c'est juste honami alors que là ça coupe juste avant xperia. donc à 33% du part 0 environ.
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Pour moi c'est une bootanimation trop volumineuse. Test avec une autre bootanimation plus légère.
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 509
Points
36
je l'ai déjà utilisée par les passé et elle fonctionnait très bien. Et du jour au lendemain... ça a merdé.
J'ai changé de Rom, de kernel... modifier la bootanimation, en vain.
Je ne trouve pas la source du problème, la seule chose que je n'ai pas testé c'est sur stock
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
Re,

Alors j'ai réussis à le faire via mon PC sur win 7, en revanche une fois le flash fait il ne le lance pas. Dans /system/media j'ai bien mon dossier "bootanimation.zip" avec dedans les dossier "part0" "part1" mais lors du reboot j'ai le bootanimation stock.

Avez-vous une idée ? :D :hello:
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
a tu un fichier .qmg ?
Si oui c'est que ta rom prend en compte les .qmg et non les bootanimation.zip
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
Oui j'en ai plusieurs. Comment ke je fé m1tenan :mdr1:
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 949
Points
48
Par défaut, il lance un .qmg.

Les .qmg sont par Samsung sur les Rom TouchWiz donc il te faut un logiciel spécial.
Regarde >>
 
I

iMiTcH

Membre
Inscrit
28 Octobre 2013
Messages
741
Points
16
ok je regarde quand je suis chez moi ;)

:super:
 
R

rvave

Membre
Inscrit
16 Décembre 2015
Messages
2
Points
0
Salut j'ai le même prombléme quand je clique sur enregistrer , et que je veut retrouver le zip que j'ai enregistrer , ben dés que je vais la ou je lai télécharger , je la vois 1 seconde et aprés il disaprait pas le temps de clik deçu .
 
V

vivi2218

Membre
Inscrit
27 Mars 2015
Messages
209
Points
0
Salut ! j'ai un probleme, quand je fais une prévisualisation de la bootanimation j'ai le message d'erreur suivant : L'index était hors limites. Il ne doit pas être négatif et doit etre inferieur a la taille de la collection. Nom du parametre : index do you want bootanimation factory to ignore and continue with the preview ?

Voici le screenshot :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


merci si y'a des réponses !
 
rico69

rico69

Membre
Inscrit
5 Mars 2012
Messages
95
Points
6
Bonsoir à Tous :D
Dans la part0 j'ai 190 images et 202 images dans la part1 ,je ne sais pas quoi mettre dans les cases Loops ,pouvez vous le renseigner svp

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


:amen:
 
Haut Bas