Sony Z3 Compact Z3C bloqué sur le logo après tentative de mise à jour via Companion

  • Auteur de la discussion mab.bonnement
  • Date de début
M

mab.bonnement

Membre
Inscrit
4 Septembre 2020
Messages
3
Points
1
  • #1
Bonjour,

La procédure d'installation a été faite en suivant la procédure via un iMac (fin 2014 - USB 3 compatible USB 2) via Companion version 20.10.3 avec cable Sony. Le Z3C est neuf et jamais utilisé (pas de lock, pas de compte). C'est arrivé hier (reçu le tel hier, fait la maj hier), la batterie était à 80/90%.

Le telephone n'est pas rooté et le bootloader n'est pas débloqué. Pas de Recovery custom installé.

Tentative de connection au Companion en mode flash (tel éteint, Vol- puis cable) ne fonctionne pas

Je peux éteindre le tel en faisant un hard reset (power & vol+)
Power : le tel s'allume sur le logo sony et reste bloqué sur ce logo
Power & Vol- : le tel s'allume sur le logo, le logo disparait puis réapparait et reste bloqué sur ce logo

Quand je faisais ces manipulations hier une petite led rouge s'allumait pour s'éteindre aussitôt (pas de bleu ou de vert...).

J'ai installé flash pour mac version 0.9.28.0 (avec un autre truc qui s'est installé je ne sais pas trop où, et je n'ai pas retenu le nom...), récupéré la rom officiel (a priori) sony ici
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
et lu la procédure mais je n'ai rien tenté pour le moment.

Mes questions :
1. mon tel est il brické (hard) ?
Si c'est le cas je ne vais pas me lancer dans une tentative de reparation (j'y connais rien et franchement ca me stress... je ne pensais pas avoir besoin de cela en utilisant les procédures standard)

2. ai-je les bonnes version des différents outils ? sinon ou puis je les récupérer ?
Quand j'installe flash il s'ouvre mais si je le ferme et que je retente de l'ouvrir il est bloqué et ne s'ouvre pas. Je le reinstall pour qu'il s'ouvre de nouveau...
Il m'indique qu'une version 0.9.30.0 existe ; dois je l'installer ? Le tel est vieux ; y a t'il une version à partir de laquel le tel ne sera de toute facon pas reconnu ?

3. La ROM récupérée D5803_23.5.A.1.291_1288-3756_R7D.ftf (ce qui correspond exactement au nom de la rom qui voulais s'installer dans companion) en revanche le nom du fichier indique : "Sony_Xperia_Z3_Compact_D5803_23.5.A.1.291_1288-3756_Customized_MEA" donc a priori customisé ??


Par avance merci pour votre aide constructive
M
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 972
Points
113
  • #2
Salut,

Tu devrais installer la dernière version de Flashtool, oui, et tenter de suivre la procédure. Par contre :

- Soit un flash normal de la ROM précédemment téléchargée fonctionne
- Soit, il faudra passer par le Wipe en cochant absolument toutes les cases correrspondante dans le logiciel Flashtool.

Les 2 sont à essayer.

Ton tel n'est pas hardbrick, mais softbrick. Le problème est logiciel, pas matériel (hardware = hardbrick / software = soft brick). S'il était hardbrick, tu ne verrais même pas le logo, et aucune manipulation logiciel ne pourra résoudre le soucis. Si c'est un hardbrick, le téléphone est bon à jeter. Mais ce n'est pas ton cas.

Chez Sony, le mot "Customized" dans le nom des ROM indique une ROM officiel, modifiée pour le pays en question. En réalité, cela ne concerne que l'installation des bloatwares (applications pré-installées par défaut). Cela ne signifie en aucun cas que la ROM est "customisée". C'est un nom officiel, donné par Sony lui-même.
 
M

mab.bonnement

Membre
Inscrit
4 Septembre 2020
Messages
3
Points
1
  • #3
Bonjour,

Merci pour toutes tes réponses

J'ai testé le flashtool 9.28 sans wipe :
- un pop up en cours de flash ou il me dis qu'il manque qqchose (mais je n'ai pas noté quoi), j'ai continué tout de même puisqu'il me le proposait
- une erreur :
"
- ERROR - Processing of system.sin finished with errors.
- INFO - Flashing finished.
- INFO - Please unplug and start your phone
- INFO - For flashtool, Unknown Sources and Debugging must be checked in phone settings
"

J'ai tout de même redémarré le tel, en me disant que cela n'avait pas marché mais finalement il a terminé l'installation et c'est ouvert. Du coup la je l'ai mis en charge et je m'occuperai ensuite de l'erreur... car pour l'instant mes recherches :
- Le system.sin peut être extrait du .ftf et réinstallé avec fastboot lorsque le bootloader est debloqué (ce qui n'est pas mon cas pour l'instant)
...
Rien d'autre ; je ne comprends pas à quoi ça sert (donc si j'ai besoin ou non de le réparer - je veux a terme passer le tel en ROM custom), ni comment le réparer

Si quelqu'un a une idée ?

Merci de nouveau

Très bonne journée
 
M

mab.bonnement

Membre
Inscrit
4 Septembre 2020
Messages
3
Points
1
  • #4
@Skelett : Merci pour ton aide de nouveau

Bien j'ai finalement installé la ROM z3c de e/ et malgré quelques déboires, cela a fini par fonctionner.

Sujet clos

Tres bonne continuation
M
 

Sujets en relation

Haut Bas