Problème TWRP "could not mount /data and unable to find crypto footer"

  • Auteur de la discussion baderlyon
  • Date de début
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #1
Bonjour à tous,
Il y a quelques jours j'ai installé la dernière version TWRP sur mon S9+ sous Android 10 puis je l'ai rooté en suivant ce guide.
Tout marchait bien jusqu'à aujourd'hui où j'ai essayé de faire une sauvegarde de mon système, je découvre un gros problème dans le TWRP; la sauvegarde échoue à plusieurs reprises!
Je constate aussi qu'il m'est impossible de monter ma partition"/data"!
J'ai plein des messages d'erreur du genre:
could not mount /data and unable to find crypto footer
failed to mount '/data' (invalid argument)...
J'ai essayé une solution qui consiste à réparer et changer l'extension de la partition mais sans succès.
Y aurait-il quelqu'un qui a rencontré ce problème ou qui peut m'aider à trouver une solution?
En vous remerciant par avance.
IMG_20200601_171353.jpg
 
Tekken

Tekken

Samsung Galaxy S10
Moderateur Global
Inscrit
4 Août 2012
Messages
26 770
Points
113
  • #2
Bonjour
est-ce que tu as bien fait un "Format datas" dans TWRP après l'avoir flashé ?
 
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #3
Tekken a dit:
Bonjour
est-ce que tu as bien fait un "Format datas" dans TWRP après l'avoir flashé ?
Bonsoir,
Oui j'ai fait le "Format data" après l'avoir flashé.
En lisant
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
J'ai cru comprendre qu' Android 10 n'est pas encore supporté par TWRP! Je ne sais pas si c'est toujours d'actualité ?
Je me demande aussi si je flashe une ancienne version TWRP (la twrp-3.2.3-0-star2lte.img.tar par exemple) peut résoudre ce problème?
Merci à toi en tout cas .
 
Tekken

Tekken

Samsung Galaxy S10
Moderateur Global
Inscrit
4 Août 2012
Messages
26 770
Points
113
  • #4
Bonjour
si la dernière version de TWRP n'est pas compatible avec Android 10 alors dans ce cas une ancienne version ne le sera pas non plus
tu as quelle version de TWRP ?
tu as flashé quelle version du "no-verity-opt-encrypt" ?
 
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #5
Tekken a dit:
Bonjour
si la dernière version de TWRP n'est pas compatible avec Android 10 alors dans ce cas une ancienne version ne le sera pas non plus
tu as quelle version de TWRP ?
tu as flashé quelle version du "no-verity-opt-encrypt" ?
Bonjour Tekken,
La version TWRP que J'ai flashée est "twrp-3.3.1-1-star2lte.img.tar"
Ensuite les deux derniers via TWRP: "no-verity-opt-encrypt-6.1" puis "Magisk-v20.4".
Je rappelle que tout fonctionne bien sauf qu'on ne peut pas faire de sauvegarde nandroid par le recovery du TWRP.
La procédure fini par un échec et affiche les erreurs qui j'ai citées plus haut ..!
J'ajoute que j'ai essayé
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
mais mon problème n'est toujours pas résolu!
Je continue de chercher mais je commence à désespérer :(
Avoir un téléphone rooté avec un recovery qui ne peut pas faire des sauvegardes ce n'est pas top pour moi!
Je te remercie.
 
Dernière édition:
Tekken

Tekken

Samsung Galaxy S10
Moderateur Global
Inscrit
4 Août 2012
Messages
26 770
Points
113
  • #6
tu dis que tout fonctionne, mais si TWRP ne peux pas faire de backup c'est qu'il a un problème
donc va y tu peux tester la version précédente tu n'as pas grand chose à perdre
 
B

bigrck

Membre
Inscrit
27 Octobre 2014
Messages
2
Points
1
  • #7
Bonjour baderlyon

J'ai exactement le même soucis que toi, j'arrive à formater la partition /data dans TWRP, mais dès que Android 10 démarre, il réinitialise tout et doit changer quelque chose sur la partition /data. Car par la suite, TWRP n'arrive plus à monter la partition :(
As-tu trouvé une solution ?

Je suis sur Galaxy S9 + XEF-G960FXXS9DTD7 + twrp-3.4.0-0-starlte
 
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #8
Bonjour Bigrck,
Non je n'ai malheureusement pas trouvé de solution à ce problème. Après de longues recherches j'ai fini par abandonner et garder le root avec le TWRP mais sans utiliser vraiment toute les fonctions du recovery, à savoir les sauvegardes et les nandroid Backup.
J'ai l'impression qu'il n'y a pas grand monde dans cette situation pour l'instant et qu'il va falloir peut être attendre un moment...
 
B

bigrck

Membre
Inscrit
27 Octobre 2014
Messages
2
Points
1
  • #9
J'ai trouvé la solution!
Le problème ne venait ni de TWRP 3.4.0, ni de Magisk 20.4, mais du Disable_Dm-Verify.zip, il faut télécharger cette version:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
le lien xda correspondant:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Pour avoir une solution 100% OK j'ai donc:
- Installé le firmware stock G960FXXS9DTD7 sur le Galaxy S9
- Réactivé l'option "OEM Unlock" en jouant avec les dates et la recherche de MAJ manuelle
- Installé le twrp-3.4.0-0-starlte.img.tar en tant que recovery
- Reformaté la partition data depuis TWRP, puis rebooter en Recovery
- Copié via USB les fichiers Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip + Magisk-v20.4.zip
- Lancé l'installation depuis TWRP de Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip, puis de Magisk-v20.4.zip
- Rebooté le système

Voila un android 10 rooté, qui a bien accès à /data. TWRP à également un accès correct à /data :)
 
  • Like
Les réactions: Princekasar
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #10
Bonsoir Bigrck,
J'ai déjà essayé cette solution avec ce fichier "Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020" que j'ai trouvée
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
sur XDA et j'ai fait tourné le système pendant 15 jours.
Le problème du montage de la partition Data a été effectivement résolu, mais mon système est devenu instable. Ça a commencé par des bug dans le Google Play, puis petit à petit je ne pouvais ni installer ni désinstaller des applications... Même la restauration des sauvegardes que j'ai effectuées par le recovery TWRP plantaient!
Du coups, j'ai fini par laisser tomber cette solution et revenu à la première solution du "no-verity-opt-encrypt-6.1"
Peut être j'avais zappé quelque chose, mais tu vas peut être me confirmer ou m'infirmer dans quelques jours ce que je viens de dire.
Merci pour ton partage :)
 
coyote950

coyote950

Bip Bip !!
Moderateur Global
Inscrit
5 Février 2013
Messages
24 412
Points
113
  • #11
Bonjour

Pour ces soucis dans twrp, vous pouvez aussi réparer les partitions, voir ici entre autre

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Ça consiste à changer le format de partition qui pose souci en fat ou exfat puis de la remettre en ext4.

Pour dm_verity, il est vrai que parfois il faut tester une autre version,mais ça ne fonctionne pas toujours,c'est bizarre ;)

Bonne journée à tous :)
 
B

baderlyon

Membre
Inscrit
19 Décembre 2012
Messages
90
Points
8
  • #12
Bonjour,
J'avais déjà essayé cette solution, mais sans succès.
Merci à toi.
coyote950 a dit:
Bonjour

Pour ces soucis dans twrp, vous pouvez aussi réparer les partitions, voir ici entre autre

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Ça consiste à changer le format de partition qui pose souci en fat ou exfat puis de la remettre en ext4.

Pour dm_verity, il est vrai que parfois il faut tester une autre version,mais ça ne fonctionne pas toujours,c'est bizarre ;)

Bonne journée à tous :)
 
  • Like
Les réactions: coyote950
A

AndroSwiss

Membre
Inscrit
18 Août 2020
Messages
5
Points
1
  • #13
bigrck a dit:
J'ai trouvé la solution!
Le problème ne venait ni de TWRP 3.4.0, ni de Magisk 20.4, mais du Disable_Dm-Verify.zip, il faut télécharger cette version:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
le lien xda correspondant:
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Pour avoir une solution 100% OK j'ai donc:
1- Installé le firmware stock G960FXXS9DTD7 sur le Galaxy S9
2- Réactivé l'option "OEM Unlock" en jouant avec les dates et la recherche de MAJ manuelle
3- Installé le twrp-3.4.0-0-starlte.img.tar en tant que recovery
4- Reformaté la partition data depuis TWRP, puis rebooter en Recovery
5- Copié via USB les fichiers Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip + Magisk-v20.4.zip
6- Lancé l'installation depuis TWRP de Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip, puis de Magisk-v20.4.zip
7- Rebooté le système

Voila un android 10 rooté, qui a bien accès à /data. TWRP à également un accès correct à /data :)

Si tu repasses par ici ;)

J'ai actuellement une "LineageOS 17.1" et j'ai le même problème qu'expliqué sur ce sujet. Si je suis ton explication et si je part du point 4 car mon TWRP est déjà installé, est-ce que l'installation d'une ROM LineagOS serait au point 3', 4' ou au 6' ?

3'- Installation de la ROM LineageOS
4
- Reformaté la partition data depuis TWRP, puis rebooter en Recovery
4'- Installation de la ROM LineageOS
5- Copié via USB les fichiers Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip + Magisk-v20.4.zip
6- Lancé l'installation depuis TWRP de Multi_Disable_Dm-Verity_ForceEncrypt_03.04.2020.zip, puis de Magisk-v20.4.zip
6'-Installation de la ROM LineageOS
7
- Rebooté le système

Merci pour ton aide ou/et l'aide d'un autre membre :)

EDIT : selon ce qu'il me semble expliqué sur le net c'est plutôt le 4' ... mais j'ai tout de même un doute
 
Dernière édition:

Sujets en relation

Haut Bas