Problème Fastboot Mi 9

  • Auteur de la discussion RaacerzZ
  • Date de début
R

RaacerzZ

Membre
Inscrit
16 Septembre 2012
Messages
6
Points
1
  • #1
Salut à tous,

Depuis hier, je suis bloqué en mode Fastboot sur mon Xiaomi Mi 9 après une tentative de ROM custom qui a mal tourné.

Evidemment, toutes les manip pour redémarrer le téléphone via les boutons de côtés ne marche pas, je suis définitivement bloqué dessus. J'ai tout essayé, ou presque. J'ai essayé de faire la manip via le logiciel mi Flash mais il ne reconnaît mon téléphone. D'ailleurs via l'invité de commandes, il reconnaît bien le fastboot mais pas ADB. Du coup je ne peux pas faire de reboot ou quoi que ce soit, que ce soit via ADB ou MiFlash.

J'ai donc été vers le gestionnaire de périphériques (je suis sous windows 10) pour voir si mon PC reconnaissait bien mon smartphone. Il le reconnaît, mais pas en tant que "smartphone" mais en tant que "Appareils Mobiles" et affiche une lettre comme si cela était un disque dur. J'ai bien essayé de mettre à jour le pilote en désignant le Périphérique USB MTP mais la mise à jour refuse de se faire, cela me marque "Ce périphérique ne peut pas démarrer (Code 10)". Et quand je réessaye de faire une mise à jour sur cet appareil MTP dans le gestionnaire, cela me fait une mise à jour automatique avec le "Pilote de volume de système de fichiers WPD".

Fin bref, l'ordinateur reconnaît le smartphone mais pas en tant que smartphone du coup je suis bloqué.

Quelqu'un a t-il une petite solution a mon gros problème o_O

Merci à tous
 
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
15 179
Points
113
  • #2
Salut
Tu as essayé de désactiver la verification des signatures de pilotes ?
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Tu pourras réinstallé les drivers adb ensuite.
Il s'agit bien d'une erreur de pilotes
 
R

RaacerzZ

Membre
Inscrit
16 Septembre 2012
Messages
6
Points
1
  • #3
spat a dit:
Salut
Tu as essayé de désactiver la verification des signatures de pilotes ?
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Tu pourras réinstallé les drivers adb ensuite.
Il s'agit bien d'une erreur de pilotes
Salut, merci du message. J'ai fais les manip du lien que tu as mis mais pareil, j'ai toujours le même message d'erreur :

"Ce périphérique ne peut pas démarrer (Code 10)"

Je suis toujours au même endroit du coup. Merci d'avoir aidé en tout cas ;)
 
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 488
Points
113
  • #4
Hello,

Vu que les commandes fastboot fonctionnent, que donne la commande :

fastboot reboot

?
 
R

RaacerzZ

Membre
Inscrit
16 Septembre 2012
Messages
6
Points
1
  • #5
Cela fonctionne, comme pour fastboot devices, je vois bien mon téléphone. Cela redémarre le téléphone et le remet direct dans le mode fastboot
 
Dernière édition par un modérateur:
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 488
Points
113
  • #6
Ok donc le système est complètement foutu.
Pour utiliser Mi Flash, tu as tenté de démarrer ton appareil en EDL Mode ? De mémoire, il n'y a qu'avec ce mode que cela fonctionne (comme OnePlus).

Pour lancer l'EDL Mode chez Xiaomi, c'est la commande : fastboot oem edl
Avec l'EDL Mode, pas de panique, l'écran du smartphone sera entièrement noir, c'est normal. Mais ton gestionnaire de périphérique devrait le reconnaitre sous le nom Qualcomm HS-USB QDLoader 9008

Si ça ne fonctionne pas, je te redirige vers ce tuto : https://www.phonandroid.com/forum/threads/tutoriel-recuperation-de-brick-xiaomi.202843/.
Il est écrit pour MI 9T, mais fonctionne pour le MI 9. Par contre, à l'étape où tu devras choper les ROMs officielles, si cela t'indique une erreur, tu pourras la télécharger ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


PS : J'ai déplacé ton sujet au bon endroit. Fais attention à l'avenir stp, les catégories de smartphones ne sont pas là pour rien.
 
R

RaacerzZ

Membre
Inscrit
16 Septembre 2012
Messages
6
Points
1
  • #7
Salut, déjà désolé pour la catégorie j'avoue ne pas avoir fait attention.

Entre temps j'ai finalement trouvé la solution grâce à une tuto sur Youtube ! Comme quoi fouiller dans les bas fonds d'Internet ça a du bon des fois ! Je met le lien de la vidéo pour ceux qui pourrait avoir le même problème un jour :


Merci en tout cas d'avoir essayer de m'aider
 
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 488
Points
113
  • #8
GG, parce que je ne comprends rien à la vidéo, et tout est flou.

Il paraît avoir réinstallé la ROM via fastboot.
 

Sujets en relation

Haut Bas