[Résolu] Flash kernel impossible sur Xperia X10 Mini Pro

  • Auteur de la discussion Fred23195
  • Date de début
F

Fred23195

Membre
Inscrit
30 Septembre 2012
Messages
10
Points
0
  • #1
bonjour,

je suis désolé de poster un nouveau sujet sur ce thème, mais bien que j'en ai lu un bon paquet partout sur la toile, je désespère de trouver la solution à mon problème. déjà, je vous remercie pour ce forum qui m'a bien aidé jusqu'à là!

je dispose d'un X10 mini pro U20i - version noyau 2.6.29 - n° de build 2.1.1.A.0.6.
comme ça fait la 5ème fois que je lance une récup par SEUS ou PC Companion, je suis sous la version officielle Android 2.1.
je sais comment faire pour être en root et installer ClockWorkMod avec les 3 fichiers, etc...
j'ai essayé d'installer à plusieurs reprises des Roms customs, et la seule qui ne m'a pas affichée de message d'erreur est la version "MiniCM9-3.0.4-mimmi.zip".
mais au redémarrage dans tous les cas, l'écran se bloque au logo Sony Erickson.
j'enlève donc la batterie, j'essaie de flasher le kernel, impossible, et donc je lance la ré-install complète via SEUS ou PC Companion.

voici ce qui me bloque:
sous Flashtool version 0.9.7, chaque fois que je veux installer un nouveau kernel, j'ai le message d'erreur suivant:
02/023/2012 19:23:13 - INFO - Selected U20_nAa-ics-04_2.6.29.6-nAa-ics-04.ftf
02/023/2012 19:23:13 - INFO - Preparing files for flashing
02/023/2012 19:23:13 - INFO - Please connect your device into flashmode.
02/023/2012 19:23:21 - INFO - Device connected in flash mode
02/023/2012 19:23:22 - INFO - Opening device for R/W
02/023/2012 19:23:22 - INFO - Reading device information
02/023/2012 19:23:22 - INFO - Phone ready for flashmode operations.
02/023/2012 19:23:22 - INFO - Start Flashing
02/023/2012 19:23:22 - INFO - Processing loader
02/023/2012 19:23:22 - INFO - Checking header
02/023/2012 19:23:22 - INFO - Ending flash session
02/023/2012 19:23:22 - ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ERR_DYNAMIC="SIN header verification failed"

ça me le fait avec tous les firmwares que j'ai trouvés, SAUF avec l'officiel "U20_1.0_Default Kernel.ftf".
j'ai bien vérifié que l'antivirus était désactivé, etc...

auriez-vous une idée?

merci
a+
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 400
Points
38
  • #2
Re: Flash kernel impossible...

Salut, bienvenue ;)

Je suppose que ton bootloader n'est pas déverrouillé ?

Si c'est le cas, il faut savoir que l'installation d'un kernel custom n'est possible qu'après un déverrouillage du BL ;)
 
F

Fred23195

Membre
Inscrit
30 Septembre 2012
Messages
10
Points
0
  • #3
Re: Flash kernel impossible sur Xperia Mini Pro

bonjour et merci pour le contact.

j'avais bien essayé de déverrouiller le bl par flashtool; voici le message:
02/021/2012 21:21:56 - INFO - <- This level is successfully initialized
02/021/2012 21:21:56 - INFO - Flashtool Version 0.9.7.0 built on 2012-09-28 19:01:25
02/021/2012 21:21:56 - INFO - You can drag and drop ftf files here to start flashing them
02/022/2012 21:22:01 - INFO - Device connected with USB debugging on
02/022/2012 21:22:01 - INFO - Connected device : U20
02/022/2012 21:22:01 - INFO - Installed version of busybox : BusyBox v1.18.4 (2011-04-04 18:40:20 CDT) multi-call binary.
02/022/2012 21:22:01 - INFO - Android version : 2.1-update1 / kernel version : 2.6.29 / Build number : 2.1.1.A.0.6
02/022/2012 21:22:02 - INFO - Installing toolbox to device...
02/022/2012 21:22:02 - INFO - Pushing C:\Flashtool\custom\root\ftkit.tar to /data/local/tmp
02/022/2012 21:22:03 - INFO - Running installftkit as root thru sysrun
02/022/2012 21:22:03 - INFO - Root Access Allowed
02/022/2012 21:22:07 - INFO - Please connect your device into flashmode.
02/022/2012 21:22:11 - INFO - Device disconnected
02/022/2012 21:22:31 - INFO - Device connected in flash mode
02/022/2012 21:22:31 - INFO - Opening device for R/W
02/022/2012 21:22:31 - INFO - Reading device information
02/022/2012 21:22:31 - INFO - Phone ready for flashmode operations.
02/022/2012 21:22:31 - INFO - Processing loader
02/022/2012 21:22:31 - INFO - Checking header
02/022/2012 21:22:31 - INFO - Flashing data
02/022/2012 21:22:33 - INFO - Loader : S1_Loader_Root_8e35 - Version : R4A045 / Bootloader status : UNROOTABLE
02/022/2012 21:22:33 - INFO - Start Reading property
02/022/2012 21:22:33 - INFO - Reading TA finished.
02/022/2012 21:22:33 - INFO - Ending flash session
02/022/2012 21:22:33 - INFO - Found semcSL
02/022/2012 21:22:33 - INFO - You can now unplug and turn on device, then plug it again
02/022/2012 21:22:33 - INFO - Waiting for device
02/022/2012 21:22:33 - INFO - Device connected in flash mode
02/022/2012 21:22:34 - INFO - Device disconnected
02/022/2012 21:22:37 - INFO - Device connected in flash mode

on lit donc : "Bootloader status : UNROOTABLE"
ça veut dire que pour la version de mon X10, c'est mort?

j'avais aussi lancé S1tool / Identify :
RUNNING S1_EROM VER "R8A029"
SOFTWARE AID: 0001
LOADER AID: 0001
FLASH ID: "0020/00BC"
LOADER VERSION: "R4A045"

MODEL (from GDFS): U20i
SOFTWARE VERSION: 1235-3411_2.1.1.A.0.6
CUSTOM VERSION: 1237-9454_R4B
FILESYSTEM VERSION: WORDL-1-8_2.1.1.A.0.6
SERIAL NO: CB511P7T1W

SEMC SIMLOCK CERTIFICATE

je continue à explorer les forums xda et autre... si vous avez une idée...

EDIT: ça y est! petite avancée enfin!

quel con, en fait, lorsque j'utilisais la fonction "Bootloader unlock" de Flashtool, je n'attendais pas assez longtemps; dès que je voyais le message "Device disconnected" et que le téléphone se lançait tout seul, je débranchais le cordon, alors qu'il fallait attendre qu'il boote et reboote tout seul au moins 2 fois!

j'ai donc pu enfin installer un kernel différent, le "U20_nAa-ics-04_2.6.29.6-nAa-ics-04.ftf" pour une Rom "MiniCM9-3.0.4-mimmi.zip".
ça fonctionne bien apparemment, puisqu'au redémarrage, j'ai bien le logo nAa rouge qui apparait.

mais maintenant après le logo nAa, ça bascule sur le logo Sony Ericsson, et c'est figé.
bref, une grande avancée apparemment, et un nouveau problème à résoudre...

je continue.
+

EDIT 2: petite correction : le logo nAa n'est pas rouge mais légèrement bleuté...

EDIT 3: bon, plutôt que me prendre la tête à essayer de débriquer mon tel, j'ai enlevé la batterie, relancé le tel en mode recovery, et directement installé la Rom "MiniCM9".

et là enfin, après 1 semaine de prise de tête, c'est fait!
merci à ceux qui travaillent sur ces applis!
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 400
Points
38
  • #4
Re,

Content pour toi que le problème soit résolu :)

PS: à l'avenir, pense à éditer un message au lieu d'en poster d'autres à la suite du premier.
 
Haut Bas