Sony Xperia Arc S reboot en boucle toujours après flahage

  • Auteur de la discussion M0umou
  • Date de début
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #1
Salut à tous, c'est ma toute première question depuis 3 ou 4 ans que j'ai découvert le site/forum que je trouve génial :)

Je possède un Sony Ericsson Xperia Arc S LT18i et depuis un peu plus d'une semaine maintenant, il passe son temps à redémarrer seul et en boucle. L'écran pour entrer le code pin s'affiche, et pas le temps de le rentrer qu'il disparait sous un fondu et le téléphone redémarre en boucle. Pour l'éteindre je suis obliger d'enlever la batterie.

J'étais en train d’utiliser mon téléphone avec le données mobiles activées et des applications ouvertes, hors sans faire exprès j'ai appuyé sur mes widgets Wi-Fi et bluetooth, le tél a commencé à buger puis il s'est réinitialisé et il a commencé à redémarrer en boucle.
Pour moi, la réinitialisation n'est pas le soucis, ça m'était déjà arrivé.
Peut-être ça peut aider, mais depuis à peu près 2 mois mon Xperia ne voulait plus charger éteint sinon il redémarrait en boucle et vider la batterie, obliger de le charger allumer.

Je vous demande de l'aide s'il vous plaît parce que j'ai passé ma semaine, nuit et jour (pas h24) a chercher dans le forum et a tester les solutions proposées, celle de xda et sur internet. J'ai essayé plein de choses. J'ai fait un backup avec le recovery avant de faire quelque chose.
J'ai essayé :
  • J'ai fait un reset factory et essayé la restauration avancées mais sans succès
  • J'ai flashé avec flashtool le téléphone. Il démarre mais il y a un soucis, super utilisateur ne veut pas faire la mise à jour binaire avec le message "une erreur est survenue pendant l'installation de super-utilisateur .Merci d'envoyer le rapport d'erreur au developpeur" . Le téléphone me dit qu'il n'y plus de mémoire, c'est normal vu que j'avais viré toute s les apps intégré par Sony comme Facebook, les jeux et trucs comme ça et du coup je reste bloqué. Et quand je veux redémarrer le téléphone il recommence
  • J'ai fait un reset factory et le téléphone marche niquel ps : Je veux utiliser mes données sauvegardées, d'où mon acharnement !


Modèle : Xperia Arc S Lt18i
Firmware : 4.1.B.0.587 (officiel) sans surcouche opérateur normalement (acheté nu)
Root : Rooté avec Eroot.
Bootloader : déverrouillé
J'ai un CWM comme recovery v5.5.0.4 mais avant j'avais v5.0.2.7
J'ai quasiment toute mes applications sur ma carte SD avec link2SD

Si quelqu'un a des solutions à proposer je suis preneur pour les essayer. Un point très important, je ne veux perdre aucunes données. :super:

Personnellement j'avais dans l'idée de flasher le téléphone avec le firmware officiel mais sans les applications (mais je ne sais pas si c'est possible) et faire la mise à jour binaire se Super-Utilisateur pour voir si tout remarche et faire ensuite une sauvegarde avec Titanium (oui je l'ai et je l'ai jamais utilisé pfff) et tout supprimer et faire un installation propre. Mais ça c'est si ça marche ! :amen:

Voilà, je pense n'avoir rien oublié. Je vous remercie par avance de vos réponses et impatient de tester vos propositions
 
Tardis

Tardis

Docteur qui?
Admin suppléant
Inscrit
24 Février 2014
Messages
48 060
Points
113
  • #2
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Bonjour

En effet, repars sur une install propre dans un premier temps pour voir si la rom est en cause. Mais je t'avoue que ca ne sent pas très bon. Essaie aussi avec une autre sim, elle peut être abîmée.
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #3
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Merci pour ta réponse.

Mais ce que je ne comprends pas c'est que quand
M0umou a dit:
J'ai fait un reset factory et le téléphone marche niquel ps : Je veux utiliser mes données sauvegardées, d'où mon acharnement !
Quand je dis ça, c'est qu'il marche normal quoi.

Chose que je n'ai pas dit, j'ai l'impression que le problème vient du Bluetooth. Quand le démarre et que je vois l'écran d’accueil, on voir le Bluetooth activé.
 
Tardis

Tardis

Docteur qui?
Admin suppléant
Inscrit
24 Février 2014
Messages
48 060
Points
113
  • #4
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Alors, c'est ton backup qui est daubé.
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #5
Re: Sony xpéria arc S reboot en boucle toujours après flahage

En fait, j'ai fait le backup qu'après le bug. C'est un peu inutile j'avoue.
 
Tardis

Tardis

Docteur qui?
Admin suppléant
Inscrit
24 Février 2014
Messages
48 060
Points
113
  • #6
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Oui, en effet. Du coup, tu restaures le problème à chaque fois :(
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #7
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Oui, c'est ça. Mais quand je fais ma restauration puis que je flashe avec Flashtool et le firmware officielle 4.1.B.0.587, le téléphone démarre mais je reste bloqué parce que Super-Utilisateur ne veut pas faire la mise à jour binaire, du coup je ne peux pas utiliser Link2SD et du coup tout s’enchaine. Le téléphone me dit mémoire pleine, chose bizarre google play store est introuvable, même pas le logo, et l'APK est in-installable aussi...

J'ai comme l'impression qu'il se déroot quand je le flashe.

Je me trompe peut-être, mais si je n'arrive pas à faire la mise à jour binaire, je n'aurais jamais les droits pour faire les applications qui en ont besoin.
 
Tardis

Tardis

Docteur qui?
Admin suppléant
Inscrit
24 Février 2014
Messages
48 060
Points
113
  • #8
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Quel est l'intérêt de faire ta restauration puis de flasher la rom? Ca annule en effet le root et enlèves une partie de tes saivegardes systèmes.
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #9
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Eh bien mon but, si c'est possible, de restaurer pour sauvegarder mes données de certaines applications avec Titanium et puis te refaire une installe propre.
 
Tardis

Tardis

Docteur qui?
Admin suppléant
Inscrit
24 Février 2014
Messages
48 060
Points
113
  • #10
Re: Sony xpéria arc S reboot en boucle toujours après flahage

A priori, ça ne demarre pas en faisant ton backup :(
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
  • #11
Re: Sony xpéria arc S reboot en boucle toujours après flahage

Hey :hello: me voilà de retour pour dire que j'ai enfin réussi à faire remarcher mon téléphone :super:

J'ai utilisé une mise à jour apparemment officielle, dont Sony n'a peu ou pas parlé et disponible que pour certain téléphone. Je suis donc passé du 4.1.B.0.587 au 4.1.B.1.13 (Xperia Arc S 4.1.B.1.13 Vodafone DE firmware)
Personnellement, je n'ai pas utilisé le même procédé pour ne pas perdre mes données. J'ai procédé ainsi :
  • Télécharger le firmware en fichier Zip
    S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
  • J'ai démarré mon téléphone en mode recovery en tapotant la touche retour de mon LT18i, avant l'apparition du logo SONY
  • J'ai remis mon téléphone d'usine en cliquant sur "Wipe data/factory reset" dans le recovery
  • J'ai restauré ma backup (mon système avec toutes mes données qui redémarrait en boucle). Je suis rentré dans "backup and restore" puis sur "restore" et j'ai choisi la backup à restaurer
  • Je suis rentré dans "mount and storage", puis "mount USB storage" pour que mon ordinateur détecte le téléphone, et j'ai placé le fichier "4.1.B.1.13.zip" à la racine de ma carte SD
  • J'ai fait redémarrer mon téléphone. Une fois qu'il a commencé à redémarrer en boucle, j'ai enlevé la batterie et l'ai remis

  • J'ai démarré mon ARC S en mode recovery et j'ai cliqué sur "Install zip from sdcard" puis sur "choose zip from sdcard" et j'ai cherché le fichier "4.1.B.1.13.zip" et j'ai laissé faire
  • Une fois terminé, j'ai démarré le téléphone normalement, c'est un peu long mais le téléphone marche
  • J'ai fait la mise à jour binaire de Superuser (moi j'étais en conflit avec Super-Utilisateur)
  • Je suis allé dans Link2SD et j'ai lié ma seconde partition. Il faut redémarré pour la prise en compte
  • Une fois démarré, une partie des applications dans la SD réapparaissent mais le téléphone n'a plus de mémoire
  • Pour y remédié, j'ai désinstallé avec link2Sd les applications comme Facebook, Twitter, les applis intégrés par Sony...
  • J'ai remis tous mes widgets
  • J'ai mis à jour la vingtaine d'applications

Par contre, je rencontre un souci sur le niveau de batterie. Elle est vide, le niveau est a 100% et même quand je l'utilise. Quand je mets à la charge, la led est toujours verte et jamais rouge.
Aussi, je n'arrive plus à me souvenir où sont les fichiers pour les SMS et MMS et le journal d'appel. Je crois que c'est des fichier .db

Enfin, ma dernière question. Que dois-je faire pour avoir une install propre ?
J'envisagerais peut-être de mettre [ROM] [Android 5.1.1] CyanogenMod 12.1 pour Xperia Arc / Arc S ou [ROM] [Android 5.1.1] LegacyAOSP pour Xperia 2011

En tout cas, :merci: merci d'avoir essayé de m'aider :smile:


EDIT : Finalement, après avoir utilisé mon téléphone et aussi après quelque recherche, j'ai résolu comment remettre le niveau de batterie réel :
  • Rentrer dans le recovery, aller dans "Advanced" et sélectionner "Wipe Battery Stats" et "Yes"
  • Allumer le téléphone et le brancher (au secteur c'est mieux) et laisser charger environ une 1/2 journée. Normalement la batterie devrait être pleine.
  • Redémarrer le téléphone et voir en l'utilisant si le niveau de batterie change.
  • Si non, refaire un "Wipe Battery Stats"décharger complètement le téléphone, puis le rallumer en le branchant au secteur et voir si le niveau bouge.
 
Haut Bas