Ulefone Armor 3T Root

  • Auteur de la discussion Grouik666
  • Date de début
G

Grouik666

Membre
Inscrit
25 Juillet 2019
Messages
2
Points
1
  • #1
Bonjour à tous.

Je galère grave pour rooter mon Ule Armor 3T.

J'ai tenté de suivre les instruction de ce tuto posté sur XDA, mais ce dernier n'est absolument pas clair :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


J'ai réussi à déverrouiller le bootloader avec Fastboot, puis à flasher la rom avec SP-MultiPortFlash, mais la je bloque.

J'ai cru comprendre que pour installer TWRP il fallait impérativement désactiver le chiffrement de la partition système. Une archive "disable_encryption_+Armor+3-2" est d’ailleurs fourni à cet effet, mais je ne vois pas ou y mettre les fichiers qu'elle contient (META-INF & vendor).

Si quelqu'un qui maitrise le sujet pouvait allez voir sur XDA et me donner un coup de main, je lui offre des chocolats.

C'est mon premier root et je maitrise assez mal la langue de Shakespeare.

Merci à tous :)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 240
Points
113
  • #2
Salut,

Tu as lu absolument tout le tuto ? Car il y a un fichier docx dans les téléchargements en fin de post qui explique toutes les manipulation à suivre...

Le lien redirige ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
G

Grouik666

Membre
Inscrit
25 Juillet 2019
Messages
2
Points
1
  • #3
Effectivement j'ai lu ce document.

Il n’explique pas grand chose, et mal en plus. (Ou plus probablement c'est moi qui n'ai rien compris à la tisane.)

Installer les drivers requis OK, passer en mode MTP OK, copier Magisk et disable_encryption sur la carte sd OK.

Lancement de SP Flash Tools, choix du scatter dans le fichier de l'image TWRP, choix de "recovery" uniquement, download, tel éteint et branché.
Le téléchargement se passe bien, "download ok".

Reboot de tel, impossible d'accéder à TWRP. Reboot du tel après écran noir lorsque je reste appuyé sur la commande qui devrait normalement me faire entré dans TWRP.


Il est précisé à la fin du document :

"TWRP cannot not see the "internal memory" (it cannot decrypt the / data section and asks password when starting)"

Et en solution :
" 1. Put the patch disable_encryption_Armor3.zip (133.96 KB) in the memory card, boot into TWRP, go to the "mount" section, check the vendor , then go to "install", select storage and install the patch.
2. After installation, go to Wipe, Advanced Wipe, Data Partition, Swipe to format.
3. Then go Back, back, Format Data, type yes, Reboot System (it will take a little longer than usual)"


Ce qui me parait logique vu que dans la méthode de base exposée dans ce tuto la phase "Disable Ulefone Armor 3 encryption " arrive en seconde position. Bien avant le flashage du recovery.

Seulement voilà, la seule référence a cette étape dans le doc, est "Copy Magisk-v18.0.zip and patch (disable_encryption_ + Armor + 3) to the phone's memory card. NOT IN MEMORY OF PHONE !!!"

Ce que j'ai fais. Mais je n'en vois absolument pas l’intérêt. Le fichier est copié sur la carte mémoire, et ? A aucune moment n'est fait mention d'une manip pour rendre le déchiffrement effectif.

Mon analyse du problème est la suivante :

1 ) L’installation de TWRP requière la suppression du chiffrement de la partition, système.
2) Le protocole de suppression du chiffrement de la partition requière le passage par TWRP.

Donc, devant cet illogisme, j'en arrive à la conclusion que je n'ai rien compris au tableau ^^.
 

Sujets en relation

Haut Bas