[TUTORIEL] Installer CWM Recovery + root

  • Auteur de la discussion Pgx
  • Date de début
Pgx

Pgx

Membre
Inscrit
12 Avril 2013
Messages
32
Points
6
  • #1
J'ai mon Wiko Getaway depuis une semaine et aucune solution 1-click pour le rooter ne fonctionnait.
J'ai donc tenté (avec succès) de le faire en manuel.
Je fourni le fichier recovery.zip afin de vous épargner l'extraction du stock recovery et son patchage.
C'est mon premier tuto, soyez indulgents.
Les manipulations expliquées ci dessous comportent des risques et je ne pourrai nullement être tenu pour responsable en cas de problème : prenez vos responsabilités.

Pré-requis :

recovery.zip :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

SP Flash Tool :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

UPDATE-SuperSU-v2.02.zip :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Avoir installé le driver usb

Installation du custom recovery (CWM)

- Exécutez SP Flash Tool en tant qu’administrateur.
- Sélectionnez l’onglet Download (normallement déjà sélectionné par défaut).
- Chargez MT6582_Android_scatter.txt en cliquant sur le bouton Scatter-loading.
- Veillez à ne cocher que RECOVERY et rien d’autre.
- Cliquez dans la colonne Location sur la ligne RECOVERY et sélectionnez le fichier recovery.img
- Cliquez sur le bouton Download et connectez votre Wiko Getaway éteint et attendez la fin du processus qui affichera une fenêtre avec un cercle vert.

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Votre custom recovery est installé.

Root

- Copiez le fichier UPDATE-SuperSU-v2.02.zip sur une micro sd insérée dans le logement à gauche de votre Getaway (le flash via le stockage interne ne fonctionne pas).
- Eteignez votre Getaway et rebootez le en mode recovery (volume +, volume – et power).
- Sélectionnez le mode recovery (bouton volume +).
- Flashez le fichier UPDATE-SuperSU-v2.02.zip
- Rebootez.

Votre Getaway est rooté.
 
Tipiak

Tipiak

Pirate !
Moderateur Global
Inscrit
2 Juillet 2012
Messages
26 912
Points
63
  • #2
:hello:
Merci pour le partage. :super:
 
Agrimok

Agrimok

Membre
Inscrit
25 Août 2013
Messages
278
Points
0
  • #3
Merci, excellent partage :)
 
D

dvro

Membre
Inscrit
27 Juin 2013
Messages
2
Points
1
  • #4
Bonjour, je voulais suivre ce tuto, mais je n'arrive pas à télécharger le recovery.zip.
Faut-il avoir un compte free ?
Merci
 
D

dvro

Membre
Inscrit
27 Juin 2013
Messages
2
Points
1
  • #5
Ah j'ai trouvé, c'était AdblockPlus qui bloquait...

Décidément, je ne suis pas doué, excusez-moi, je débute...
J'ai donc lancé flash_tool.exe en mode administrateur, sélectionné MT6582_Android_scatter.txt, coché seulement RECOVERY, sélectionné recovery.img, cliqué sur Download, connecté le tél éteint.
Et là... il ne se passe rien.

Les fichiers log contiennent les messages suivants :
QT_FLASH_TOOL.log :
09/18/2014 19:16:44.060 FlashTool[3460][4444][D]: USBSetting::SearchUSBPortPool(): Scaning USB port failed!(..\QT_FlashTool_Refactor\Conn\USBSetting.cpp,195)
09/18/2014 19:17:14.083 FlashTool[3460][4444][D]: USBSetting::SearchUSBPortPool(): Scaning USB port failed!(..\QT_FlashTool_Refactor\Conn\USBSetting.cpp,195)
...

BROM_DLL_V5.log :
09/18/14 19:17:36.067 BROM_DLL[3460][4444]: IsValidCOMPort(): Instance ID(USB\VID_0461&PID_0010\5&348D690&0&2) (FlashToolLib/host/windows/com_enum.cpp:942)
09/18/14 19:17:36.067 BROM_DLL[3460][4444]: IsValidCOMPort(): Instance ID(USB\VID_045E&PID_0040\5&348D690&0&1) (FlashToolLib/host/windows/com_enum.cpp:942)
09/18/14 19:17:36.067 BROM_DLL[3460][4444]: IsValidCOMPort(): Instance ID(USB\VID_0BB4&PID_2008\0123456789ABCDEF) (FlashToolLib/host/windows/com_enum.cpp:942)
09/18/14 19:17:36.067 BROM_DLL[3460][4444]: WARNING: EnumerateDevice(): Get friendly name failed! Err(13) (FlashToolLib/host/windows/com_enum.cpp:609)
09/18/14 19:17:36.068 BROM_DLL[3460][4444]: WARNING: EnumerateDevice(): Get friendly name failed! Err(13) (FlashToolLib/host/windows/com_enum.cpp:609)
...

Pouvez-vous m'aider svp ?


Et le lendemain matin...
j'y suis finalement arrivé en :
- désinstallant les drivers usb pour installer ceux fournis dans le tuto : "http://forum.lien non autorisé.com/topic/201442-tuto-cwm-root-du-wiko-getaway/"
- activant le débogage usb comme indiqué dans la vidéo :"
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
"

Donc ça y est, mon Wiko Getaway est rooté !

Merci à tous ceux qui passent du temps à écrire des tutos, faire des vidéos, ... si utiles aux prophanes.
 
Agrimok

Agrimok

Membre
Inscrit
25 Août 2013
Messages
278
Points
0
  • #6
Super :)
 
P

papillard

Membre
Inscrit
14 Avril 2013
Messages
3
Points
1
  • #7
Bien joué,

Et par hasard, est ce que cette manipulation serait compatible avec un Wiko Birdy 4G ?
Quelle est le moyen de savoir si le recovery.img est compatible ?

Merci !
 
Pgx

Pgx

Membre
Inscrit
12 Avril 2013
Messages
32
Points
6
  • #8
papillard a dit:
Bien joué,

Et par hasard, est ce que cette manipulation serait compatible avec un Wiko Birdy 4G ?
Quelle est le moyen de savoir si le recovery.img est compatible ?

Merci !

Aucune chance et perso, je n'essayerais pas !
 
X

xenekton

Membre
Inscrit
30 Décembre 2013
Messages
102
Points
0
  • #9
Bonjour,
J'ai récupéré le wiko d'un pote pour essayer de le réparé, mes Sony ne m'ont jamais au temps résister, mais ce wiko, il m'énerve franchement, donc j'explique son problème, même après réinstallation du firmware officiel, il me demande un mots de passe au démarrage, j'ai à peine le temps de choisir la langue qu'il switch la dessus, donc impossible d'accéder a la mémoire interne, j'ai réussi à mettre le CWM, j'ai mis une rom custom que j'ai trouver sur ma carte SD, mais elle n'est pas détecter, j'ai essayer avec une autre SD, essayer NTFS/Fat32 rien à faire, le SAV ne veule rien faire car il à une petite "côme" sur la partie en dessous de l'écran en alu" excuse bidon c'est un problème non hardware mais software...
 
N

Nourh

Membre
Inscrit
17 Août 2013
Messages
13
Points
0
  • #10
Les fichiers MT6582_Android_scatter.txt, MTK_AllInOne_DA.bin et recovery.img doivent être dans le téléphone pour que sa fonctionne ? Parce que lorsque je lance le processus ca dure des heures et ce ne s'arrête pas
 
R

robellec

Membre
Inscrit
31 Mai 2015
Messages
1
Points
0
  • #11
Salut, j'ai fait toute la procédure, mais quand je lance l'appli super su j'ai un message d'erreur m'indiquant '' aucun binaire su n'est installé ".
Je ne comprends pas pourquoi, si quelqu'un à une solution, je suis preneur.
merci
 
P

Pouletto

Membre
Inscrit
22 Juin 2015
Messages
1
Points
0
  • #12
Je n'arrive pas à ouvrir les fichiers téléchargée
 
N

NkdroidJ

Membre
Inscrit
5 Décembre 2015
Messages
1
Points
0
  • #13
Bonjour à tous!En fait j'ai installé cwm sur mon wiko getaway,le souci c'est que une fois dans le recovery mon wiko redêmarre automatiquement;j'ai réinstallé le recovery stock mais c'est pareil!Je ne sais pas d'où vient le problème s'il vous plaît de l'aide car je ne peux même pas faire un backup car environ 10 seconde dans le recovery et hop redémarrage auto !!!!?
 
Haut Bas