[TUTO][MARSHMALLOW]Root du Sony Xperia Z5C + Installation du TWRP (Bootloader déverrouillé)

  • Auteur de la discussion Skelett
  • Date de début
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
on est censé tout coché nan ? j'ai suivi lautre tuto et j'avais pas eu de probleme a flasher la 5.1.1
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Salut,

Normalement, tu ne dois rien cocher, surtout pas dans cette catégorie là, et encore moins pour le Z5/C/P.

Donc réessaye en décochant tout, sauf les wipes :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
pourtant je cite "Cochez toute les cases de l'encadré "MiscTA Exclude"

enfin pas grave

Jretenterai un jour j'ai de toute façon plus acces a adb mon telephone est plus reconnu

Jcrois que je vais piquer le pc de ma cops sous win 7 pour tout bidouiller
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Le tuto est général pour tous les Xperia, et pas mis à jour depuis un bon moment.

Du coup je te confirme qu'il ne faut pas les cocher, ça provoque des erreurs (là preuve, tu en fait actuellement les frais).
 
Y

Yxzoum

Membre
Inscrit
9 Mars 2014
Messages
27
Points
0
Hello,
Mon z1 ayant perdu la bataille contre le carrelage, je me suis tourné vers le z5c ^^.
Je voudrais rooter celui-ci avec la méthode de skelett mais je suis bloqué à l'étape ou on rentre "fastboot flash boot boot.img" dans le cmd.
Après avoir entré la commande j'ai <waiting for device> et plus rien... Impossible d'écrire une nouvelle ligne de commande et l'écran reste noir.
La led sur le téléphone est bien bleue, j'ai bien activé le debogage usb et autorisé les sources inconnues.
Merci d'avance,
Zoum
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Salut,

Tu as bien déverrouillé ton bootloader ?
 
Y

Yxzoum

Membre
Inscrit
9 Mars 2014
Messages
27
Points
0
Effectivement j'ai sauté cette étape :D.
J'ai un bootloader déverrouillable.
Le déverrouiller fait-il bien perdre la garantie ? Si oui, y a-t-il un moyen de récupérer cette garantie par la suite (en conservant le root) ?
Existe-il une méthode similaire à KingRoot (celui-ci ne fonctionne pas encore sur le z5c) ? Car j'ai encore 2 ans de garantie et j'aimerais en profiter ;).
Merci de ton aide.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Quoi qu'il arrive, le fait de déverrouiller son bootloader te fera perdre la garantie quoi qu'il arrive. Mais !

Il existe une méthode pour rooter temporairement ton appareil avec un bootloader verrouillé, afin de sauvegarder la partition TA, là où est "rangée" la garantie. Tu pourras la restaurer plus tard, afin de retrouver la garantie de ton appareil si besoin est. Du coup, je te laisse jeter un coup d'oeil à ce tuto -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
... Et te souhaite bien du courage ! :D
 
M

Moods13

Membre
Inscrit
25 Avril 2016
Messages
2
Points
0
Bonjour,

Tout d'abord, merci pour ce tuto bien clair (pour newbie comme moi), j'ai suivi la procédure comme indiqué et... Cela ne fonctionne pas..
Je précise: j'ai un Z5C, modèle 5823, sous Android 6.0.

J'ai bien monté le kernel et le twrp. J'avais déjà placé le SU(bêta) à la racine de mon téléphone avant même de débuter la procédure. Une fois tout le process accompli, le téléphone redémarre et à l'affichage "démarrage d'Android, lancement des application", il y a un led rouge qui clignote (une fois) de manière plus ou moins régulière et rien ne se passe, même avec du temps. J'ignore totalement à quoi c'est dû ni de quoi il s'agit..

En attendant d'en savoir plus, je vais flasher le firmware 6.0 (made in Singapore) et puis patienter sagement!
Merci d'avance (et bonne journée)

Edit: J'ai donc flashé mon téléphone avec le firmware dont je disposais, tout est revenu à la normale et j'ai même super SU d'installé, pourtant quand je le lance, il me dit "Aucun binaire SU n'est installé, et SuperSu ne peut l'installer. C'est un problème! Si vous venez de faire la mise à jour vers Android 5.0 (ce qui n'est pas mon cas, vous devez re-rooter manuellement votre appareil".
Je suis largué là 8|
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Salut,

Essayes avec cette version du SuperSU, que tu reflasheras via le recovery -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
:wink:
 
M

Moods13

Membre
Inscrit
25 Avril 2016
Messages
2
Points
0
C'est fait :) ! En téléchargeant le fichier, j'ai vu que c'était exactement le même que celui que j'avais déjà utilisé mais j'ai tenté le coup malgré tout.
Du coup, ça me fait exactement la même chose, je vais attendre un moment pour voir si le démarrage d'android se fait (ou non): si oui tant mieux, sinon, as-tu une idée de ce qui fait défaut?

Merci!
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Bonjour,

Merci pour ce tuto, je rencontre cependant un problème la procédure ce déroule bien jusqu'au reboot du téléphone ou la LED a clignoter plusieurs fois en rouge. A présent s'allume en vert et reboot quelques temps rouge avant de repasser au vert.

Ecran noir, le téléphone ne démarre plus

Pouvez vous m'éclairer ?

Merci par avance.

Cordialement
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Salut,

J'ai juste besoin d'une petite précision : Sous quel firmware tourne ton appareil ? Ça me permettra de déterminer le kernel que tu utilises.
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Salut,

Merci pour ta réponse, je suis sous le firmware 32.0.A.6.200.

Mon bootloader est bien déverrouillé.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Je vois. Tu es encore sous Lollipop (Android 5), tandis que là, tu suis un tutoriel pour Marshmallow (Android 6).

Dans ce cas, il faut que tu prennes ce kernel-ci -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Ou bien que tu mettes à jour ton Z5C en Marshmallow et utiliser l'un de ceux présents sur le tutoriel.
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Autant pour moi, quel abru... je suis c'est pas comme si c'était marqué dans le titre...

Désolé et encore merci !
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Pas de soucis et avec plaisir :wink:
 
S

Snouzy

Membre
Inscrit
25 Avril 2014
Messages
108
Points
0
Bonsoir n'étant pas sûr je me permet de vous demander si il s'agit bien de xposed-v79-sdk23-arm64 pour le z5c sous 6.x afin de ne pas faire d'erreurs ^^ bonnes soirée tout le monde


De plus, il me met "waiting for device" à "fastboot flash boot boot.img" ... une solution ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 584
Points
113
Salut,

Pour le Xposed, c'est la v86 qu'il te faut.

Pour le message du CMD, c'est parce que tu n'as pas installé les drivers ADB ou bien que tu n'as pas ouvert l'invit' de commande au bon endroit.
 
Haut Bas