[ROM] [Android 5.1.1] LegacyAOSP pour Xperia 2011

  • Auteur de la discussion maxouffr
  • Date de début
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #1

Salut à tous,

Je vais vous expliquer comment installer LegacyAOSP sur votre téléphone Xperia de 2011.

Avertissement : Cette opération comporte des risques. Phonandroid ou moi-même ne peuvent être tenu responsables des éventuels problèmes rencontrés.
Merci de lire le tuto dans son intégralité avec de commencer !!


Pour commencer, cette version est basée sur Android 5.1.
Vous pouvez trouver sur
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
, une présentation rapide des nouveautés de Lollipop.

________________________________________________________________________________________________________________________________________________________________________

Captures d'écrans :

Screenshot_2015_04_05_11_49_14.png
Screenshot_2015_04_05_11_49_18.png
Screenshot_2015_04_05_11_49_27.png
Screenshot_2015_04_05_11_49_39.png

________________________________________________________________________________________________________________________________________________________________________
Information

Liste des bugs :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Changelog :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


YQBMRQX.png
_______________________________________________________________________________________________________________________________________________________________________

Prérequis

  • Avoir déverrouillé son Bootloader ()
  • Etre sous le dernier firmware disponible.
  • Avoir fait une sauvegarde de votre téléphone

  • Avoir téléchargé :
    • La rom (Prendre la dernière build en se référant au changelog pour votre appareil) :
      S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
    • (Signification des versions :
      S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
      )
    • Le fichier
      S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

  • Il est obligatoire d'avoir une 2ème partition primaire de 2GO minimum en EXT4 ou F2FS sur la carte SD. ( d'aide)

  • Certaines opérations de ce tutoriel nécessitent des manipulations expliquées dans les guides suivants :

________________________________________________________________________________________________________________________________________________________________________

Installation :

  • Copier les gapps et la rom à la racine de la carte SD (en .zip, ne pas les décompresser)
  • Flasher le Kernel (boot.img) présent dans le zip de la rom via flashtool.
  • Démarrer le téléphone
  • Appuyer plusieurs fois sur la touche volume - (ou volume +) avant l'affichage de l'animation de démarrage.
  • Dans le menu principal du recovery, faire :
    • wipe data/Factory reset
  • Puis :
    • Apply update >> choose from sdcard0 >> (selectionner le .zip de la ROM)
    • Apply update >> choose from sdcard0 >> (selectionner le .zip de SuperSU)
    • Apply update >> choose from sdcard0 >> (selectionner le .zip des GAPPS)
  • Redémarrer le téléphone avec "Reboot system now"

Il ne vous reste plus qu'a paramétrer le système à votre convenance, restaurer vos SMS.., installer vos applications !![/list]

Pour effectuer une mise à jour de LegacyAOSP, il n'est pas nécessaire de faire un factory reset. Un wipe cache est suffisant. Ainsi, vos données de sont pas impactées.
Le reste de la manipulation reste identique.


S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Fred

Fred

Administrateur
Inscrit
19 Juin 2011
Messages
57 035
Points
113
  • #2
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Merci a toi :super:
 
M

maflo

Membre
Inscrit
4 Novembre 2013
Messages
111
Points
16
  • #3
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Pourquoi cette build s'appelle LegacyAOSP et non Legacy Xperia ou CyangenMod comme les précédentes build de cette team.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #4
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Car ce n'est pas cyanogenmod :D
Et que ce n'est pas Mike de LegacyXperia qui la fait seul.

D'après la source, c'est un regroupement de plusieurs dev dont Mike et Mardon.
 
M

maflo

Membre
Inscrit
4 Novembre 2013
Messages
111
Points
16
  • #5
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

D'accord. Je vais peut être attendre la build "Nightly build 201504xx - cm-12.1" qui si je comprend bien sera donc basé sur cyanogenmod
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #6
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Celle la oui !
 
P

prodax

Membre
Inscrit
28 Janvier 2012
Messages
39
Points
0
  • #7
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Le lien de DL le la rom semble être dead ;)

edit : le "System-Formating-Tool_signed.zip" aussi
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #8
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Essaye de passer par la source.
 
P

prodax

Membre
Inscrit
28 Janvier 2012
Messages
39
Points
0
  • #9
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

La source ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #10
Re: [ROM] [Android 5.1] LegacyAOSP pour Xperia2011

Le lien à la fois du post.
 
discours

discours

Membre
Inscrit
19 Avril 2012
Messages
4 408
Points
0
  • #11
Merci pour cette rom Lollipop sur nos vieux Ray.
Attention ! Une carte SD de classe 10 est requise. L'auteur affirme qu'avec une classe 4, cela met le tel en carafe... J'ai testé, c'est vrai :mrgreen: :pleur4:

Classe 10 pour sauver mon antiquité ??? Faut voir :?
 
Kerat19

Kerat19

Membre
Inscrit
4 Mai 2015
Messages
16
Points
0
  • #12
Bonjour, la ROM est-t-elle fluide et stable ? Me la conseilleriez-vous pour un usage quotidien (pour mon téléphone enfaite ^^ ) ? Merci d'avance pour vos réponses.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #13
Salut,

Oui, la rom fonctionne correctement ;)
Garde bien a l'esprit que l'appareil est vieux dans tout les cas.
 
Kerat19

Kerat19

Membre
Inscrit
4 Mai 2015
Messages
16
Points
0
  • #14
Salut et merci pour ta réponse, je viens de voir que ma carte sd était de classe 4 donc, je vais rester sur jelly bean :) et oui je m'aperçois qu'il commence à marquer le coup après 3ans et demi de bons et loyaux services, vas falloir songer à investir...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #15
Ok

Comme tu veux !
 
S

solar10

Membre
Inscrit
16 Avril 2013
Messages
6
Points
1
  • #16
'tite question?
Quand on est déjà en CM12, est-ce qu'on peut simplement sauter des étapes pour ne garder que :
- Reboot en recovery
- Wipe data/factory reset
- Apply update de la ROM + SuperSU + GoogleApps.
- Reboot.

Et question subsidiaire:
Si on ne veux pas des Google apps (j'ai le pack mini) du tout. Est-ce que le phone est utilisable? (Je veux tenter une aventure avec des appstore alternatifs comme FossDroid, par ex.)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #17
Oui, tu peux ;)

Les gapps ne sont pas obligatoire. Le téléphone fonctionnera mais tu n'aura pas les services de Google.
 
S

solar10

Membre
Inscrit
16 Avril 2013
Messages
6
Points
1
  • #18
Petit retour sur la re-install...
Ma première tentative s'est vautrée.
J'ai donc recommencé en rebootant en recovery
J'ai refait un wipe data/factory reset puis j'ai fait les 'apply update' de (dans cet ordre):
- System-Formating-Tool_signed.zip
- la ROM LegacyXperiaAOSP_haida-ota-52-beta1.zip (vu que la toute récente a buggué au démarrage sur le UI)
- UPDATE-SuperSU-v2.46.zip

Notes:
1- J'ai fait un downgrade de CM12.1 Andro5.1.1 vers CM12/Andro5.1
2- L'install ne prends plus 30-40min. comme l'upgrade de 4.x vers Lollipop mais à peine 3-5 minutes.

Et c'est tout.
Bon démarrer sans les GApps, c'est chaud pour installer des apk sans le Play Google mais pas impossible.
Il existe des appstore alternatifs comme F-Droid, FossDroid, AppBrain, ... Le contenu est orienté "Open", on n'y retrouve donc pas la myriade des jeux débiles et inutiles voire arnaqueurs comme sur le store Google.
Un autre site intéressant est APKMirror qui permet de télécharger les APK les plus courantes directement à partir du Browser.
Pour mon utilisation, l'essentiel y est et je me sens moins envahi par les intrusions Google.

Le truc bon à savoir si vous voulez vous passer de Google: Mettre les APK dans le répertoire "Downloads" (Téléchargements). Avec l'install d'Android, par defaut, il y a un widget qui ouvre ce répertoire et donc vous permettra d'installer les APK qui s'y trouvent (ne pas oublier de cocher la case qui autorise les installs d'APK non-signées).

@Kerrat19 : Pourvu qu'on ai une carte SD Class10 au minimum, oui c'est fluide et stable. Mais il faut faire gaffe à ce qu'on installe parce que certaines applis peuvent toujours faire des dégâts (Sensorly dans mon cas). Mon Xperia Neo V a une 2e vie, je suis super-content et remercie une nouvelle ceux qui sont derrière ce projet de LegacyXperia.
Seul regret (minime), la disparition de la RadioFM (une histoire de framework manquant apparemment).
 
A

Alteo

Membre
Inscrit
16 Juillet 2013
Messages
31
Points
8
  • #19
Salut à tous !

Je viens d'installer cette ROM, non sans mal (j'ai pourtant l'expérience des installations de ROM custom...). Je viens donc faire un petit retour.

Tout d'abord, pour situer le contexte : j'avais abandonné mon Xperia Arc S il y a un an et demi au profit d'un Xperia Z1 Compact (très bon appareil, soit dit en passant). Avant cela, lassé de ses lenteurs sous l'ultime ROM officielle avec Android ICS 4.0.4, j'ai testé des ROM custom avec bootloader verrouillé, et, peu convaincu côté performances, j'ai déverrouillé ce dernier pour installer Cyanogenmod 10.1... juste avant de passer à l'Xperia Z1 Compact.

Récemment, j'ai été contraint de laisser l'Arc S reprendre du service (mon Z1 Compact est parti en réparation :( ), et en réinstallant l'essentiel des applications que j'utilise au quotidien, je me suis heurté à l'autre gros point noir qui m'avait saoûlé à mort et qui m'avait convaincu (presque) de changer de téléphone : la capacité mémoire interne impressionnante de 420Mo !
J'ai jamais compris comment SonyEricsson a pu concevoir un modèle haut de gamme avec si peu de mémoire ! On est très vite limité dans l'installation d'applications ! Et du coup, là, en reprenant mon Xperia Arc S sous Cyanogen, je passais mon temps à faire quelque chose que je faisais déjà sous ROM stock : gratter de ma mémoire en sacrifiant des applications.

Alors, convaincu qu'Android offrait certainement la possibilité de s'installer sur une carte SD externe, j'ai googlisé et je suis tombé sur les ROM Cyanogen et LegacyXperia Lollipop pour Xperia Arc S !
Et après installation, je revis ! Déjà, c'est fluide... même si ça l'est moins qu'avec un Xperia Z1 Compact, bien sûr. Il y a quelques ralentissements, mais rien de bien méchant. Mais d'une façon générale, le téléphone est stable et offre un niveau de performances très satisfaisant. Rien à voir avec la lenteur sous ICS !
Et puis, je me peux pas bouder le plaisir suprême de voir mon espace de stockage interne passer de 420Mo à... 7Go ! Alleluia !! J'installe enfin sur ce téléphone toutes les applications que je veux ! C'est génial !

Je recommande vivement l'installation de cette ROM, quitte à débourser 15€ pour déverrouiller le bootloader pour ceux qui ont un modèle d'opérateur, et un peu plus pour l'achat d'une carte mémoire de classe 10. Ce sont des moindres frais pour rallonger considérablement la durée de vie de l'Xperia Arc S.

Par contre, je disais que j'avais rencontré des soucis à l'installation, alors pour ceux qui se lancent dans l'aventure, j'ai quelques préconisations :
- munissez-vous impérativement d'une carte SD de classe 10. Ca, c'est pas moi qui le dit, c'est le concepteur de la ROM. Pour que le système reste fluide, c'est obligatoire. Personnellement, j'ai opté pour une carte de 16Go à 8€, c'est largement suffisant ;
- conformément au mod-op, vous devrez partitionner votre carte SD pour créer une partition Ext2/3/4 pour le système. Là dessus, aucun souci, tout est bien indiqué dans le tuto. Par contre, il y a plusieurs choses à respecter, sous peine de ne même pas pouvoir entrer dans le recovery !
Premièrement, pensez à faire des partitions primaires autant pour la FAT-32 que pour la Ext2/3/4. Easeus permet de préciser que les partitions sont "principales", c'est l'option à choisir.
Ensuite, il est possible qu'il soit obligatoire de mettre le label "sd-ext" à la partition Ext2/3/4. C'est ce qui est indiqué par plusieurs exemples, mais je n'ai pas essayé avec un label différent.
Après, évidemment, ces deux points sont indiqués dans le tuto, mais il est impératif d'être vigilant dessus. J'avais fait un premier partitionnement avec Easeus, et la seconde partition que j'ai créé, la Ext2, était en partition étendue par défaut.
Par la suite, j'ai utilisé Gparted sous Linux pour partitionner 7Go de ma carte en Ext4, avec ce label "sd-ext". Si vous optez pour cette solution, pensez à vérifier que le point de montage est vide : j'avais "/usr" par défaut.
- le mod-op de LegacyXperia indique qu'il faut formater la partition système avec System-Formating-Tool_signed.zip ; il est disponible ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

- si vous souhaitez installer les Google Apps, prenez ce package :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
; contrairement aux tk-gapps ou pa-gapps, celui-là n'aboutit pas à l'erreur "signature verification failed". Et puis, c'est celui qui est suggéré par LegacyXperia. :)

Pour le reste, l'installation est simple et limpide. Une fois faite, il ne vous reste plus qu'à profiter de la seconde jeunesse de votre Xperia Arc/Arc S !
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #20
Salut et merci pour les informations complémentaires !
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #21
Bonjour,

Quand vous dites "Etre sous le dernier firmware disponible. ", vous parler de la dernière rom officielle (pour le St15i c'est la 4.0.4), c'est ça ?
On ne peut pas installer de rom custom si on tourne déjà sur une rom custom (je suis actuellement en 4.4.2 carbon) ?

D'avance merci.
:D

Cordialement,
Redfish
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #22
Salut,

Oui c'est bien ça ;)

Avec un factory reset, ça devrait marcher !
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #23
Merci pour ta réponses.
Donc un factory reset remettrai ma rom d'origine... j'ai quand même un doute quand je vois les tutos (mais je n'y connais pas grand chose).
Je vais tenter.

Encore merci...
:wink:
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #24
Bon, c'est bien ce que je pensais, ça ma juste remis à zero mon 4.4.2 Carbon...

Et là j'ai un gros bug.
Pour accéder au téléphone, il me demande la langue... mais je ne peux pas valider, car la flèche est en bas de l'écran, sous le "Appel d'urgence".
Donc impossible de faire autre chose qu'un appel d'urgence, je ne peux plus accéder au bureau.
:pleur4:
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #25
Bon cette fois je suis passé par le CWM pour faire le reset:
-Wipe data/factory reset
-Wipe cache partition
-Wipe dalvik cache
Résultat identique qu'en le faisant par le menu du téléphone...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #26
Il est toujours bloqué ?
Essayes de reflasher la rom (sans les gapps pour ne pas avoir ce menu pour commencer)
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #27
Merci, ça a marché...
Bon, reste à trouver comment revenir sur une rom officielle.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #28
Bonne nouvelle^^

Tu peux retourner en stock avec Flashtool ou Emma ;)
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #29
Encore merci pour tes réponses.

J'ai une dernière question avant de me lancer en 5.1...
Quand j'ai installé la 4.4 carbon, j'ai dévérouillé mon bootloader, flashé le kernel et installé la rom.
Pour revenir en arrière et réinstaller la rom d'origine en 4.0.4, ai-je besoin de remettre un kernel d'origine ou pas (il y a contradiction suivant les tutoriels).
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #30
Il n'y a pas de contradiction.... Tu suis la partie du tutoriel pour réinstaller un firmware officiel qui concerne flashtool.
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #31
Ok, donc même si je n'ai changé que le Kernel, il faut donc quand même installer un firmware d'origine complet (qui comprend donc le kernel d'origine).
Pas de possibilité de ne réinstaller que le kernel d'origine ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #32
Si tu réinstalles que le kernel d'origine, tu te retrouve dans la configuration kernel + système incompatible = bootloop !

C'est moi ou tu veux éviter de le reflasher entièrement ? Des problèmes dans le passé ?
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #33
C'est logique en effet...

Juste que flashtool ne marche pas bien avec mon xperia mini (st15i de 2012)... j'ai toujours un message d'erreur en plein milieu du flash.

Pour le déverrouillage du bootloader, flashtool me disait que mon tel était pas compatible (alors qu'il l'est)... j'ai du faire la manip en ligne de commande msdos (manip trouvée sur un autre site).
Pour l'installation du kernel de la carbon 4.4, même soucis avec la dernière version... mais pas de soucis avec une vielle version de flashtool... puis la suite se fait sur le tel, pas de soucis non plus.

Et là, pour repasse en 4.0.4, avec flashtool, en plein milieu du flash (juste après la décompression du fichier, quelques secondes après avoir branché le tel en vol-/diode+), message d'erreur

08/033/2016 14:33:33 - INFO - Preparing files for flashing
08/033/2016 14:33:36 - INFO - Please connect your device into flashmode.
08/033/2016 14:33:54 - INFO - Device connected with USB debugging off
08/033/2016 14:33:54 - INFO - For 2011 devices line, be sure you are not in MTP mode
08/033/2016 14:33:56 - ERROR - Drivers need to be installed for connected device.
08/033/2016 14:33:56 - ERROR - You can find them in the drivers folder of Flashtool.
08/034/2016 14:34:00 - INFO - Device disconnected
08/034/2016 14:34:11 - INFO - Device connected in flash mode
08/034/2016 14:34:12 - INFO - Opening device for R/W
08/034/2016 14:34:12 - INFO - Reading device information
08/034/2016 14:34:12 - INFO - Phone ready for flashmode operations.
08/034/2016 14:34:12 - INFO - Opening TA partition 2
08/034/2016 14:34:12 - INFO - Current device : ST15i - BX902X28SY - 1249-9900_R2I - 1244-2098_4.1.B.0.587 - WORLD-i_4.1.B.0.587
08/034/2016 14:34:12 - INFO - Closing TA partition
08/034/2016 14:34:12 - INFO - Start Flashing
08/034/2016 14:34:12 - INFO - Processing loader.sin
08/034/2016 14:34:12 - INFO - Checking header
08/034/2016 14:34:12 - ERROR - Processing of loader.sin finished with errors.
08/034/2016 14:34:13 - INFO - Ending flash session

Alors que les pilotes sont bien installés... et que je n'ai pas toujours ce message d'erreur, la plupart du temps je n'ai que ERROR - Processing of loader.sin finished with errors.

Parfois j'ai juste:
08/044/2016 14:44:37 - ERROR -
08/044/2016 14:44:37 - ERROR - Error flashing. Aborted

Bref, je cherche plutot à remettre le kernel seul (vu que je sais comment le faire avec succés en ligne de commande)... puis installer la rom 4.0.4 un peu comme j'ai fait pour la carbon (le soucis c'est que c'est pas un fichier zip comme pour la carbon, mais un ftf).
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #34
Pour l'avant dernier test j'ai eut ça:
08/047/2016 14:47:47 - INFO - Checking header
08/047/2016 14:47:47 - ERROR - Processing of loader.sin finished with errors.
08/047/2016 14:47:47 - INFO - Ending flash session
08/047/2016 14:47:47 - ERROR - Error in processHeader : 2 : Le fichier spécifié est introuvable.
08/047/2016 14:47:47 - ERROR - Error flashing. Aborted

Et le dernier, uniquement ça:
08/049/2016 14:49:46 - ERROR - Processing of loader.sin finished with errors.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #35
Il faut une vieille version de flashtool pour les Xperia 2011.

Pour faire ce que tu veux, il faut que tu ai une rom en zip (comme ultimate HD) ainsi qu'un kernel custom base stock avec un recovery (Regarde le kernel lupus)
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #36
Hum, info bonne à savoir... vu que ce n'est précisé nul part (et que j'ai bien téléchargé le firmware stock via l'outil interne de flashtool... le xperia st15i est dans la liste).
Reste à retrouvé où j'ai pris ma vieille version lors du flash custom... vu que les anciennes versions ne sont pas présentes sur le site de flashtools.
Un vrai casse tête cette histoire...
:vieux-smiley:
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #37
C'est pas notre faute si les outils sont mise à jour et qu'un appareils devient mal supporté.
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #38
J'ai pas dit que c'était de votre faute...
Je disais juste que dans la dernière version de flashtool, via l'outil interne, il propose le dl du firmware d'origine pour le st15... le fait qu'il ne soit pas compatible est quand même gênant et incompréhensible.
:D

Après vérification j'ai bien un Xperia mini 2012 (12W15)... et non pas 2011 (12W13 et avant), ce qui fait que beaucoup de tuto/outils ne sont pas valable.
Tu n'aurais pas un lien vers une vieille version de flashtool par hasard ?
Car là je tourne vraiment en rond, j'arrive pas à trouver.
;)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #39
Il fait bien partie dee la gamme 2011 car il est sorti en 2011 avec le arc le néo, ect...

Nan je n'ai pas de lien mais regarde sur xda.
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #40
Merci.
Au final pas besoin de revenir très en arrière pour avoir l'ancienne version (avec le dossier firmware dans le dossier d'installation de flashtool au lieu de l'avoir dans users)... j'ai prix la 9.6.
Y a avait même un firmware pour X10 mini déjà dedans...

Par contre, même soucis, ca plante:
8/058/2016 17:58:08 - INFO - Start Flashing
08/058/2016 17:58:08 - INFO - Processing loader
08/058/2016 17:58:08 - INFO - Checking header
08/058/2016 17:58:08 - INFO - Ending flash session
08/058/2016 17:58:08 - ERROR -
08/058/2016 17:58:08 - ERROR - Error flashing. Aborted
08/058/2016 17:58:08 - INFO - Device connected in flash mode

(PS: Faudra peut être supprimer mes posts une fois toute l'histoire finie, histoire de ne pas polluer ce topic qui n'a rien à voir).
:oops:

Idée (vu qu'en mode "diode bleu" j'ai pas de soucis):
-Démarrer en fastboot
-Installer le kernel.sin
-Puis installer le system.sin
Ca pourrait marcher ?
Les autres fichier (loader.sin, etc...) ne risquent pas de manquer ?
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #41
Bon, je viens de tester avec sony compagnion (ou point ou j'en suis) en mode réparation:
"Problème:
Le téléphone/tablette contient un logiciel modifié, qui est impossible à mettre à jour.

Détails:
Echec du moteur de mise à jour Sony (erreur 0x000007d3)."


Et je peux oublier "Update service", pas trouvé un seul site qui propose de le télécharger.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #42
Il faudrait déplacer les messages mais je ne suis pas depuis un PC pour le moment.

Tu ne peux plus utiliser PCC à cause du bootloader. Update service n'est plus disponible et en plus tu aurais eu la même erreur.

Tu as Emma sinon.

J'ai jamais flasher de rom stock en sin donc je ne pourrais pas te dire si c'est possible...

Et en reprenant ton idée de flasher une rom via le recovery ?
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #43
Alors, j'ai trouvé une rom stoc, apparemment non modifiée sur la base (mais un peu allégée en bloatware) en zip >
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Est ce que j'install le kernel.sin (extrait de mon firmware stock) ça pourrait passer ?

Encore merci pour ton aide.
:)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #44
Il te faut un recovery puisqu'elle est en zip donc flash plutôt le kernel lupus.
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #45
Ok (je pensais que le recovery était inclus dans tous les kernels, même celui stock).
Au final, un kernel lupus + la rom que j'ai cité plus haut... je serais considéré comme "stock" et pourrais passer en 5.1 sans soucis ?

PS (question que j'aurai du poser dès le départ) > C'est quoi le risque de passer d'une 4.4carbon à une 5.1 de ce topic directement sans repasser par l'état 4.0.4 "stock" ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #46
Oui, tu sera considéré comme stock !

il n'y a pas vraiment de risque en changeant de rom custom. Il y a éventuellement un risque de bootloop si tu ne changes pas le kernel ou si tu ne fais pas les wipes
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #47
Encore merci.
Reste plus qu'à me lancer en espérant que ça passe sans soucis...
;)
 
RedfishTheCat

RedfishTheCat

Membre
Inscrit
30 Novembre 2013
Messages
20
Points
0
  • #48
Bon, ça s'est bien passé... juste le wifi qui ne marche pas.
Faut donc que je passe rapidement sur Android 5.

Encore merci pour ta précieuse aide Maxxouffr et pour ta patiente.
Série de posts à supprimer (désolé).
Et ça serait peut être pas bête que je fasse un mini-tuto pour ceux qui sont dans mon cas, ça pourrait toujours servir.
;)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 605
Points
38
  • #49
Bonne nouvelle :)

Tiens nous au courant pour ton passage sous LP.
 
B

bct2016

Membre
Inscrit
2 Avril 2016
Messages
9
Points
1
  • #50
svp le lien des gapps ne marche pas
 
P

pakrett-bm

Membre
Inscrit
22 Mai 2014
Messages
13
Points
1
  • #51
JeanCombret

JeanCombret

Membre
Inscrit
20 Août 2015
Messages
97
Points
8
  • #52
Merci pour ces dépôts alternatifs :wink:
 
Haut Bas