[Résolu] Comment flasher correctement une rom custom ?

  • Auteur de la discussion Optogram
  • Date de début
Optogram

Optogram

Membre
Inscrit
7 Août 2020
Messages
2
Points
3
  • #1
Bonjour !

Je suis ici en quête d'aide francophone avec ce fabuleux nouveau téléphone qui, pour le moment, me tient tête :(
C'est mon 3eme Oneplus, et mon 4eme smartphone Android. Tout les précédents ont été déverrouillés, rootés, bidouillés, mais je n'ai jamais autant été perdu qu'avec celui-ci. Je viens de terminer pour la seconde fois un débrickage en bonne et due forme avec MSMDownloadTool, je ne sais plus quoi faire.

Mon problème est rapidement écrit : Je n'arrive pas à installer une ROM custom sur le Oneplus 7 Pro.

Voilà mon état des lieux avec la liste des étapes que j'ai réalisées : (Je me suis rendu compte en furetant sur vos tutoriaux que la démarche n'est pas celle que j'ai trouvé ailleurs)
  • Bootloader dévérouillé
  • Recovery :
    • fastboot boot recovery.img (aka TWRP 3.4.0.0 de Mauronofrio)
    • Advanced -> Install Recovery Ramdisk
    • Install -> Flash TWRP_Installer.zip (toujours celui de Mauronofrio)
    • Install -> Magisk.zip
  • Reboot -> System
Je constate déjà des différences entre les méthodes énoncés sur ce forum et ce que j'ai trouvé sur XDA, par exemple. Me serais-je déjà planté à cette étape ?
Ensuite, voilà les étapes que l'on m'a proposé de suivre. Et c'est là que je suis totalement perdu.
  • Wipe -> Factory Reset : Wipe Data, Cache et Dalvik Cache
  • Install -> Flash ROM
  • Install -> Flash TWRP Installer
  • Reboot -> Recovery Dans mon cas, après avoir flashé quoi que ce soit, le reboot recovery redémarre sur le slot inactif précédemment.
  • Wipe -> Format Data
  • Reboot -> System
En globalité, je ne comprends pas ce que je fais. Et je me dis que si je ne comprends pas, un paquet d'autres personnes doivent être perdues.
  • A quoi sert le TWRP_Installer.zip ?
  • Pourquoi il n'est pas nécessaire de flasher l'image (le fichier au format .img) maintenant ?
  • Comment diable fonctionnent ces deux slots A/B ?
Merci de votre aide !
 
Dernière édition:
Dernière édition:
Optogram

Optogram

Membre
Inscrit
7 Août 2020
Messages
2
Points
3
  • #3
Merci !

Après plusieurs essais, voilà ce qui a fonctionné pour moi :
  • Wipe -> Factory Reset + : Wipe Data, System, Cache et Dalvik Cache
  • Install -> Flash ROM
  • Install -> Flash TWRP Installer : Sans redémarrer le recovery
  • Reboot -> Recovery : Le rédémarrage du bootloader charge le second slot
  • Wipe -> Format Data : Taper le mot "yes" et valider
  • Reboot -> System : Redémarrer et lancer pour la 1ere fois le nouveau système
  • Install -> Magisk
  • Reboot -> System
  • Install -> Modules Magisk, Mods, etc...
  • Reboot -> System
Merci de votre aide ! Bonne fin de week-end !
 
  • Like
Les réactions: Buck2000 et Fred
Haut Bas