Problème suite à un root (pas de connexion, carte sim non détecté, etc...)

  • Auteur de la discussion yassklokil
  • Date de début
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #1
Bonjour je viens vers vous pour vous demander de l'aide car j'en ai bien besoin en ce moment, voilà j'ai root mon téléphone One Plus 7 avec ADB et TWRP (en flashant l'IMG) mais une fois que tout c'est réalisé je me retrouve avec un téléphone qui ne peut ni se connecter en Wifi ni même reconnaitre la carte SIM.

Du coup voilà j'aimerai savoir comment résoudre ce problème s'il vous plait notamment en flashant une ROM car je pense que je ne dispose pas de firmaware où du moins ce dernier c'est mal installé.

Comment résoudre ce problème s'il vous plait :(
 
M

Membre supprimé 871227

  • #2
Salut essaie de flasher un kernel custom.
Si ton problème n'est pas réglé à l'issue passe un coup de msm tool pour restaurer ton oneplus 7 en config usine.
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #3
Salut Zayatoshi merci de ta réponse rapide, comme tu fais pour flasher un kernel (j'imagine que c'est une ROM) je dispose de lineage 1.7.1

Cordialement.

EDIT : MSM Tool ne fonctionne pas 'packet image not exist" :(

Edit 2 : J'ai tenté le flash de la rom lineage 17.1 en mode recovery mais là ça 10-15 minutes qu'il charge sans rien se produire .... je sent que c'est foutu :(
 
Dernière édition par un modérateur:
M

Membre supprimé 871227

  • #4
Ton problème de connexion wifi et détection carte sim est apparu juste après le root ou après le flash de lineage ?
Je pensais que tu étais sous rom stock.
Le kernel se flash avec un kernel manager et les droits root ou depuis le twrp fonctionnel.
Et je ne sais pas si le twrp du 7 est pleinement fonctionnel. Et tous les kernels manager ne sont pas adaptés au rom custom.
Donc ma réponse n'en tiens pas compte
Essaie de flasher une autre rom custom ou de restaurer ton oneplus avec msm tool.
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #5
Merci de la réponse le problème c'est que je viens de flasher la ROM lineage en ce moment en recovery via TRMP(une rom très connu pourtant) mais là il charge continuellement ça fait 15 minutes déjà et impossible de l'éteindre ou d'accéder à ADB (qui évidement ne reconnait pas le device) ....

Et le MSM tool ne fonctionne pas je l'ai téléchargé mais visiblement je ne peux pas le lancer il me dit qu'il y' a une erreur du packed ...
 
Dernière édition par un modérateur:
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #6
Salut,

Pour l'installation de LineageOS, as-tu fais tous les wipes et un factory reset avant le flash ? Si non, ton blocage vient de là.

Pour MSM, où l'as-tu téléchargé ? Car sur mon tuto, le package est pleinement fonctionnel.
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #7
Bon apparement je sais ce que j'ai fais c'est moi qui est fait une gaffe (une très grosse même)

J'ai reboot le system avec TRMP ce qui fait qu'apparement cela a supprimé mon OS :(

Comment faire du coup ?

EDIT : Merci de la réponse.

J'ai flash la rom lineage en mode recovery puis j'ai reboot en selectionnant "system" avec TRMP et apparement il ne fallait pas faire ça car mon OS a été supprimé.

Mais apparemment on peut encore corrigé cela mais comment je ne sais pas :

je suis tombé sur ça :d) https://www.phonandroid.com/forum/t...e-systeme-apres-essai-flash-root-twrp.186043/

EDIT 2 : Pour MSM sinon puis je avoir le lien s'il te plait (bien que je doute que ça marche vu la situation)
 
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #8
Bon. Déjà, stp, arrête d'écrire plusieurs messages d'affilés. Le règlement du forum l'interdit et je n'ai pas envie de repasser derrière toi à chaque fois. Le bouton "éditer" en bas de chacun de tes messages permet de rajouter du texte.

Ensuite le TWRP prend en charge le MTP. Donc tu fais ça :

- Sur le TWRP -> Wipes -> Advanced Wipes -> Coche toutes les cases et tu valides
- Retour -> Factory Reset -> YES
- Retourne au menu du TWRP en cliquant sur précédent (flèche en bas à gauche de l'écran) -> Reboot -> Recovery

- Tu branches ton téléphone démarré sur le TWRP sur ton PC
- Tu injectes Lineage sur ton téléphone
- Et tu flash via le TWRP.

Pour MSM, regarde ici : https://www.phonandroid.com/forum/t...0-debricker-ou-downgrader-son-oneplus.202870/
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #9
Merci de la réponse, comment j'accède au TWRP sur mon téléphone sachant qu'il est complètement bloqué au chargement impossible de l'éteindre, impossible d'accéder à ADB car il ne détecte aucun "device" sur le PC.

Cordialement.
 
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #10
En fait, tu t'es lancé dans le truc à l'arrache ? Pour démarrer en recovery, téléphone éteint, maintiens les touches volume bas + Power.

Pour qu'ADB reconnaissance ton téléphone, il faut le démarrer en fastboot mode : Téléphone éteint, maintiens les touches volume haut + power.
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #11
Skelett a dit:
En fait, tu t'es lancé dans le truc à l'arrache ? Pour démarrer en recovery, téléphone éteint, maintiens les touches volume bas + Power.

Pour qu'ADB reconnaissance ton téléphone, il faut le démarrer en fastboot mode : Téléphone éteint, maintiens les touches volume haut + power.

Merci de la réponse, on peut dire à l'arrache car j'ai fais une erreur où il ne fallait pas reboot le system via TWRP comme je te l'ai dit précédement impossible d'éteindre mon téléphone, il affiche le logo lineage en chargement (défile de droite à gauche) continuellement.

Du coup je ne peux peux ni l'éteindre, ni du coup passer en fastboot / recovery mode (avec ADB j'ai la possiblité de le faire depuis une commande) mais ADB ne détecte pas le téléphone.

Du coup là je tente de télécharger MSM tool via le forum XDA car le lien que tu as posté ne dispose pas du One Plus 7 GM1900 (mon modèle de téléphone) du coup je vais tenter de voir via MSM mais je ne pense pas que ça va marcher puisque j'imagine que MSM devra reconnaitre mon téléphone ...


EDIT : alors je peux éteindre mon téléphone en appuyant sur volume UP + POWER

EDIT 2 : j'ai le RECOVERY de Lineage il me propose : reboot to bootloader / reboot to recovery / mount - system / enable ADB / power off

EDIT 3 : adb sideload c'est pour flasher une rom / firmware / kernel ?
 
Dernière édition:
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #12
Bon, tu as raison, mieux vaut redémarrer de 0, et MSM t'aidera pour ça. On verra la suite après.
 
  • Like
Les réactions: Nico97605
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #13
Tout d'abord je tenais à te remercier, j'ai suivi à la lettre ton tuto MCM et .... PAR MIRACLE j'ai pu débloquer mon téléphone maintenant j'ai un léger problème, l'OS que je dispose est en anglais US peut là mettre en Français s'il te plait
 
Dernière édition par un modérateur:
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #14
Ben est à toi de choisir au premier démarrage de l'appareil, c'est la première chose qu'il te demande.
 
Y

yassklokil

Membre
Inscrit
20 Décembre 2020
Messages
8
Points
1
  • #15
L'OS en question est uniquement en US et je ne peux choisir que l'Anglais ou le Mandarin / mandarin simplifié. (Hydrogen OS)
 
Skelett Skelter

Skelett Skelter

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 491
Points
113
  • #16
Ah oui, forcément.

Télécharge donc un des package qui est sur mon tuto, et passe par-là. Ça réinstallera OxygenOS
 

Sujets en relation

Haut Bas