Modifier fichier APK pour le rendre compatible sur version antérieure android

N

nicotoul

Membre
Inscrit
23 Avril 2016
Messages
21
Points
1
Bonjour à tous,

Dans le play store, je remarque que certaines applications ne sont pas compatible pour être installé sur des version antérieure d'android.
J'arrive à trouver les fichiers APK de l'application mais lors de l'installation j'ai une "erreur d'analyse du paquet".

Je possède un HTC ONE MINI 2 qui possède Android 4.4.2.
J'aimerais pouvoir installer des applis qui demandent minimum Android 5.

Je sais qu'il est possible de modifier des fichiers de configuration d'une application APK à l'aide de 7zip par exemple mais je ne sais où aller une fois que je suis dans l'arborescence.

Pouvez-vous svp me dire dans quels fichiers ou quels type de fichiers est stocké cette information?

L'idée étant de modifier le paramètre qui force la configuration minimale afin que je puisse changer la valeur pour la rendre compatible avec la version 4.4.2.

Merci pour votre réponse.
 
fruity101079

fruity101079

Membres VIP
Inscrit
7 Mars 2012
Messages
3 396
Points
48
Bonjour
Ce n'est pas une simple restriction.
Si les anciennes version d'android ne sont pas supportées, c'est simplement que de nouvelles API inexistantes sur les précédentes versions sont utilisées.
Sinon quel serait l’intérêt du dev de se priver de potentiels clients?
 
N

nicotoul

Membre
Inscrit
23 Avril 2016
Messages
21
Points
1
Bonjour,

Merci pour ta réponse.

Je suis d'accord sur le fait que certaines API ne sont pas compatibles.

Mais j'ai lu il y a quelques temps(je ne sais plus où) que certaines applications étaient bloquées par un paramètre qui forçait la condition d'une version minimal pour fonctionner.
Il suffisait alors de modifier ce paramètres pour pouvoir lancer l'appli.

Concernant la question/réflexion
"Sinon quel serait l’intérêt du dev de se priver de potentiels clients?"

Il y en a plusieurs, notament
- assurer le support de l'application que sur certaines versions
- Eviter d'éventuels bug liés aux versions trop anciennes
- Réserver l'application à ceux qui ont un téléphone récent
 

Haut Bas