[Tutoriel] Installer le CWM Recovery 6.0.2.8 sur son Sony Xperia Z

  • Auteur de la discussion gabriel59
  • Date de début
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #1
INSTALLER LE CWM RECOVERY 6.0.2.8 SUR SON SONY XPERIA Z​

Installer le CWM Recovery 6.0.2.8 sur son Sony Xperia Z

Avertissement : Cette opération comporte des risques. Phonandroid ne peut être tenu responsable des éventuels problèmes rencontrés. Pensez à effectuer une sauvegarde avant d'installer cette rom

Je vous propose d'installer le CWM recovery 6.0.2.8 sur son Sony Xperia Z. Vous allez pouvoir installer des roms customs, faire des sauvegardes, des restaurations...Attention, ne pas utiliser ce CWM recovery pour installer CM10.1.

Merci à
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !



-------------------------------------------------------------------------

Pré-requis :


Installation :

  1. Décompressez le fichier fastboot.zip et collez le dossier à la racine de votre ordinateur C:\.

  2. Renommez le Z_DooMLoRD_AdvStkKernel_FW-350_v2.img en kernel.img (ça sera plus simple à entrer dans la fenêtre de commande ;))

  3. Collez le fichier kernel.img dans le dossier fasboot.

  4. Éteignez votre mobile. Puis appuyez simultanément sur la touche Volume Haut et connectez votre mobile à votre ordinateur via le câble USB. La led de votre mobile devient BLEUE.

  5. Sur votre ordinateur, appuyez sur les touches Windows + R. Une fenêtre s'ouvre. Tapez cmd puis validez sur OK.


    step6.png

  6. Une fenêtre de commande s'ouvre. Tapez le code suivant :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
    puis validez avec la touche Entrée




  7. Puis tapez le code suivant :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
    puis validez avec la touche Entrée

  8. Voilà, vous pouvez démarrer votre mobile en CWM recovery. Pour cela, Allumez votre mobile. Quand le logo Sony apparaît et que la led violet puis orange, appuyez plusieurs fois sur la touche Volume Haut

Merci de publier vos retours si vous effectuez ce tuto ;)
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #2
Merci pour le partage :wink:
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #3
moi ça n'as pas fonctionner il marque error:device not found
quand je tape la commande adb reboot bootloader
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #4
Slt tu as installé les pilotes ?
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #5
oui il sont installé
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #6
Tu tape bien le bon chemin d accès ?
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #7
oui vu qu'il me marque deamon startup
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #8
je viens de réessayer et maintenant il marque tout de suite error device not found des que je tape adb reboot bootloader
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #9
Essaie en branchant ton tel sur un autre port usb.
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #10
j'ai essayer rien a faire
maintenant j'ai un autre probleme le telephone ne veut plus demarrer,j'ai essayer update service pour le réinitialiser
et il me dit qu'il peut pas mettre a jour car le programme es modifier,et avec flashtool il reste bloquer sur flashing data je dois attendre combien de temp pour flashtool fasse son travail
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #11
c'est bon j'ai régler le problème de démarrage,je vais voir pour installer le cwm maintenant
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #12
OK :wink:
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #13
toujours impossible d'installer le recovery il me dit error: not device found
pourtant les drivers sont installé donc je cherche une solution mais pour le moment rien trouver
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #14
Tu as le Débugage usb de cocher dans tes paramètres ?
 
K

kaiserajt60

Membre
Inscrit
7 Août 2012
Messages
16
Points
1
  • #15
gttao a dit:
moi ça n'as pas fonctionner il marque error:device not found
quand je tape la commande adb reboot bootloader

Bonjour

Même problème,le processus ce lance et stop en cours avec le message d erreur :device not found
Capture :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Débugage usb activé et autorisation source inconnu activé

Une idée ?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 679
Points
0
  • #16
Salut,
Cette commande ne te sers à rien si tu as déjà branché ton mobile en mode Fastboot.

Éteignez votre mobile. Puis appuyez simultanément sur la touche Volume Haut et connectez votre mobile à votre ordinateur via le câble USB. La led de votre mobile devient BLEUE.
 
K

kaiserajt60

Membre
Inscrit
7 Août 2012
Messages
16
Points
1
  • #17
sebastien207 a dit:
Salut,
Cette commande ne te sers à rien si tu as déjà branché ton mobile en mode Fastboot.

Éteignez votre mobile. Puis appuyez simultanément sur la touche Volume Haut et connectez votre mobile à votre ordinateur via le câble USB. La led de votre mobile devient BLEUE.


Ok Sebastien207

En faite j'ai reussi peu de temps aprés en lancant directement la commande suivante mais j ai été obligé de bidouiller un peu car il ne reconnaissait pas le tel.

Encore merci de ton retour
kaiserajt
 
Souleymane

Souleymane

Modérateur de secteur
Inscrit
15 Janvier 2012
Messages
7 243
Points
36
  • #18
Salut, Golem j'ai mis à jour le tuto en enlevant l'étape en trop :)
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #19
Merci à toi. Tu parles de quelle étape ?
 
MutantX

MutantX

Membre
Inscrit
29 Octobre 2011
Messages
6 679
Points
0
  • #20
Salut,
Il parle de la ligne de commande "abd" qui n'est pas à effectuer, puisque dans l'étape 4 tu demande de rentrer en mode fastboot en raccordant le mobile.
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #21
Exact. C'est du à une copie du tuto d'origine ;)
 
K

kaiserajt60

Membre
Inscrit
7 Août 2012
Messages
16
Points
1
  • #22
c est bien ça les gars
merci a vous de votre aide
 
J

jigsaw89

Membre
Inscrit
3 Septembre 2012
Messages
86
Points
8
  • #23
bonsoir, jai suivie le tuto a la lettre mais il me marque waiting for device alors j attends mais toujours rien une idee ?
merci
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #24
Tu as installé les drivers adb ?
 
emilie64

emilie64

Membre
Inscrit
13 Mars 2013
Messages
86
Points
0
  • #25
Merci du portage! ;)
 
J

jigsaw89

Membre
Inscrit
3 Septembre 2012
Messages
86
Points
8
  • #26
Golem a dit:
Tu as installé les drivers adb ?
je dirais oui car jai reussi a le rooter ,jai installer les drivers fastboot et les drivers pc compagnon , avec le cable d origine et le port usb 2.0
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #27
pareil pour moi maintenant waiting for device il marque
 
K

kaiserajt60

Membre
Inscrit
7 Août 2012
Messages
16
Points
1
  • #28
quand j ai indiqué dans mon post que j avais été obligé de bidouiller car il ne reconnait pas le tel ,c etait le fichier fasboot qui ne fonctionnais pas ,j'ai récupéré le fastboot beta z et la pas de soucis

Si ca peux aider !!
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #29
tu a trouver ou le fastboot beta ?
 
S

S4dique

Membre
Inscrit
5 Novembre 2012
Messages
20
Points
0
  • #30
Bonjour,
en suivant les instructions à la lettre j'arrive à l'étape 6 je met la ligne de code " adb reboot bootloader" il me marque "error : more than one device and emulator" je sais rien faire d'autre...

j'ai un firmware 10.1.A.1.434 et pas 10.1.A.1.350, je me demande si ca ne change pas qq chose...
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #31
Tu as installé un émulateur Android ou tu as un autre mobile de brancher ?
 
S

S4dique

Membre
Inscrit
5 Novembre 2012
Messages
20
Points
0
  • #32
aucuns mobiles de branché, mais bluestack est installé sur mon pc et comme ça émule android....

en virant bluestack le message change pour le même que ceux qui ont des problèmes avec le "waiting for device "

une solution ? merci d'avance :D
 
K

kevin85

Membre
Inscrit
16 Décembre 2011
Messages
10
Points
0
  • #33
Bonjour,

J' ai rooter mon téléphone et installé le cwm recovery , tout fonctionne , mais mon boot loader est verrouillé , est il possible d 'installer quand meme un rom custom genre cyanogen ou faut il absolument que le bootloader soit déverrouiller si c 'est cela à quoi peut me servir le cwm recovery?

Merci d' avance
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #35
toujours pas de solution pour la waiting for device ?
 
S

S4dique

Membre
Inscrit
5 Novembre 2012
Messages
20
Points
0
  • #36
Bonsoir, en fouillant le net j'ai testé différentes versions de fastboot et j'ai réussi à en trouver une qui me met un nouveau message d'erreur : FAILED remote : command not allowed


l'autorisation pour l'install des fichiers sources inconnues est activée ainsi que le débogage usb et j'ai testé sur 2 pc au cas ou...




Je pense que Fastboot n'est pas compatible avec tout les firmware, 2 versions différentes me donnent 2 erreurs différentes...

Si quelqu'un à réussi à utilisé fastboot sur un firmware .434 je suis preneur :D
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #37
Ton bootloader n'est pas déverrouillé, normal que fastboot ne fonctionne pas.
 
S

S4dique

Membre
Inscrit
5 Novembre 2012
Messages
20
Points
0
  • #38
tu a raison, mon bootloader était pas déverouillé, je viens de le faire et maintenant après avoir installé le recovery, en redémarant le gsm c'est écran noir... je sais aller dans les options recorvery démarrer en mode fastboot mais le gsm refuse de démarrer
..
une idée ?
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #39
D'après ce que je lis dans le tuto, le kernel est tiré d'une version .350
tu as quel version de firmware en ce moment ?
 
S

S4dique

Membre
Inscrit
5 Novembre 2012
Messages
20
Points
0
  • #40
ouf problème réglé et enfin il est rooté, je viens de comprendre enfin ce qui se passait, c'est bel et bien un problème de compatibilité avec le firmware 434.

Pour ceux qui veulent installer le recovery sur un firmware 434 aller là et choisissez la dernière version :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


une dernière question, j'ai fait un backup via pc compagnion de mes appli contact etc, en faisant une restauration, pc compagnon ne risque pas de me retirer le root ?
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #41
LA base : un firmware A doit fonctionner avec un kernel A
Va faire un tour dans ma signature ;)

Maintenant t'es bon pour soit :
- faire une réparation via PC Companion ou Sony Update Service
- soit flasher une rom avec flashtool (voir le tuto)
 
K

karlit0z

Membre
Inscrit
8 Avril 2013
Messages
2
Points
0
  • #42
Salut :)

Bon voilà,

Xperia Z C6603 fw 350 rooté, CWM Recovery 6.0.2.8 installé ainsi que busybox etc :)

Je suis en train de sauvegarder !


Rien de bien compliqué, je comprends pas comment des gens foirent !
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #43
Merci pour le retour. Il faut prendre le temps de lire. Certains pêchent par précipitation ;)
 
G

gttao

Membre
Inscrit
11 Décembre 2012
Messages
39
Points
0
  • #44
j'ai tout essayer il me marque toujours waiting for device personne a une solution
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #45
les derniers drivers adb dispos sont installés ?
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #46
Salut,

Moi j'ai le message suivant "fastboot n'est pas reconnu en tant que commande interne ou externe un programme éxécutable ou un fichier de commande" ???
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #47
J'ai bien pris le lien pour le firmware 434 et moi aussi j'ai waiting for device !!!
 
F

Fl3xhd

Membre
Inscrit
22 Avril 2013
Messages
3
Points
1
  • #48
Merci pour ce tuto , tout est passé nickel chrome ^^
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #49
Merci à toi. Tu avais quelles configurations sur ton mobile ?
 
F

Fl3xhd

Membre
Inscrit
22 Avril 2013
Messages
3
Points
1
  • #50
Bootloader Dévérouillé.
Firmware 10.1.A.1.434.
Rooté.
et donc du coup CWM 6.0.3.0 (
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
) via Flashtool la dernière rev.Beta6 qui facilite la tache d'ailleurs , Flashtool puis FastBoot Mode, on tombe la dessus :



on éteint l'appareil puis la manip habituelle on branche le cable micro usb + volume haut, led bleue.



Colonne de droite, on va chercher son kernel.img ( pour moi le :
Advance Stock Kernel with Recovery v05 (FW: 10.1.A.1.434)) et le tour est joué.

Bon courage à vous perso j'ai bien galèrer entre des soucis de drivers etc..de droits..bref le tout sous Win8 pro, faut dire que je passe d'IOS (iphone5) @ Android (XperiaZ)..mais bon...ça en vaut la peine.

:D
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #51
Merci pour le retour très complet. On va mettre tout ça à jour ;)
 
J

jeanmoise.ndoh

Membre
Inscrit
24 Avril 2013
Messages
3
Points
0
  • #52
Fl3xhd a dit:
Bootloader Dévérouillé.
Firmware 10.1.A.1.434.
Rooté.
et donc du coup CWM 6.0.3.0 (
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
) via Flashtool la dernière rev
.Beta6 qui facilite la tache d'ailleurs , Flashtool puis FastBoot Mode, on tombe la dessus :



on éteint l'appareil puis la manip habituelle on branche le cable micro usb + volume haut, led bleue.



Colonne de droite, on va chercher son kernel.img ( pour moi le :
Advance Stock Kernel with Recovery v05 (FW: 10.1.A.1.434)) et le tour est joué.

Bon courage à vous perso j'ai bien galèrer entre des soucis de drivers etc..de droits..bref le tout sous Win8 pro, faut dire que je passe d'IOS (iphone5) @ Android (XperiaZ)..mais bon...ça en vaut la peine.

:D


Bonjour,
j'ai un C6602, firmware 10.1.A.1.434 Rooté. J'ai essayé la méthode avec les cmd mais j'avais un "waiting for device".
J'ai utilisé flashtool mais il affiche :
writing 'boot'
FAILED (remote: Command not allowed)
FASTBOOT Output:
Sending 'Boot' (9848KB)...
OKAY [0.618s]
writing 'Boot'
FAILED (remote: Command not allowed)
finished.total time: 0.620s

Merci pour votre aide
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #53
ton bootloader est bien déverrouillé ?
 
J

jeanmoise.ndoh

Membre
Inscrit
24 Avril 2013
Messages
3
Points
0
  • #54
Breck a dit:
ton bootloader est bien déverrouillé ?

mad1 Bootloader déverrouillé d'origine et là je m'arrache les cheveux (enfin ce qu'il en reste sur ma calvitie) sealed :cry:
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #55
Le bootloader n'est jamais déverrouillé d'origine.
 
J

jeanmoise.ndoh

Membre
Inscrit
24 Avril 2013
Messages
3
Points
0
  • #56
Breck a dit:
Le bootloader n'est jamais déverrouillé d'origine.

Bonjour,
à l'achat en faisant le checking (*#*#7378423#*#* test, config) il m'affichait à unlockable Bootloader le Yes qui correspond (d'après un post sur xda) à Bootloader devérouillé (je crois).
J'ai rooté suivant la méthode Goro_kun et, effectivement, d'après le troubleshooting il s'avère que des utilisateurs ont perdu le déverouillage du Bootlader en rootant par cette méthode.
Je viens de déverouillé le Bootloader donc je vais procéder au flashage du recovery
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #57
jeanmoise.ndoh a dit:
unlockable Bootloader le Yes qui correspond (d'après un post sur xda) à Bootloader devérouillé (je crois).
unlockable : déverrouilable
unlock : déverrouillé
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #58
Salut

Tout c'est bien deroulé mais pourtant je ne peux pas demarré en recovery pourquoi ?
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #59
Tu bloques où exactement ?
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #60
nul part via fastboot tout s'installe mais quand je veux redemarré en recovery en appuyant sur volume haut ca marche pas j'ai pas les leds qui s'allument et le tel demarre normalament
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #61
Et si tu rentres le code adb reboot recovery dans la fenêtre de commandes ?
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #62
pas essayé pourtant j'ai bien l'icone super user
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #63
Teste et dis-nous ce que tu vois :D
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #64
bon je viens d'installer la rom nu tft.253 il faut que je refasse toute les manip pour avoir le CWM ?
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #65
ce tuto n'est bon que pour le firmware .350
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #66
oui ca se trouve pour le firmware 253 le CWM ?
 
Breck

Breck

Membres VIP
Inscrit
11 Avril 2012
Messages
3 448
Points
36
  • #67
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #68
Merci je vais essayer !
 
R

Rasta Homer

Membre
Inscrit
26 Juin 2011
Messages
111
Points
0
  • #69
Ca a marché impecc merci ! :D
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #72
Ok. N'hésite pas à poster un commentaire si il y a une maj à faire ;)
 
Haut Bas