[TUTO][XZ3][9.0] Installation du TWRP + Root

  • Auteur de la discussion Skelett
  • Date de début
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#21
J'ai tenté mais j'ai eu un bootloop avec le logo Sony, impossible de restaurer avec Xperia Companion car il indique que le bootloader a été déverrouillé, du coup j'essaie de récupérer un fichier pour le reflasher car le fastboot et le flashmode fonctionnent toujours mais le téléphone ne boot plus :unsure:

Par contre juste une petite précision, la partie
fastboot flash boot twrp-3.2.3-0.img
Elle est complètement fausse car le fichier img du lien s'appelle twrp-xz3.img et ensuite il ne contient pas de stockkernel-installer.zip
Du coup j'ai un sérieux doute sur le tuto, je l'ai essayé 2 fois, re téléchargé tous les fichiers 2 fois, jamais ça ne fonctionne, bootloop systématique, la diode ne devient jamais ni jaune ni ambre, c'est rouge vert ou bleue.
je doute que qui que ce soit l'ait véritablement testé car il ne fonctionne assurément pas.

EDIT : J'ai réussi à récupérer mon appareil en reflashant avec Sony Emma (j'ai essayé un FTF via flashtool mais ça ne fonctionne pas), mais comme le bootloader est toujours verrouillé, plus d’aperçu sur l'appareil photo, il faut que je trouve un moyen de relocker le bootloader.

EDIT 2 : Relocker le bootloader ne règle pas le souci de caméra, le seul choix est d'utiliser le DRM fix en laissant le BL unlock...ouch

EDIT 3 : Il existe un package plus récent
Vous n'avez pas la permission de voir ce lien Connectez-vous ou inscrivez-vous dès maintenant.
Je ne l'ai pas testé mais je suis en train de voir ce qui cloche avec MartinX3 sur XDA.
D'après MartinX3 il est absolument CAPITAL que le firmware du téléphone et la version du TWRP doivent être identique, ça paraît évident mais je me suis fait avoir comme quoi ça ne l'est pas tant que ça.

EDIT 4 : J'ai du reflasher le téléphone avec Xperifirm et Newflasher avec une Stock ROM en 52.0.A.8.25 et reflasher le TWRP pour que ça fonctionne.

EDIT 5 : MartinX3 confirme que le firmware Ukrainien qu'il a utilisé pour son package d'avril pose problème avec les XZ3 en France il va essayer de recompiler son package avec le firmware d'Europe Centrale

EDIT 6 : Tout fonctionne avec la version de Mars (sauf l'appareil photo) mais pas avec celle d'Avril, en tout cas pour le moment.
 
Dernière édition:
Dernière édition:
K

koolhigh

Membre
Inscrit
24 Avril 2013
Messages
10
Points
3
#22
Bonjour à tous, tout comme QualQuek j'ai eu un souci avec mon root et j'ai eu reflasher mon téléphone avec une Rom officielle 52.0.A.8.25. Et je voulais savoir si le package twrp du 9/04/2019 fonctionnait bien ? À savoir que mon bootloader est déverrouillé et que je n'ai aucun problème d'aperçu photo. Merci par avance cordialement
 
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#23
Le TWRP d'avril avec le package de MartinX3 n'a pas fonctionné chez moi, malgré les multiples tentatives avec lui sur Telegram, même lorsqu'il a recompilé avec un firmware de source FR, à tes risques et péril.
Par contre je serais curieux de savoir comment tu as l’aperçu sur les photos sachant que le simple fait de déverrouiller le bootloader supprime les DRM et l'aperçu en question et que d'après MartinX3 il n'y a pas encore de fix fonctionnel il faut attendre.
 
K

koolhigh

Membre
Inscrit
24 Avril 2013
Messages
10
Points
3
#24
Salut QualQuek, après mes tentatives de rooter mon téléphone, celui-ci ne voulait plus démarrer (il rebootait à chaque fois sur TWRP), j'ai télécharger le même firmware que toi sur Xperifirm et j'ai flashé mon tel avec FlashTool (en fait quand j'ai flashé mon tel c'était pas Firmware XZ3 qui apparaissait sur FlashTool mais XZ2 car dans la liste des téléphones le XZ3 n'apparaissait pas) et j'ai suivi ce tuto (
) et sa a marché et du coup l'appareil photo marche. Mais cela étant, j'ai mémoire (il me semble) que mon appareil photo marchait quand j'ai déverrouillé mon bootloader.
Car j'ai exactement mis le même firmware que toi, mais tu dis que malgré que le package d'avril correspond au même firmware que toi sa ne marche pas du tout ? A quel moment exactement ? En attente de ton retour. Cordialement
 
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#25
salut koolhigh, j'essaie de reboot mon xz3 avec flash tool sans succès (je suis novice) je sais as peut près utiliser flash tool mais je voudrais savoir, avant de faire n'importe quoi étape par étape ce qu'il faut faire, sauve moi de toute les connerie d'Internet j'ai vraiment pas envie de le rendre inutilisable ?? Ou si tu as un lien vers un vrai et bon tutoriel sa serait top merci !!
 
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#27
Koolhigh non le package d'avril ne fonctionne pas, tu ne peux pas booter sur le twrp ça bootloop sur le logo Sony, MartinX3 n'a pas encore trouvé de solution mais tu peux toujours essayer.
Par contre je te confirme que le déverrouillage du bootloader cause l'anomalie de l'appareil photo.
Tu as de la chance que le tiens fonctionne.

Fahdel, pas de panique, prend xperifirm et flash ton téléphone avec newflasher, si tu n'y arrives pas il reste Sony Emma.

Salut,

Tu es sur le fil d'un tuto et tu demandes où en trouver un ???? Sauf erreur, en post #, c'est un tuto, non ?
Désolé mais non ce tuto ne fonctionne pas, il est très incomplet et manque de précision essentielles, je l'ai essayé c'est du grand n'importe quoi.
 
Dernière édition par un modérateur:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 617
Points
113
#28
Salut,

Désolé mais non ce tuto ne fonctionne pas, il est très incomplet et manque de précision essentielles, je l'ai essayé c'est du grand n'importe quoi.
Ce tuto n'est rien d'autre qu'une traduction française de ce qui a été fait sur XDA, ni plus, ni moins. Et au moment où je l'ai fait, c'était pleinement fonctionnel. Si Sony mets à jour ses appareils, change les choses et qu'il devient plus compliqué pour les devs indépendants de créer les fichiers nécessaires et de faire les manips à chaque nouvelle version, je n'y suis pour rien.

Le tuto n'est peut-être pas à jour (il est compatible et fonctionnel uniquement pour la 52.0.A3.202, c'est écrit dans les pré-requis, faut apprendre à lire correctement, et pas uniquement ce qui nous arrange) c'est tout. Et j'ai autre chose à foutre que d'être constamment derrière absolument TOUT les tutos.

Alors au lieu de l'ouvrir pour critiquer, soit plus intelligent, envoi-moi un MP et aide-moi à le compléter lorsqu'il se met à jour. Ça vaudra mieux que ce genre de réaction à la mords-moi-le-noeud qui ont tendance à me mettre hors de moi.

Maintenant, si tu penses faire mieux, libre à toi d'en faire un tuto.
 
Dernière édition:
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#29
Salut,

Tu es sur le fil d'un tuto et tu demandes où en trouver un ???? Sauf erreur, en post #, c'est un tuto, non ?
Si tu parle du tuto sans image et en anglais je galère encore plus ! J'ai bien précisé que jatait totalement novice pour l'instant je sais juste utilisé flash tool et j'ai tout regarder dans le désordre mais merci pour ton commentaire y l'est vraiment très utile .
 
K

koolhigh

Membre
Inscrit
24 Avril 2013
Messages
10
Points
3
#30
Koolhigh non le package d'avril ne fonctionne pas, tu ne peux pas booter sur le twrp ça bootloop sur le logo Sony, MartinX3 n'a pas encore trouvé de solution mais tu peux toujours essayer.
Par contre je te confirme que le déverrouillage du bootloader cause l'anomalie de l'appareil photo.
Tu as de la chance que le tiens fonctionne.

Fahdel, pas de panique, prend xperifirm et flash ton téléphone avec newflasher, si tu n'y arrives pas il reste Sony Emma.



Désolé mais non ce tuto ne fonctionne pas, il est très incomplet et manque de précision essentielles, je l'ai essayé c'est du grand n'importe quoi.
Re QualQuek, même en faisant POWER + Vol Bas simultanément au démarrage de l'appareil tu n'accedes pas au TWRP recovery ? Cordialement
 
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#31
Re QualQuek, même en faisant POWER + Vol Bas simultanément au démarrage de l'appareil tu n'accedes pas au TWRP recovery ? Cordialement
j'ai pas le deboguage usb activée et impossible de le faire je n'ai plus acces au telephone, sur pc compagnion il me demande de deblocker le telephone avec mon code ou mon empreinte mais il ne s'allume pas jusqua la je ne peut rien faire ?
 
K

koolhigh

Membre
Inscrit
24 Avril 2013
Messages
10
Points
3
#32
j'ai pas le deboguage usb activée et impossible de le faire je n'ai plus acces au telephone, sur pc compagnion il me demande de deblocker le telephone avec mon code ou mon empreinte mais il ne s'allume pas jusqua la je ne peut rien faire ?
Salut, sur internet tu as des bons tutos ( https://www.phonandroid.com/forum/t...iciel-sony-avec-flashtool-mac-windows.120495/) pour flasher avec Flashtool, faut que tu récupéres le firmware stock sur Xperifirm et bien suivre les instructions, avec un peu de chance (même le deboguage usb désactivé) tu vas réussir à flasher le téléphone et il marchera. J'espère que sa va t'aider.
 
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#33
Salut, sur internet tu as des bons tutos ( https://www.phonandroid.com/forum/t...iciel-sony-avec-flashtool-mac-windows.120495/) pour flasher avec Flashtool, faut que tu récupéres le firmware stock sur Xperifirm et bien suivre les instructions, avec un peu de chance (même le deboguage usb désactivé) tu vas réussir à flasher le téléphone et il marchera. J'espère que sa va t'aider.
Je test sa en rentrant merci en tout cas ta assurer !! Je te dirais se qui se passe.
 
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#34
Re QualQuek, même en faisant POWER + Vol Bas simultanément au démarrage de l'appareil tu n'accedes pas au TWRP recovery ? Cordialement
Non malheureusement pas de boot sur le TWRP, libre à toi d'essayer.

Fahdel si tu n'y connais rien, télécharge Sony Emma, il va te remettre une rom officielle Sony.

Salut QualQuek, après mes tentatives de rooter mon téléphone, celui-ci ne voulait plus démarrer (il rebootait à chaque fois sur TWRP), j'ai télécharger le même firmware que toi sur Xperifirm et j'ai flashé mon tel avec FlashTool (en fait quand j'ai flashé mon tel c'était pas Firmware XZ3 qui apparaissait sur FlashTool mais XZ2 car dans la liste des téléphones le XZ3 n'apparaissait pas) et j'ai suivi ce tuto (
) et sa a marché et du coup l'appareil photo marche. Mais cela étant, j'ai mémoire (il me semble) que mon appareil photo marchait quand j'ai déverrouillé mon bootloader.
J'ai voulu effectuer la dernière mise à jour de Magisk ce qui m'a direct mis un bootloop alors j'ai reflashé la ROM H8416_Orange MCV FR-ES-PL-SK-RO_1316-5268_52.0.A.8.25_R26B avec Xperifirm et effectivement j'ai récupéré mon appareil photo!
Par contre je n'ai même pas osé réinstaller TWRP avec le package de MartinX3 de peur que ça me refasse le bootloop.
Par contre je suis dégoûté qu'il n'existe pas à ce jour de moyen de relocker le bootloader :'(
 
Dernière édition par un modérateur:
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#35
Merci j'ai réussi mais sa ne m'a pas servis à grand chose au final sa me redemande mon code pin que je nai plus du tout et je viens de voir qu'il n'y a aucune solution pour déverrouiller sa ces vraiment la merde.
 
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#36
Merci j'ai réussi mais sa ne m'a pas servis à grand chose au final sa me redemande mon code pin que je nai plus du tout et je viens de voir qu'il n'y a aucune solution pour déverrouiller sa ces vraiment la merde.
Le code pin c'est celui de ta carte sim ou tu parles du code de déverrouillage du téléphone?
 
K

koolhigh

Membre
Inscrit
24 Avril 2013
Messages
10
Points
3
#37
J'ai voulu effectuer la dernière mise à jour de Magisk ce qui m'a direct mis un bootloop alors j'ai reflashé la ROM H8416_Orange MCV FR-ES-PL-SK-RO_1316-5268_52.0.A.8.25_R26B avec Xperifirm et effectivement j'ai récupéré mon appareil photo!
Par contre je n'ai même pas osé réinstaller TWRP avec le package de MartinX3 de peur que ça me refasse le bootloop.
Par contre je suis dégoûté qu'il n'existe pas à ce jour de moyen de relocker le bootloader :'(
Hello, content que t'ai récupéré ton appareil photo. Pour le moment j'attends aussi qu'il y est un package qui fonctionne je tente pas non plus. Malheureusement oui j'ai tenté via Flashtool pour reverouiller le bootloader mais sans succès.

Merci j'ai réussi mais sa ne m'a pas servis à grand chose au final sa me redemande mon code pin que je nai plus du tout et je viens de voir qu'il n'y a aucune solution pour déverrouiller sa ces vraiment la merde.
Hello, ta essayé sans ta carte sim ? Normalement ta pas de code pin (sauf si t'en a mis un). Cordialement
 
Dernière édition par un modérateur:
Fahdel

Fahdel

Membre
Inscrit
29 Avril 2019
Messages
6
Points
1
#38
Y me demande le code pin de ma sim 1 et je l'ai plus j'ai réussi à le flasher à nouveau mais sa ne me le déverrouille pas
 
QualQuek

QualQuek

Membre
Inscrit
5 Juin 2013
Messages
389
Points
16
#39
Y me demande le code pin de ma sim 1 et je l'ai plus j'ai réussi à le flasher à nouveau mais sa ne me le déverrouille pas
Redemande une carte sim à ton fournisseur ou demande leur le code puk qui permet de choisir un autre code pin.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 617
Points
113
#40
Bonjour à tous,

Mise à jour du tuto pour le dernier firmware en date.
Toute la procédure d'installation du TWRP et du root a été revue pour qu'elle soit un petit peu plus simple à faire et fiable.
 

Haut Bas