[TUTO] Rooter le Xperia Z1 Compact en 4.4.4 - Firmware .157 - {BL verrouillé compatible}

  • Auteur de la discussion maxouffr
  • Date de début
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #1

Salut a tous !

Je vais vous expliquer comment rooter votre Xperia Z1 Compact en 4.4.4 (firmware .157) avec un Bootloader verrouillé.

  • ATTENTION :
    [*]Cette opération comporte des risques. Phonandroid ou moi-même ne peut être tenu responsable des éventuels problèmes rencontrés.
    Merci de lire ce tutoriel dans sa totalité avant de commencer ! Pensez à sauvegarder vos données.

_______________________________________________________________________________________________________________________________________________________________________

Pré-requis


  • Savoir à quoi sert le root :
  • Savoir utiliser
    S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
  • Être sous le firmware .157 (Vous devez faire la mise à jour via PCC ou flashtool, ce qui vous fera provisoirement perdre le root)
  • Être capable de faire fonctionner

_______________________________________________________________________________________________________________________________________________________________________

Installation

  1. Flasher le fichier "D550X_14.4.A.0.108_KernelOnly.ftf" avec Flashtool.
  2. Démarrer le téléphone.
  3. Rooter le téléphone avec RootKitXperia (ou autre méthode compatible)
  4. Éteindre le téléphone
  5. Flasher le fichier "D550X_14.4.A.0.157_KernelOnly.ftf" avec Flashtool.
  6. Démarer le téléphone
  7. Lancer SuperSu et mettre à jour les binaires si nécessaire.

Source :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 597
Points
0
  • #2
Salut,

En un bon tuto de root par notre Rootmann maxouffr. ;)
 
S

Supremad

Membre
Inscrit
9 Janvier 2013
Messages
31
Points
6
  • #3
Parfait :amen:
 
A

Azoxy

Membre
Inscrit
24 Février 2014
Messages
43
Points
6
  • #4
Bonjour,

ça ne marche pas pour moi, on dirait que rootkitxperia ne détecte pas mon téléphone...
Ca bloque sur waiting for device.

Quelqu'un aurait une idée ?
 
morfredus

morfredus

Moderateur Global
Inscrit
19 Juin 2013
Messages
7 026
Points
63
  • #5
Salut.
Tu as bien installer les driver pour ton z1 compact?
Tu as bien active le déboggage usb dans les paramètres developpeur?
 
A

Azoxy

Membre
Inscrit
24 Février 2014
Messages
43
Points
6
  • #6
J'ai suivi la partie "être capable de faire fonctionner ce root" donc pour les drivers s'il en faut des bien spécifiques, je pense que c'est ça qui coince.
Oui le débogage usb est coché.
J'avais déjà rooté mon téléphone avec ce tuto :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Et tout c'était très bien passé...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #7
Tu peux utiliser le lien que tu as mis à la place de rootkitXperia, ça revient au même.
 
R

Rollmops67

Membre
Inscrit
18 Juin 2014
Messages
6
Points
1
  • #8
MERCI maxouffr pour ce Tuto.

Venant de passer en .157 par PC Companion (marchait pas en OTA because GSM rooté), ce qui m'a enlevé le root, je suis tombé sur ton tuto en cherchant comment rerooter.
Je ne m'étais jamais servi de flashtool ni de rootkitxperia, j'ai lu les tutos sur ces logiciels sur Phonandroid, téléchargé les fichiers qu'il faut, et je me suis lancé...
Ben ça a marché, me voilà donc avec un Z1 compact en .157 rooté :frime1:

Encore une fois mille merci pour le temps que tu t'es pris ! :merci:

Amicalement, Roland
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #9
Avec plaisir :)
 
A

Azoxy

Membre
Inscrit
24 Février 2014
Messages
43
Points
6
  • #10
C'est bon j'ai réussi le root ! J'ai fait une raz du téléphone (je ne pense pas que c'était nécessaire), mais j'ai surtout tout supprimé, bien réinstaller le tout. Et ça a fonctionné, je pense que le problème venait des drivers de flashtool que je n'avais pas installé avant (il ne me semble même pas avoir vu ce lien d'ailleurs) et en plus étant sous windows 8.1 il y avait une manip en plus à faire.

Enfin bon, le plus important c'est que ça marche maintenant ! Merci pour le tuto et pour les réponses fournies :D
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #11
Merci pour le retour :)
 
SamirR.

SamirR.

Membre
Inscrit
17 Février 2014
Messages
13
Points
1
  • #12
Azoxy a dit:
C'est bon j'ai réussi le root ! J'ai fait une raz du téléphone (je ne pense pas que c'était nécessaire), mais j'ai surtout tout supprimé, bien réinstaller le tout. Et ça a fonctionné, je pense que le problème venait des drivers de flashtool que je n'avais pas installé avant (il ne me semble même pas avoir vu ce lien d'ailleurs) et en plus étant sous windows 8.1 il y avait une manip en plus à faire.

Enfin bon, le plus important c'est que ça marche maintenant ! Merci pour le tuto et pour les réponses fournies :D

bsr,
moi aussi je suis sous windows 8.1, alors c quoi cette manip en plus à faire?
merci
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #13
Salut,

Pour pouvoir installer les pilotes compatible, tu dois désactiver la signature des pilotes.
 
SamirR.

SamirR.

Membre
Inscrit
17 Février 2014
Messages
13
Points
1
  • #14
maxouffr a dit:
Salut,

Pour pouvoir installer les pilotes compatible, tu dois désactiver la signature des pilotes.

merci
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #15
De rien ;)

Tiens nous au courant !
 
SamirR.

SamirR.

Membre
Inscrit
17 Février 2014
Messages
13
Points
1
  • #16
Bonsoir, voila j'ai rooter mon xperia Z1 Compact 14.4.A.0.157 (BL verrouillé) en suivant ce tuto et ça fonctionne 100%
Simple et efficace
un grand MERCI maxouffr
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #17
Avec plaisir :)
 
W

winixboum

Membre
Inscrit
22 Août 2014
Messages
1
Points
0
  • #18
bonjour, ses pour savoir si ses normal d attendre a i have client like hookers


merci :D
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #19
Salut,

Tu as bien flasher le kernel juste avant ?
 
aimalibaba

aimalibaba

Membre
Inscrit
5 Avril 2013
Messages
555
Points
0
  • #20
Je viens juste faire un retour ici pour vous dire que ça marche, ou plutôt cette méthode a marché pour moi, après en avoir essayé plusieurs autres (4en tout) et passé presque une semaine sur mon Z1Compact.

Bon, j'explique un peu quand même: j'ai utilisé ce tuto pour la très grande partie ,
puis naturellement comme c'est bien indiqué dans le tuto, bahhh faut savoir utiliser "RootKitXperia" et le "Flashtool" quoi, si vous sautez une étape, bahhh rien ne se passe!!!

Par contre, pour ma part, après plusieurs tentatives, je suis passé voir notre vieil ami américain à tous (google pour ne pas le nommer) et je lui ai demandé pourquoi je n'y arrivais pas, et là, miracle, il m'a illuminé de ses milles lueurs (euuhhh 2 420 000 de résultats en 0,29 secondes >>> big brother exagère des fois quand même 8| 8/ 8| >>> euhhh, shuutttt, He's watching me sealed ) ,
bref il m'a dit qu'il fallait des fois mettre son téléphone en mode MSC ( Reglages>Connectivité Xperia> Connectivité USB>Mode de Connexion USB> MSC ) pour que le root fonctionne, et cela a fonctionné :langue2:

:amen: Merci milles fois maxouffr pour ton aide :amen:
J'ai fini par t'avoir Sony le Jap :merci: lol :lol: :lol: :lol: (je précise qu'avant j'ai eu en ma possession un NexusOne, GSG2, HTC One et Nexus4 qui sont nettement moins prise de tête niveau rootage)

Anyway, c'est drôle quand même la sensation qu'on a de savoir qu'on contrôle sa machine, et non l'inverse
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

:frime1: :frime1: :frime1:
Thanks again
Night all...
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #21
Merci pour le retour :)
 
B

Bewit

Membre
Inscrit
18 Décembre 2014
Messages
11
Points
1
  • #22
Bonjour,

Nouveau ici depuis peu, je viens de suivre avec succès le tuto, un grand merci pour la simplicité et clarté de description!

Tout fonctionne.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #23
Avec plaisir :)
 
S

stuart

Membre
Inscrit
16 Août 2012
Messages
133
Points
0
  • #24
Bonjour

Quand je suis au stade du Rootkitxperia j'ai en continu ce message :

error : more than one device and emulator....

appuyez sur une touche pour continuer....

Merci!

PS : je suis en 14.4.A.0.157
 
diablotok

diablotok

Membre
Inscrit
17 Septembre 2011
Messages
220
Points
16
  • #25
Salut à tous!!!

C'est la première fois que j'essaye de rooter mon Z1C, j'étais à l'aise avec mon S4 mais là je suis un peu perdu.

Mon ordi est sous windows 7 et j'ai uniquement installé Pcc, est ce que cela veut dire que j'ai les drivers nécessaire pour rooter mon Z1C?

J'ai acheté le tel sans abonnement, j'ai un BL déverouillé (vérifié avec *#*#7378423#*#*, dans config en bas il y a yes)

Je suis déjà en firmware "14.4.A.0.157" et je me pose la question suivante : ou dois je commencer le tuto?depuis le début? dois je suivre un autre tuto? dans celui là tout n'est pas très clair pour moi!

En fait après avoir lu, si j'ai bien compris il va falloir que je me balade sur plusieurs tutos?
Il y aurait il un tuto encore plus détaillé pour des utilisateurs comme moi qui ne comprennent rien à ces sony (du moins pour l'instant)



Merci d'avance et même si je ne comprend pas encore tout merci pour votre travail c'est top!!!
 
aiglelille

aiglelille

Membre
Inscrit
5 Janvier 2012
Messages
90
Points
6
  • #26
Si tu as installé PCC alors oui tu as les drivers necessaires.
Par contre il va falloir que tu installes Flashtool pour flasher ler kernel_108_only puisque tu est déjà en 157.
Ensuite une fois flasgé en .108 il faut que tu fasses le root en suivant la méthode du EasyRootTool.
Puis flasher le kernell_157_only
 
diablotok

diablotok

Membre
Inscrit
17 Septembre 2011
Messages
220
Points
16
  • #27
Salut,

Merci!
Bon j'ai flasher le 108 en premier j'ai redémarrer, j'ai vérifier ma version du firmware mais toujours 157, j'ai supposé que c'était normal car on ne touche que le kernel. Ensuite j'ai rooté et puis flasher le 157. J'ai installé titanium backup et je suis rooté donc c'est ok cependant j'ai um message qui me dit une chose par rapport au montage(voir photo) que dois je faire

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !



edit : j'ai un peu ramé pour le mettre désolé ;-)
 
inadij.18

inadij.18

Membres VIP
Inscrit
9 Juin 2012
Messages
4 025
Points
38
  • #28
Salut
Tu peux mettre le screen au format 640x480 car on distingue rien :mrgreen:
 
diablotok

diablotok

Membre
Inscrit
17 Septembre 2011
Messages
220
Points
16
  • #29
ensuite il y a les mise à jour des applis sur les sony, celles ci sont indépendantes des maj system peut on les faire quand on est rooté?
 
aiglelille

aiglelille

Membre
Inscrit
5 Janvier 2012
Messages
90
Points
6
  • #30
Oui d'être rooté n'empeche aucune mise à jour Sony...
Pour le message de Titanium je crois qu'il y a une option à coher dans SuperSU..
 
diablotok

diablotok

Membre
Inscrit
17 Septembre 2011
Messages
220
Points
16
  • #31
oui j'ai vu l'option, il y a écrit :
Séparation du montage
Les processus root on chacun leurs montage(sûr). Redémarrer après avoir changer l'option.

C'est coché d'origine dans SU et c'est pour ça que j'ai ce message, dois je décocher, si oui qu'est ce que cela implique,
 
J

JO_DROID

Membre
Inscrit
23 Avril 2014
Messages
4
Points
0
  • #32
Merci, merci et merci :D
Ce téléphone, je l'utilise pour usage pro aussi et donc, je serre les fesses à chaque manip, mais grâce à ce tutoriel, que du bonheur !!!

Au fait, merci :amen:
 
S

stuart

Membre
Inscrit
16 Août 2012
Messages
133
Points
0
  • #33
stuart a dit:
Bonjour

Quand je suis au stade du Rootkitxperia j'ai en continu ce message :

error : more than one device and emulator....

appuyez sur une touche pour continuer....

Merci!

PS : je suis en 14.4.A.0.157

Je ne peux rebasculer sur la version 108...

Il reste sur 157
 
aiglelille

aiglelille

Membre
Inscrit
5 Janvier 2012
Messages
90
Points
6
  • #34
Comme tu ne flashé que le kernel le firmware contine d'afficher 157
 
S

stuart

Membre
Inscrit
16 Août 2012
Messages
133
Points
0
  • #35
Ok, mais puis-je mettre a jour tout de même ?

Quand je lance Rootkitxperia j'ai le message d'erreur plus haut.
 
aiglelille

aiglelille

Membre
Inscrit
5 Janvier 2012
Messages
90
Points
6
  • #36
Moi j'ai utilisé EasyRootTool
 
P

Ptilou62

Membre
Inscrit
1 Avril 2014
Messages
1
Points
0
  • #37
Merci pour le tuto, ça fonctionne nickel, bien que tout au long du processus, on a un peu les boules que ça foire mais quand on arrive au bout, on est fier :vieux-smiley: je l'ai fait gamin, je l'ai fait :happy1:
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #38
Super :)
 
T

Thecountryman

Membre
Inscrit
21 Janvier 2015
Messages
4
Points
0
  • #39
Bonjour

je suis nouveau houhou :vieux-smiley:

jai achete mom xperia z1c bloque sur orange, et j aimerai debloquer le reseaux et rooter mon xperia z1c ! rien que ca !

Avant de faire une bêtise j'aimerais un retour, j'ai cru comprendre qu'il fallait le rooter pour ensuite pouvoir le déverrouiller

butloader no 4.4.4 firmware 157 et je suis prêt a le rooter

suis je sur la bonne direction ?

bien a vous :merci:
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #40
Salut,

Tu parles du Simlock ?
Tu as juste besoin de demander un code auprès d'orange.
 
T

Thecountryman

Membre
Inscrit
21 Janvier 2015
Messages
4
Points
0
  • #41
merci de ta reponse

oui je parle du desimlock

je ne suis pas le titulaire de l' abonnement, je l'ai achete d'ocasion (est il possible que orange me le debloque si je ne suis pas le titulaire?)

j`aimerais le desimlocker par un autre moyen
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #42
Essaye de te renseigner en boutique si tu as la facture.
Sinon, il faudra prendre un code sur un site spécialisé. (je ne connais pas trop ce secteur par contre)
 
T

Thecountryman

Membre
Inscrit
21 Janvier 2015
Messages
4
Points
0
  • #43
ok merci

donc tu me preconise de desimlocker mon z1c avant de le rooter ?

cela va t'il changer le butloader ?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #44
bah le root n'a aucun rapport avec le simlock.
Si tu en as besoin, tu le fait quand tu veux.

Pour le changement de bootloader, normalement non.
 
T

Thecountryman

Membre
Inscrit
21 Janvier 2015
Messages
4
Points
0
  • #45
merci
 
C

Crystauw

Membre
Inscrit
22 Janvier 2015
Messages
2
Points
0
  • #46
Hello,

J'ai réussi à rooter mon Xperia Z1 Compact après 3 bonnes heures de galère !

Le plus important est vraiment de bien lire et de toujours fermer flashtool après que le flash soit terminé (du moins avant l'utilisation de EasyRootTool).

D'ailleurs, RootKitXperia n'a jamais fonctionné pour ma part, EasyRootTool a fonctionné du premier coup, allez savoir pourquoi !

Merci beaucoup pour le travail effectué !
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #47
Merci pour le retour :)
 
C

Crystauw

Membre
Inscrit
22 Janvier 2015
Messages
2
Points
0
  • #48
Et bien me voilà de nouveau, après le boot de mon portable, j'ai décidé de supprimer toutes les couches inutile de mon opérateur et de Sony, quelle mauvaise idée... J'ai supprimé une application importante et mon portable ne peut simplement plus m'amener sur l'écran d'accueil. Je suis donc un peu en galère, mais après mais qq heures de compréhension, je peux reflasher mon portable avec un firmware ? Est-ce le bon choix, et surtout, est-ce possible ?

Morale : Supprimer pas directement les applications après le root...

EDIT : Après avoir reflasher avec le firmware proposé sur le site, le téléphone refonctionne correctement, plus de peur que de mal !

Si cela vous arrive : Éteignez le portable grace au petit bouton dans le compartiment de la carte SIM (petit bouton rouge avec une indication OFF) si vous ne pouvez pas l'éteindre (rien ne s'affichant sur l'écran), téléchargez le firmware complet (
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
) et reflashez votre téléphone, l'opération prend ... 5min maximum.

Merci pour tous les bons tutoriels maxouffr !
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #49
Merci pour le retour :)

Oui, tu as du supprimer le HOME !
 
P

Phil_c

Membre
Inscrit
16 Janvier 2015
Messages
1
Points
0
  • #50
root effectué ce jour sur mon Z1 compact en suivant ce tuto, parfait , sans problème. Merci :)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #51
Avec plaisir :)
 
C

chanin95

Membre
Inscrit
13 Février 2015
Messages
1
Points
0
  • #52
Merci Maxou pour ce tuto parfait (combiné avec les bons liens sur le forum), je n'avais jamais rooté un smartphone et j'y suis arrivé facilement!
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #53
Avec plaisir :)
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #54
bonsoir,
Voila je me suis lancer dans le root de mon z1 ,tout ce passe bien jusqu'aux moment ou je lance supersu et là le message:Aucun binaire Su n'est installé, et SuperSU ne peut l'installer. C'est un problème !
Si vous venez de faire la mise à jour vers Android 4.3, vous devez re-rooter manuellement votre appareil. Veuillez consulter les forums correspondants à votre appareil !.
J'ai tout recommencer et toujours le même problèmes???
Merci pour votre aide.
Cordialement
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #55
Salut,

Tu peux mettre le log de rootkitxperia ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #56
Salut,
Non je n'arrive même pas a le télécharger car une foi le lancement fait il s'arrête???
Merci,
Cordialement
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #57
C'est à dire ?
Normalement, quand tu le lance, tu as du texte qui défile et tu dois appuyer sur un touche pour quitter.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #58
Je clique sur le lien de ton post( rootkitXperia_20140719.zip) de 1.66mb je lance le téléchargement et il s'arrête immédiatement.
Merci.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #59
Donc SuperSu tu l'as pris du play store ?

Si tu as un problème de téléchargement, essaye EasyToolRoot. Le résultat sera le même !
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #60
Salut,
J'ai bien télécharger SuperSu sur play store faut il l'installer avant de rooter le tel? et le lancer une foi le root terminer.
Pour easy root tool il est ecrit qu'il ne fonctionne plus depuis le firware 157.
Merci
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #61
RootKitXperia non plus :lol:

En faite le but de ce tutoriel, c'est de flasher le kernel de l'ancienne version qui possède l'exploit et de l'utiliser pour avoir le root sur le système en .157.
Ensuite, tu remet le kernel d'origine pour revenir sur une configuration stable.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #62
ça commence à me gaver ,j'ai tout refait de a à z et rien ne fonctionne je croit que je vais jeter l'éponge.
Comment savoir si le flash 108 à bien fonctionné.
Comment savoir si le root à bien fonctionné.
j'ai l'impression que le flashtool ne va pas au bout car à la fin du flash 108 ça s'arrête à.(android version:4.4.4/kernel version:3.4.0-perf-gaee6e5a/build number:14.4.a.0.157
Merci pour t'on aide et ta persévérance à démerder des personne comme moi .
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #63
Copie-colle tout les log ici pour que je regarde un petit peu !
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #64
Je n'arrive pas à copier le log de flashtool pour te le transférer.
Désolé
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #65
Ou une capture d'écran sinon :D
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #66
j'ai fait un recovery ,est ce nécessaire ? mais bon vu que rien ne vas je ne suis pas à ça prêt .
Voici le compte rendu.
==============================================
= =
= PhilZ Touch, CWM and TWRP Dual Recovery =
= Maintained by [NUT] =
= =
= For Many Sony Xperia Devices! =
= =
==============================================

1. Installation on ROM rooted with SuperSU
2. Installation on ROM rooted with SuperUser
3. Installation on unrooted ROM using the TowelRoot method
4. Install ADB drivers to windows
5. Exit

Please choose install action.
[1,2,3,4,5]?1
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Waiting for Device, connect USB cable now...
=============================================
Device found!

=============================================
Getting ro.build.product
=============================================
Device model is D5503
Firmware is 14.4.A.0.157

=============================================
Step2 : Sending the recovery files.
=============================================
mkdir failed for /data/local/tmp/recovery, File exists
0 KB/s (30 bytes in 1.000s)
986 KB/s (15757 bytes in 0.015s)
0 KB/s (501 bytes in 1.000s)
741 KB/s (11842 bytes in 0.015s)
1778 KB/s (56834 bytes in 0.031s)
192 KB/s (3082 bytes in 0.015s)
0 KB/s (385 bytes in 1.000s)
4574 KB/s (657704 bytes in 0.140s)
5412 KB/s (2853431 bytes in 0.514s)
4214 KB/s (2221752 bytes in 0.514s)
4347 KB/s (1875015 bytes in 0.421s)
8 KB/s (8985 bytes in 1.000s)

=============================================
Step3 : Setup of dual recovery.
=============================================
Look at your device and grant supersu access!
Press any key to continue AFTER granting root access.
/system/bin/sh: /system/xbin/su: not found
Appuyez sur une touche pour continuer...
/system/bin/sh: su: not found
/system/bin/sh: /system/xbin/busybox: not found

=============================================
Installation finished. Enjoy the recoveries!
=============================================

Appuyez sur une touche pour continuer...
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #67
Et voilà le log pendant le root.

==============================================
= =
= Easy Root Tool v12 =
= Supports various Xperia devices =
= created by zxz0O0 =
= =
=
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
=
= showthread.php?p=53448680 =
= =
= Many thanks to: =
= - [NUT] =
= - geohot =
= - MohammadAG =
= - cubeundcube =
= - nhnt11 =
= - xsacha =
= =
==============================================

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
=============================================
Waiting for Device, connect USB cable now...

Make sure that you authorize the connection
if you get any message on the phone
=============================================
Device found

=============================================
Getting device variables
=============================================
Device model is D5503
Firmware is 14.4.A.0.157

=============================================
Sending files
=============================================
1 KB/s (1593 bytes in 1.000s)
2940 KB/s (657704 bytes in 0.218s)
98 KB/s (1575 bytes in 0.015s)
9 KB/s (9496 bytes in 1.000s)
855 KB/s (13672 bytes in 0.015s)

Copying kernel module...
2158 KB/s (34473 bytes in 0.015s)
0 KB/s (823 bytes in 1.000s)
13 KB/s (13592 bytes in 1.000s)
Kernel version is 3.4.0-perf-gaee6e5a
Version does not match 3.4.0-perf-ge4322cd, needs patching...
1+0 records in
0+1 records out
19 bytes transferred in 0.001 secs (19000 bytes/sec)
Kernel module patched.

modulecrcpatch (by zxz0O0)

module_layout: match
__aeabi_unwind_cpp_pr1: match
kallsyms_lookup_name: not found
printk: not found
mem_text_write_kernel_word: not found
__aeabi_unwind_cpp_pr0: match
successfully patched

=============================================
Loading towelzxperia
=============================================
13 KB/s (13592 bytes in 1.000s)
3088 KB/s (197320 bytes in 0.062s)
=============================================

Waiting for towelzxperia to exploit...

towelzxperia by zxz0O0 (EasyRootTool Version)
libexploit by geohot

libzxploit.so created
doing the magic
creating vm (loljavasucks)
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #68
Alors pour le recovery, vu que superSU ne marche pas, c'est normal.
Tu aurais du prendre l'option 3.

Tu es sûr d'avoir correctement flashé le kernel en 108 ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #69
Comment le savoir???
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #70
Tu as bien suivi la procédure du tutoriel ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #71
Oui à par le rootkitxperia remplacer par easyrootool.
je n'arrive pas a faire de capture d'écran pour te faire voir le moment ou le flash du 108 me semble bloqué.
je recommence tout et on verra
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #72
Si tu as Windows 7 et +, utilise l'outil capture.
Ensuite tu as un module pour envoyer les photos quand tu es sur l'éditeur complet.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #73
Voici une capture juste avant de flasher le kernel 108.
je ne sais pas ou elle et parti cette capture?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #74
je ne sais pas si tu trouve ma capture d'écran sur l'hébergeur ?
j'en ai refait une pendant le flash je la poste aussi en espérant que tu les trouvent
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #75
Normalement, ça te donne un lien à coller dans ton message.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #76
On vas y arrivé :vieux-smiley:
Avant de lancer le flash , tout te parais ok?
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Et une en lançant le flash.
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Ouah je crois que j'y suis arrivé 8/ .
Un grand merci pour t'on aide
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #77
pour flashtool c'est bon ^^^

Tu as réussi pour la suite ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #78
Non ,donc pour toi c'est tout ok pour l'instant ?
suite a l'image du flash ça s'arrête là, je doit faire quoi cliquer sur cancel?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #79
Bah tu branche ton téléphone en mode flash : volume bas + branchement USB.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #80
C'est fait , je croit qu'on vas le faire en live ,quand pense tu ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #81
Et voila pendant le root , ça s'arrête là.
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #82
Pas d'évolution...

Tu peux mettre le log de flashtool ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #83
J'essaye avec rootkitxperia.
je te poste le log du root
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Tu ma dit que pour toi flashtool était ok
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #84
Oui, avec les screen de préparation, mais il n'y a pas celui du flash en lui-même !
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #85
Salut ,
Dans le message 76 page4 il y à la capture d'écran du flash ,ça s'arrête comme tu peu le voir sur l'image ou il y à 157 a la fin après plus rien ne défile donc pour moi c'est fini et je clique pour fermer.
Bon ou pas bon???
Merci beaucoup
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #86
A oui... Tu n'as pas flashé le kernel ! Tu as juste préparé le flash^^

Quand tu as l'image avec le Xperia X10, tu branche ton téléphone en maintenant volume bas.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #87
Je re re essaye.
Mais c'est ce que je fait volume bas en branchant le câble usb ,ensuite il me m'est un message sur mon z1c ,me demandant d'autoriser l'envoie du pc je dit ok le flash démarré et s'arrête là ou il parle du firmware 157.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #88
Ton téléphone est bien éteint quand tu veux le connecter ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #89
non!
C'est long le flash ???
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #90
Il faut qu'il soit éteint....

Tu as un lien dans les pré-requis pour expliquer le fonctionnement du logiciel pour le besoin de ce tutoriel.
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #91
C'est bon le flash à fonctionne pour le 108.
J'ai lancé le root ,comment savoir si il est terminé?
Je te met une capture
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
.
Grace à toi j'ai appris à les faire
Merci
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #92
Normalement, ton téléphone devrait redémarrer et tu devras avoir un truc qui te dit d'appuyer sur une touche !

Essaye de coller le texte de flashtool pour voir s'il y a quelque chose !
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #93
Ca marche le flash le root ? tout quoi, youpi!!!!.
Maintenant supersu me demande comment installer le binaire ;NORMAL ou TWRP/CWM.???
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #94
L'option normal devrait suffire :D

Tu as bien remise le kernel d'origine ? (Dernière étape de la manipulation)
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #95
Pour le kernel 157 oui c'est ok.
en normal l'installation a échoue redémarrez et réessayez.
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #96
ok^^

Tu n'as pas mis le XZDR ?
Dans ton les cas, le root fonctionne ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #97
Je l'ai en mode TWRP/CWM et il à redémarrer en recovery bon?
 
maxouffr

maxouffr

Membres VIP
Inscrit
20 Juillet 2012
Messages
16 632
Points
38
  • #98
ça a marché ?
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #99
Non il demande toujours la mise à jour et en normal ça ne fonctionne toujours pas
 
T

tonton38

Membre
Inscrit
10 Février 2015
Messages
28
Points
0
  • #100
J' ai installer root checker et tout est ok .
Supersu est obligatoire?
 

Sujets en relation

Haut Bas