[TUTO][OP 7 / 7 Pro] Débloquer le Bootloader, Installer TWRP, Rooter avec Magisk

  • Auteur de la discussion texas2607
  • Date de début
B

bebert83980

Membre
Inscrit
16 Février 2020
Messages
3
Points
1
merci comment faire pour réinstaller une rom officiel qui est une ancienne version??
 
O

osmoze30

Membre
Inscrit
25 Juin 2013
Messages
49
Points
8
Bonjour à tous !!

Je suis en train d'essayer de rooter mon OnePlus 7 Pro, mais que ce soit en utilisant ce tuto ou l'outils Allinone, il m'est impossible de le rebooter sur le TWRP, le smartphone reste en fastboot mode (je n'ai pas tenté de l'installer), une idée de ce que je dois faire?

Le bootloader est bien déverrouiller.

Merci d'avance !
 
Dernière édition:
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Salut,
Je crois que tu vas devoir repasser là :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
[/URL]
A plus
 
O

osmoze30

Membre
Inscrit
25 Juin 2013
Messages
49
Points
8
Ah mais il démarre c'est pas le problème.

J'avais réussi à le rooter, mais plus de réseau de disponible. Donc j'ai remis la ROM OOS d'origine, et là maintenant, le mode debogage ne me demande plus d'autorisation, comme s'il ne détectait pas le PC. Et j'ai toujours "waiting for device" quand je tente de le redemarrer sur twrp.
 
O

osmoze30

Membre
Inscrit
25 Juin 2013
Messages
49
Points
8
C'est bon j'ai réussi.

Donc pour information, pour que ça fonctionne, il faut utiliser cette version du recovery :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Attention toutefois à ne pas faire la même grosse erreur que moi, il faut le lancer depuis l'adb et ne surtout pas le flasher, sinon, plus de réseau et plus de WiFi.

Si vous le pouvez, mettez à jour le premier topic avec ce lien. ;)
 
  • Like
Les réactions: spat
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Salut,
Merci, je vois pour la maj
 
  • Like
Les réactions: osmoze30
Tome05

Tome05

Membre
Inscrit
21 Mars 2020
Messages
9
Points
3
Bonjour,
J'essaie de suivre le tuto a la lettre, or des le début des l'étape 3 ça ne reconnaît pas mon tél, j'ai réinstallé les drivers et ça ne change rien.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 899
Points
113
Salut,

Quels drivers as-tu installés ?
 
Tome05

Tome05

Membre
Inscrit
21 Mars 2020
Messages
9
Points
3
Salut Skelett, désolé du délais de réponse.
J'ai essayé avec les drivers du tutoriels ainsi que ceux qui me sont proposés quand je connecte mon OnePlus 7 pro à mon ordi mais dans les deux cas le tél n'est pas détecté.
 
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Salut,
Tu avais fais ça :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Essaie, on ne sait jamais.
 
  • Like
Les réactions: Tome05
Tome05

Tome05

Membre
Inscrit
21 Mars 2020
Messages
9
Points
3
Je viens d'essayer spat effectivement quand j'ai installer le driver ca m'a demandé si j'autorisais ou non cette fois.
Hors le téléphone n'est toujours pas reconnu ..
1585482550249.png
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 899
Points
113
Hello,

Ton appareil est bien démarré en fastboot mode ?
 
  • Like
Les réactions: Tome05
Tome05

Tome05

Membre
Inscrit
21 Mars 2020
Messages
9
Points
3
Au temps pour moi .. Merci à Spat du coup car effectivement après avoir ré-installer les drivers j'ai complétement oublié de relancer en fastboot mode..
Merci à toi aussi Skelett !
Il est maintenant bien détecté je continues le tuto
 
  • Like
Les réactions: Skelett et spat
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Tome05

Tome05

Membre
Inscrit
21 Mars 2020
Messages
9
Points
3
Re !
J'ai une petite question concernant Magisk, quand je clique sur la petite fleche à côté de "Controle SafeNet réussi" ca me met une croix rouge pour ctsProfile : false.
Avez-vous une solution ?
Merci d'avance.

EDIT : Après avoir cherché sur internet j'ai trouvé.
Le tuto a bien fonctionné pour ma part sur mon OnePlus 7 Pro - Android 10
MERCI !
 
Dernière édition:
  • Like
Les réactions: spat
Guerriche84

Guerriche84

Membre
Inscrit
13 Août 2012
Messages
62
Points
8
Bonjour, j'ai réussi a déverrouiller le bootloader mais impossible d'installer le recovery. A chaque fois sa me dit sucess mais il reste bloquée sur le logo fastboot.
 
B

bebert83980

Membre
Inscrit
16 Février 2020
Messages
3
Points
1
bonjour a mon avis tu as pas installer la bonne version du trwp ca depend si tu possede android 9 ou android 10 la version du trwp change

regarde la
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Dernière édition par un modérateur:
Guerriche84

Guerriche84

Membre
Inscrit
13 Août 2012
Messages
62
Points
8
Merci pour ta réponse.
Je suis sous Android 10 et j'ai pris le dernier TWRP sur le site TWRP.me
 
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Salut,
Il me semble qu'il est conseillé d'installer la version de mauronofrio dans sa dernière version.
A confirmer, je n'utilise pas twrp.
A plus
 
Guerriche84

Guerriche84

Membre
Inscrit
13 Août 2012
Messages
62
Points
8
Merci, j'ai installé la version de mauronofrio et ça fonctionne nickel.
Encore merci la comu
 
  • Like
Les réactions: spat
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Avec plaisir
 
C

castous12

Membre
Inscrit
11 Octobre 2014
Messages
17
Points
1
Salut je suis le seul qui se fait refuser toutes les maj via oxygen update par twrp ?
 
dany67310

dany67310

Membres VIP
Inscrit
12 Décembre 2014
Messages
668
Points
43
Hello

Mis à jour twrp officiel 3.4.0-0
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
  • Like
Les réactions: Nico97470
W

walkpto

Membre
Inscrit
24 Août 2016
Messages
15
Points
1
Bonjour,

Je suis bloqué à l'étape 4 de Boot/Installation du TWRP et du root.
En effet, mon portable s'est figé dans le mode FastBoot avec un écran indiquant le logo OnePlus et le texte FastBoot en-dessous.

Quelqu'un a déjà rencontré ce type de problème ?

Merci d'avance.
 
Dernière édition par un modérateur:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 899
Points
113
Salut,

Cet écran ne me parle pas. Tu n'aurais pas une photo stp ?
 
M

Millenius

Membre
Inscrit
29 Août 2013
Messages
9
Points
1
message édité, reformulation ;)
 
Dernière édition:
spat

spat

Moderateur Global
Inscrit
27 Décembre 2012
Messages
12 419
Points
113
Salut,
Si tu commence ton message par bonjour, ce sera plus sympa que help.
Merci d'y penser
 
M

Millenius

Membre
Inscrit
29 Août 2013
Messages
9
Points
1
Bonjour,

Je reformule mon précédent message. J'ai besoin de votre aide :/
Depuis 48h, je suis bloqué sur ce tutorial avec mon téléphone.

Hier matin, j'étais coincé à l'étape 4, comme walkpto.
Depuis, j'ai réussi à avancer en téléchargant la dernière version de twrp (3.4.0-0 au lieu de 3.3.1-30)
Ca a fonctionné, car j'ai réussi à booter en recovery sur TWRP.

Ensuite, j'ai copié les fichiers sur le téléphone via adb push, et j'ai installé :
- Oxygen OS dernière version depuis
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
(car j'étais brické, donc fallait unbrick)
Seul problème.. qd je faisais une install avec ce zip, cela ne marchait pas lorsque je cochais "Zip signature" (Signature failed), du coup j'ai fais sans...
- Puis j'ai installé Magisk-v19.3.zip depuis TWRP (sans reboot)
- Puis j'ai installé twrp-3.3.1-30-guacamole-installer.zip (depuis TWRP), et comme je me suis rendu compte que ce n'était pas la bonne version, j'ai réinstallé par dessus twrp-3.4.0-0-guacamole-unified-installer-mauronofrio.zip

Ensuite, j'ai lancé le boot system, et ca fait 11Min que ca charge là... inquiétant :/
Que me conseillez vous ?

Cela pourra servir à d'autres.. donc je détaille mes recherches en cours :

[9h45]
- je retente toute l'opération, en cliquant sur Restore et non pas Install (dans TWRP) pour installer Oxygen OS.
- j'en profite pour télécharger également la dernière version de Magisk 20.4 a lieu de 19.3

[10h00]
- Impossible de restaurer.. j'ai le choix entre Internal Storage 0Mb, et USB Storage 0Mb. Je tente un tuto (
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
) pour corriger ce prb de 0Mb. Ca marche, Internal Storage a de nouveau un espace correct
- Par contre, qd je tente un restore, il ne me trouve aucun package... j'ai tenté de copier le fichier OnePlus7ProOxygen_21.E.26_OTA_026_all_2005192135_8474bf58a0ec4716.zip ds tous les repertoires. Rien n'y fait
- Je retente donc un "Install" avec ce fichier OxygenOS, sans réinstaller Magisk et TWRP derrière
(en cours)

[10h15]
- Toujours brické.. je vais donc essayer avec l'image disponible ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

- MsM ne detecte pas mon tel :(((
je tente avec cette solution :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


[11h15]
- Je suis maintenant en mode QUALCOMM CrashDump Mode :((((((((((((
 
Dernière édition:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 899
Points
113
Salut,

Quand tu es sur Qualcomm Crash Dump, seul le MSM pourra sauver ton smartphone et rien d'autre.

Regarde ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Tu t'en sortiras peut-être mieux avec un tuto français plutôt qu'anglais.
 
Dernière édition:
M

Millenius

Membre
Inscrit
29 Août 2013
Messages
9
Points
1
Pas de bol, ca m'indique çà qd je veux télécharger la version OnePlus 7 Pro GM21BA : OOPS! no mirrors found
J'ai décidément pas de bol...

J'ai trouvé une version + ancienne, qui a fonctionné.
J'ai eu un mal fou à lancer le mode EDL : en fait, il faut laisser les boutons + et- tout le temps enfoncé et lancer MSMDownload Tool
Dés que je lachais un bouton, ca le deconnectait du PC
 
Dernière édition:
M

Millenius

Membre
Inscrit
29 Août 2013
Messages
9
Points
1
Merci donc pour la solution !!
J'ai finalement pu reinstalle une ancienne version Oxygen (10.0.4), passer TWRP et Magisk pour root.
Au démaragge suivant, il m'a proposé d'install la dernière version Oxygen (10.0.7), ce que je suis en train de faire.
Je serai donc bon pour refaire la manip ;p
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 899
Points
113
Hello,

Avec plaisir.

Par contre, tu dois avoir un problème avec ton PC. Je n'ai jamais eu de déconnexion lorsque mon téléphone était en EDL Mode. Il se connecte, et je peux lâcher, avant même de lancer le MSM.

Sache que le TWRP n'est pas obligatoire et déconseillé par son mainteneur. Je ne suis donc pas étonné que tu rencontres autant de soucis avec. Tu peux rooter ton téléphone sans.
 

Haut Bas