[TUTO][NOUGAT]Root du Sony Xperia Z5 + Installation du TWRP (Bootloader déverrouillé)

H

HOUILLIER

Membre
Inscrit
29 Octobre 2013
Messages
65
Points
0
Bonjour,
Je ne comprends pas . J'ai utilisé la rom de Xperifirm. Mais je ne crois pas qu'il y ait de différence.
Mont28, si l'étape 22 s'est bien passé, normalement tu dois pouvoir redémarrer sur le TWRP.
J'ai appuyé sur volume bas, puis allumé mon Z5. Il a démarré sur la page habituelle et a tout de suite basculé sur le TWRP.
 
M

mont58

Membre
Inscrit
31 Octobre 2017
Messages
17
Points
0
Bonsoir Houillier,
Peut-etre cela vient-il que tu as un 6603 et moi un 6653!!!!
Je pense que c'est le "Kernel" de Nougat qui ne passe pas car le même "Recovery" passe très bien avec Marshmallow

J'ai installe Marshmallow finalement comme l'a suggérè Spat

Merci!

spat24 a dit:
skelett a dit:
Salut Spat,

Merci pour ton retour.

Au cas où, j'ai tout de même remis absolument tous les liens à jour, donc il faut tester avec eux et c'est la dernière chose que je puisse faire...

Si ça ne passe toujours pas, il faudra très sérieusement à penser à un downgrade sur MM.
Pas de quoi, d'autant que ce téléphone commence à se faire vieux(il faut dire les choses) mais offre encore de très bonnes performances. MM reste d'actualités et en y intégrant les modules qui vont bien, on peut avoir le fonctionnement de nougat.
 
spat

spat

Membres VIP
Inscrit
27 Décembre 2012
Messages
2 754
Points
48
mont58 a dit:
Bonsoir Houillier,
Peut-etre cela vient-il que tu as un 6603 et moi un 6653!!!!
Je pense que c'est le "Kernel" de Nougat qui ne passe pas car le même "Recovery" passe très bien avec Marshmallow

J'ai installe Marshmallow finalement comme l'a suggérè Spat

Merci!

spat24 a dit:
skelett a dit:
Salut Spat,

Merci pour ton retour.

Au cas où, j'ai tout de même remis absolument tous les liens à jour, donc il faut tester avec eux et c'est la dernière chose que je puisse faire...

Si ça ne passe toujours pas, il faudra très sérieusement à penser à un downgrade sur MM.
Pas de quoi, d'autant que ce téléphone commence à se faire vieux(il faut dire les choses) mais offre encore de très bonnes performances. MM reste d'actualités et en y intégrant les modules qui vont bien, on peut avoir le fonctionnement de nougat.
Hello,
Bon choix, le mien tournait sous MM avec stock, root et xposed et j'avais une bombe [BOMB]
 
C

crowme

Membre
Inscrit
29 Juin 2013
Messages
1
Points
0
salut salut
le lien du firmware FW 32.4.A.0.160 Stock Kernel Patched ne marche plus si vous en avez un autre je suis preneur merci
 
G

gerbizon

Membre
Inscrit
7 Avril 2012
Messages
1
Points
1
Bonjour, merci pour le tuto.
Mon Z5 (6653) est sous Nougat 7.1.1 (
Vous n'avez pas la permission de voir ce lien Connectez-vous ou inscrivez-vous dès maintenant.
), j’ai suivi le tuto tout c’est dérouler normalement (firmware FW 32.4.A.0.160 Stock Kernel Patched ) jusqu’au reboot la Led passe au rouge et le téléphone redémarre malgré le fait que j’appuie plusieurs fois sur volume haut. Après plusieurs tentatives et après avoir cherché comment démarrer TWRP manuellement, j’ai pu installer SuperSU et finir la procédure comme indiqué dans le tuto.
Tout fonctionne normalement, mais ma carte SD a disparu, je l’ai testé sur un autre tel et un PC elle est bonne et elle apparait sous TWRP.
J’ai fait une réinstallation complète avec Emma et ma carte SD est réapparu, j’ai refait la procédure de root et elle n’apparait plus sauf sous TWRP ou elle apparait et je peux même y avoir accès depuis le PC.
Si quelqu’un a une idée, voir une solution, je suis preneur, merci d’avance.
 
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
14 752
Points
38
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
9 014
Points
48
Salut Cédric,

Merci beaucoup pour tes liens.

S'ils viennent de nouveau à être HS, il faudra envoyer le tuto aux archives.
 
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
14 752
Points
38
Salut
ok ça marche coupin...mais c'est ton tuto à toi :wink:
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 497
Points
36
Hello,
J'aimerai savoir si c'est compatible avec nougat (firmware .54)
Si non, alors il n'existe pas de méthode de root sans downgrade ??
En fait j'ai un problème de MMS et je me dis que refaire tout propre peut aider.
Pour l'instant quand je flash le fw .54 mon problème est résolu. Ensuite je flash en fastboot le twrp 3.1.1, puis ma rom custom stock based (Mrom XZ2 style) et le problème de MMS apparaît, l'envoi et la réception ne se font plus si je n'active pas les donnée moi-même contrairement à ce qui se passe en stock.
merci d'avance
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
9 014
Points
48
Salut Tickle,

Dans tout les cas, c'est que le problème vient très clairement de la ROM Custom et de rien d'autres.

Pour te répondre, si le firmware n'est pas dans la liste, et bien c'est non, sorry.
Par contre, j'ai trouvé ce firmware en 2.33, pré-rooté :
Vous n'avez pas la permission de voir ce lien Connectez-vous ou inscrivez-vous dès maintenant.
(à flasher avec le TWRP après un full wipes, tu enquilles le flash de Magisk par la suite et roule ma poule)
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 497
Points
36
C'est bien ce que je pense aussi.
Après, je ne lis plus trop les tuto (expérience la fautive) et du coup, peut-être que je fais des erreurs.
Enfin pour l'installation d'une rom, y a pas grand chose quand même. Wipe rapide proposé par le TWRP puis le flash. Par contre, pour un restore de backup, il faut faire les wipe avant ou pas ? Parce que ma dernière tentative à lamentablement échoué à base de "tel_fichier_introuvable"...
Le truc c'est que su une version précédente de la Rom (sous le même firmware, hein, ça fait un bout que le Z5 a finit sa vie), bah, j'avais pas ce problème, et je ne crois pas avoir utilisé autre chose pour résoudre le problème genre un module xposed, je me serai fais une note la-dessus.
Je vais essayer de remettre la version plus ancienne, tant pis pour les nouveautés... Je te redis si ça corrige.
Merci l'ami ;)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
9 014
Points
48
pour un restore de backup, il faut faire les wipe avant ou pas ?
Franchement, je ne pourrais pas te confirmer ou t'infirmer si cela est vraiment nécessaire ou pas. Mais perso, j'ai toujours fait tous les wipes, avant de rebalancer un backup. Je ne me suis jamais vraiment posé la question mais logiquement, c'est ce qu'il faut faire.

Le truc c'est que su une version précédente de la Rom (sous le même firmware, hein, ça fait un bout que le Z5 a finit sa vie), bah, j'avais pas ce problème, et je ne crois pas avoir utilisé autre chose pour résoudre le problème genre un module xposed, je me serai fais une note la-dessus.
Ouais, et donc ? Ça signifie que c'est la mise à jour de la ROM qui déconne, tout simplement. Parfois, faut pas trop chercher loin, hein...

Je te redis si ça corrige.
Ça marche, j'attends ton retour ;)
 
Tickle

Tickle

Membres VIP
Inscrit
3 Novembre 2012
Messages
2 497
Points
36
Re Oscar (le squelette),
Bon bah... backup réinstallé (bon pas le boot, le TWRP plantait (error: unable to find file system) mais pas grave, je reflash mon kernel et c'est bon) et les MMS sont de nouveau automatiques. C'est cool mais à la fois ça veut dire que je vais peut-être plus upgrader ma Rom... Je vais essayer d'en toucher 2 mots au(x) dev il est chinois et pas sur xda ça va pas être facile. Peut-être qu'un membre de la Rom saura faire ça, je verrai ^^.
A+
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
9 014
Points
48
T'inquiète, en général ils utilisent Google Traduction, donc parle anglais, ils te répondront en anglais aussi ;)
 
Haut Bas