[TUTO][MARSHMALLOW]Root du Sony Xperia Z5C + Installation du TWRP (Bootloader déverrouillé)

  • Auteur de la discussion Skelett
  • Date de début
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113

Root du Sony Xperia Z5 Compact sous Marshmallow + Installation du TWRP (Bootloader déverrouillé)

Source :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Un grand merci à
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
et
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
!​

=============================================================================================================================================


Avertissement : Cette opération comporte des risques. Phonandroid et moi-même ne pouvons être tenus pour responsables des éventuels problèmes rencontrés.

=============================================================================================================================================



Salut à toutes et à tous !

A peine Marshmallow déployé sur nos Xperia Z5C que le root est déjà disponible !

La procédure est simple : Elle consiste à flasher via l'invit' de commande et ADB un kernel modifié et le TWRP pour ensuite démarrer son appareil et flasher le SuperSU via le Recovery Custom.​


  • Avoir déverrouillé votre bootloader -->>
  • Avoir les drivers ADB installés -->> ou bien en installant le
  • Avoir téléchargé les fichiers suivanst :








Du coup, cela ce passe en 2 étapes :

I- Flasher le fichier kernel et le TWRP:

  1. Activer le Déboguage USB et autoriser votre PC
  2. Extrayez le fichier boot.img du kernel précédemment téléchargé, et l'extraire dans votre dossier adb ou platform-tools (seulement si vous avez installé le SDK Android).
  3. Copier ou déplacer le fichier .img du TWRP dans le même dossier cité ci-dessus.
  4. Sur ce dossier, appuyez sur Shift + Clique droit de votre de votre souris, et sélectionnez Ouvrir une fenêtre de commandes ici
  5. Branchez votre appareil au PC et dans l'invite de commande qui s'est ouverte, rentré cette ligne de commande afin de démarrer votre appareil en fastboot :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
  6. Une fois fait, votre LED est maintenant de couleur bleue, ce qui veut dire que tout est bon. Ensuite, flashez le fichier boot.img en entrant cette commande :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
  7. Le kernel est donc flashé, on passe ensuite au TWRP :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
  8. Redémarrez votre appareil avec cette commande :

    Code:
    S'il vous plaît, Connexion ou S'inscrire to view codes content!
  9. Lors du redémarrage de votre appareil, attendez que la LED s'allume jaune. Dès que c'est le cas, appuyez plusieurs fois sur le bouton volume haut. Là, elle vire au ambre.
    Votre appareil démarre alors sur le TWRP

II- Rooter votre Z5C:

  • Placez le fichier Stable-SuperSU v2.76 à la racine de votre appareil
  • Démarrez votre appareil en recovery
  • Appuyez sur Installer puis sur Sélectionner emplacement, pour enfin choisir Mémoire interne
  • Sélectionnez Stable-SuperSU v2.76 et slidez pour accepter et lancer le flash.
  • Après le flash, le TWRP vous demande si vous voulez effectuez un wipe cache. Vous pouvez ne pas le faire si vous le souhaitez, cependant je vous conseille tout de même de le faire.
  • Redémarrez votre appareil et vérifiez si l'application SuperSU est bien présente. Si c'est le cas, c'est fini !

Et voilà ! Votre téléphone est maintenant rooté !



N'hésitez pas si vous avez des questions / précisions / corrections.
 
Tipiak

Tipiak

Pirate !
Moderateur Global
Inscrit
2 Juillet 2012
Messages
27 080
Points
63
Salut, merci pour le tuto. :super:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Hello :hello:

Avec plaisir :wink:
 
P

pimpon60

Membre
Inscrit
3 Juillet 2012
Messages
78
Points
6
Super...
Merci pour le tuto.
Fonctionne très bien pour moi.
Par contre, pour flasher le recovery il a fallu que je tape : "fastboot flash recovery recovery.img"
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut :hello:

Merci pour ton retour.

Pour le recovery.img, en fait cela dépend de comment a été nommé le *.img. Du coup, j'ai voulu vérifier le nom du fichier mais Androplus a changé d'hébergeur de fichiers et du coup, impossible de remettre la main sur la v3 du TWRP :-|

Donc je vais remettre (demain) à jour le tuto suite à ta remarque, avec un lien vers le TWRP v3.0.0-0 pour le Z5C renommé en recovery.img :wink:
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Bonjour,

Vraiment un super boulot !

J'ai un petit soucis, je n'arrive pas à installer ni le img ni le recovery, j'ai a chaque fois: failed remote command not allowed

Mon bootloader est bien dévérrouillé .... Quelqu'un a t'il une idée?

Merci
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Oui j'ai peut-être une idée : Tes pilotes ADB sont-ils installés ? Si oui, dans le cmd, es-tu dans le dossier où se trouvent les pilotes ADB ainsi que les fichiers .img ?
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Salut,

A priori oui ils sont installés, je viens de flasher sans soucis en 6.0.

Et oui je lance la fenêtre de commande via le dossier adb qui est dans le lecteur C du PC. Avec dedans les boot.img et le recovery ....

Et la première commande passe sans soucis, j'ai bien la led bleue
:shock: :shock:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
SI la première commande passe, c'est qu'ils sont bien installés, effectivement.

Pour le reste, tu fais un copier/coller des commandes ?
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Bonsoir,

Yes pile poil copié collé.

J'ai réessayé plein de fois et RAS
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
RAS ? Rien à signaler ? Bah où est le problème alors ? :lol:
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Enfin non RAS dans le sens ou pour les img j'ai le foailed qui s'affiche .....

:D :lol:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
As-tu le déverrouillage OEM d'activé, ainsi que le débogage USB et éventuellement les sources inconnues ?
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
le dévérouillage OEM n'était pas activé mais cela ne change rien :? :pleur4: :pleur4: :pleur4:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
C'est bizarre ça, tu n'as rien qui pourrait le faire échouer. Je veux dire, tout me semble correct de ton côté :-|

Change de port USB et de câble, même si je doute fort que cela change quoi que ce soit.

Essaye aussi en passant par le SDK Android (lien dans le tuto).

Dans le pire des cas, essaye avec un autre PC si tu en a la possibilité, ça sera déjà plus parlant si l'erreur se reproduit sur un autre (ça voudra dire qu'il y a quelque chose que tu ne fais pas correctement :langue2: )
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Merci pour ton retour! :super: :super:

Quand vous rentrez ./adb devices, ça vous note quoi?

Je n'ai pas d'autre pc mais un mac où je galère à mettre les pilotes adb ....

Bref ça commence à me gonfler....
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Ce qu'il est censé me dire lorsque mon téléphone est reconnu :

Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!
gancho a dit:
Je n'ai pas d'autre pc mais un mac où je galère à mettre les pilotes adb ....
T'as pas moyen de virtualiser un Windows (7 de préférence) sur ton MAC ?
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
Bonjour j'ai je pense le meme problème que gancho lorsque je copie la commande "fastboot flash boot boot.img" , cela m'écrit :

<<target reported max download size of 536870912 bytes
sending 'boot' <14944 KB>...
OKAY [ 0.341s]
writing 'boot'...
FAILED (remote: Command not allowed) <----- Ici mon problème je pense
finished. total time: 0.365s >>

Voila si quelqu'un peut m'aider svp :D
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
Re-bonjour ,

j'ai un peu lus les commentaires en dessous de ce tuto et j'ai exactement comme gancho , j'ai bien tout installé les driver adb ,activé L'OEM ,sources inconnus , etc

C'est donc pour cela que je me permet de redemander si quelqu'un a trouvé une solution a ce problème de "Command not allowed " car je vois qu'il n'y a pas de nouvelles de gancho si oui ou non il a réussi a root son Z5C .

(Personnellement je suis sur windows 8.1 , avec je pense tous les drivers nécessaires pour le root )

Donc une dernière fois si quelqu'un a une solution je suis preneur , car la j'aimerai vraiment root mon Z5C ^^
 
G

gancho

Membre
Inscrit
20 Mars 2016
Messages
7
Points
0
Bonjour,

Toujours pareil pour moi ...... impossible malgrès plusieurs essais sur mac et sur windows 10.

J'ai perso un tél d'origine orange ...

A voir
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut à vous deux,

@Nico, attention les doubles posts stp, le bouton "éditer" est là pour ça.

Laissez tomber, je sais d'où cela vient : J'ai mis à jour les lien vers des versions plus récentes du kernel et du recovery. Essayez avec celles-là et donnez-moi votre retour :wink:
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
Salut , oui sorry pour le double post ,

alors j'ai re-téléchargé boot et recovery et pour moi c'est toujours pareil cela me met : ( command not allowed )
:/
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Arf... Même avec "Débogage USB" Et "Sources Inconnues" d'activées (Le premier est obligatoire) ?
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
Oui j'ai bien le débogage USB et sources inconnues d'activées et cela me fait toujours pareil .

Par contre peu être que le problème vient de la (je sais pas trop) car au début quand je branche mon téléphone a mon pc il me propose "charger uniquement" , "transférer des fichiers(MTP)" et "MIDI" .

j'ai essayé avec transférer des fichiers(MTP) , c'est ce qui me parait le plus logique et j'ai essayer avec rien du tout sans cliquer nul par mais le résultat est le même dans les deux cas : command not allowed
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
Bonsoir, j'ai un ami qui a le Z5 compact, et il voudrait savoir si son tel a le bootloader verrouiller ou non, comment peut-il le savoir ??

Et pour le root, il y a pas une manière plus simple, flasher avec odin par exemple ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Niko549954 a dit:
Oui j'ai bien le débogage USB et sources inconnues d'activées et cela me fait toujours pareil .

Par contre peu être que le problème vient de la (je sais pas trop) car au début quand je branche mon téléphone a mon pc il me propose "charger uniquement" , "transférer des fichiers(MTP)" et "MIDI" .

j'ai essayé avec transférer des fichiers(MTP) , c'est ce qui me parait le plus logique et j'ai essayer avec rien du tout sans cliquer nul par mais le résultat est le même dans les deux cas : command not allowed
Non ça ne vient pas d'ici car quoi qu'il arrive, lorsque tu rentres la première commande (adb reboot bootloader), l'appareil te la prend en compte et il redémarre en mode fastboot (écran noir avec LED bleue).

Comment as-tu installé les drivers adb de ton appareil ?

ThomasTom a dit:
Bonsoir, j'ai un ami qui a le Z5 compact, et il voudrait savoir si son tel a le bootloader verrouiller ou non, comment peut-il le savoir ??
Salut :hello:

Tout les tutos sont présents sur le forum, y compris celui qui permet de savoir si ton bootloader est déverrouillable ou non (le lien de ce tuto est présent dans mon premier post, dans le pré-requis) :wink:

ThomasTom a dit:
Et pour le root, il y a pas une manière plus simple, flasher avec odin par exemple ?
Ceci est la manière la plus simple de rooter un Z5, les méthodes diffères d'une marque à une autre, tu n'auras jamais la même pour Samsung, Sony, HTC, LG, par exemple.

Odin n'est utile que pour les appareils Samsung et rien d'autre.
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
D'accord merci du renseignement, parce que avec Samsung et Odin, c'est beaucoup plus rapide j'trouve.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Oui, pour Samsung ça a toujours été très simple :-|
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
skelett a dit:
Oui, pour Samsung ça a toujours été très simple :-|
C'est pour sa que je reste chez Samsung, même mon ami va quitté Sony pour Samsung je pense.

Mais merci pour les renseignements
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
C'est vous qui voyez, perso, je ne retournerais en rien chez Samsung x)

Sinon, avec plaisir :wink:
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
skelett a dit:
C'est vous qui voyez, perso, je ne retournerais en rien chez Samsung x)

Sinon, avec plaisir :wink:
Ah oui pourquoi, aucun retour chez Samsung ?? Il y a le Touchwiz que je trouve juste magnifique, barre de notification, etc.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
J'ai eu le S3 (qui tourne toujours grace à CyanogenMod) et un S4 (décédé par un mort subite). Déjà, je ne supportais pas TW à l'époque, mais je reconnais qu'ils ont fait des efforts depuis le S6 (design de l'appareil, matériaux utilisés, et TW).

Par contre, leur SAV est catastrophique. Mon S3 qui a eu un écran cassé s'est vu remplacé ce dernier sans problème. Mais pour mon S4, qui a été victime d'une mort subite, ils n'ont jamais voulu me le prendre en garantie, je devais toujours payer la moitié du prix de l'appareil pour le réparer. J'ai bataillé des mois contre eux, sans succès.

Mes parents ont chacun une tablette Samsung ainsi qu'un smartphone de la marque. La batterie des tablettes est morte au bout de quelques mois seulement, la réception wifi est complètement foireuse malgré toutes les manipulation que j'ai pu effectuer, et elles ont des lags à répétitions malgré tout ce que je fais.

Un des 2 téléphones fait une restauration d'usine quand bon lui semble (véridique ! Il s'éteint tout seul, peu importe le pourcentage de batterie, puis lorsque tu le redémarre, il affiche un popup disant que la réinitialisation d'usine à bien été effectuée !)

Le seul appareil sur lequel nous ne sommes pas embêté, c'est le A3 2015 de mon père. Mais malgré tout, lui qui est très Samsung, commence à regarder ailleurs.

Donc je ne sais pas si c'est notre famille qui a véritablement la poisse avec Samsung ( :lol: ), mais clairement, ils me sortent par les yeux.

Mais attention, ce sont des expériences personnelles qui font que j'ai actuellement cet avis. Du coup, il se peut très fortement voire sûrement que d'autres personnes ne rencontrent aucun problème avec les appareils de la marque, qu'ils en sont même très content, et je n'irais pas à l'encontre de ceci :wink:
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
skelett a dit:
J'ai eu le S3 (qui tourne toujours grace à CyanogenMod) et un S4 (décédé par un mort subite). Déjà, je ne supportais pas TW à l'époque, mais je reconnais qu'ils ont fait des efforts depuis le S6 (design de l'appareil, matériaux utilisés, et TW).

Par contre, leur SAV est catastrophique. Mon S3 qui a eu un écran cassé s'est vu remplacé ce dernier sans problème. Mais pour mon S4, qui a été victime d'une mort subite, ils n'ont jamais voulu me le prendre en garantie, je devais toujours payer la moitié du prix de l'appareil pour le réparer. J'ai bataillé des mois contre eux, sans succès.

Mes parents ont chacun une tablette Samsung ainsi qu'un smartphone de la marque. La batterie des tablettes est morte au bout de quelques mois seulement, la réception wifi est complètement foireuse malgré toutes les manipulation que j'ai pu effectuer, et elles ont des lags à répétitions malgré tout ce que je fais.

Un des 2 téléphones fait une restauration d'usine quand bon lui semble (véridique ! Il s'éteint tout seul, peu importe le pourcentage de batterie, puis lorsque tu le redémarre, il affiche un popup disant que la réinitialisation d'usine à bien été effectuée !)

Le seul appareil sur lequel nous ne sommes pas embêté, c'est le A3 2015 de mon père. Mais malgré tout, lui qui est très Samsung, commence à regarder ailleurs.

Donc je ne sais pas si c'est notre famille qui a véritablement la poisse avec Samsung (), mais clairement, ils me sortent par les yeux.

Mais attention, ce sont des expériences personnelles qui font que j'ai actuellement cet avis. Du coup, il se peut très fortement voire sûrement que d'autres personnes ne rencontrent aucun problème avec les appareils de la marque, qu'ils en sont même très content, et je n'irais pas à l'encontre de ceci :wink:
Ah ouais d'accord, moi j'ai eu un S, S2 puis la un S4 et jamais eu de problème, jamais eu de SAV.
J'ai même une tablette de la même marque et aucun problème.
J'en suis très content de cette marque

Xpéria moi j'aime pas tout, barre de notification tout comme sur cyanogen, j'ai l'impression que le travail n'est pas abouti niveau barre de notification, après c'est que mon avis
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
skelett pour les drivers adb je les ai installé grace a flashtool ,et je les ai normalement tous installés (ceux de mon Z5C , les deux premiers pour le bon fonctionnement du logiciel et voila)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
ThomasTom a dit:
Ah ouais d'accord, moi j'ai eu un S, S2 puis la un S4 et jamais eu de problème, jamais eu de SAV.
J'ai même une tablette de la même marque et aucun problème.
J'en suis très content de cette marque
Et bien il y en a qui ont de la chance :lol:

ThomasTom a dit:
Xpéria moi j'aime pas tout, barre de notification tout comme sur cyanogen, j'ai l'impression que le travail n'est pas abouti niveau barre de notification, après c'est que mon avis
Chacun ses goûts :wink:

J'adore le design des Xperia mais ma surcouche préférée reste Sense de HTC :D

Niko549954 a dit:
skelett pour les drivers adb je les ai installé grace a flashtool ,et je les ai normalement tous installés (ceux de mon Z5C , les deux premiers pour le bon fonctionnement du logiciel et voila)
Non ça, ce sont les drivers Flashtool, pas ADB.

J'ai bien indiqué dans le tuto les liens pour les télécharger. D'ailleurs, tu devrais passer par le SDK Android pour les prendre et les installer (c'est un peu plus long à télécharger, mais c'est plus fiable) :wink:
 
N

Niko549954

Membre
Inscrit
31 Janvier 2016
Messages
11
Points
0
ah oui nan mince j'ai confondu ^^ les drivers adb je les ai installer grâce a AdbDriverInstaller
 
ThomasTom

ThomasTom

Membres VIP
Inscrit
14 Février 2015
Messages
1 686
Points
38
skelett a dit:
Chacun ses goûts :wink:

J'adore le design des Xperia mais ma surcouche préférée reste Sense de HTC :D
Oui c'est vrai

Ah j'ai jamais eu de HTC moi.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Niko549954 a dit:
ah oui nan mince j'ai confondu ^^ les drivers adb je les ai installer grâce a AdbDriverInstaller
Bon et bien il faudra que je regarde plus en profondeur, car je ne vois absolument pas où est le problème...

Mais du coup, tu as quand même essayé de les installer par le SDK Android ?

ThomasTom a dit:
Ah j'ai jamais eu de HTC moi.
Le HTC One M8 est, jusqu'à présent, le meilleur smartphone que j'ai pu avoir entre les mains. J'en étais "amoureux" !

Malheureusement une mauvaise chute sur des graviers a mis un terme à sa vie =(
 
J

jskeqo

Membre
Inscrit
19 Mai 2016
Messages
2
Points
0
Bonjour,

Savez-vous si cela fonctionnera avec E5803 ?
Si oui, si je comprend bien, le fichier TWRP v3.0.2-0 n'est pas nécessaire ?

Merci !
Jskeqo
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Le kernel est pour tous les modèles de Z5C, contrairement au TWRP.

Le problème qui ce pose, c'est que sans le TWRP, pas moyen de flasher le SuperSU et donc de rooter l'appareil :-|
 
T

tomtomdepomme

Membre
Inscrit
6 Mars 2016
Messages
1
Points
0
Salut, j'ai un Z5C avec le bootloader dévérouillé et je me demandais si en rootant l'appareil j'allais perdre toutes mes données comme lors du dévérouillage de bootloader, parce que la méthode que j'ai utilisé pour restaurer les applis/parametre/messages était très longue et fastidieuse (à l'aide de l'appli my backup).

Si jamais il faut sauvegarder le système connaissez-vous une méthode simple et rapide pour tout sauvegarder d'un coup ??

Merci d'avance ;)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut :hello:

Tu peux tout sauvegarder en passant par un recovery custom. Mais ça nécessite le root :lol:

Sinon ne t'inquiètes pas, le fait de rooter son appareil n'effacera en aucun cas tes données personnelles.
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
Hello

apres avoir essayé tous les tutos de root pour le z5c
toujours pas reussi a installé le supersu et pas de root a l'horizon

J'ai du reflasher mon tel en 5.1

si vous avez un tuto en partant de ca en mode basique je suis preneur

car apres avoir rooter la totalité de mes telephones depuis des années le z5c est un gros mystere :(
please help !

merci d'avance
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Ce tuto existe bel et bien, et c'est celui sur lequel tu viens de poster.

Où cela a-t-il bloqué ?
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
ahah mais c'est ca qui est genial

ca bloque jamais

il me dit meme instalation du trwp done

je relance
pas de lumiere jaune donc forcement je peux pas rentrer dedans donc je peux pas installé super su

j'ai aussi eu une boucle continuel de reboot lors d'un des multiples essaye.

dans lautre tuto
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


idem super su installé (via push update) je relance le tel et rien (en revenant sur ce tuto j'ai un doute que le la partition soit bien monté. l'etrange impression que la fonction n'est pas prise en compte. (c'est aussi pour ca que je voulais passer par le trwp)

moi pas comprendre du tout

edit : pretite precision car je viens de regarder le bootloader est passé du mode booleader unlockable yes (avant deverouillage) a rooting status : unknow (c'est ptete ça le probleme mais j'ai rien vu a ce propos)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Ton bootloader est déverrouillé ?
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
jaycounet a dit:
edit : pretite precision car je viens de regarder le bootloader est passé du mode booleader unlockable yes (avant deverouillage) a rooting status : unknow (c'est ptete ça le probleme mais j'ai rien vu a ce propos)
juste ecrit a la fin de mon poste

j'ai unlock le bootloader via le site sony comme indiqué tout c'est bien passé
par contre le nouveau statut de celui ci me semble etrange
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Au temps pour moi, je n'avais pas fait attention.

Le rooting status en Unknow ne me choque pas.

Peux-tu me confirmer le modèle de ton appareil stp ?
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
le numero du modele ?
E5823 ca semble logique ^^ si tu veux autre chose et que j'ai pas compris la question dis moi
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
En sachant qu'il existe aussi le E5803, désolé mais non, ce n'est pas forcément logique :wink:

J'ai relu tout tes posts pour essayer de comprendre d'où venait le problème, mais je n'ai rien trouvé de particulier. Du coup, j'en viens à cette question : Avant de faire toutes les manips' via l'invit' de commande, as-tu activé le déboguage USB et les sources inconnues ?
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
oui tout etait activé meme oem truc
on sait jamais

je peux essayer de tout refaire encore une fois je ne suis plus vraiment a ca pret.

il faut mieux que j'essaye de refaire quelle version ? je suis en 5.1.1 maintenant :)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
jaycounet a dit:
oui tout etait activé meme oem truc
Et bien du coup, tu vas me recocher cette option :wink:

jaycounet a dit:
je peux essayer de tout refaire encore une fois je ne suis plus vraiment a ca pret.

il faut mieux que j'essaye de refaire quelle version ? je suis en 5.1.1 maintenant :)
Justement, j'allais te demander de réessayer après avoir flashé la 0.224 (Android 6.0.1) sur ton Z5C :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
et je la trouve ou cette petite nouvelle rom ? (ca vous manque pas en passant stamina ?)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Tu l'as trouve sur Xperifirm, lui-même dispo' via Flashtool. Prends une Customized, mais pour les pays étranger (La FR n'étant pas encore sortie).

Ne t'inquiètes pas, elles prennent toute en charge le français (actuellement, je tourne sur la Taïwanaise :D ) et la seule différence se fait dans les applications pré-installées qui sont juste différentes et plus ou moins nombreuses :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
Merci je regarde ca en rentrant
et j'essaye de me motiver (un peu relou de passer des heures :D)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Le plus long, c'est le flash et la reconfiguration de l'appareil suite au flash.

D'ailleurs, un bon gros conseil avant le flash de la 0.224, sauvegardes toutes tes données. Et sur Flashtool, lors de la sélection du firmware à flasher, sélectionnes toutes les cases Wipes si tu ne veux pas te retrouver avec un bootloop certain :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
J'ai plus rien a sauvegarder de toute façon :D

ok donc flash 6.0.1
usb debug
authoriser source inconnu

et retantage de root avec ce tuto right ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
+ activer l'option Déverrouillage OEM

Et c'est tout bon :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
he llo

apres deux essai avec 2 rom differentes j'ai cette erreur quand je veux flasher

13/010/2016 21:10:52 - ERROR - TA entry (0000084F)parsing error

forcement ca a tout casser quand meme ^^

une idéee ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Tu as coché une case particulière dans les catégories Misc TA ?
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
on est censé tout coché nan ? j'ai suivi lautre tuto et j'avais pas eu de probleme a flasher la 5.1.1
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Normalement, tu ne dois rien cocher, surtout pas dans cette catégorie là, et encore moins pour le Z5/C/P.

Donc réessaye en décochant tout, sauf les wipes :wink:
 
J

jaycounet

Membre
Inscrit
25 Décembre 2012
Messages
11
Points
0
pourtant je cite "Cochez toute les cases de l'encadré "MiscTA Exclude"

enfin pas grave

Jretenterai un jour j'ai de toute façon plus acces a adb mon telephone est plus reconnu

Jcrois que je vais piquer le pc de ma cops sous win 7 pour tout bidouiller
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Le tuto est général pour tous les Xperia, et pas mis à jour depuis un bon moment.

Du coup je te confirme qu'il ne faut pas les cocher, ça provoque des erreurs (là preuve, tu en fait actuellement les frais).
 
Y

Yxzoum

Membre
Inscrit
9 Mars 2014
Messages
27
Points
0
Hello,
Mon z1 ayant perdu la bataille contre le carrelage, je me suis tourné vers le z5c ^^.
Je voudrais rooter celui-ci avec la méthode de skelett mais je suis bloqué à l'étape ou on rentre "fastboot flash boot boot.img" dans le cmd.
Après avoir entré la commande j'ai <waiting for device> et plus rien... Impossible d'écrire une nouvelle ligne de commande et l'écran reste noir.
La led sur le téléphone est bien bleue, j'ai bien activé le debogage usb et autorisé les sources inconnues.
Merci d'avance,
Zoum
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Tu as bien déverrouillé ton bootloader ?
 
Y

Yxzoum

Membre
Inscrit
9 Mars 2014
Messages
27
Points
0
Effectivement j'ai sauté cette étape :D.
J'ai un bootloader déverrouillable.
Le déverrouiller fait-il bien perdre la garantie ? Si oui, y a-t-il un moyen de récupérer cette garantie par la suite (en conservant le root) ?
Existe-il une méthode similaire à KingRoot (celui-ci ne fonctionne pas encore sur le z5c) ? Car j'ai encore 2 ans de garantie et j'aimerais en profiter ;).
Merci de ton aide.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Quoi qu'il arrive, le fait de déverrouiller son bootloader te fera perdre la garantie quoi qu'il arrive. Mais !

Il existe une méthode pour rooter temporairement ton appareil avec un bootloader verrouillé, afin de sauvegarder la partition TA, là où est "rangée" la garantie. Tu pourras la restaurer plus tard, afin de retrouver la garantie de ton appareil si besoin est. Du coup, je te laisse jeter un coup d'oeil à ce tuto -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
... Et te souhaite bien du courage ! :D
 
Y

Yxzoum

Membre
Inscrit
9 Mars 2014
Messages
27
Points
0
:mrgreen: Merci :
 
M

Moods13

Membre
Inscrit
25 Avril 2016
Messages
2
Points
0
Bonjour,

Tout d'abord, merci pour ce tuto bien clair (pour newbie comme moi), j'ai suivi la procédure comme indiqué et... Cela ne fonctionne pas..
Je précise: j'ai un Z5C, modèle 5823, sous Android 6.0.

J'ai bien monté le kernel et le twrp. J'avais déjà placé le SU(bêta) à la racine de mon téléphone avant même de débuter la procédure. Une fois tout le process accompli, le téléphone redémarre et à l'affichage "démarrage d'Android, lancement des application", il y a un led rouge qui clignote (une fois) de manière plus ou moins régulière et rien ne se passe, même avec du temps. J'ignore totalement à quoi c'est dû ni de quoi il s'agit..

En attendant d'en savoir plus, je vais flasher le firmware 6.0 (made in Singapore) et puis patienter sagement!
Merci d'avance (et bonne journée)

Edit: J'ai donc flashé mon téléphone avec le firmware dont je disposais, tout est revenu à la normale et j'ai même super SU d'installé, pourtant quand je le lance, il me dit "Aucun binaire SU n'est installé, et SuperSu ne peut l'installer. C'est un problème! Si vous venez de faire la mise à jour vers Android 5.0 (ce qui n'est pas mon cas, vous devez re-rooter manuellement votre appareil".
Je suis largué là 8|
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Essayes avec cette version du SuperSU, que tu reflasheras via le recovery -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
:wink:
 
M

Moods13

Membre
Inscrit
25 Avril 2016
Messages
2
Points
0
C'est fait :) ! En téléchargeant le fichier, j'ai vu que c'était exactement le même que celui que j'avais déjà utilisé mais j'ai tenté le coup malgré tout.
Du coup, ça me fait exactement la même chose, je vais attendre un moment pour voir si le démarrage d'android se fait (ou non): si oui tant mieux, sinon, as-tu une idée de ce qui fait défaut?

Merci!
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Bonjour,

Merci pour ce tuto, je rencontre cependant un problème la procédure ce déroule bien jusqu'au reboot du téléphone ou la LED a clignoter plusieurs fois en rouge. A présent s'allume en vert et reboot quelques temps rouge avant de repasser au vert.

Ecran noir, le téléphone ne démarre plus

Pouvez vous m'éclairer ?

Merci par avance.

Cordialement
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

J'ai juste besoin d'une petite précision : Sous quel firmware tourne ton appareil ? Ça me permettra de déterminer le kernel que tu utilises.
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Salut,

Merci pour ta réponse, je suis sous le firmware 32.0.A.6.200.

Mon bootloader est bien déverrouillé.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Je vois. Tu es encore sous Lollipop (Android 5), tandis que là, tu suis un tutoriel pour Marshmallow (Android 6).

Dans ce cas, il faut que tu prennes ce kernel-ci -->>
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Ou bien que tu mettes à jour ton Z5C en Marshmallow et utiliser l'un de ceux présents sur le tutoriel.
 
S

slider07210

Membre
Inscrit
25 Mars 2013
Messages
13
Points
1
Autant pour moi, quel abru... je suis c'est pas comme si c'était marqué dans le titre...

Désolé et encore merci !
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Pas de soucis et avec plaisir :wink:
 
S

Snouzy

Membre
Inscrit
25 Avril 2014
Messages
108
Points
0
Bonsoir n'étant pas sûr je me permet de vous demander si il s'agit bien de xposed-v79-sdk23-arm64 pour le z5c sous 6.x afin de ne pas faire d'erreurs ^^ bonnes soirée tout le monde


De plus, il me met "waiting for device" à "fastboot flash boot boot.img" ... une solution ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Pour le Xposed, c'est la v86 qu'il te faut.

Pour le message du CMD, c'est parce que tu n'as pas installé les drivers ADB ou bien que tu n'as pas ouvert l'invit' de commande au bon endroit.
 
S

Snouzy

Membre
Inscrit
25 Avril 2014
Messages
108
Points
0
Salut, merci pour le Xposed, et merci pour ta réponse.

J'ai bel et bien installer les driver ADB, cependant quand mon téléphone est en mode fastboot, quand je vais dans le gestionnaire de périphériques il y a un triangle jaune avec un point d'exclamation sur mon z5c. (pas de pilote en mode fastboot donc)

Hum, j'ai essayé d'ouvrir la commande sur le dossier adb, et dans le dossier adb, même problème.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Donc tes drivers ADB sont bel et bien pas installés, ou alors mal (peut-être qu'en réinstallant les pilotes après avoir désactivé la vérification de la signature des pilotes, ça passerais).

Si le problème persiste, passe par le SDK Android, en prenant soin de bien installer le platform-tools (une fois le SDK installé, il s'ouvrira et tu pourras sélectionner des choses à installer. Il faudra donc que tu choisisses le platform-tools).
Une fois fait, tu ouvriras une invit' de commande sur ce dossier (qui se trouve dans C:\Users\*nom d'utilisateur*\AppData\Local\Android...) :wink:
 
GmHtAf

GmHtAf

Membre
Inscrit
30 Novembre 2012
Messages
9
Points
0
Hey !

D'abord merci pour le Tuto ! ensuite juste un petit truc qui me titille :
Le lien du fichier TWRP 3.0.2 est concu pour le E6653 (z5) , ça n'a aucune importance ça marchera quand même avec le E5823 (z5c) ?

Cdt.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
15 004
Points
113
Salut,

Yep, ne t'inquiètes pas, ça fonctionnera :wink:

Dans le cas contraire... Ben il ne se passera rien de bien méchant (peut-être un freeze). Si tel est le cas, reviens ici et je te donnerais un autre lien (si j'en trouve un).
 
S

Sulith

Membre
Inscrit
22 Décembre 2016
Messages
1
Points
0
Bonjour à tous,

Cela fait 2 jours que j'ai mon Xperia Z5C et la batterie tombe en flèche... J'avais un Z3C il y a deux ans et j'en étais très satisfait. Je n'ai jamais voulu passer le pas du root car complètement novice dans le sujet.
J'ai bien lu ton tuto et tout me paraît clair. La seule chose que j'aimerais faire est repasser en lollipop 5.1.1 car des la première mise en route il a fait toutes les mises à jour jusqu'à Marshmallow et j'ai l'impression que la gestion de la batterie n'est pas du tout optimisé comme elle l'était à l'époque :vieux-smiley:

Si par dessus le marché je peux retirer quelques applis constructeur, je ne suis pas conte :) .

Ma question est la suivante : comment dois-je m'y prendre en prenant ton tuto comme pattern de root mais uniquement pour chopper l'ancien firmware et non une rom personnalisée? (un peu peur de foutre le bordel dans mon téléphone...)


Merci d'avance et bonne fêtes à tous!
 
M

misterko

Membre
Inscrit
28 Février 2012
Messages
16
Points
1
salut tout le monde, j'ai trouvé la solution pour ceux qui arrive pas mettre le recovery, il suffit de renomer le fichier "twrp-3.0.2-0-E5823.img" en "recovery.img", en relacant la commande : "fastboot flash recovery recovery.img" et miracle. bonne continuation
 
G

gropokar

Membre
Inscrit
17 Janvier 2017
Messages
14
Points
0
Salut à tous,

pour ceux qui ont un E5803 comme moi, il y a un twrp disponible ici:

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


wink

Edit de 3 jours après

tout à bien fonctionné pour moi smiley

merci phonandroid :merci: :super:
 

Haut Bas