[TUTO] Désactiver le micro d'ambiance

  • Auteur de la discussion zemarsu
  • Date de début
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #1
Désactiver micro d'ambiance
Galaxy S2​
Tout d'abord, retrouvez la notice officielle de votre Galaxy S2 , qui reprend les diverses fonctions de bases du Samsung Galaxy S II. Très utile en cas d'oublie!

Bonjour à tous,

nombreux sont les possesseurs de Galaxy S2 qui ont un problème d'écho lors de leurs appels téléphonique. L'interlocuteur n'arrive dans la plupart des cas pas à comprendre ce que dit le possesseur du S2. Ceci est dû à un défaut du micro d'ambiance.

A quoi sert ce micro ? En fait c'est un petit micro qui se trouve sur le dos du téléphone et dont le but est de capter les sons ambiant. Ensuite le téléphone fait une sorte de soustraction en retirant du micro principal les sons qui lui parviennent par le micro d'ambiance améliorant très nettement la qualité sonore ... sauf que le micro est défectueux.

Il s'avère que certaines personnes ayant ce problème ont renvoyé le téléphone en SAV mais à chaque fois le micro revenait tel quel et donc le problème restait identique.
Un développeur de chez XDA a donc fait un mod de l'appli du téléphone (Phone.apk) afin de désactiver le micro d'ambiance par défaut, mais au besoin il y a tout de même la possibilité de le réactiver en appuyant sur menu pendant un appel.

Pour installer ce mode il vous faut :
- Un téléphone rooté avec le recovery CWM
- Une ROM deodexed
- Le mod (que vous trouverez )

Intallation :
- Copier le fichier à la racine de votre téléphone
- Etteignez votre téléphone
- Redémarrez en mode recovery (vol haut + home + power)
- Sélectionnez Apply zip from SD card
- Choose zip from SD card
- Sélectionnez le fichier du mod
- Validez
- Back puis reboot

Normalement le micro d'ambiance sera désactivé et il n'y aura plus d'écho.


PS : merci à William33000 pour le lien vers le tuto XDA
 
david

david

Administrateur
Inscrit
12 Juillet 2010
Messages
3 116
Points
63
  • #2
oh merci l'ami coool
 
B

baroncito

Membre
Inscrit
19 Janvier 2012
Messages
2
Points
0
  • #3
Merci ! j'aimerais essayer cette méthode, le problème c'est que l'explication est chargée de termes que je ne comprends pas, et rien que la démarche pour rallumer le téléphone me parait barbare...
Vous pourriez récapituler tout ça en mode "pour les nuls" ?!
 
ttk22

ttk22

Membre
Inscrit
9 Novembre 2011
Messages
27
Points
3
  • #4
perso, j'ai mis un tout ptit bout de scotch sur le trou et ça fait l'affaire !! :lol: :lol:
 
V

vctgdx

Membre
Inscrit
27 Décembre 2011
Messages
34
Points
6
  • #5
Si ça peut aider.......
Même problème que beaucoup. Mes interlocuteurs s'entendent parler dans leur tel. (mobile ou fixe) !!!!
J'ai essayé avec une autre Sim, même problème.
J'ai essayé ma Sim dans un autre SG S2, OK.

J'ai donc appelé le sav SFR, qui pour le coup, s'est aperçu du problème de suite, et m'a dit que c'était un problème connu sur les SG S2. Je pense qu'il est donc inutile d'essayer de désactiver ce fameux micro d'ambiance.
Donc, aussi sec, mon tel est parti en réparation (délai annoncé: 15 jrs)

Pour info, j'avais acheté mon SG S2 d'occas (mais encore sous garantie) à une personne qui l'avait elle même acheté sur RDC.
SFR n'a fait aucun problème pour l'envoyer en sav.
 
S

stef2002

Membre
Inscrit
18 Janvier 2012
Messages
1
Points
1
  • #6
Bonjour je suis nouveau dans le monde du samsung galaxy s2 et j'ai le meme probleme d'echo mais j'ai beau chercher dans le forum il y a tellement de posts que je ne comprend rien au " Un téléphone rooté avec le recovery CWM " et " Une ROM deodexed " serait il possible de mettre un lien , merci :?:
 
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #7
Hello, CWM c'est le clockworkmod que tu as de facto en faisant un root avec CF-Root.
Si tu as une ROM officielle elle est de base odexed (cherche pas à comprendre le sens) et il te faudra passer sur une custom qui elle sera deodexed.
Sache tout de même qu'une conséquence de ça est la perte de la garantie de ton téléphone.
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #8
Bonjour,

Je suis sous ROM sensation et lorsque je suis ton tuto ca me met "not found" lorsque je valide le .zip en mode "recovery".

Pourtant le .zip contient bien les .apk etc

Une idée ?
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #9
J'ai donc réussi à l'install en mode recovery en validant d'abord la signature toujours en mode recovery.

Ce qui est dommage c'est que si vous avez une ROM custom la mise en page et les images utilisées pendant l'appel sont remplacés par cette apk et c'est pas très beau :/
 
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #10
J'ai pas tout compris a ton histoire de signature mais si tu as reussi c'est le principal.

Pour ta remarque je suis tout a fait d'accord avec toi. Cette solution est une solution simple pour pouvoir solutionner rapidement et simplement un probleme tres genant que le SAV ne veut pas prendre en compte.

J'envisage de detailler la procedure complete un de ces quatre, mais c'est loin d'etre simple vu qu'il faut sortir le phone.apk du zip de la rom, le decompiler, le modifier et tout recompiler ... en clair pas super easy :s

Sinon la manip a fonctionner pour toi, ca a bien desactiver le micro d'ambiance ?
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #11
Désolé si je n'ai pas été clair dans mon message précédent.

Lorsque j'ai voulu install le .zip j'avais une "erreur" ( l'appli n'était pas signée. Même principe que pour installer certaines applis que l'on récupère en dehors du market, il faut utiliser superuser pour valider la signature sinon l'install ne se fait pas ) Il a donc fallu que je vérifie la signature en mode recovery ( option présente nativement mais je ne me souviens plus du nom ) et une fois la signature vérifié j'ai pu l'installer.

Le problème du phone.apk ( je n'ai pas vérifié les .xml de ce celui ci ) c'est que la plus part du temps les .apk du ROM modifié sont cryptés afin de protéger le code du développeur ce qui rend quasi impossible la modification des fichiers sans la clé de cryptage :/

Mais entre ne rien toucher et avoir des problèmes ou accepter un "graphisme" différent de sa ROM modifiée et moins beau mais qui rend les appels agréable à tous, le choix est vite :)
Ce phone.apk ma bien désactivé par défaut mon micro d'ambiance et pour le moment personne ne s'est plein d'un écho ou du fait de m'entendre de loin.
 
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #12
Merci pour le complement d'info, vu que j'utilise essentiellement des ROMs AOSP je n'ai pas trop ce genre de probleme ;)
 
B

baroncito

Membre
Inscrit
19 Janvier 2012
Messages
2
Points
0
  • #13
je ne comprends toujours pas les manipulations à faire pour désactiver le micro d'ambiance. Ceci dit, j'ai essayé de scotcher le micro et ça n'a pas fonctionné. En revanche, quand je retire la housse de mon mobile, il n'y a plus d’écho :shock: . Sinon, lors de chaque appel, on peut désactiver, au coup par coup, le micro d'ambiance en appuyant sur la touche de gauche du téléphone puis sur "désactiver...".
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #14
baroncito a dit:
je ne comprends toujours pas les manipulations à faire pour désactiver le micro d'ambiance. Ceci dit, j'ai essayé de scotcher le micro et ça n'a pas fonctionné. En revanche, quand je retire la housse de mon mobile, il n'y a plus d’écho :shock: . Sinon, lors de chaque appel, on peut désactiver, au coup par coup, le micro d'ambiance en appuyant sur la touche de gauche du téléphone puis sur "désactiver...".
Si tu télécharge le phone.apk il n'y pas de manip à faire, ton micro serait systématiquement désactivé.

Après comme tu le souligne on peut le désactiver à chaque mais c'est bien casse ...

Le "problème" de housse qui donne l'écho est connu, ce souvent les housses en silicone ou autre qui obstrue le micro et crée cet écho.
 
A

ana90000

Membre
Inscrit
26 Janvier 2012
Messages
1
Points
0
  • #15
bonjour jai le meme souci d echo ou trouve t on l appli phone.apk car je ne comprends pas trop les termes de rom etc je n y connais rien
 
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #16
Hello,

on va faire simple, il te faut une ROM custom afin de pouvoir le faire fonctionner (si tu ne sais pas ce que c'est prends 10 min et vas lire le post que j'ai en signature).

Une fois que tu as une custom tu suis le tuto et ca marche.

Petite precision : cela ne desactive pas definitivement le micro d'ambiance, cela le met en position desactiver par defaut et cela ne vous empeche pas de le remettre au besoin.
 
V

vctgdx

Membre
Inscrit
27 Décembre 2011
Messages
34
Points
6
  • #17
Bjr tous et toutes,
Pour ceux et celles que ça intéresse, un retour sur mon post du 19 janvier 12 (desactiver-le-micro-d-ambiance-t9447.html#p119611)

J'ai récupéré mon SG S2 ce matin, et effectivement il y avait bien un pb matériel (pour info, 1 sem en sav; rapide donc).
A donc été changé:
- Platine secondaire I9100/P/G
- Module Receiver/vibreur/Jack I9100/P/G
- Vis
- Pastille d'humidité

Bref, je ne sais absolument pas à quoi tout ceci correspond, mais pour le moment, le problème semble résolu; mes correspondants ne s'entendent plus parler. Pourvu que ça dure !!!
 
psykauz

psykauz

Membre
Inscrit
6 Janvier 2012
Messages
13
Points
0
  • #18
Petite question :
Lorsqu'on parle d'echo, il s'agit bien de la personne qui appelle vers le S2 qui a un probleme d'echo et qui entends sa voix?
 
V

vctgdx

Membre
Inscrit
27 Décembre 2011
Messages
34
Points
6
  • #19
psykauz a dit:
Petite question :
Lorsqu'on parle d'echo, il s'agit bien de la personne qui appelle vers le S2 qui a un probleme d'echo et qui entends sa voix?

En effet. C'était bien mon problème.
 
zemarsu

zemarsu

Membre
Inscrit
23 Mars 2011
Messages
4 201
Points
0
  • #20
C'est tout a fait ca
 
M

miki

Membre
Inscrit
5 Février 2012
Messages
1
Points
0
  • #21
Moi aussi un simple mirceau de stcoch et ca marche lol
 
3

306or

Membre
Inscrit
10 Février 2012
Messages
1
Points
0
  • #22
Bonsoir, j'ai le meme soucis, mais ton tuto ne marche pas le site marque erreur de chargement
Comprend pas
 
S

smith5945

Membre
Inscrit
7 Février 2012
Messages
148
Points
0
  • #23
ui en effet problème avec multiupload.

Sinon le patch marche bien. Seul problème l'icone de contact lors de l'appel est fortement diminué et parfois le processus android.phone fait un FC donc obliger de rebooter pour pouvoir appeler.

J'espère qu'une nouvelle version du patch sortira ^^
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #24
Bonjour,

le lien pour télécharger le mod ne fonctionne plus...

Il y a t il un autre lien?
Merci ;-)

Djadj55
SGS2
Cyanogen mod7
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #25
Bonjour,

Je t'ai uploader le fichier ici :
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #26
hello!

merci Tiben013!

cependant, j'ai téléchargé le fichier et je l'ai mis sur mon téléphone à la racine.
Ce n'est pas 1 fichier zip, alors j'ai essayé 2 façons :

- 1 fois le téléphone allumé normalement, j'ai essayé d'installer le fichier .apk comme n'importe quelle application.
l'installation n'a pas fonctionné.
- j'ai donc zippé le .apk puis redémarré le phone en recovery. Ensuite, j'ai suivi la suite du mode op'...
Installation aborded!!!

Est ce que tu comprends pkoi?

merci

mon samsung galaxy s2 :
version de la bande passante : I9100XXKH1
Version du noyau : 2.6.35.7-g1e46077
version du mode : cyanogenMod- 7.1.0
N° de build : GWK74
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #27
Désolé j'ai uploader le .apk en non le .zip comme un boulet.

Le nouveau lien :

Tu passe en mode recovery et install .zip

Si tout ce passe bien le micro sera désactivé par défaut, par contre si tu as une ROM custom ton écran d'appel changera ( tu comprendras en appelant )
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #28
Super!!!

Merci bien, je l'ai installé!
merci pour ta réactivité!
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #29
djadj55 a dit:
Super!!!

Merci bien, je l'ai installé!
merci pour ta réactivité!
Avec plaisir ;)

Je suis bien content quand j'ai une galère et que l'on m'aide, il faut savoir en faire autant.

Bonne journée à toi.
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #30
hello!

euh :-s
ouais mais... on dirait que mon phone reste bloqué sur l'icone Cyanogen mod7... En clair, il ne reboot plus!
ooopssss

je crois que je vais devoir tout réinstaller!
enfin c'est pas grave, je vais finir par y arriver...

;-)
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #31
ok, pour mon soucis de freeze au reboot, j'ai lu qu'il fallait que je fasse les wipe...

Donc c'est parti!
enfin, je sauvegarde d'abord mes applis puis c'est parti!

je reviens pour dire si ca a fonctionné!
des fois que qn d'autres ai le meme soucis, il saura le résultat!
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #32
ben non, ca marche toujours pas

:-(

je mettrais la solution que je trouverai...
Quand je la trouverai !
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #33
djadj55 a dit:
hello!

euh :-s
ouais mais... on dirait que mon phone reste bloqué sur l'icone Cyanogen mod7... En clair, il ne reboot plus!
ooopssss

je crois que je vais devoir tout réinstaller!
enfin c'est pas grave, je vais finir par y arriver...

;-)
Il bloque suite à l'install du .zip ? ou rien à voir ?
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #34
ouais, il bloque suite à l'install du zip.

Dès que je ré-installe le zip de cyanogen, ca fonctionne, mon téléphone s'allume bien...
Mais le zip du phone.apk ne fonctionne pas (toujours de l'écho, et pas de modification des icones quand j'ai des appels).

Quand je ré-installe le zip du phone.apk : je ne peux pas rebooter...

J'ai fait les 2 wipes, puis ré-installe du cyanogen, puis ré-installe du zip phone.apk...
J'ai toujours le même soucis!

c'est aussi ça la bidouille ;-)
mais je ne sais plus trop quoi faire...
Je parcours le web, mais si tu as une idée, je suis preneur : le web est plus vaste que l'univers lol
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #35
bonjour,
même téléphone, même souci...

J'ai installé un CF root avec CWM mais je suis resté avec la surcouche opérateur... téléphone neuf... encore garanti.
Je peux utiliser le .zip ou pas ?
Si je flash le phone.apk, et que ca ne fonctionne pas bien, avec juste un reset factory, je retrouve le phone.apk d'origine ?
A chaque fois que plus tard je changerai de rom il faudra réappliquer ce fix ?

merci d'avance
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #36
@Djad : je test dans la journée le .zip et je te dis ce qu'il en est peut etre est ce le fichier qui est corrompu.

@Alex : je te répond dans la journée. Je pars au taf la.
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #37
Djad : tu as quoi comme ROM ?

Tu es bien root ?
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #38
tiben013 a dit:
J'ai donc réussi à l'install en mode recovery en validant d'abord la signature toujours en mode recovery.

Ce qui est dommage c'est que si vous avez une ROM custom la mise en page et les images utilisées pendant l'appel sont remplacés par cette apk et c'est pas très beau :/
Djad ? Ne serait ce pas ton problème ?
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #39
Tiben013,

J'ai cyanogenmod7.

Je n'ai pas de pb de signature, car lorsque j'install le zip du phone.apk, tout à l'air de fonctionner correctement : je n'ai pas de message d'erreur, pas de failed, etc...
Je connais ce pb de signature, car je l'ai déjà rencontré, mais pas pour ce fichier zip là.

Et oui, je suis bien en root. J'ai même vérifier via l'appli root tester (ou qch comme ca).
Mais de tte facon, pour installer cyanogen, il fallait bien que je sois en root.
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #40
Cela viendrait il de la ROM ?

Le fichier est le bon et tout est ok pour moi donc je ne vois que la ROM ou le ROOT.

Ta ROM est une no wipe sur base samsung ou une full wipe ? Si second cas peut etre que le développeur a fait des modifications sur cette partie et rend le phone.apk incorrect.
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #41
tiben013 a dit:
@Djad : je test dans la journée le .zip et je te dis ce qu'il en est peut etre est ce le fichier qui est corrompu.

@Alex : je te répond dans la journée. Je pars au taf la.


ok... merci par avance
 
D

djadj55

Membre
Inscrit
6 Février 2012
Messages
9
Points
0
  • #42
Ok merci tiben.

Il s agit d une rom full wipe...
c est donc surement le dvpt qui a changé le phone.apk

Mais il na pas corrigé le pb... dommage!
 
T

tiben013

Membre
Inscrit
21 Janvier 2012
Messages
38
Points
6
  • #43
alextit a dit:
bonjour,
même téléphone, même souci...

J'ai installé un CF root avec CWM mais je suis resté avec la surcouche opérateur... téléphone neuf... encore garanti.
Je peux utiliser le .zip ou pas ?
Si je flash le phone.apk, et que ca ne fonctionne pas bien, avec juste un reset factory, je retrouve le phone.apk d'origine ?
A chaque fois que plus tard je changerai de rom il faudra réappliquer ce fix ?

merci d'avance
Si tu es root tu devrais pouvoir installer le .zip sans problème vu que je l avais installé a partir d'une rom officielle.

Si le .zip ne te convient pas il faudra réinstaller ta rom pour supprimer le .zip.

Djad : passe sous sensation c est une excellente ROM.
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #44
Un petit retour pour confirmer que la méthode a fonctionné nickel pour moi.
Merci encore pour l'aide apportée !
 
S

stoemp2003

Membre
Inscrit
13 Janvier 2012
Messages
3
Points
0
  • #45
Rebonjour à tous j'avais il y à de ça plus de 2 mois posté un message parlant de mon problème d'éco que rencontrais mes interlocuteurs, auj ça fais la 2eme fois que je rend mon portable en SAV, la 1er fois il y est revenu après une semaine mais rien n'avais changé. Je vois que la méthode de Zemarsu à l'air de bien fonctionner et je voudrais bien l'essayer, le problème est que je ne comprend rien au ROM, ZIP ou autres lol je suis nuls dans ce domaine, je voudrais savoir si quelqu'un aurait bien la bonté de repartir avec moi de zéro et m'expliquer ça pas à pas ?? Je suis vraiment désoler d'avance du dérangement et surtout de redemander des choses qui ont été expliqués plusieurs fois !!! Par rapport aussi à ce fameux micro d'ambiance, je ne sais pas si c'est normal mais moi je n'est pas l'option dans mon menu lors d'un appel ??? Tout mes amis qui ont ce tel l'ont sauf moi, est ce normal ?
Voila si quelqu'un peux m'aider ça serais super et désolé encore pour tout, et pardonnez moi mon amateurisme mais je suis nul en tout ce qui concerne l'informatique etc etc

Merciiiiiiiii
 
YohKenshiro

YohKenshiro

Membres VIP
Inscrit
11 Février 2012
Messages
3 335
Points
0
  • #46
pour le micro je sais pas du tout aucun probleme avec et sinon pour la rom quand tu aura reçu ton tel du SAV va dans la zone question réponse et on recommencera tout a 0 ;)
 
S

stoemp2003

Membre
Inscrit
13 Janvier 2012
Messages
3
Points
0
  • #47
Merci Yoh je compte sur vous lol
Bonne soirée !!!
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #48
Bonsoir
J'ai appliqué le tutoriel
Intallation :
- Copier le fichier à la racine de votre téléphone
- Etteignez votre téléphone
- Redémarrez en mode recovery (vol haut + home + power)
- Sélectionnez Apply zip from SD card
- Choose zip from SD card
- Sélectionnez le fichier du mod
- Validez
Le thème à commencé à s'installér.. completed. puis là , mon telephone reboot , et est resté bloqué à l'écran "Samsung GALAXY S2 (2eme ecran)
Je suis totalement novice et en panique complète .J'avais effectué une sauvegarde avec CWM;
Que dois je faire ? Merci d'avance
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #49
Ton téléphone est bien roote ?


Envoyé depuis mon GT-I9100 avec Tapatalk
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #50
Oui
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #51
Fais les wipe data dans ce cas

Envoyé depuis mon GT-I9100 avec Tapatalk
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #52
Merci pour les réponses.

J’ai fait un Wipe data un Wipe cache et un Wipe Dalvik cache ont mais en vain.Le mode download et recovery sont toujours accessibles.
Le problème est également qu’il n’est pas reconnu par Odin ni par le PC (périphérique USB non reconnu)
J’ai supprimé KIES puis téléchargé de nouveau pour les pilotes. Rien à faire. Enfin chargement pilote seul sans Kies.Pas mieux.
Je ne sais plus quoi faire.
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #53
Reset factory

Envoyé depuis mon GT-I9100 avec Tapatalk
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #54
Bonjour

Je l'ai fait.Et rien de plus .Il faut savoir que j'ai fait ces manips à partir de l'écran qui contient les ces infos:
CRM Base Recovery v5.0 .2.7
-reboot system now
-apply update from sdcard
-wipe data /factory reset
-wipe cache partition
etc
Rien à faire
 
YohKenshiro

YohKenshiro

Membres VIP
Inscrit
11 Février 2012
Messages
3 335
Points
0
  • #55
ton téléphone reste bloquer sur le bootanimation, il faut reinstaller la KI3

et quand tu branche ton SII en mode download sur odin, ton pc ne le cherche meme pas juste odin a la case qui devient jaune et ecrit com5 ou un truc du genre avec 5
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #56
Problème réglé.Encore merci pour les conseils.Cela fait plaisir d'avoir des réponses !!!
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #57
Et tu as reapplique le zip pour couper le micro ?

Envoyé depuis mon GT-I9100 avec Tapatalk
 
G

goodbye

Membre
Inscrit
20 Janvier 2012
Messages
15
Points
0
  • #58
Non pas encore.Je vais essayer et je te tiens informé.
 
K

kikou82

Membre
Inscrit
19 Décembre 2011
Messages
16
Points
0
  • #59
Bjr,
Impossible de réinstaller le Phone_mod, depuis mon passage en ics LPQ et Siyah 3.0.1...Reste bloqué sur boot animation du "S". J'ai utilisé les wipes... sans succès.
Le phone.apk fonctionnait très bien quand j'étais en KK5. Si qqun à une solution car j'ai bien sûr de nouveau un gros prob d'échos. Merci d'avance.
 
M

metafizzz

Membre
Inscrit
10 Avril 2012
Messages
2
Points
0
  • #60
salut kikou82 à tu une protection en caoutchouc sur ton S2 si c'est le cas essaye sans, j'avais le même soucis et depuis que j'ai enlevé la protection plus d'écho, tien mois informé.
 
K

kikou82

Membre
Inscrit
19 Décembre 2011
Messages
16
Points
0
  • #61
Merci de ta réponse, j'ai effectivement une housse, qui amplifie l'écho je sais, mais avec le phone.apk j'avais résolu le prob, même avec la housse. Sans housse c'est un peu mieux mais pas parfait... Je voudrais juste pouvoir réinstaller cette appli qui reste la meilleure solution. Merci
 
K

kikou82

Membre
Inscrit
19 Décembre 2011
Messages
16
Points
0
  • #62
Visiblement personne n'a de solution ??
De mon côté, j'ai essayé de lancer le phone.apk avec le CF-root v5 à la place de siyah 3.01 mais rien à faire, toujours bloqué sur bootanimation... c'est pas le kernel, je pense que l'appli ne fonctionne pas sous ICS. D'ailleurs le lien du fichier est mort dans le tuto. Qqun aurait un lien valide ? Merci
 
K

kikou82

Membre
Inscrit
19 Décembre 2011
Messages
16
Points
0
  • #63
Pour ceux qui ont le même problème, je vous conseille d'installer la ROM Custom OMEGA v8 ISC XXLPS, omega-series-v9-0-xxlp4-et-v8-0-xxlps-t14026.html . Avec cette ROM, le micro d'ambiance est désactivé par défaut, donc plus d'écho... même avec une housse silicone.
 
G

gabriel59

Membre
Inscrit
14 Février 2011
Messages
20 148
Points
0
  • #64
Merci pour le retour. J'ai corrigé ton lien qui ne fonctionne pas ;)
 
K

Keratum

Membre
Inscrit
7 Mars 2012
Messages
1
Points
0
  • #65
Salut,

Je voulais savoir si vctgdx avait résolu le problème avec le SAV?
Le problème a t-il bien disparu après un envoie en SAV? Ou le problème est-il revenu malgré les pièces changées?

A vrai dire, je ne tiens pas à rooter mon GSII, mais je ne tiens pas non plus à retirer la coque silicone qui le protège et qui génère ce problème.
 
M

metallman

Membre
Inscrit
28 Avril 2012
Messages
1
Points
1
  • #66
Bonjour;

Je viens d'acheter un Xperia Mini sous android 2.3.4 mais voilà à peine utilisé pendant deux jours, j'ai un problème d'appels, j'entends juste l'écho de ma voix alors que l'interlocuteur n'entend rien, que puis-je faire sachant que je suis dans un coin du monde où le SAV n'existe pas?

Merci d'avance.

NB: A noter que je ne comprends pas vraiment le langage android et que le problème d'écho c'est moi qui le rencontre l'interlocuteur n'entend que dalle.
 
J

Jack90350

Membre
Inscrit
12 Mai 2012
Messages
11
Points
0
  • #67
Salut à tous.

J'ai un SGS2 mais la version G, celle qui est vendue depuis le début de l'année. J'ai le problème d'écho et j'ai essayé d'installer le phone.apk modifié mais il a fait planter mon tel au boot, bloqué sur le S qui scintille. Je l'ai restauré avec CWM mais j'aimerais savoir comment modifier mon propre phone.apk car il est sûrement différent de celui du SGS2 "original".
Merci d'avance.
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #68
Bonjour,Bonsoir.
J'ai également un problème d'écho ...
apparemment mon contact n'entend rien mais moi je m'entend en fond .
J'ai testé le bout de scotch,d'enlevé ma house de protection & rien ... Je n'ai pas envi de testé votre "phone.apk" si ça fait planté mon téléphone.

y'a t-il d'autres soluces qui ont été trouvées entre temps ou pas ?

Merci d'avance .
++ Jokso
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #69
JoKso a dit:
Bonjour,Bonsoir.
J'ai également un problème d'écho ...
apparemment mon contact n'entend rien mais moi je m'entend en fond .
J'ai testé le bout de scotch,d'enlevé ma house de protection & rien ... Je n'ai pas envi de testé votre "phone.apk" si ça fait planté mon téléphone.

y'a t-il d'autres soluces qui ont été trouvées entre temps ou pas ?

Merci d'avance .
++ Jokso

p'tit up :D
 
J

Jack90350

Membre
Inscrit
12 Mai 2012
Messages
11
Points
0
  • #70
JoKso a dit:
Bonjour,Bonsoir.
J'ai également un problème d'écho ...
apparemment mon contact n'entend rien mais moi je m'entend en fond .
J'ai testé le bout de scotch,d'enlevé ma house de protection & rien ... Je n'ai pas envi de testé votre "phone.apk" si ça fait planté mon téléphone.

y'a t-il d'autres soluces qui ont été trouvées entre temps ou pas ?

Merci d'avance .
++ Jokso
Je penses que tu peux tester le phone.apk, il n'a pas marché sur mon tel car j'ai la version G du i9100. Au pire, tu fais une savegarde via CWM avant de remplacer le phone.apk comme ca si ca ne fonctionne pas, tu pourras toujours restaurer ton tel.

Pour ceux qui ont un i9100G comme moi, j'ai trouvé la solution : falsher via CWM ce fichier
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Depuis, plus d'écho grâce à la désactivation permanente du micro anti bruit.
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #71
Jack90350 a dit:
Je penses que tu peux tester le phone.apk, il n'a pas marché sur mon tel car j'ai la version G du i9100. Au pire, tu fais une savegarde via CWM avant de remplacer le phone.apk comme ca si ca ne fonctionne pas, tu pourras toujours restaurer ton tel.

Pour ceux qui ont un i9100G comme moi, j'ai trouvé la solution : falsher via CWM ce fichier
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

Depuis, plus d'écho grâce à la désactivation permanente du micro anti bruit.

Hello Jack,
ça fonctionne pour la version P ton fichier ?
et comment fais-tu une sauvegarde avec CWM ?
merci d'avance.
++ JoKso
 
J

Jack90350

Membre
Inscrit
12 Mai 2012
Messages
11
Points
0
  • #72
A priori, le phone.apk du forum devrait fonctionner car la seule différence c'est le nfc mais pour phone.apk ça devrait pas poser problème.
Pour faire une sauvegarde avec CWM, il faut que ton tu ai CWM d'installé. Pour cela il faut que tu flashe un kernel qui intègre CWM. Je suis sur mon portable là donc plutôt dur de trouver un lien mais tu devrais pouvoir trouver ça sur le forum. pense à prendre un kernel pour i9100p.

Si tu as déjà CWM, tu éteins ton tel.
Volume haut + home + power pour démarrer en recovery mode. Ensuite backup and restore / backup to external sd carr.
Une fois la sauvegarde finie, tu redémarres ton tel puis tu copies sur ton pc le dossier external sd card / clockworkmod

Ensuite, en cas de pb, tu retournes en recovery mode et au lieu de faire backup tu fais restore.

Envoyé depuis mon GT-I9100G avec Tapatalk
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #73
Jack90350 a dit:
A priori, le phone.apk du forum devrait fonctionner car la seule différence c'est le nfc mais pour phone.apk ça devrait pas poser problème.
Pour faire une sauvegarde avec CWM, il faut que ton tu ai CWM d'installé. Pour cela il faut que tu flashe un kernel qui intègre CWM. Je suis sur mon portable là donc plutôt dur de trouver un lien mais tu devrais pouvoir trouver ça sur le forum. pense à prendre un kernel pour i9100p.

Ok mais j'ai déjà "CWM" ainsi que "Super User"le phone.apk j'le trouve plus c'est fou !! J'suis tombé dessus l'autre fois & j'le trouve plus ...
 
J

Jack90350

Membre
Inscrit
12 Mai 2012
Messages
11
Points
0
  • #74
JoKso a dit:
Jack90350 a dit:
A priori, le phone.apk du forum devrait fonctionner car la seule différence c'est le nfc mais pour phone.apk ça devrait pas poser problème.
Pour faire une sauvegarde avec CWM, il faut que ton tu ai CWM d'installé. Pour cela il faut que tu flashe un kernel qui intègre CWM. Je suis sur mon portable là donc plutôt dur de trouver un lien mais tu devrais pouvoir trouver ça sur le forum. pense à prendre un kernel pour i9100p.

Ok mais j'ai déjà "CWM" ainsi que "Super User"le phone.apk j'le trouve plus c'est fou !! J'suis tombé dessus l'autre fois & j'le trouve plus ...



celui que tu dois remplacer se trouve dans system/app , utilises root explorer pour y accéder
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #75
Jack90350 a dit:
celui que tu dois remplacer se trouve dans system/app , utilises root explorer pour y accéder

Merci bien Jack c'est good !
Comment fais-tu une sauvegarde avec CWM ?
merci d'avance .
++ JoKso
 
J

Jack90350

Membre
Inscrit
12 Mai 2012
Messages
11
Points
0
  • #76
JoKso a dit:
Jack90350 a dit:
celui que tu dois remplacer se trouve dans system/app , utilises root explorer pour y accéder

Merci bien Jack c'est good !
Comment fais-tu une sauvegarde avec CWM ?
merci d'avance .
++ JoKso

tu éteins ton tel.
Volume haut + home + power pour démarrer en recovery mode. Ensuite backup and restore / backup to external sd carr.
Une fois la sauvegarde finie, tu redémarres ton tel puis tu copies sur ton pc le dossier external sd card / clockworkmod

Ensuite, en cas de pb, tu retournes en recovery mode et au lieu de faire backup tu fais restore.

Envoyé depuis mon GT-I9100G avec Tapatalk
 
J

JoKso

Membre
Inscrit
26 Avril 2012
Messages
125
Points
0
  • #77
Jack90350 a dit:
tu éteins ton tel.
Volume haut + home + power pour démarrer en recovery mode. Ensuite backup and restore / backup to external sd carr.
Une fois la sauvegarde finie, tu redémarres ton tel puis tu copies sur ton pc le dossier external sd card / clockworkmod

Ensuite, en cas de pb, tu retournes en recovery mode et au lieu de faire backup tu fais restore.

re jack, Ok c'est noté je testerai ça demain j'ai fais 1 copier coller de ce que tu m'as dis pour le garder de coté au cas ou :D
merci pour tes réponses rapides .

EDIT :

C'est bon j'ai tester mais ça ne fonctionne pas .. j'ai bien remplacer le fichier ça a fait 1 mini reboot il n'a pas bloké mais quand quelqu'un m'apelle j'ai un message " désolé com.android.phone va se fermer" & je ne peu pas décrocher ... donc restore obligé..
Merci quand même pour l'astuce mais si il y en a une autre je suis preneur !
++ Jokso
 
spounky

spounky

Membre
Inscrit
25 Août 2011
Messages
42
Points
0
  • #78
Salut à tous...
Patch installé sur une ROM Batista70 FOXHOUND 3.0 WIPE XWKL1 2.3.6 et tout marche nickel !!!! tongue
Vachement content, surtout que c'est sur le téléphone de ma femme et que j'en avais marre de m'entendre en écho !!!! lool
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #79
Bonsoir à tous, avant de me lancer dans un flash de ma rom gingerbread...

Petite question qui me démange... est ce que certains ont utilisé le patch sur une version ICS ? officielle ? custom ?

Sinon connaissez vous des versions qui intègrent par défaut le micro d'ambiance désactivé ?

Merci pour les retours
 
E

Elemental

Membre
Inscrit
15 Décembre 2011
Messages
97
Points
6
  • #80
Je sais que la CyanogenMod9(ROM ICS donc) désactive par défaut le micro d'ambiance.

Je sais aussi que c'est pareil pour les TurbkeyRom.

Donc, si ça t'arrange de passer sous ces ROMs là, lance toi ;)
 
A

alextit

Membre
Inscrit
17 Février 2012
Messages
136
Points
16
  • #81
Merci. Mais ma question datait...
Depuis je suis passé sous ICS en rom stock 4.0.3
Il n'y a plus de souci d'écho sous ics même avec le micro d'ambiance activé
Mais merci quand même
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #82
Bonjour
J ai également ce pb. On m à conseille ce tuto mais le lien pour le fichier mod est mort. Connaissez vous un autre lien s il vous plait.
Merci par avance
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #83
Il semblerait effectivement que le lien et mort. J'ai bien le fichier sur le pc je vais essayer de vous le mettre en ligne.
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #84
Merci beaucoup c est très gentil
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #85
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #86
re
merci beaucoup
je viens d essayer mais le tel reste bloqué au démarrage sur le S de samsung galaxy s2
je n y connait absolument rien c est pour ça que je voulais enlever le root :(
j ai vu dans les messages precedents que c etait arrive mais ils parlent de wispe ou autre ... je ne sais pas du tout ce que c est ... je suis completement perdue .. j ai besoin d aide svp
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #87
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #88
heu ça veut dire qu il faut que je reinstalle mon portable ?
franchement merci pour ton aide
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #89
Normalement si tu éteint ton tel et que tu le rallume en appuyant en même temps sur le bouton power + home (celui qui est en bas de l écran) + volume haut tu vas tomber dans le mode recovery et la il y a wipe cache et ds avanced il y a wipe davilk cache tu fais les deux et tu fais reboot pour voir si il redemarre.
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #90
ok
bon ben je viens de faire et toujours pareil snif snif
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #91
Sort la batterie et recommence
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #92
pareil
la j ai fait ça root-rooter-son-samsung-galaxy-2-ii-t910.html j ai pris la premiere solution ... ça
1/ Télécharger le Kernel .tar.
2/ Ouvrir Odin, sous Windows Vista et Windows 7, il faut l'exécuter en tant qu'administrateur.
3/ Dans PDA, mettre le fichier .tar.
4/ Démarrer le Samsung Galaxy S II en mode download (volume bas + home + power puis volume haut).
5/ Brancher le smartphone au PC. La première case de Odin doit devenir jaune (mobile reconnu).
6/ Ne pas cocher Repartition!
7/ Cliquer sur Start et laisser le mobile se rallumer.

et la mon portable reste sur le premier ecran avec le point d exclamation
je crois que la c est mort
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #93
Indique ta signature. Et poste sur l autre tuto. Merci
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #94
heu lol c est quoi ?
je t ai dit je n y connait absolument rien et je me retrouve avec tout ça ...
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #95
Signature :
. version de ton tel
. Kernel
....
 
A

alyia64

Membre
Inscrit
30 Novembre 2012
Messages
17
Points
0
  • #96
re
alors ça y est j ai enfin reussit a le faire refonctionner ! le fichier kernel.tar n etait pas bon et j en ai pris 1 autre et ça fonctionne tres bien et le son nickel
merci beaucoup encore pour ton aide c est tres tres sympa
bonne soiree
 
Math

Math

Membre
Inscrit
17 Mars 2011
Messages
13 036
Points
0
  • #97
De rien. :grin:
 
K

karimmw

Membre
Inscrit
13 Mars 2013
Messages
1
Points
0
  • #98
Math a dit:
Signature :
. version de ton tel
. Kernel
....


le lien pour le fichier et supprimer :(
 
A

alexinet

Membre
Inscrit
19 Mars 2013
Messages
1
Points
0
  • #99
bonjour tout le monde,
quelqu'un peut mettre à dispo le fichier ZIP pour désactiver le micro d'ambiance?
merci pour votre aide
bonne jourrnée
 
S

smith5945

Membre
Inscrit
7 Février 2012
Messages
148
Points
0
  • #100
Hello,

Jelly bean et les dernière version android n'ont toujours pas réglé ce soucis en pouvant le désactiver par défaut?

Il faut encore mettre une custom ROM?
 
Haut Bas