[Tuto] 4 manières de flasher un kernel custom sur un xperia

Souleymane

Souleymane

Modérateur de secteur
Inscrit
15 Janvier 2012
Messages
7 268
Points
0
Salut, l'accès au recovery ne fonctionne pas sur les dernières CM.
Essaie d'installer le kernel de FXP 303 ou 308 et tu auras accès au recovery et tu pourras installer la rom.
Mais vu que là tu y es déjà il faut que tu installes le kernel FXP lié à la version que tu as et peut-être que le Wi-Fi sera de retour.
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 552
Points
38
Re,

Etrange tout ça, c'est donc la même rom que tu n'arrivais pas à installer au départ que tu as réussi à flasher ?

Pour le Wifi je t'invite à re-poster la question à la suite du tuto d'installation :)
 
E

eye-q

Membre
Inscrit
24 Juillet 2013
Messages
12
Points
0
oui j'avais installé le kernel mais comme je n'arrivais pas à acceder au recovery impossible de flasher... je vais tenter de reinstaller un kernel plus ancien je vous dis "quoi" !!
 
N

noish97

Membre
Inscrit
8 Mai 2012
Messages
20
Points
0
Bonjour, j'ai voulu installer la rom cyanogenMod 11 officiel pour Xperia Sp après avoir fait les sauvegarde rooté, déverrouillé je me lancée à l'eau et je flash le kernel le plus récent et là je redemarre mais il me marque sony mais écran noir par la suite. Peut-être j'ai fais le con j'ai pas copié avant la rom et les Gapps sur ma carte SD avant de flasher le kernel mais je n'ai pas de mode recovery quand j'appuie sur le bouton +. Et je dois l'éteindre en mode urgence sinon il reste allumé.
 
N

noish97

Membre
Inscrit
8 Mai 2012
Messages
20
Points
0
Dsl mais j'ai trouvé ma réponse sur les autres pages j'avais un vieux téléphone et jai copié les fichier en mettant sur ma carte micro SD et après j'ai enfin compris la manip pour entre dans le recovery.
 
J

john30420

Membre
Inscrit
17 Février 2015
Messages
2
Points
0
Bonsoir, petite question qui pourrais m'aider a flasher le kernel:

Voila je suit les manipulations indiquées j'éteins mon téléphone et le met en mode fastboot (voyant bleu fixe allumé comme témoin), dans les 4 méthodes mon téléphone n'est pas considéré comme étant en fastboot mode...
HELP Please!!!!

ps: j'ai déja rooter le téléphone, et il contient la rom de base ( je souhaitais flasher le kernel pour installer cyanogen mod 10.2 ^^)

Par avance Merci !!! =)
 
P

pep_ka

Membre
Inscrit
24 Février 2015
Messages
1
Points
1
Bonjour à Tous

J'essaye de télécharger le kernel elixer mais je tombe toujours sur un fichier "boot.img.exe".
Mon antivirus le prends pour un virus...
Je peux le télécharger, mais ma question est le .exe n'est pas pris par flashtool !!!
Donc soit le fichier est réellement un virus soit j'ai loupé qq'chose.

Si qq'un pouvait m'aider en m'envoyant en MP le kernel pour xperia m (C1905)

Merci d'avance

Alex
 
J

john30420

Membre
Inscrit
17 Février 2015
Messages
2
Points
0
Bonjour, j'ai résolu mon problème.

effectivement il s'agissait d'un problème de pilote que win 8 me bloquais, j'ai donc suivi un très bon tuto sur ce site pour pourvoir autoriser l'installation de ceux ci .
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 552
Points
38
Salut,

Merci pour le partage, je n'en avais pas entendu parler.

Mais à première vue il offre déjà les mêmes fonctions que QuickIMG, et se base sur les mêmes commandes. Il n'est donc pas indispensable que l'on ait un tutoriel dessus, mais si tu es intéressé n'hésite pas à en écrire un toi-même :)

A bientôt sur le fofo !
 
L

lemaroc1

Membre
Inscrit
3 Mai 2015
Messages
5
Points
0
OK alors
Je vais faire un prochain post dessus et tu pourra mettre un lien de redirection sur la première page
 
G

gastonix

Membre
Inscrit
8 Janvier 2015
Messages
44
Points
6
Bonjour,


Mon xperia sp me fait un drôle de truc, si je reste appuyé sur la touche power le logo SONY apparait et avant de disparaitre j'ai droit à 3 cocktails de couleurs avant que la led devienne bleue pendant une minute. Après ce long moment en bleu, la led s'éteind puis revoilà les 3 cocktails de couleurs et la led bleue qui fait fait cette fois que clignoter. Ensuite j'arrive sur un recovery tactile ou je peux que :

-reboot system now

-apply update

-wipe data/factory reset

-wipe cache partition

-wipe media

-reboot to bootloader

-power down

-view recovery logs

Si j'appuie sur reboot system now, ça refait la même chose qu'au début

Si je branche le tèl sur l'ordi, le logo sony apparait accompagné de sa led rouge (témoin de charge) mais le logo sony disparait et la led aussi et c'est reparti pour un tour :-|

je vais essayer de flasher un autre kernel :?

Me conseillez vous de faire autre chose ?
 
L

lmonkeyd6

Membre
Inscrit
23 Août 2014
Messages
3
Points
1
Bonjour,
J'ai un problème lors du flash du kernel sur Flashtool c'est à dire qu'il me met : "10/023/2016 17:23:55 - INFO - Selected kernel (boot.img or kernel.sin): C:\Users\DeathMask\Desktop\QuikIMG\images\twrp-3.0.0-1-bacon.img" puis "10/023/2016 17:23:55 - INFO - Flashing selected kernel" et plus rien il reste bloqué figé ... Et je suis bien en fastboost mode.
Mon tel : Xperia SP
Numéro de build : 12.1.A0.266
 
Joe

Joe

Moderateur Global
Inscrit
23 Juillet 2011
Messages
17 552
Points
38
Salut,

Est-ce que tu as essayé de changer le port USB utilisé ?

Aussi, est-ce que FlashTool te sortait la même erreur avec d'autres kernels ?
 
S

Samikaze

Membre
Inscrit
8 Juillet 2016
Messages
4
Points
0
Bonsoir, en voulant flasher le kernel (boot.img pour Cyanogen mod 11), j'ai branché mon Xperia SP en fastboot mode (LED bleu) et j'ai flashé boot.img avec Quickimg le processus s'est correctement terminé mais maintenant mon téléphone ne s'allume plus et reste figé sur un écran noir :-| :roll: , la led ne s'allume plus depuis, j'ai tenté le hard reboot et le pc ne détecte plus le téléphone... :?
Je pense bien qu'il est foutu mais je demande quand même, on sait jamais :smile:
EDIT : j'ai fini par réussir en accédant au recovery merci pour le tuto!
 
E

elaeoth

Membre
Inscrit
3 Février 2017
Messages
1
Points
0
Bonjour,
Déjà, merci pour ces tutos.
Mon téléphone est un sony xperia Z3 compact, j'ai dévérouillé le bootloader, mais j'ai un problème, après avoir suivi ce tuto installer-le-recovery-twrp-root-xperia-z3-d6603-bl-deverrouilles-t101909.html j'ai entré la dernière invite de commande "fastboot reboot", mais mon téléphone n'a pas redémarré. A la place, une led rouge s'est allumé brièvement, puis l'ecran s'est allumé et la led est devenue verte, mais l'écran s'est reéteint, la led rouge est revenue, puis s'est rallumé avec la led verte, et a continué comme ça (avec deux vibrations à chaque fois que l'écran s'allumait)

J'ai essayé d'autres kernel du tuto , mais pareil, le téléphone n'a pas démarré, maintenant, à chaque fois que je met un kernel, la led fait une couleur (rose-violet, jaune...), puis l'écran s'allume, la led s'éteint et plus rien ne bouge... Je l'éteins en appuyant sur marche/arrêt, volume up et volume down en même temps et le relance en fastboot mode.... J'ai essayé plusieurs kernels, du tuto mais aussi celui-ci
Vous n'avez pas la permission de voir ce lien Connectez-vous ou inscrivez-vous dès maintenant.
mais aucun ne marche ... J'ai aussi essayé d'installer ces kernels en utilisant flashtool, mais ça ne marche pas...

Auriez-vous une idée?
 

Haut Bas