[Résolu] Gérer la compatibilité avec les appareils

  • Auteur de la discussion p4nzer
  • Date de début
P

p4nzer

Membre
Inscrit
7 Août 2014
Messages
5
Points
0
#1
Bonjour,

Je développe une application Android avec windev pour mon travail. J'ai mis en ligne hier la dernière mise à jour et je me suis rendu compte après coup que la tablette que nous offrons à nos clients avec cette application, n'est plus compatible sur le playstore (alors que si j'installe directement l'app sur la tablette sans passer par le playstore, cette dernière fonctionne parfaitement...).



Comment puis-je déterminer ce qui fait que cette tablette soit "incompatible" avec mon application pour que je puisse du coup y remédier ?

Merci
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 884
Points
38
#2
Re: Gérer la compatibilité avec les appareils

Salut,

regarde dans ton manifest.xml tu devrais voir une balise <uses-sdk> avec en attribut la version minimum.
Si non, rajoute le.
 
P

p4nzer

Membre
Inscrit
7 Août 2014
Messages
5
Points
0
#3
Re: Gérer la compatibilité avec les appareils

Bonjour Valentin, merci pour ta réponse.

Dans mon AndroidManifest.xml, j'ai effectivement cette ligne là :
Code:
<uses-sdk
        android:minSdkVersion="18"
        android:targetSdkVersion="24" />
Ma tablette est en Android 4.4.4, mais je ne sais pas comment voir la version du SDK qu'elle utilise...

Merci
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 884
Points
38
#4
Re: Gérer la compatibilité avec les appareils

Dans le "minSdkVersion" remplace 18 par 14 et renvoie l'apk sur le Play Store afin de voir si tu peux la télécharger sur ton appareil.
 
P

p4nzer

Membre
Inscrit
7 Août 2014
Messages
5
Points
0
#5
Re: Gérer la compatibilité avec les appareils

Bonjour, c'est fait, cela ne règle pas mon problème malheureusement... :/

Question, puis-je reprendre le manifeste de mon ancienne version et le copier tel quel dans ma nouvelle version ? Mais je pense que cela risque de poser des problèmes au niveau des autorisations, etc... :?
 
P

p4nzer

Membre
Inscrit
7 Août 2014
Messages
5
Points
0
#6
Re: Gérer la compatibilité avec les appareils

Re,

Ok c'est bon, c'était un problème dans les permissions et les fonctionnalités de l'application.

Merci pour ton aide Valentin :)
 
Valentin

Valentin

Moderateur Global
Inscrit
20 Février 2013
Messages
10 884
Points
38
#7
Re: Gérer la compatibilité avec les appareils

Content pour toi dans ce cas :wink:

Ce n'était pas dans le Manifest ? Comment as tu fait ?
 
Haut Bas