Problème flashtool

L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
Bonjour,

J'ai récemment acheté sur internet le XZ en version dual, comme il d'agit d'un import et du modèle fournit avec la rom customized de hong-Kong j'aimerai le basculer sur la rom Customized FR. Hors lorsque je j'utilise flashtool comme j'en avais l'habitude avec mon Z2 j'ai ce message d'erreur qui apparaît:
14/013/2017 13:13:51 - WARN - No loader found or set manually. Skipping loader

J'aimerai donc savoir que faire, merci d'avance pour toute réponse
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Salut,

Sûrement un problème avec le x10flasher.jar et la prise en charge du XZ...

S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
, colle-le dans C:\Flashtool, écrase l'ancien x10flasher par le nouveau et re-test.
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
ok, je vais essayer pourtant le x10 est bien le dernier dispo (celui de la maj de flashtool a faire manuellement)

Edit : ça ne vient pas de ça, je pense que le problème vient du fait qu'il s'agit d'un dual sim et non du modèle de base, pourtant c'est bien la rom du dual sim que j'ai téléchargée
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Lumos a dit:
ça ne vient pas de ça, je pense que le problème vient du fait qu'il s'agit d'un dual sim et non du modèle de base, pourtant c'est bien la rom du dual sim que j'ai téléchargée
Je ne crois pas que ce soit lié. Le problème ne vient ni du téléphone, ni du firmware, mais bel et bien de Flashtool et d'éventuellement son paramétrage.

Si le x10flasher est bon, c'est sûrement un problème de pilotes. D'ailleurs, je crois me souvenir qu'ils ne sont pas disponible dans l'exe fourni avec Flashtool (mais je me trompe peut-être).

Ceux du XZ (uniques, ils sont valables pour tous les modèles de XZ, soit le F8331/ F8332/ SO-01J/ 601SO/ SOV34) sont installés ? Si non, tu peux les récupérer sur
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
.
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
C'est déjà fait mais j'arrive pas a les installer et pourtant y a rien de plus simple en temps normal
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Ah ah ! Donc il est là, le problème !

As-tu désactivé la vérification de la signature des pilotes de ton PC ? Car ce sont des pilotes non-signés.

Si tu n'y arrives toujours pas malgré ça, et bien essaye avec un autre PC.
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
j'ai pas pensé à ça effectivement, je vais essayer du coup
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
je sais pas si ça vient du fait qu'il soit pas signer mais il met impossible de les installer le gestionnaire de périph détecte pas les pilotes quand j'essaye l'install manuelle
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Hello hello pour tes drivers adb tu peux utilisé ce petit lien
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
, en ce qui concerne ton message de warning, il t'indique juste qu'il n'y a pas de fsc présent dans les documents flashtool pour ton DEVICE, je pense a vrai dire j'ai également ce message et je l'avais aussi hier de deverouillant mon bootloader. Mon XZ ce porte bien lol. Il me faudrai savoir ce que tu tu as après ton warning, genre sa par exemple : 22/032/2016 12:32:48 - INFO - Parsing boot delivery
22/032/2016 12:32:48 - INFO - No flash script found.
22/032/2016 12:32:48 - INFO - Flash script is mandatory. Closing session
22/032/2016 12:32:48 - INFO - Ending flash session

La sa changerais tout et tu serai dans l'incapacité de flashé une rom 7.1 Tu peux également voir si ton flashtool est à jour mais pour te rassurer le mien l'es à j'ai le même message de warning que toi.
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
il est a jour, pour une raison étrange (j'ai du faire un peu trop de menage un jour) il était plus installé. Je l'ai donc installé mais la il crashait lors de la decompilation de la rom via xperifirm (bundler create) donc j'ai téléchargé le x10 à jour via le site du dev, mais maintenant c'est le flash qui merde.

Pour les pilotes adb j'ai déjà essayer mais j'arrive pas à utilisé le nouvel installateur, en gros il capte pas mon telephone.

Pour flashtool voici le log complet lors de l'essaye de flash:

15/041/2017 10:41:47 - INFO - Flashtool Version 0.9.23.2 built on 19-01-2017 21:50:00
15/041/2017 10:41:47 - INFO - Executing search strategies to find proxy selector
15/041/2017 10:41:47 - INFO - No proxy found for IE. Trying next one
15/041/2017 10:41:47 - INFO - Strategy firefox failed trying next one : No Firefox installation found
15/041/2017 10:41:47 - INFO - No proxy found for java. Trying next one
15/041/2017 10:41:47 - INFO - Syncing devices from github
15/041/2017 10:41:47 - INFO - Opening devices repository.
15/041/2017 10:41:47 - INFO - Scanning devices folder for changes.
15/041/2017 10:41:54 - INFO - Pulling changes from github.
15/041/2017 10:41:55 - INFO - Quietly closing devices repository.
15/041/2017 10:41:55 - INFO - Devices sync finished.
15/041/2017 10:41:55 - INFO - Loading devices database
15/041/2017 10:41:55 - INFO - Loaded 97 devices
15/041/2017 10:41:55 - INFO - Starting phone detection
15/041/2017 10:41:59 - INFO - Device disconnected
15/042/2017 10:42:26 - INFO - Device connected with USB debugging off
15/042/2017 10:42:26 - INFO - For 2011 devices line, be sure you are not in MTP mode
15/042/2017 10:42:28 - INFO - Device disconnected
15/042/2017 10:42:29 - INFO - Device connected with USB debugging off
15/042/2017 10:42:29 - INFO - For 2011 devices line, be sure you are not in MTP mode
15/045/2017 10:45:50 - INFO - Device disconnected
15/045/2017 10:45:57 - INFO - Selected Bundle for Sony Xperia XZ(F8332). FW release : 41.2.A.2.223. Customization : Customized FR
15/045/2017 10:45:57 - INFO - Preparing files for flashing
15/046/2017 10:46:52 - INFO - Please connect your device into flashmode.
15/047/2017 10:47:10 - INFO - Device connected in flash mode
15/047/2017 10:47:10 - INFO - Opening device for R/W
15/047/2017 10:47:10 - INFO - Reading device information
15/047/2017 10:47:10 - INFO - Phone ready for flashmode operations.
15/047/2017 10:47:10 - INFO - Opening TA partition 2
15/047/2017 10:47:10 - INFO - Current device : F8332 - CB512DS3LQ - 1305-2218_R10C - 1302-9162_39.2.A.0.417 - GENERIC_39.2.A.0.417
15/047/2017 10:47:10 - INFO - Closing TA partition
15/047/2017 10:47:10 - INFO - Start Flashing
15/047/2017 10:47:10 - INFO - No loader in the bundle. Searching for one
15/047/2017 10:47:10 - INFO - No matching loader found
15/047/2017 10:47:10 - WARN - No loader found or set manually. Skipping loader
15/047/2017 10:47:10 - INFO - Loader : S1_Root_de8d - Version : 1299-4832_S1_Boot_MSM8996_LA2.0_N_110 / Boot version : 1299-4832_S1_Boot_MSM8996_LA2.0_N_110 / Bootloader status : ROOTABLE
15/047/2017 10:47:10 - INFO - Max packet size set to 4M
15/047/2017 10:47:10 - INFO - USB buffer size set to 512K
15/047/2017 10:47:13 - INFO - Parsing boot delivery
15/047/2017 10:47:13 - INFO - No flash script found.
15/047/2017 10:47:13 - INFO - Flash script is mandatory. Closing session
15/047/2017 10:47:13 - INFO - Ending flash session
15/047/2017 10:47:13 - INFO - Flashing finished.
15/047/2017 10:47:13 - INFO - Please unplug and start your phone
15/047/2017 10:47:13 - INFO - For flashtool, Unknown Sources and Debugging must be checked in phone settings
15/047/2017 10:47:13 - INFO - Device connected in flash mode
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Je me permets de t'envoyer vers ce sujet
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


Aussi n'oublie pas d'activer ton déboguage usb, dans option développeur (taper plusieurs fois sur numéro de Build dans réglage> à propos du téléphone pour faire apparaître l'option )
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
Merci, grace à vous deux, je crois que j'ai reussi, le flash est en cours cette fois-ci.
J'ai juste ça comme erreur:
15/057/2017 13:57:16 - WARN - Qnovo is excluded from bundle
15/057/2017 13:57:18 - WARN - persist is excluded from bundle
15/057/2017 13:57:12 - WARN - apps_log is excluded from bundle
15/057/2017 13:57:12 - WARN - diag is excluded from bundle
15/057/2017 13:57:12 - WARN - ssd is excluded from bundle
le seul problème c'est que j'ignore de quoi il s'agit
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
Bon je vous confirme que le flash c'est bien passé, je suis bien en version française et sous 7.1.1 et plus 7.0 comme avant
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
C'est tout ce qui a été exclu de ta rom cela dépend des roms je pense...

Admin :amen: si tu me lis faudra faire un tuto de mon tuto :super:
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Bonjour ?

Dorynous a dit:
C'est tout ce qui a été exclu de ta rom cela dépend des roms je pense...

Admin :amen: si tu me lis faudra faire un tuto de mon tuto :super:
Tu sais, il n'y a pas que les admins et les modos qui peuvent faire les tutos... Tu peux faire un tuto de ton propre tuto aussi :wink:
Je peux éventuellement t'aider à la mise en page et autres, si tu le souhaites.
 
L

Lumos

Membre
Inscrit
21 Septembre 2012
Messages
9
Points
1
En tout cas votre tuto ma été utile
 
A

antoboy32

Membre
Inscrit
4 Avril 2014
Messages
28
Points
0
Salut a tous,

J'ai un soucis avec flashtool, je n'arrive pas a compiler ma ROM a partir des fichiers de XPERIAFIRM ! Avant je le faisais sans soucis pour mon Z3, mais depuis que j'ai le XZ... pas reussi !

Avec la dernière version de flashtool, quand je clique sur CREATE, flashtool plante. Et avec une ancienne version, la création se fait jusqu'au fichier loader.sin et puis ça tourne dans le vide....

Une idée ?
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Essayer avec un autre pc ou réinstaller FT.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
antoboy32 a dit:
J'ai un soucis avec flashtool, je n'arrive pas a compiler ma ROM a partir des fichiers de XPERIAFIRM !
Salut,

Tu as quelle version de Flashtool ?
 
Goldo 62

Goldo 62

Membre
Inscrit
29 Janvier 2012
Messages
1 460
Points
36
Salut à tous,
Voilà mon soucis,
J'ai fait l'acquisition du Sony Xperia XZ Premium via la boutique Orange. Comme vous vous doutez il possède une rom stock orange, et je voudrais passer en rom nue. J'ai donc téléchargé la dernière customized fr via xperifirm et tenté de l'installer via flash tool.
Mais je bloque au niveau du passage en mode flash du téléphone c'est à dire au moment où il faut débrancher et re branché avec la touche vol bas appuyée.
Qd je fais la manipulation rien ne se passe....
J'ai lu sur XDA-Developers qu'il fallait un script pour pouvoir flash. Si quelqu'un avait des informations ?
Pour information tout est OK au niveau des pilotes et de flash tool.
Est ce que quelqu'un a le même problème ?
Merci pour vos réponses.
En espérant ne pas avoir été trop long dans mes explications...
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Goldo 62 a dit:
Salut à tous,
Voilà mon soucis,
J'ai fait l'acquisition du Sony Xperia XZ Premium via la boutique Orange. Comme vous vous doutez il possède une rom stock orange, et je voudrais passer en rom nue. J'ai donc téléchargé la dernière customized fr via xperifirm et tenté de l'installer via flash tool.
Mais je bloque au niveau du passage en mode flash du téléphone c'est à dire au moment où il faut débrancher et re branché avec la touche vol bas appuyée.
Qd je fais la manipulation rien ne se passe....
J'ai lu sur XDA-Developers qu'il fallait un script pour pouvoir flash. Si quelqu'un avait des informations ?
Pour information tout est OK au niveau des pilotes et de flash tool.
Est ce que quelqu'un a le même problème ?
Merci pour vos réponses.
En espérant ne pas avoir été trop long dans mes explications...

Deuxieme parti de ce tuto :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
a parti de ...
En cas d’erreur : No Loader Found / FSC Script is mendatory - ou erreur lié au Bundle ...
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
ton script fsc devrais ce trouver dans cette liste
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !

41.fsc pour XZpremium G82XX normalement
 
S

Stom

Membre
Inscrit
28 Juillet 2012
Messages
101
Points
16
Bonjour a toi aussi j'ai le même soucis que toi la manipulation ne fonctionne pas du moins la fenêtre reste toujours activer mais je vois sur un autre post mais rien ne se passe :( alors je sais plus quoi faire et vu que je suis nouveau sur le robot vert sincèrement pour les manipulations de Flashage c'est beaucoup plus facile sur Windows mobile mais je veux persister aussi pour avoir comme toi un Sony sans couche opérateur
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Salut Storm que dis ta fenetre Flashtool ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Salut,

Je vous arrête tout de suite :

Stom à déjà ouvert un sujet ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
, alors merci de continuer là-bas, ça évitera d'avoir la tête à différents endroits et se perdre.

D'ailleurs @Dorynous, ton aide sera vraiment la bienvenue parce moi et les XZ...
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Hello hello je suis la et je part de suite vers le nouveau sujet :) préparé vos questions et votre config
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
14 717
Points
113
Merci à toi :super:
 
Goldo 62

Goldo 62

Membre
Inscrit
29 Janvier 2012
Messages
1 460
Points
36
Salut à tous, si je pige bien, ma question passe à l'as.... Lol [GRINNING FACE WITH SMILING EYES]
Pourtant c'est bien un problème de flash tool puisque apparemment il faut créer un script...
Merci pour vos réponses
 
D

Dorynous

Membre
Inscrit
27 Février 2015
Messages
106
Points
18
Oui ce problème est lié a flashtool mais n'empeche rien car si tu ouvre ton dossier C:\Users\...\.flashTool\devices tu y verra différent devices avec leurs fsc propres ,
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
.

Pour flashé assure toi de créé ta rom en y insérant le script propre a ton téléphone.

Pour répondre a ta question envoie ton Log flashtool si possible.
 
Goldo 62

Goldo 62

Membre
Inscrit
29 Janvier 2012
Messages
1 460
Points
36
Ok merci pour la réponse
 
A

aatioua

Membre
Inscrit
2 Avril 2015
Messages
3
Points
1
merci vraiment c’était problème de signature des pilotes.
 
M

Mathiou97200

Membre
Inscrit
7 Décembre 2012
Messages
42
Points
6
Bonjour, je vous écrit car j'ai un souci avec flashtool et mon Xperia XZ, je voudrais flasher une rom stock Nougat mais flashtoll ne veut jamais, voici le log que j'obtiens
23/038/2018 01:38:52 - INFO - Flashtool Version 0.9.18.6 built on 30-05-2015 22:30:00
23/038/2018 01:38:52 - INFO - Executing search strategies to find proxy selector
23/038/2018 01:38:52 - INFO - No proxy found for IE. Trying next one
23/038/2018 01:38:52 - INFO - Strategy firefox failed trying next one : No Firefox installation found
23/038/2018 01:38:52 - INFO - No proxy found for java. Trying next one
23/039/2018 01:39:48 - INFO - Syncing devices from github
23/039/2018 01:39:48 - INFO - Scanning devices folder for changes.
23/039/2018 01:39:53 - INFO - Pulling changes from github.
23/039/2018 01:39:53 - INFO - Devices sync finished.
23/039/2018 01:39:58 - INFO - Device disconnected
23/040/2018 01:40:26 - INFO - Selected null
23/040/2018 01:40:26 - INFO - Flash canceled
23/040/2018 01:40:48 - ERROR - root : this bundle is not valid
23/040/2018 01:40:48 - INFO - Selected Bundle for Sony Xperia XZ (F8331). FW release : 41.2.A.7.8_R2D. Customization : Customized AU
23/040/2018 01:40:48 - INFO - Preparing files for flashing
23/042/2018 01:42:21 - INFO - Please connect your device into flashmode.
23/042/2018 01:42:38 - INFO - Device connected in flash mode
23/042/2018 01:42:38 - INFO - Opening device for R/W
23/042/2018 01:42:38 - INFO - Reading device information
23/042/2018 01:42:38 - INFO - Phone ready for flashmode operations.
23/042/2018 01:42:39 - INFO - Current device : F8331 - CB512FAHJK - 1305-5167_R3E - 1302-9157_41.3.A.2.75 - GENERIC_41.3.A.2.75
23/042/2018 01:42:39 - INFO - Start Flashing
23/042/2018 01:42:39 - ERROR - root : this bundle is not valid
23/042/2018 01:42:39 - INFO - Ending flash session
23/042/2018 01:42:39 - ERROR - C:\Flashtool\devices\F83XX\loader.sin (Le fichier spécifié est introuvable)
23/042/2018 01:42:39 - ERROR - Error flashing. Aborted
23/042/2018 01:42:39 - INFO - Device connected in flash mode
23/042/2018 01:42:39 - INFO - Device disconnected
23/042/2018 01:42:45 - INFO - Device connected in flash mode

Il y'a au début le root : this bundle is not valid puis la session de flash est avortée avant d'avoir commencé.. Pourriez-vous m'aider? Merci d'avance
 

Haut Bas