Problème de reconnaissance Pc-->téléphone

K

kirk9176

Membre
Inscrit
5 Janvier 2013
Messages
185
Points
18
Bonjour à tous,
Lorsque je connectais mon Galaxy S5 à mon pc, celui-ci le reconnaissait de suite et je pouvais donc naviguer de mon pc vers mon téléphone et inversement sans problème.
Driver Samsung installés, mode débogage USB activé et sources inconnues également.
Depuis que je l'ai rooté(via un tuto trouvé sur le site), mon téléphone n'est plus reconnu. Je le branche avec le même cordon en bon état mais il ne se passe rien.
Le root a-t-il modifié quelque chose au niveau du téléphone qui fait que je ne puisse plus communiquer entre pc et tel ?
Merci
 
Fred

Fred

Administrateur
Inscrit
19 Juin 2011
Messages
58 059
Points
113
Salut,non le root ne change rien au niveau du pc,sauf si tu passe par le logiciel samsung pour explorer ton tel.
 
K

kirk9176

Membre
Inscrit
5 Janvier 2013
Messages
185
Points
18
Non, je ne passe par aucun logiciel. Le simple fait de raccorder mon tél au pc suffisait. J'avais accès à tout le contenu du tel sur le pc. Je l'ai rooté hier(le root a bien fonctionné(vérifié avec racine checker))et depuis cet instant, je ne peux plus accéder au tél sur le pc. Quand je le branche, il ne se passe plus rien. J'ai le message suivant qui s'affiche sue le téléphone "L'appareil connecté ne peut pas accéder aux données sur cet appareil. Reconnectez le câble USB et réessayez. L'application Android File Transfer ou Samsung Smart Switch doit être installée sur les appareils Mac OS X. Pour télécharger Android file Transfer, accédez à
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
. Pour télécharger Samsung Smart Switch, accédez à
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
."
 
Dernière édition:
Fred

Fred

Administrateur
Inscrit
19 Juin 2011
Messages
58 059
Points
113
Quand tu le branche,déroule le menu de la barre d'état et regarde tes options de débogage usb,tu es peut être en mode "charge usb" et pas en partage de fichiers.
 
K

kirk9176

Membre
Inscrit
5 Janvier 2013
Messages
185
Points
18
Quand tu le branche,déroule le menu de la barre d'état et regarde tes options de débogage usb,tu es peut être en mode "charge usb" et pas en partage de fichiers.
Ben en fait, en dessous du mode débogage usb qui est bien activé, y a "Annuler autorisat. de débogage USB". Quand je clic dessus, ça me met comme message "L'accès au débogage USB a été annulé sur tous les ordinateurs que vous aviez précédemment autorisés". Sauf qu'hormis rooter mon tél, je n'ai rien fait d'autre. Pourquoi est-ce que le mode débogage usb fonctionnait et plus maintenant alors que je n'ai rien changé aux paramètres(et j'ai bien noté que le root n'a rien changé sur cet état ;-) ) ?
Sinon, je ne suis pas en "configuration USB chargement" mais en MTP !
Est-ce que le fait d'avoir laissé cocher "Auto reboot" lors de la procédure du root a-t-il pu avoir une incidence sur mon problème rencontré ?
 
Dernière édition:
L

Lampang

Membre
Inscrit
14 Décembre 2017
Messages
93
Points
8
Bonjour,
Le débogage USB n'a rien à voir avec le fait d'autoriser le mode MTP (partage de fichiers), PTP (appareil photo) ou charge seule. Ce sont deux choses complètement indépendantes et qui ne se configurent pas au même endroit.
Lorsqu'on connecte un ordinateur pour la première fois à un smartphone ayant le débogage USB activé et qu'on lance la commande ADB, il y a un échange de clefs entre le PC et le smartphone et ce dernier demande d'accepter la clef du PC par un popup sur son écran. Clef qu'il garde ensuite, il ne le redemandera pas.
La manipulation faite ci-dessus revient à effacer les clefs précédemment stockées, ce qui obligerait à les revalider si on connectait à nouveau un PC avec ADB.
Le message "L'appareil connecté ne peut pas accéder aux données sur cet appareil...." signifie que le smartphone n'a pas reçu d'acquittement de protocole MTP venant du PC. Il considère donc que celui-ci n'a pas le logiciel correct installé. C'est ce qui se passe quand on branche un smartphone à un PC Linux ou un Mac sans ajouter le logiciel nécessaire. Mais le protocole MTP est natif dans Windows depuis Vista. Je pencherais donc plutôt vers un problème sur le smartphone. Le root modifiant le ramdisk de boot, il n'est pas exclu que quelque chose se soit mal passé et que cela soit la cause. Cela dépend de ce qui a été utilisé pour rooter : Magisk ou autre.
 
Dernière édition:
K

kirk9176

Membre
Inscrit
5 Janvier 2013
Messages
185
Points
18
Ta réponse à l'air complète bien que ce soit un peu du chinois pour moi. Pour rooter, je me suis servi d'un tuto que j'ai trouvé sur le site. Je suis passé par Odin. Ai-je bien coché et/ou décoché tout ce qui était nécessaire et pas "dangereux" ? Je pencherais effectivement pour quelque chose qui ce soit mal passé pendant le root même si celui semble avoir fonctionné "sans problème" d'après ODIN et racine checker pour la vérification.
J'avais déjà eu ce même problème sur mon ancien tel, un S4. Idem, lorsque je le raccordais au pc, celui-ci le détectait de suite et une fois le root effectué, plus rien.
Rebelote avec mon S5. Tel détectait au premier raccordement avec le pc et une fois le root effectué, plus rien.
Je tenterai bien d'enlever le root "proprement" et de réessayer. Tu me conseilles quoi lors de l'opération de root, en plus de ce qu'on peut trouver ici ? Choses à faire, à ne pas faire ?
Si tant est que ce puisse être une solution ?!
Merci
 

Haut Bas