PC linux

  • Auteur de la discussion Grompf2
  • Date de début
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #1
Bonsoir,
J'ai un PC équipé de Linux Mint (Cinnamon 17.3). Je viens d'acheter un Xperia Z5 Compact et je constate qu'il n'y a pas moyen de le connecter à mon PC. Apparemment, ce type de téléphones est prévu ne fonctionner qu'au travers de programmes spécifiques installés sur le PC, programmes qui n'existent pas sous Linux.

Bref, qqn aurait-il une idée pour connecter par câble mes photos du smartphone vers un PC équipé d'Ubuntu ou dérivés ?

Salutations


edit :
En fait, il semblerait que le souci soit sur le PC. Linux Mint Cinnamon semble ne pas reconnaître mon smartphone, alors que Linux Mint Xfce le reconnaît sans problèmes. Donc, je suppose que Linux Mint Cinnamon a de la peine avec le protocole mtp.
Bon, si qqn a une suggestion, je suis preneur...
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #2
Hello,

Cela peut-être dû aux drivers aussi. Peut-être que Linux Mint Xfce a les drivers et pas Linux Mint Cinnamon.

J'ai pu connecté mon S5 mini sous Linux Mint Cinnamon que j'utilise en virtualisation sur mon PC hôte sous Windows 10 Pro en 64 Bits.

Regarde ce que je viens de trouver :

ICI.

J'ai vérifié sur le mien, et je les avais installé pour autre chose.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #3
Sur un site dédié à Linux Mint (Forum Francophone LinuxMint), on m'a parlé d'une fonctionnalité cachée dans le Xperia :
La fonction est "cachée" en standard sous Android 5, il y a juste une petite manip’ à faire pour débloquer :
Paramètres > À propos de l'appareil
Cliquer 7 fois sur "Numéro de version" (un décompte apparaît), puis suivre les indications.
Tu as alors "options de développement" qui s'ajoute au menu des paramètres, il suffit de cocher "débogage USB".
Ça fonctionne pour tous les appareils sous Android 5.x.

Pas besoin d'installer quoi que ce soit sous Android ni sur le PC.

Je n'ai encore pas testé.
Mais en gros il y a 2 pistes :
1. Agir sur le smartphone en activant la fonction stockage de masse. Je vais probablement essayer ça.
2. Agir sur le PC en installant de quoi lire le protocole mtp. Mais je ne vais pas me lancer dans un changement de gestionnaire de fichiers, vu que je n'ai jamais fait ça (et je ne vais pas non plus substituer Mate ou Xfce à Cinnamon). Bon, ben peut-être que les développeurs de Linux Mint on loupé un truc en programmant Cinnamon....

Je vais éviter d'installer des apps supplémentaires sur mon Xperia.
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #4
Pas forcément que les développeurs de Linux Mint est loupé un truc entre les versions Mate, Xfce ou Cinnamon. Car il n'utilise pas le même support comme le KDE ou gnome ou bien d'autres. C'est comme ça que l'on s'aperçoit les avantage et les inconvénients entre les différentes versions de Linux Mint.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #5
J'ai testé la manipulation sur mon Xperia. J'accède bien aux menus indiqués. Mais ça ne sert à rien. Le PC et le smartphone refusent de se parler...
J'ai fait un test avec un Lumia sous WindowsPhone 5.1 : il se connecte, je peux lire les fichiers. Même succès avec un Galaxy SIII sous CyanogenMod 11.
Donc il y a vraiment une incompatibilité entre Mint Cinnamon et mon Xperia sous Android 5.1.1.
...
J'aimerais éviter de faire 36'000 manip que je ne maîtrise pas.
Je vais laisser ça de côté pour l'instant.
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #6
Effectivement.

Tu as une autre solution, le faire en FTP, c'est simple. Je le fais sous Linux Mint et Windows sans malaise.

Il te faut un serveur FTP, il y a des applications sur le Play Store, et ils sont très léger et ne consomme pas de batterie s'il n'est pas lancé, et, Filezilla par exemple sous ton Linux. En gros, tu fais du transfert via le réseau.

Si tu veux tenter, je peux t'expliquer comment faire.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #7
yoanf26 a dit:
Effectivement.

Tu as une autre solution, le faire en FTP, c'est simple. Je le fais sous Linux Mint et Windows sans malaise.

Il te faut un serveur FTP, il y a des applications sur le Play Store, et ils sont très léger et ne consomme pas de batterie s'il n'est pas lancé, et, Filezilla par exemple sous ton Linux. En gros, tu fais du transfert via le réseau.

Si tu veux tenter, je peux t'expliquer comment faire.

Pour l'instant je laisse ça de côté.
Je pense que j'utiliserai mon PC principal pour les photos et tout le reste. Et cette mésaventure me pousse à opter pour Xfce plutôt que Cinnamon.

Merci
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #8
Bon... Ben on dirait bien qu'il y a une incompatibilité entre 2 matériels. Mon Lenovo X220 et mon Sony Xperia Z5 Compact ne s'aiment pas. Point.
J'ai fait les essais suivants :
- Avec un Samsung S4 Mini (Android 4) : pas de problèmes pour accéder au contenu
- Avec un Samsung S5 (Android 5) : au premier essai le téléphone s'affiche avec un message d'erreur; je change de câble USB (j'avais un câble Sony et j'ai mis un câble Samsung) et j'ai pu accéder sans soucis au contenu du téléphone

...
J'ai fait démarrer mon PC depuis un CD live Linux Mint KDE.
- J'ai branché mon Xperia et il ne se passait rien sur l'ordinateur (le téléphone, lui, indique une connexion USB)
- J'ai branché mon Samsung SIII sous CyanogenMod 11 et j'ai pu accéder sans soucis au contenu
- J'ai branché mon Nokia Lumia 925; je n'ai pas pu accéder au contenu, mais le téléphone apparaissait

J'ai fait démarrer mon PC depuis un CD live Xubuntu.
- J'ai branché mon Xperia et il ne se passait rien sur l'ordinateur (le téléphone, lui, indique une connexion USB)
- J'ai branché mon Samsung SIII sous CyanogenMod 11 et j'ai pu accéder sans soucis au contenu
- J'ai branché mon Nokia Lumia 925 et j'ai pu accéder sans soucis au contenu

J'ai branché mon Xperia sur un PC sous Windows Seven et on peut accéder sans soucis au contenu

Un truc m'intrigue
La première fois que j'ai essayé de brancher le Xperia sur mon PC Lenovo sous Linux Mint, le téléphone semble avoir été reconnu : j'ai vu apparaître une icône, l'ordinateur semblait identifier un appareil sur le port USB. Le téléphone a tenté d'installer un pilote. Je ne me rappelle plus ce que j'ai fais précisément. Mais le fait est que ça ne s'est plus jamais reproduit. ?????
Je me suis demandé s'il n'y avait pas eu une fausse manipulation affectant mon système. Mais si c'est le cas, pourquoi le problème se répète en démarrant depuis un CD live ?????


Et je n'ai aucun souci à brancher ce Xperia sur mon mini-PC sous Linux Mint Xfce. Donc il ne doit pas y avoir d'incompatibilité entre Linux et ce type de smartphone...

Ai-je déréglé qqch dans le téléphone ? Ou dans le Bios du PC ?...
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #9
Hello.

Au vu de tout tes tests, il semblerait bien que le souci est plus hardware. J'ai le pc pro qui a dû mal à détecter mon S4 et Note 3 de ma femme, alors que deux S2, un S3 et un S5 se sont connectés sans problème, et je me suis aperçu que le pc ne fourni pas pleinement les 500mA de la norme USB, mais il est à 475mA, et c'est juste la limite....
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #10
yoanf26 a dit:
Hello.

Au vu de tout tes tests, il semblerait bien que le souci est plus hardware. J'ai le pc pro qui a dû mal à détecter mon S4 et Note 3 de ma femme, alors que deux S2, un S3 et un S5 se sont connectés sans problème, et je me suis aperçu que le pc ne fourni pas pleinement les 500mA de la norme USB, mais il est à 475mA, et c'est juste la limite....

...
Si c'est matériel ça pourrait être très ennuyeux pour moi.
Ce Lenovo X220 est un petit PC portable destiné au boulot et aux prises de notes.
Mais je suis sur le point de recevoir un PC plus grand, destiné à la maison, qui devra me servir entre autres à classer mes photos (un Lenovo T510). J'espère que je n'aurai pas le même genre d'incompatibilités... Bon, je n'ai pas encore testé la carte SD. Si elle marche bien, après tout ça ira très bien pour le transfert des photos...

J'ai vérifié avec différents câbles : le problème ne varie pas.

Je vais encore faire un ou deux essais pour voir...

Merci !
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #11
...
Ce n'est pas du matériel.

J'ai avancé un peu.

1. Lors de la première connexion entre mon Xperia et mon PC Lenovo sous Linux Mint, j'avais vu apparaître l'icône du téléphone et celui-ci avait proposé d'installer un logiciel. Ce ne s'était plus reproduit. Normal. En fait j'avais désactivé l'option en question sur le téléphone. Par défaut, le Xperia propose d'installer un logiciel lorsqu'il se connecte à un PC, et si je clique dessu, il y a l'apparition d'une icône "SONYINSTALLER" dans le PC. Mais il ne s'agit pas de l'icône du téléphone à proprement parler : il s'agit d'un installateur (avec l'icône d'un CD) avec 3 fichiers d'installation.

2. Au vu de ce qui précède, il faut avouer qu'il doit se passer qqch entre le téléphone et le PC. Ce dernier affiche l'icône et la fenêtre du Xperia si on essaie d'installer le logiciel depuis ce dernier. Et même si l'option d'installation est désactivée, à chaque branchement, le téléphone affiche un message indiquant qu'il est branché sur un PC en mode MTP.

3. Comme indiqué plus haut, j'ai essayé avec un PC Samsung sous Windows 7 64bits : aucun problème, ça marche. Or, j'ai fait démarrer ce même PC Samsung avec un CD live Xubuntu 64bits. J'ai exactement le même problème que sur mon Lenovo : rien ne se passe (sauf si j'active sur le téléphone l'option installation du logiciel). Donc, le PC Lenovo X220 et le PC Samsung réagissent de la même manière, exactement.

Conclusion : il y a une incompatibilité entre le Xperia Z5 compact et les ordinateurs sous Linux (ou au moins ceux sous Ubuntu & co).... :?: Pas si sûr ! Parce qu'avec mon Compaq Mini, sous Linux Mint Xfce 32bits, ça marche...

Alors ?

Avec mes maigres connaissances, je vois 2 hypothèses :
1. Le problème se pose avec les distributions linux 64bits et pas avec celles de 32bits.
2. Il y a un souci de drivers. Peut-être que mon PC Lenovo et mon PC Samsung ont des similitudes dans la gestion des ports USB (par exemple), et qu'il y a un même driver utilisé, driver qui pourrait ne pas réussir à faire copain-copain avec mon Xperia.

J'ai voulu essayer avec un distribution Linux totalement différente. J'ai fait un CD live de Mageia et il plante sur les 2 ordinateurs. Bon, je vais me coucher.

Et s'il y a qqn par là qui ait un PC sous Linux et un Xperia récent, je serais ravi de partager mes expériences....

:?:
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #12
Hello.

Mon Linux Mint en virtualisation est en 64 bits, et il voit mon S4 sans problème. Sachant, que je dis à VirtualBox que l'usb de branché est pour Linux Mint, du coup, mon Windows en hôte ne le vois plus et pas de drivers utilisé sous Windows. J'ai effectué le même test avec le Note 3 de ma femme et même résultat. Même les commandes ADB fonctionne depuis Linux...
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #13
Oui.
Je vois d'autres types de smartphones sans soucis...
Mais mon PC Samsung repère le Xperia depuis Windows et pas en démarrant sous Linux.
...
Je vais tester quelques pistes :
Autre distribution Linux, non-ubuntu
Regarder le Uefi du PC
Regarder l'antivirus du Xperia
Essayer avec un CD live Ubuntu 32bits
...
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #14
Et encore merci
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #15
Tu as essayé d'installer le SONYINSTALLER sur ton linux voir si cela peut être compatible Linux ?
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #16
Pas encore
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #17
Tente, cela peut te régler le problème si compatible.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #18
Si je lance les applications il ne se passe rien.

Testé la commande lsusb :
Code:
S'il vous plaît, Connexion ou S'inscrire to view codes content!

...donc le smartphone apparaît...
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #19
J'ai fait la même commande lsusb depuis mon Compaq Mini et j'ai le même résultat. Bon, là je vais essayer un truc qu'on m'a conseiller sur le forum Linux Mint.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #20
J'ai trouvé [LIEN SUPPRIMÉ] : Ouvrir "Réglages", dans la barre de recherche taper "MTP", un menu caché s'ouvre, cliquer sur Appareil multimédia, un nouveau menu s'ouvre, cocher la case "Monter la carte SD"

C'est tout con et ça marche.

Bon, je ne saurais jamais pourquoi est-ce que sur mon fameux Compaq Mini sous Mint Xfce 32b tout roulait sans problèmes, mais le fait est que je trouve une solution adaptée à mes besoins.
Mais Sony ne peuvent pas se vanter de nous faciliter la vie...
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #21
Ah oui quand même. Il fallait y penser. Merci pour l'info.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #22
Problème finalement réglé avec cette , sur mon PC, qui installe ce qu'il faut.
...
Je peux désormais accéder facilement à tout le contenu de mon Xperia.

Mais je ne comprends toujours pas d'où venait le problème. Pas trop grave : tout roule.



Question : comment signale-t-on que la question est résolue ?
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #23
Hello.

Cool merci pour l'info.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
40
Points
6
  • #24
Merci à toi pour ton aide.
 
yoanf26

yoanf26

Admin suppléant
Inscrit
7 Octobre 2011
Messages
37 714
Points
63
  • #25
De rien.

J'ai essayé d'aller au mieux.
 
Haut Bas