Passer en Android 4.4 minimum

  • Auteur de la discussion Dygreg29
  • Date de début
D

Dygreg29

Membre
Inscrit
23 Octobre 2016
Messages
5
Points
0
#1
Bonjour,

Voici les données du problème, je possède un vieux Samsung Galaxy SII qui tourne très bien sous une ROM Stock 4.1.2 XWLSD, il est non rooté et pas de custom recovery.

J'aimerais pouvoir utiliser ce téléphone pour le donner à mon petit neveu pour qu'il puisse jouer à Pokemon GO dessus avec moi. Seul soucis, pour pouvoir jouer à Pokemon GO, il faut être en 4.4 minimum, ne pas être rooté, et passer le SafetyNet Check. Cela est-il possible d'arriver à remplir ces conditions en installant une custom ROM ? Étant donné qu'il n'existe pas de ROM Stock 4.4...

Merci d'avance pour votre aide
 
D

Dygreg29

Membre
Inscrit
23 Octobre 2016
Messages
5
Points
0
#3
Salut et merci de ta réponse. Après de nombreuses recherches sur internet et divers forums, je suis passé à la version CyanogenMod 12.1 (cm-12.1-20160203-NIGHTLY-i9100), donc version Android 5.1.1 et j'ai désormais TWRP 3.1.0-0

Tout marche très bien, mais comme je le craignais, je ne passe pas le SafetyNet Check. J'ai pourtant vérifié que je ne suis pas root, j'ai même supprimé les fichiers /system/bin/su et /system/xbin/su comme conseillé. Ça doit peut être venir du fait que le bootloader est unlock ?!

Du coup, j'essaye maintenant d'installer Magisk v16.0 pour voir si MagiskHide va régler mon problème. Mais quand je flash Magisk v16.0 par TWRP, il me dit "unable to unpack boot image". J'ai essayé du coup la technique de d'abord installer Magisk Manager, d'extraire le fichier boot.img de ma rom et de la copier dans le téléphone, pour ensuite patcher ce boot.img par Magisk Manager, mais il me dit également "unable to unpack boot image". Je suis coincé... :(
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 645
Points
113
#4
Salut,

Rien à voir avec le bootloader.

Si tu n'es pas root, c'est normal que ça passe pas. Bref, installé Magisk 16.4 (bêta), fais le test du safetynet et s'il passe, ne touche plus à rien.
 
D

Dygreg29

Membre
Inscrit
23 Octobre 2016
Messages
5
Points
0
#5
Ok, d'accord, merci.

Pour le root, c'est étonnant puisque sur une rom stock, si tu es root, tu ne passes pas le safetynet, il faut le cacher... Et comme j'ai lu plusieurs fois que des personnes arrivent à passer le safetynet sur une custom rom sans être root, ça me parait étonnant de vouloir être root dans le but de passer le safetynet.

Mais comme indiqué dans mon message précédent, je n'arrive pas à installer Magisk v16.0, ni v16.4, le message "unable to unpack boot image" apparait au cours du flash sous twrp.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 645
Points
113
#6
Dygreg29 a dit:
Pour le root, c'est étonnant puisque sur une rom stock, si tu es root, tu ne passes pas le safetynet, il faut le cacher..
C'est le principe de Magisk : Etre rooté tout en faisant passe le safetynet... Je n'ai aucun problème sur mes 2 OnePlus, sur ROM Customs.
Mais au temps pour moi, j'ai mal compris ton problème concernant le safetynet dès le départ.

Tu as songé à passer sur ROM Custom, ou est-ce déjà fait ?
 
D

Dygreg29

Membre
Inscrit
23 Octobre 2016
Messages
5
Points
0
#7
Je connais bien le principe de Magisk. Ce que je ne comprends pas c'est que tu me dises "pas étonnant que tu ne passes pas le safetynet puisque tu n'es pas root". Je devrais, au contraire, avoir plus de facilité à passer le safetynet sans être root non ?

Oui je suis passé a une rom custom (la version CyanogenMod 12.1 (cm-12.1-20160203-NIGHTLY-i9100)) comme indiqué dans le 3ème post.

Peut-être qu'il existe d'autres roms custom que je peux tester et qui passent plus facilement le safetynet ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 645
Points
113
#8
On va reprendre : Sur ROM Stock, si tu n'es pas root, effectivement, tu passes sans problème le safetynet. Si tu veux rooter ET passer le safetynet, il te faut Magisk.
Sur Custom, tu ne passeras pas le safetynet (la faute aux GApps). Donc pour le passer, il te faut forcément rooter ton mobile avec Magisk.

Par contre, je n'arrive pas à savoir pourquoi tu ne peux pas installer les dernières versions de Magisk... Sûrement la ROM qui est trop ancienne.
Il y a LineageOS que tu peux tester (ROM Custom sous Android 7, LineageOS est le remplaçant de Cyanogen).
 
FrankLucas

FrankLucas

Membre
Inscrit
7 Septembre 2014
Messages
97
Points
0
#9
Bonsoir à vous deux,

Comme l'a dit Skelett, si Magisk ne s'installe pas, c'est très probablement un problème de compatibilité. Avec le modèle de téléphone, ou la ROM Custom.

Sinon, effectivement avec Magisk, tu passe le SafetyNet sans soucis (J'ai dû y recourir pour certaines applications il y plusieurs mois). Donc aucun problème pour utiliser Pokemon Go.
Par contre, et c'est la raison de mon message, je pense malheureusement que niveau performance un Galaxy SII c'est vraiment très limite pour ce genre de jeu qui risque d'être assez gourmand, car qu'il me semble que le SII a seulement 1Go de RAM et un processeur à 1,2Ghz. En espérant que je me trompe.
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
11 645
Points
113
#10
Salut,

Il verra bien de lui-même, pour ce qui concerne la capacité de l'appareil à faire tourner PoGo ou pas.
Mais ce que tu annonces ne m'étonnerait même pas.
 
FrankLucas

FrankLucas

Membre
Inscrit
7 Septembre 2014
Messages
97
Points
0
#11
Ouais c'est relativement léger.

Mais pour faciliter les choses y'a ici toute les ROMS pour le S2:
samsung-galaxy-s2-roms-et-customs-roms-f149.html

Ensuite re-tester Magisk. Et si ça marche vraiment pas, ou que le téléphone est pas performant. Faudra envisager l'achat d'un autre.
Un petit truc en occasion à 60 - 100€ de 2016 au moins et de pas trop grosse marque genre Honor, Huawei etc fera probablement l'affaire, un cadeau d'anniversaire en avance quoi
 
D

Dygreg29

Membre
Inscrit
23 Octobre 2016
Messages
5
Points
0
#12
OK, merci les gars pour vos réponses. Oui je sais que ça risque d'être assez limite de pouvoir faire tourner Pokemon GO dessus, je verrai bien le rendu si j'arrive à le faire tourner.

Pour ce qui est de Magisk, je viens de découvrir sur XDA que le Galaxy S2 n'est pas compatible avec Magisk, quelque soit la version de la rom. Je vais faire des recherches sur Xposed, il parait que certains ont réussi à faire passer le safeynet grâce à ça
 

Haut Bas