Impossible de créer le script de montage App2SD

  • Auteur de la discussion Gotiplex
  • Date de début
G

Gotiplex

Membre
Inscrit
31 Août 2019
Messages
32
Points
6
  • #1
Bonjour,
Je suis sur lineage 16.1, et après avoir partitionner ma carte sd avec une seconde partition en ext4 (j'ai testé avec ext1, 2 et 3 aussi), impossible de créer le script de montage avec App2SD ou Link2SD, il y a une erreur :
- Si je choisit l'option "I use Magisk interface", un message d'erreur me dit : Unable to determine su.d path, you can set the "su.d/post-fs-data/service.d" path in Settings and try again. J'ai pourtant bien Magisk d'installé, et je ne comprend pas comment créer le chemin via quels paramètres ?
- Si je choisit "Utiliser la méthode normale", cela m'affiche : Command failed
- Enfin si je choisit "Méthode avancé" (la méthode que j'utilisait sur mon ancienne ROM, j'obtient aussi :Command Failed

En fait je viens de voir que ma seconde partition n'est pas montée, et quand je clique sur monter le 2nd partition, un message d'erreur s'affiche : mount: mounting / dev / block / vold / public:179,65 on data/sdext2 failed : Device or ressource busy


Voila donc si quelqu'un à déjà fait face à ce problème ou sait comment le résoudre, je voudrais pas de l'aide.

Merci
 
Dernière édition:
Dernière édition:
SkelettSkelter

SkelettSkelter

Administrateur
Inscrit
12 Mai 2013
Messages
12 856
Points
113
  • #2
Salut,

Et pour que ce soit plus fluide et fiable, tu as tenté de créer la seconde partition avec un PC ?
 
G

Gotiplex

Membre
Inscrit
31 Août 2019
Messages
32
Points
6
  • #3
Oui bien sûr, je ne partitionne mes cartes sd qu'avec un PC, j'utilise Minitool Partition.
Mais le problème ne vient pas de là, sur mon ancienne ROM, la création du script de montage ne posait aucun soucis.
 
G

Gotiplex

Membre
Inscrit
31 Août 2019
Messages
32
Points
6
  • #4
J'ai détaillé les erreurs que j'obtiens dans mon post.
 
G

Gotiplex

Membre
Inscrit
31 Août 2019
Messages
32
Points
6
  • #5
J'ai formaté ma seconde partition en ext4 et pourtant, quand j'ouvre app2sd, un message me dit : impossible de monter la 2nd partition en ext3, formater la carte en ext 4 et reessayer...
 
G

Gotiplex

Membre
Inscrit
31 Août 2019
Messages
32
Points
6
  • #6
J'ai maintenant formaté ma partition en "Logique" et non primaire, je ne sais pas vraiment ce que ça change mais pour tester.
J'ai supprimer le script de montage et maintenant l'erreur est : mount: mounting / dev / block / mmcblk1p2 on data/sdext2 failed : Invalid argument
 
Haut Bas