Extinction intempestive et échec de mise à jour avec Lineage OS [abandon]

Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
Bonsoir,
Il s'agit d'un Xperia Z5 Compact. J'y avait installé Lineage OS sans les Gapps. J'ai ensuite installé par dessus une version de Lineage OS avec microG.
En gros, ça fonctionne.
Je me suis décidé à changer la batterie, bien décidé à faire durer mon smartphone.
Et il y a 2 problèmes, qui ne sont peut-être pas liés, mais qui sont apparus ces derniers jours :

1. J'ai eu parfois des extinctions intempestives. Le smartphone s'éteint. Cela m'est arrivé 2 fois. Et impossible de le redémarrer. Pour redémarrer, j'ai branché le chargeur. J'ai attendu et j'ai redémarré. Mais je précise que le smartphone était loin d'être déchargé. C'est donc bien une sorte de bug.
2. La dernière mise à jour ne s'installe pas. Je peux la télécharger, mais l'installation ne fonctionne pas.

Je ne sais pas si c'est lié à la nouvelle batterie, à une mise à jour récente ou à autre chose.

Autre bizarrerie, mais celle-là n'est pas nouvelle. J'ai 2 stores : F-Droid et Yalp. Yalp me propose certaines mises-à-jour pour des apps installées au travers de F-Droid. Les apps installées par F-Droid, je veux continuer à les gérer par F-Droid. Dans Yalp, on peut désigner les apps dont on veut "ignorer les mises à jour" et elles apparaissent dès lors marquées "sur liste noire". Mais bizarrement, pour certaines apps, ce réglage n'est pas conservé. Et à Yalp me propose à nouveau les mises à jour, la mention "sur liste noire" ayant disparu.


Est-ce que ça parle à qqn ?
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 265
Points
113
Salut,

J'ai eu parfois des extinctions intempestives. Le smartphone s'éteint. Cela m'est arrivé 2 fois. Et impossible de le redémarrer. Pour redémarrer, j'ai branché le chargeur. J'ai attendu et j'ai redémarré. Mais je précise que le smartphone était loin d'être déchargé. C'est donc bien une sorte de bug.
Cela à de très fortes chances de provenir de la nouvelle batterie.
Il faut savoir que les Xperia supportent très mal le démontage/remontage (même pour une simple batterie) et que très peu redémarre suite à tout ça.

La dernière mise à jour ne s'installe pas. Je peux la télécharger, mais l'installation ne fonctionne pas.
Non, là, ça ne vient pas de la batterie. Cela n'a même rien à voir.
Sur quelle version de LOS es-tu actuellement ? Quelle version essayes-tu d'installer ?

Enfin, concernant Yalp, je ne pourrais te dire, je ne m'en suis jamais servi. Mais quitte à utiliser un store alternatif de ce type, autant se servir uniquement de F-Droid, non ? Il reste quand même la référence dans le domaine du libre et de l'open-source.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
"Les Xperia supportent très mal le démontage/remontage..." Donc, il est très probable que mon smartphone ait été irrémédiablement abîmé... Grrrmllll. La batterie était fatiguée, le panneau arrière était fendu. Je me suis décidé à le "tirer" le plus longtemps possible et j'ai fait changer la batterie et le panneau. Et là, je vais probablement devoir me payer un truc neuf !

J'utilise la version de Lineage OS 14.1Suzuran. La dernière mise à jour correctement installée datait du 11 janvier. Et la mise à jour du 18 janvier ne s'installe pas.
Au départ, j'avais installé Lineage OS sans les Open Gapps. Après coup, j'avais utilisé une procédure permettant d'installer MicroG sans devoir tout réinstaller.

Quant à Yalp, il me permet d'acquérir certains softs que je ne trouve pas sur F-Droid. Au maximum j'essaie d'utiliser ce dernier. Pour certaines apps installées depuis F-Droid, Yalp me propose de les mettre à jour. Ce que je ne veux pas. En principe, avec la liste noire, ça devrait se régler. Mais Yalp semble "oublier" la mise en liste noire pour certaines apps.

J'en suis à me demander si je ne vais pas essayer de tout réinstaller (quitte à faire une installation "standard", avec Open Gapps) et, si mes extinctions continuent, me payer un téléphone portable neuf (ou d'occase)....
 
Dernière édition par un modérateur:
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 265
Points
113
Donc, il est très probable que mon smartphone ait été irrémédiablement abîmé...
Effectivement, il y a des chances.

La dernière mise à jour correctement installée datait du 11 janvier. Et la mise à jour du 18 janvier ne s'installe pas.
C'est bizarre, sur le site officiel de LOS je ne trouve qu'une version datant du 07/01/2019 :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
...
Dommage, il n'y a pas la version 15 pour ton appareil...

J'en suis à me demander si je ne vais pas essayer de tout réinstaller (quitte à faire une installation "standard", avec Open Gapps) et, si mes extinctions continuent, me payer un téléphone portable neuf (ou d'occase)....
Franchement, c'est ce que je te conseille de faire dans un premier temps, ne serait-ce que pour installer la dernière mis à jour en date que tu as trouvé : Installation au propre avec Full Wipe, installation de la ROM avec les GApps (et root avec Magisk si ça t'intéresse).

Si effectivement tes reboot continuent, n'insiste pas, tu n'en tireras rien de plus.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


En fait, j'ai un York de Lineage, incluant microG

Mais je vais essayer de repartir de zéro.
Question : Les OpenGapps, c'est juste que tu as du code non-libre ou est-ce que ça a vraiment de gros désavantages par rapport à microG ?

(Et merci...)
 
Skelett

Skelett

Moderateur Global
Inscrit
12 Mai 2013
Messages
12 265
Points
113
Ah oui, d'accord.

Très franchement, je n'en sais rien, je ne me suis jamais posé la question, désolé.
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
Premier retour.
J'ai tout réinstallé à zéro. J'ai finalement opté pour essayer encore avec Lineage for microG. J'avais mis un LIneage "normal", avec les Gapps et quand j'ai vu du Google partout, j'en ai eu marre de suite.
Sauf que là, j'ai fait le truc "proprement", en partant de zéro. La première fois, j'avais une version de Lineage OS déjà installée, avec quelques apps, et j'ai fait une manip "sale" pour rajouter microG.
Pour l'instant, pas d'extinction intempestive, mais ça peu encore venir.
Bizarrement, on me propose la fameuse mise à jour qui plantait tout le temps, alors que je venais d'installer la version la plus récente. Et l'installation plante toujours... Je ne vais pas paniquer et je vais juste attendre la prochaine mise à jour.
Yalp semble maintenant enregistrer la fameuse liste noire et ne me propose plus sans cesse de mettre à jour les apps que je veux gérer par F-Droid. Mais Yalp a un problème ces jours-ci (problème déjà présent avant ma réinstallation). Je peux installer des apps sans problème. Mais quand je lance la mise à jour, il me demande si je veux me connecter au Google Play Store avec mon compte Google ou mon compte partagé par Yalp Store. Et cette 2ème option rame, ne fonctionne pas. Mais je suppose que c'est un problème chez Yalp et pas sur mon smartphone... Est-ce que d'autres personnes ont des soucis avec Yalp, en l'utilisant sans identifiant Google ?

____

edit : Yalp semble souffrir de problèmes de connexion. Des fois ça marche sans soucis. Des fois, ça bloque. Mais l'histoire de la liste noire est maintenant réglé.
 
Dernière édition:
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
Deuxième retour, après la réinstallation de Lineage OS - microG
1. J'ai eu 1 extinction intempestive... En cherchant, je trouve divers trucs sur ce thème (ça, par exemple :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
). On dirait que ça arrive sur certains Sony. Je vais essayer de laisser la batterie se décharger complètement et faire une charge complète.
2. J'ai téléchargé une mise à jour. Je l'ai installée. Et elle est toujours indiquée comme étant à installer. Sauf que... Si je regarde dans version Lineage OS, il semblerait que la mise à jour a bel et bien été installée. Donc la mise à jour se fait, mais le système ne s'en rend pas compte. Et j'ai trouvé un problème similaire décrit ici :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
. En gros, ça ne doit pas être bien grave.
3. Concernant Yalp, le problème de liste noire est réglé. Mais j'ai parfois des soucis de connexion. Je pense que c'est lié aux services de Yalp et pas à mon smartphone.

Donc ce sont probablement 3 problèmes bien distincts, dont seul le 1er est vraiment préoccupant; à suivre...
 
Grompf2

Grompf2

Membre
Inscrit
24 Janvier 2016
Messages
49
Points
6
J'ai laissé le smartphone se décharger complètement. Je l'ai rechargé (avec le chargeur d'origine).
Et je continue à avoir ces extinctions intempestives. Cela se produit lorsque j'utilise l'appareil. Et ça s'éteint d'un coup (ce n'est pas comme lorsque la batterie est à 1% et que le téléphone affiche qu'il s'éteint, non, c'est d'un coup).
Ma conclusion est qu'on a un problème matériel.
Donc c'est foutu.
Et je dois pouvoir compter sur mon smartphone.
Donc je vais faire les petites annonces.
 
Haut Bas