Existe-t-il un custom recovery compatible avec Lineage 14.1 pour le Xperia Arc S

M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
Bonjour à tous,

Je pense que tout est dans le titre.

J'ai testé il n'y a pas si longtemps sur mon Xperia Arc S, Android Nougat 7.1.1 grâce à une version non officielle de Lineage 14.1.
Je l'ai trouvé bien sympa, sauf le recovery très restreint de Lineage à mon gout.

J'ai fait plusieurs recherches, je ne sais pas si j'ai tapé les bons mots clés mais je n'ai pas trouvé des custom recovery compatible ou des spécialement fait pour Lineage 14.1.

Si quelqu'un a des réponses même négatives je suis preneur.
Je suis également ouvert au bidouillage, en attendant d'acheter un nouvel Xperia ;)

Je vous remercie d'avance.
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
Merci pour ta réponse mais il me semble avoir essayé et il me semble qu'après avoir flashé le custom recovery sur la rom Lineage 14.1 ça démarre plus, ça fait un bootloop.

Mais dans le doute je vais ré-essayer ce soir.
 
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
19 124
Points
113
OK tiens moi au courant ;)
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
Bonjour Tekken,

J'ai réessayé avec "twrp2.4-boot-anzu.img" dans le doute comme je t'avais dit et ouais ça fait toujours pareil, à moins que je m'y prends mal.
Quand je flashe TWRP soit avec Flashtool soit avec la commande ADB "fastboot flash boot boot.img", le téléphone ne démarre pas. j'ai vraiment l'impression que ça écrase le kernel de Lineage 14.1 puisqu'au démarrage du téléphone j'ai plus "LegacyXperia" mais "KangXperia Project bringing AOKP to Xperia" qui apparaît à l'écran et puis ça reste là, ça va pas plus loin.
Par contre, si au démarre je tapote volume haut, ça rentre bien dans TWRP

Et je confirme qu'avec ICS ça marche normalement

Du coup, as-tu une idée ?
 
Dernière édition par un modérateur:
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
19 124
Points
113
est ce que le Xperia S c'est le même modèle que le Xperia Arc S ?
si OUI il existe une version plus récente de TWRP :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !


J'ai aussi trouvé une version de CWM, c'est un vieux recovery custom :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
Bonjour Tekken,

Merci pour ta réponse !
est ce que le Xperia S c'est le même modèle que le Xperia Arc S ?
Le Xperia S est de la gamme 2012 si je ne dis pas de bêtises alors que le Xperia Arc et Arc s sont de la gamme 2011, son autre nom c'est Anzu ou LT18i (ou a ou autre lettre). Donc je ne pense pas que ça devrait marcher, mais ça ne coûte rien d'essayer.

Après, si ça peut t'aider à me diriger, certaines choses des Xperia de la gamme 2011 sont compatible entre eux.

J'ai aussi trouvé une version de CWM, c'est un vieux recovery custom :
S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
Ça je peux essayer de voir ce soir, et je te fais un retour sur une partie ou les 2.

A plus tard ;)
 
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
19 124
Points
113
Le Xperia S est de la gamme 2012 si je ne dis pas de bêtises alors que le Xperia Arc et Arc s sont de la gamme 2011, son autre nom c'est Anzu ou LT18i (ou a ou autre lettre). Donc je ne pense pas que ça devrait marcher, mais ça ne coûte rien d'essayer.

Après, si ça peut t'aider à me diriger, certaines choses des Xperia de la gamme 2011 sont compatible entre eux.
je pense aussi que c'est des versions différentes, sinon ils s’appelleraient pareil :p

Ça je peux essayer de voir ce soir, et je te fais un retour sur une partie ou les 2.
OK ça marche ;)
 
M0umou

M0umou

Membre
Inscrit
9 Mai 2015
Messages
36
Points
6
Salut,

Alors j'ai essayé le cwm que tu m'as donné dans le lien, et j'ai essayé 3 fois mais ça ne fait absolument rien quand l'installation via ce script est terminé. Ou bien c'est moi qu'il l'ai mal utilisé.

Après avoir téléchargé le fichier "CWM-Install.zip" je l'ai décompressé sur mon pc et j'ai lancé "install-cwm1.cmd" comme c'est pour le Xperia Arc S (voir le fichier recovery.txt) et le script se lance. Il faut ensuite brancher le téléphone après avoir activé le mode debugage. Le Pc et le script détecte le téléphone puis il faut appuyer 2 fois sur une touche pour poursuivre et terminer l'installation.
Après avoir redémarré le téléphone, le recovery n'a pas changé, c'est toujours celui de Lineage 14.1.

Mais je me dis aussi que ça n'a pas marché aussi parce que quand je regarde le post d'origine il y a écrit : "[...] ClockworkMod for Stock Xperia Mini/Pro/Active/Arc" alors que moi je suis sur Lineage anciennement CyanogenMod
 
Tekken

Tekken

Moderateur Global
Inscrit
4 Août 2012
Messages
19 124
Points
113
salut désolé mais je n'ai pas d'autres idées :confused:
 
Haut Bas