Besoin d'aide pour Root et le top de modifications possible sur Xperia SP

  • Auteur de la discussion deathpairs
  • Date de début
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #1
Bonjour à tous !


Je suis nouveau ici et je possède depuis 2 semaines maintenant mon premier smartphone Android qu'est le Xperia SP.
J'ai été durant 6 ans avec Iphone et le IOS alors je dois dire que je me sens un peu perdu, les methodes de modifications et autres étant très differente.

Alors voila, mon Xperia SP est neuf, me proviens de Virgin Mobile (mais n'a subit aucune modification OS de leur part), il est sous android 4.3 (après la mise a jour effectué le jour ou je l'ai reçu, mise a jour que je n'aurais pas du faire semblerais t-il etant moins fluide) et en firmware 12.1.A.1.201


J'aimerais donc rooter mon Xperia, et y installer le top du top, me meilleur qui se fasse et qui est possible, et la plus fluide possible, qu'il s'agisse de la rom et tout autres.

Pourriez vous m'aidez, voir me guider ? car il y en a un peu partout et ne connaissant pas tout je me perds facilement..


Un grand merci d'avance pour toute aide !



K.
 
r34gtr

r34gtr

Super VIP
Inscrit
10 Août 2012
Messages
9 496
Points
48
  • #2
Hello !!

Alors, 1ere chose, regarde si ton bootloader déverrouillable .
Donc, tape se numéro sur le dial => *#*#7378423#*#* , ensuite clique sur SERVICE INFO--->> CONFIGURATION
en dessous de ROOTING STATUS tu doit avoir marqué:
bootloader unlock allowed: "YES" cela veut dire que tes AUTORISER à le débloquer .

Donc, soit tu reste sur des rom pour boot verrouillé, qui ont le kernel d'origine Sony, mais qui sont bien optimisé => [LIEN SUPPRIMÉ]

Soit tu passe chez les pro avec les rom custom genre Cyano ou Carbon de notre cher Alex ;)

Le root => ICI

Le bootloader => .

En fouinant un peu, avec un boot verrouillé tu peut te faire plaisir, beaucoup de mode sont dispo pour rendre notre SP fluide et performant !

Si tu a du mal avec les terme => .
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #3
woaw super ! merci beaucoup !

Donc, j'ai bien bootloader unlock allowed: "YES"

Donc l'étape suivante, je dois rooter c'est ça ? mais étant en .201 je dois utiliser flashtool pour retourner en .257 avant.

Enfin, je prendrais une rom custom c'est mieux ^^ cependant, Cyano et Carbon sont le meilleur ? et laquelle des deux me conseillez vous ?
Car j'aimerais une version des plus complete, terminer et la plus stable possible.
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #4
Salut

Carbon bien-sûr! :mdr1: si tu aimes la personnalisation Carbon est basée Cyanogen donc le même chose; et les modif visuelles en plus ;)



@ED

Je suis chez Virgin aussi; ils ne vendent que des mobiles nus; donc forcément déverrouillables ;) t'as plus qu'à migrer chez eux après ton contrat.
 
r34gtr

r34gtr

Super VIP
Inscrit
10 Août 2012
Messages
9 496
Points
48
  • #5
Ouais mais mon changement de phone se fera en.....2016..... :cry:
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #6
t'as un contrat de 3 ans??

mais de toutes façon renseignes-toi, certains couvrent les frais de résiliation si tu te ré engagges avec eux ;)
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #7
Reuh !

Dite je viens de commencer les étapes et je bloque deja sur flashtool ><... lorsque je branche mon smart en maintenant power et - (volume) la led devient bien verte mais le smart demare quelque seconde après et..ben flashtool ne fait quedal..
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #8
Tu ne dois pas le maintenir assez longtemps...maintiens vol- jusqu'à ce que tu vois dans la fenêtre principale de flashtool le script rouler...
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #9
c'est vraiment etrange je réessai encore et encore mais ça ne fonctionne pas.. il me marque :

Device connected in flash mode
et juste après :
Device disconnected
et la mon tel se met en mode charge.. o-o
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #10
quelle version de flashtool utilises-tu?

ça n'est pas étrange, faut simplement trouver ce que tu as zappé ;)
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #11
^^
Et bien la version 0.9.16.0
j'ai suivi le tuto donc mis les drivers, et bien selectionné le firmware que j'ai telecharger ^^
 
r34gtr

r34gtr

Super VIP
Inscrit
10 Août 2012
Messages
9 496
Points
48
  • #12
Hello !!

Ta bien redémarrer le PC après installation des drivers ?

Sinon recommence, le SP et tenace :hehe:
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #13
Saluuut ! ^^

bon après avoir rééssaiyé encore et encore j'ai obtenu ça :

28/003/2014 12:03:19 - INFO - Please connect your device into flashmode.
28/003/2014 12:03:30 - INFO - Device connected in flash mode
28/003/2014 12:03:30 - INFO - Opening device for R/W
28/003/2014 12:03:32 - INFO - Start Flashing
28/003/2014 12:03:32 - INFO - Processing loader.sin
28/003/2014 12:03:32 - INFO - Checking header
28/003/2014 12:03:32 - ERROR - Processing of loader.sin finished with errors.
28/003/2014 12:03:32 - INFO - Ending flash session
28/003/2014 12:03:32 - ERROR -
28/003/2014 12:03:32 - ERROR - Error flashing. Aborted
28/003/2014 12:03:33 - INFO - Device connected in flash mode
28/003/2014 12:03:42 - INFO - Device disconnected
28/003/2014 12:03:49 - INFO - Device connected with USB debugging off
28/003/2014 12:03:49 - INFO - For 2011 devices line, be sure you are not in MTP mode


c'est quoi le probleme cette fois ?? x) j'en peu plus :langue2: x)
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #14
re essaies mais cette fois-ci coche dans flashtool avant de lancer le flash "exclude TA"
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #15
Toujours pareil =/
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #16
Tiens, installes cette version plus ancienne de flashtool pour voir.

Même chose, on installe à la racine du C:\ et dans \flashtool\drivers tu coches:
pilotes flashmode
fastboot
pilotes xperia Z (oui Z)


S'il vous plaît, Connexion ou S'inscrire pour voir le contenu ou les urls !
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #17
Il n'y a vraiment rien à faire, j'ai même essaiyé sur un autre ordi, rien à faire.. je pense que je vais laisser tomber


01/017/2014 16:17:43 - INFO - <- This level is successfully initialized
01/017/2014 16:17:43 - INFO - Flashtool Version 0.9.16.0 built on 19-04-2014 19:00:00
01/017/2014 16:17:53 - INFO - Checking if changes have been made to devices folder.
01/018/2014 16:18:15 - INFO - Pulling changes from github
01/018/2014 16:18:16 - INFO - Devices sync finished.
01/018/2014 16:18:22 - INFO - Device disconnected
01/018/2014 16:18:28 - INFO - Selected Bundle for Xperia SP. FW release : 12.0.A.1.257. Customization : C5303
01/018/2014 16:18:28 - INFO - Preparing files for flashing
01/019/2014 16:19:53 - INFO - Please connect your device into flashmode.
01/020/2014 16:20:02 - INFO - Device connected in flash mode
01/020/2014 16:20:02 - INFO - Opening device for R/W
01/020/2014 16:20:03 - INFO - Start Flashing
01/020/2014 16:20:03 - INFO - Processing loader.sin
01/020/2014 16:20:03 - INFO - Checking header
01/020/2014 16:20:03 - ERROR - Processing of loader.sin finished with errors.
01/020/2014 16:20:03 - INFO - Ending flash session
01/020/2014 16:20:03 - ERROR -
01/020/2014 16:20:03 - ERROR - Error flashing. Aborted
01/020/2014 16:20:04 - INFO - Device connected in flash mode
01/020/2014 16:20:14 - INFO - Device disconnected
 
Alx31

Alx31

Active Member
Inscrit
11 Novembre 2012
Messages
6 038
Points
36
  • #18
c'est forcément quelque chose de zappé ou mal fait...la méthode marche assurément.

Tu devrais essayer d'effacer ces fw et les re télécharger pour être sûr qu'ils sont "propres" ensuite essayer une version flashtool plus ancienne, c'est obligé de marcher ;)
 
Did57350

Did57350

Membres VIP
Inscrit
16 Janvier 2012
Messages
4 580
Points
38
  • #19
deathpairs a dit:
Saluuut ! ^^

bon après avoir rééssaiyé encore et encore j'ai obtenu ça :

28/003/2014 12:03:19 - INFO - Please connect your device into flashmode.
28/003/2014 12:03:30 - INFO - Device connected in flash mode
28/003/2014 12:03:30 - INFO - Opening device for R/W
28/003/2014 12:03:32 - INFO - Start Flashing
28/003/2014 12:03:32 - INFO - Processing loader.sin
28/003/2014 12:03:32 - INFO - Checking header
28/003/2014 12:03:32 - ERROR - Processing of loader.sin finished with errors.
28/003/2014 12:03:32 - INFO - Ending flash session
28/003/2014 12:03:32 - ERROR -
28/003/2014 12:03:32 - ERROR - Error flashing. Aborted
28/003/2014 12:03:33 - INFO - Device connected in flash mode
28/003/2014 12:03:42 - INFO - Device disconnected
28/003/2014 12:03:49 - INFO - Device connected with USB debugging off
28/003/2014 12:03:49 - INFO - For 2011 devices line, be sure you are not in MTP mode


c'est quoi le probleme cette fois ?? x) j'en peu plus :langue2: x)

Salut,

Le log et incomplet enfin il passe trop vite de connection à flash.

As tu bien coché les sources inconnues dans paramètres/Sécurité et le Débogage USB dans Paramètres/Options pour les développeur?

Aussi branche ton mobile (allumé) à ton ordinateur et dans la barre de notification tu verras la connection USB alors appuis dessus et choisis MTP.
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #20
Bon je vais tout desinstaller, tout re-telecharger et suivre tout les conseils, tout reprendre a zero, et je vous re dis ça.
En tout cas merci beaucoup à tous, c'est vraiment sympa ^^
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #21
Bon ! voila j'ai tout remis a zero, tout re telechargé et je vais tout reprendre et tout refaire sur un bon ordi ! ^^

Par contre, je suis maintenant en 4.3 (12.1.A.1.205), est ce que cela change quelque chose ?
 
r34gtr

r34gtr

Super VIP
Inscrit
10 Août 2012
Messages
9 496
Points
48
  • #22
Hello !!
Tu et sur la dernière mise a jour, et, depuis hier une nouvelle méthode de root et sortie pour le SP => ICI
 
D

deathpairs

Membre
Inscrit
25 Mai 2014
Messages
17
Points
1
  • #23
Supeeeer ! merci =D
 

Sujets en relation

Haut Bas